VM reagiert nicht mehr nach dem Anwenden von Windows Update, und Fehler „C01A001D“ wird ausgegeben

In diesem Artikel werden Schritte zur Behebung von Problemen erläutert, bei denen Windows Update (KB) einen Fehler generiert und in einer Azure-VM nicht mehr reagiert, auf der Windows Server 2016 ausgeführt wird.

Problembeschreibung

Sie können das folgende Windows Update (insbesondere nach KB5003638, veröffentlicht am 8. Juni 2021) nicht auf einer Windows Server 2016-VM anwenden, ohne dass die folgenden Symptome auftreten:

  • Die VM kann nicht gestartet werden, und Remote Desktop Protocol (RDP)-Verbindungen zur VM schlagen fehl.

  • Wenn Sie Startdiagnose verwenden, um den Screenshot der VM anzuzeigen, wird das laufende Windows Update (KB) angezeigt, schlägt jedoch mit dem folgenden Fehlercode fehl: „C01A001D“.

Screenshot zeigt, dass die Ausführung der VM mit dem Fehlercode C01A001D fehlschlägt.

Ursache

Nach der Installation von Windows-Updates und Sprachpaketen wird möglicherweise der Fehler „C01A001D (STATUS_LOG_FULL)“ aus den folgenden Gründen angezeigt:

  • Nicht genügend Speicherplatz auf dem Datenträger
  • Ein Berechtigungsproblem im Zusammenhang mit der Verarbeitung von Dateien im Verzeichnis %systemroot%\system32\config\TxR nach der Anwendung von KB5003638.

Lösung

Um zu verhindern, dass das oben beschriebene Problem von vornherein auftritt, führen Sie die folgenden Lösungsschritte auf Windows Server 2016-VMs aus, bevor Sie das Windows-Update KB5003638 (Betriebssystembuild 14393.4467), veröffentlicht am 8. Juni 2021, anwenden. Sie können diese Schritte auch auf der ausgefallenen VM ausführen, aber Sie müssen die VM zuerst mit Wiederherstellen der VM aus dem Backup in den Zustand vor der Anwendung dieses Updates zurücksetzen.

  1. Stellen Sie sicher, dass das Betriebssystemvolume über mindestens 1 GB freien Speicherplatz verfügt.

  2. Geben Sie im Feld „Windows durchsuchen“ winver ein, um das Dialogfeld „Über Windows“ zu öffnen und das zuletzt angewendete Windows-Update zu ermitteln. Wenn die Zahl nach „OS Build 14393“ niedriger als 4350 ist, wenden Sie eines der folgenden Updates an (wie in der Update-Richtlinie Ihres Unternehmens zulässig), und starten Sie dann die VM neu:

Screenshot des Dialogfelds „Info“ mit hervorgehobener Betriebssystem-Buildnummer.

  1. Nachdem der Betriebssystembuild auf 13. April 2021 – KB5001347 (Betriebssystembuild 14393.4350) oder 11. Mai 2021 – KB5003197 (Betriebssystembuild 14393.4402) aktualisiert wurde, laden Sie das Rollback bekannter Probleme 062521 01.msi herunter und führen Sie es auf der VM aus, die eine lokale oder Domänenrichtlinie anwendet. Diese MSI-Datei gilt sowohl für Windows 10 als auch für Windows Server 2016. Beachten Sie das Auftreten von KB5001347 Problem 001 Rollback.admx im Ordner %systemroot%\policydefinitions, nachdem das Element installiert wurde.

  2. Öffnen Sie einen Richtlinieneditor und aktivieren Sie die folgende Einstellung in der lokalen oder Domänenrichtlinie:

    • Pfad: Computerkonfiguration\Administrative Vorlagen

    • Einstellung: KB5001347 Ausgabe 001 Rollback

    • Wert: Aktiviert

  3. Starten Sie alle VMs neu, auf denen Windows Server 2016 ausgeführt wird und die in den Geltungsbereich der soeben konfigurierten Richtlinie fallen.

Nachdem Sie die oben genannten Schritte ausgeführt haben, können Sie jetzt das Windows Update vom 8. Juni 2021 – KB5003638 (Betriebssystembuild 14393.4467) oder später anwenden.

Hinweis

Wenn Sie den Status einer VM in einem Nicht-Boot-Status nicht wiederherstellen können, öffnen Sie ein Support-Ticket beim Azure-Support.

Kontaktieren Sie uns für Hilfe

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