Nichts geschieht, wenn Sie in Internet Explorer auf einen Link klicken

Warnung

Die eingestellte, nicht mehr unterstützte Desktop-Anwendung Internet Explorer 11 wurde durch ein Microsoft Edge-Update in bestimmten Versionen von Windows 10 dauerhaft deaktiviert. Weitere Informationen finden Sie unter Häufig gestellte Fragen zur Einstellung der Desktop-App von Internet Explorer 11.

Dieser Artikel hilft Ihnen bei der Behebung des Problems, dass die Webseite nicht geöffnet werden kann, wenn Sie in Internet Explorer auf einen Link klicken.

Ursprüngliche Produktversion: Internet Explorer 9
Ursprüngliche KB-Nummer: 175775

Problembeschreibung

Wenn Sie auf einen Link auf einer Webseite oder in einer E-Mail-Nachricht klicken, geschieht nichts. Internet Explorer öffnet die Webseite nicht.

Hinweis

Diese Informationen gelten für Internet Explorer 9, Internet Explorer 8 und Internet Explorer 7.

Ursache

Das Problem tritt aus einem oder mehreren der folgenden Gründe auf:

  • Die Einstellung, in der Sie den Webbrowser auswählen, den Sie verwenden möchten, ist beschädigt. Dies kann dazu führen, dass Windows falsch interpretiert, welcher Browser als Standardbrowser auf Ihrem Computer festgelegt ist.
  • Nachdem die Software installiert wurde, wurden die Einstellungen geändert, was dazu führen kann, dass Links zu Webseiten nicht ordnungsgemäß funktionieren.
  • Ein zuvor installierter Browser oder Add-In kann andere Software auf Ihrem Computer beeinträchtigen.
  • Registrierungsschlüssel wurden geändert oder beschädigt.

Lösung

Dieser Artikel richtet sich an Einsteiger und leicht fortgeschrittene Benutzer. Wenn das Problem mit diesen Methoden nicht behoben wird, können Sie die Methoden im Abschnitt Erweiterte Problembehandlung ausprobieren. Wenden Sie die folgenden Methoden in der angegebenen Reihenfolge an, um dieses Problem zu beheben.

Methode 1: Überprüfen der Standardeinstellung des Webbrowsers

In Microsoft Windows können Sie auswählen, welchen Webbrowser Sie verwenden möchten. Gehen Sie wie folgt vor, um Internet Explorer auf die Standardeinstellungen zurückzusetzen:

  1. Um Internet Explorer zu öffnen, klicken Sie auf Start und dann auf Internet Explorer.
  2. Wenn Sie aufgefordert werden, zu bestätigen, dass Internet Explorer Ihr Standardbrowser sein soll, klicken Sie auf Ja.
  3. Klicken Sie im Menü Tools auf Internetoptionen.
  4. Klicken Sie auf Programme>Als Standardeinstellung festlegen>, dann OK und schließen Sie dann Internet Explorer.

Hinweis

Die Änderungen werden beim nächsten Starten von Internet Explorer wirksam.

Überprüfen Sie, ob das Problem behoben wurde. Wenn das Problem beseitigt ist, sind Sie fertig mit diesem Artikel. Wenn das Problem weiterhin auftritt, fahren Sie mit der nächsten Methode fort.

Methode 2: Ändern der Dateitypen, die Internet Explorer standardmäßig öffnet

Für Windows 7 und Windows Vista.

  1. Schließen Sie alle Internet Explorer-Fenster.
  2. Klicken Sie auf Start und dann auf Systemsteuerung.
  3. Klicken Sie auf Programme und dann auf Standardprogramme festlegen.
  4. Klicken Sie im Menü Programme auf Internet Explorer, und klicken Sie dann auf Standardeinstellungen für dieses Programm auswählen.
  5. Stellen Sie sicher, dass die Kontrollkästchen für .htm, .html und urls aktiviert sind, und klicken Sie dann auf Speichern.
  6. Klicken Sie auf OK.

Hinweis

Die Änderungen werden beim nächsten Starten von Internet Explorer wirksam.

Für Windows XP

  1. Um Windows Explorer zu öffnen, klicken Sie mit der rechten Maustaste auf Start und klicken Sie dann auf Mein Computer.

  2. Klicken Sie im Menü Tools auf Ordneroptionen und anschließend klicken Sie auf die Registerkarte Dateitypen.

  3. Finden Sie den HTM-Dateityp und wählen Sie ihn aus.

  4. Stellen Sie sicher, dass Internet Explorer als Öffnen mit Programm ausgewählt ist. Wenn Internet Explorer nicht ausgewählt ist, klicken Sie auf Ändern, wählen Sie Internet Explorer als empfohlenes Programm aus, und klicken Sie dann auf OK.

  5. Wiederholen Sie die Schritte 3 und 4 für die folgenden Dateitypen:

    • HTML
    • ITS
    • MHT
    • MTHML
    • XML
    • XSL

Überprüfen Sie, ob das Problem behoben wurde. Wenn das Problem beseitigt ist, sind Sie fertig mit diesem Artikel. Wenn das Problem weiterhin auftritt, fahren Sie mit der nächsten Methode fort.

Methode 3: Verwenden Sie den Internet Explorer-Modus „Keine Add-Ons“

Add-Ins können Ihre Benutzererfahrung zwar verbessern, doch sie können gelegentlich Störungen oder Konflikte mit anderer Software auf ihrem Computer hervorrufen. Beachten Sie jedoch, dass einige Webseiten oder Internet Explorer selbst möglicherweise nicht ordnungsgemäß angezeigt werden, wenn ein Add-In deaktiviert ist. Starten Sie zunächst Internet Explorer mit vorübergehend deaktivierten Add-Ins, um festzustellen, ob das Problem behoben ist. (Add-Ins bleiben nur solange deaktiviert, bis Sie Internet Explorer auf die übliche Weise neu starten). Gehen Sie dazu wie folgt vor:

  • Klicken Sie auf Start, geben Sie Internet Explorer in das Suchfeld ein, und klicken Sie dann auf Internet Explorer (Keine Add-Ons).

    Hinweis

    Für Windows XP klicken Sie auf Start, klicken Sie mit der rechten Maustaste auf das Symbol Internet Explorer und klicken Sie dann auf Ohne Add-Ons durchsuchen.

Wenn der Internet Explorer-Modus Keine Add-Ons das Problem behebt, führen Sie die folgenden Schritte aus, um das Browser-Add-In zu identifizieren, welches das Problem verursacht:

  1. Um Internet Explorer zu starten, klicken Sie auf Start und dann auf Internet Explorer.
  2. Klicken Sie auf die Schaltfläche Extras und dann auf Add-Ons verwalten.
  3. Klicken Sie auf ein Add-In in der Liste von Namen, und dann klicken Sie auf Deaktivieren. Testen Sie Internet Explorer.
  4. Wiederholen Sie Schritt 3, bis Sie das Add-In identifizieren, welches das Problem verursacht.

Überprüfen Sie, ob das Problem behoben wurde. Wenn das Problem beseitigt ist, sind Sie fertig mit diesem Artikel. Wenn das Problem weiterhin auftritt, fahren Sie mit der nächsten Methode fort.

Methode 4: Zurücksetzen von Internet Explorer-Einstellungen

Wenn das Problem durch beschädigte oder inkompatible Internet Explorer-Einstellungen oder -Add-Ins verursacht wird, können Sie das Problem in der Regel beheben, indem Sie die Internet Explorer-Einstellungen auf die Standardeinstellungen zurücksetzen.

Wenn Sie die Internet Explorer-Einstellungen zurücksetzen, gehen alle vorherigen Einstellungen verloren und können nicht wiederhergestellt werden. Wenn Sie die Standardeinstellungen von Internet Explorer wiederherstellen, funktionieren manche Webseiten, die von zuvor gespeicherten Cookies, Formulardaten, Kennwörtern oder früher installierten Browser-Add-Ins abhängig sind, möglicherweise nicht ordnungsgemäß. Durch das Zurücksetzen von Internet Explorer auf die Standardeinstellungen werden Ihre Favoriten, Feeds und mehrere andere persönliche Einstellungen jedoch nicht gelöscht.

Gehen Sie wie folgt vor, um Internet Explorer zurückzusetzen:

  1. Schließen Sie alle Internet Explorer-Fenster.

  2. Klicken Sie auf Start, geben Sie inetcpl.cpl in das Suchfeld ein, und klicken Sie dann in der Programmliste auf inetcpl.cpl. Das Dialogfeld Internetoptionen wird angezeigt.

    Hinweis

    Für Windows XP klicken Sie auf Start und auf Ausführen. Geben Sie in das Feld „Öffnen“ inetcpl.cpl ein, und klicken Sie anschließend auf OK.

  3. Klicken Sie auf die Registerkarte Erweitert.

  4. Klicken Sie unter Internet Explorer-Einstellungen zurücksetzen auf Zurücksetzen. Klicken Sie dann erneut auf Zurücksetzen.

  5. Wenn Internet Explorer das Zurücksetzen abgeschlossen hat, klicken Sie im Dialogfeld Internet Explorer-Einstellungen auf Schließen.

  6. Starten Sie Internet Explorer erneut. Die Änderungen werden beim nächsten Öffnen von Internet Explorer wirksam.

Methode 5: Erneutes Registrieren der erforderlichen Internet Explorer-DLL-Dateien

Hinweis

Dieser Artikel bezieht sich auf Windows XP

Gehen Sie folgendermaßen vor, um die DLL-Dateien erneut zu registrieren:

  1. Klicken Sie auf Start, auf Alle Programme und auf Zubehör. Klicken Sie mit der rechten Maustaste auf Eingabeaufforderung, und klicken Sie dann auf Als Administrator ausführen. Wenn Sie zur Eingabe eines Administratorkennworts oder einer Bestätigung aufgefordert werden, geben Sie das Kennwort ein, oder bestätigen Sie den Vorgang.

  2. Geben Sie regsvr32 urlmon.dll in das Feld „Öffnen“ ein, und klicken Sie dann auf OK.

  3. Klicken Sie auf OK, sobald Sie die Bestätigung erhalten.

  4. Wiederholen Sie die Schritte 2 und 3 für die folgenden Befehle:

    • regsvr32 mshtml.dll
    • regsvr32 shdocvw.dll
    • regsvr32 browseui.dll
    • regsvr32 msjava.dll

Überprüfen Sie, ob das Problem behoben wurde. Wenn das Problem beseitigt ist, sind Sie fertig mit diesem Artikel. Wenn das Problem weiterhin auftritt, fahren Sie mit dem nächsten Abschnitt fort.

Erweiterte Problembehandlung

Dieser Abschnitt richtet sich an fortgeschrittenere Benutzer.

Methode 1: Erstellen eines neuen Benutzerkontos

Weitere Informationen zu Benutzerprofilen finden Sie unter Über Benutzerprofile.

Einzelheiten zum Verfahren finden Sie auf den folgenden Microsoft-Webseiten:

Methode 2: Verwenden von Systemwiederherstellung

Die Systemwiederherstellung verwendet Wiederherstellungspunkte, um Ihre Systemdateien und -einstellungen zu einem früheren Zeitpunkt zurückzusetzen, ohne dass sich dies auf Ihre persönlichen Dateien auswirkt. Wiederherstellungspunkte werden jede Woche und unmittelbar vor wichtigen Systemereignissen wie der Installation eines Programms, eines Geräts oder eines Treibers automatisch erstellt.

Bevor Sie die Systemwiederherstellung starten, speichern Sie alle geöffneten Dateien, und schließen Sie alle Programme. Nachdem Sie den Wiederherstellungspunkt bestätigt haben, startet die Systemwiederherstellung den Computer neu. Gehen Sie wie folgt vor, um eine Systemwiederherstellung durchzuführen:

In Windows 7 und Windows Vista

  1. Klicken Sie auf Start, dann auf Alle Programme, auf Zubehör und auf Systemprogramme, und klicken Sie dann auf Systemwiederherstellung. Wenn Sie zur Eingabe eines Administratorkennworts oder einer Bestätigung aufgefordert werden, geben Sie das Kennwort ein, oder bestätigen Sie den Vorgang.

  2. Klicken Sie auf der Seite „Systemwiederherstellung“ auf Weiter.

  3. Wählen Sie das gewünschte Systemwiederherstellungsdatum oder die gewünschte Beschreibung aus.

    Hinweis

    Wenn das gewünschte Datum nicht angezeigt wird, klicken Sie auf „Weitere Datumsangaben anzeigen“, und wählen Sie dann das gewünschte Datum aus.

  4. Klicken Sie im Bestätigungsfenster auf Fertigstellen. Ihr Computer wird neu gestartet. Wenn der Vorgang abgeschlossen ist, erhalten Sie eine Bestätigungsmeldung.

Für Windows XP

  1. Melden Sie sich mit einem Konto mit Administratorrechten bei Windows an.
  2. Klicken Sie auf Start, dann auf Alle Programme, auf Zubehör und auf Systemprogramme, und klicken Sie dann auf Systemwiederherstellung.
  3. Klicken Sie auf der Seite „Willkommen“ auf die Option Computer auf einen früheren Zeitpunkt zurücksetzen und dann auf Weiter.
  4. Klicken Sie auf der Seite Einen Wiederherstellungspunkt wählen auf den neuesten Systemwiederherstellungspunkt in der Liste mit dem Titel Klicken Sie in der Liste auf einen Wiederherstellungspunkt und dann auf Weiter.
  5. Klicken Sie auf der Seite Auswahl des Wiederherstellungspunkts bestätigen auf Weiter. Die Systemwiederherstellung stellt die frühere Windows XP-Konfiguration wieder her und startet den Computer neu.
  6. Melden Sie sich beim Computer als Administrator an. Klicken Sie dann auf der Seite „Systemwiederherstellung abgeschlossen“ auf OK. Ihr Computer wird neu gestartet. Wenn der Vorgang abgeschlossen ist, erhalten Sie eine Bestätigungsmeldung.

Wenn Sie die Systemwiederherstellung verwenden, das Problem aber weiterhin auftritt oder andere Probleme auftreten, können Sie den Wiederherstellungsvorgang rückgängigmachen. Nach dem Rückgängigmachen des Vorgangs können Sie versuchen, einen anderen Wiederherstellungspunkt zu verwenden. Führen Sie zum Rückgängigmachen eines Systemwiederherstellungsvorgangs die folgenden Schritte aus:

  1. Klicken Sie auf Start, dann auf Alle Programme, auf Zubehör und auf Systemprogramme, und klicken Sie dann auf Systemwiederherstellung.
  2. Klicken Sie auf Systemwiederherstellung rückgängig machen, und klicken Sie dann auf Weiter.
  3. Überprüfen Sie Ihre Entscheidungen, und klicken Sie dann auf Fertigstellen.

Ihr Computer wird neu gestartet. Nach Abschluss des Vorgangs erhalten Sie eine Bestätigung.

Weitere Ressourcen

Überprüfen Sie, ob das Problem behoben wurde. Wenn das Problem beseitigt ist, sind Sie fertig mit diesem Artikel. Wenn das Problem nicht behoben ist, können Sie auch die Microsoft Customer Support Services nutzen, um andere Lösungen zu finden. Die Microsoft Support Services umfassen die folgenden Methoden:

  • Suchen in der Microsoft Knowledge Base: Hier finden Sie technische Supportinformationen und Selbsthilfetools für Microsoft-Produkte.
  • Solution Center: Hier finden Sie häufig gestellte produktspezifische Fragen und Antworten sowie spezielle Supportthemen.
  • Microsoft-Community: Wenden Sie sich an Fachkollegen, Gleichgesinnte und Microsoft Most Valuable Professionals (MVPs).
  • Weitere Supportoptionen: Stellen Sie Ihre Fragen im Internet, wenden Sie sich an Microsoft Support Services, oder teilen Sie uns Ihre Meinung mit.