Anwendungen versuchen, auf Webcacheinhalte zuzugreifen, die zum lokalen Administratorkonto gehören
Wichtig
Die Internet Explorer 11-Desktopanwendung wird für bestimmte Versionen von Windows 10 eingestellt und ab dem 15. Juni 2022 nicht mehr unterstützt.
Sie können mit dem Internet Explorer-Modus in Microsoft Edge weiterhin auf ältere Websites zugreifen, für die Internet Explorer erforderlich ist. Anleitung.
Die Internet Explorer 11-Desktopanwendung wird schrittweise an den schnelleren, sichereren Microsoft Edge-Browser umgeleitet und letztendlich über Windows Update deaktiviert werden. Deaktivieren von IE heute.
In diesem Artikel wird beschrieben, wie Sie ein Problem beheben, bei dem Browser oder Anwendungen, die Browsermodule verwenden, versuchen, auf Dateien zuzugreifen, die zum Administratorprofil eines Computers gehören, zusätzlich zu Dateien, die zum Profil des aktuellen Benutzers gehören.
Ursprüngliche Produktversion: Internet Explorer, Windows 10; Microsoft Edge, Windows 10
Problembeschreibung
Enterprise Benutzer von Internet Explorer, Microsoft Edge oder Anwendungen, die die Module eines browsers verwenden, melden die folgenden Symptome:
- Lange Verzögerungen treten auf, wenn sich Benutzer beim Windows Desktop anmelden.
- Die Anwendung kann Inhalte nicht im Browsercache speichern.
- Die Anwendung kann nicht aus dem Browsercache auf Inhalte zugreifen.
In diesem Szenario zeichnet ein betroffener Benutzer ein Prozessüberwachungsprotokoll auf, während das Problem auftritt. Wenn Sie das Protokoll analysieren, stellen Sie fest, dass die Browser oder Anwendungen versuchen, auf Dateien und Ordner zuzugreifen, die sich im Ordner "C:\Users\Administrator" befinden, zusätzlich zu Dateien und Ordnern, die sich im Profilordner des Benutzers befinden.
Ursache
Wenn sich der Benutzer zum ersten Mal bei Windows anmeldet, verwendet das System Informationen aus dem Standardbenutzerprofil, um das neue Benutzerprofil zu konfigurieren. Windows erstellt auch einen Cachecontainer als Teil des Benutzerprofils, damit Browser und andere Anwendungen verwendet werden können.
Dieses Zugriffsproblem kann auftreten, wenn das Standardbenutzerprofil geändert wurde, um benutzerdefinierte Einstellungen für neue Benutzerprofile zu erstellen. dies gilt insbesondere, wenn der Änderungsprozess das Kopieren von Profilinformationen aus dem Administratorprofil umfasst. Insbesondere kopieren einige Bildverarbeitungs- oder Bereitstellungstools einige oder den gesamten Inhalt des Administratorprofils in das Standardbenutzerprofil.
Das Administratorprofil verfügt über einen eigenen Cachecontainer. Wenn dieser Teil des Administratorprofils in das Standardbenutzerprofil kopiert wird, erhalten neue Benutzer eine Kopie des Administratorcachecontainers anstelle eines neuen Cachecontainers. Das Administratorkonto besitzt den Cachecontainer. Das Benutzerkonto ist dies nicht. Daher hat der Benutzer keinen vollständigen Zugriff auf den Cachecontainer.
Lösung
Auf betroffenen Computern müssen Sie das betroffene Benutzerprofil und das Standardbenutzerprofil separat korrigieren.
Achtung
Es wird dringend empfohlen, alle Speicherorte von Profilordnern oder Registrierungseinträgen zu sichern, bevor Sie Änderungen vornehmen.
Hinweis
Standardmäßig sind diese Profildateien und Ordner in der Ansicht ausgeblendet. Um sie sichtbar zu machen, müssen Sie vorübergehend die Ordneransichtsoptionen des Ordners "C:\Users\Default" und den Benutzernamen "C:\Users"> Ordners ändern \ < (in <user name> dem sich der Name des Profils des betroffenen Benutzers befindet). Gehen Sie dazu wie folgt vor:
- Öffnen Sie Windows Datei-Explorer, und suchen Sie den entsprechenden Speicherort des Profilordners.
- Select View > Options > View.
- Wählen Sie in der Liste der erweiterten Einstellungen ausgeblendete Dateien, Ordner und Laufwerke anzeigen aus.
- Deaktivieren Sie in derselben Liste das Kontrollkästchen Geschützte Betriebssystemdateien ausblenden (Empfohlen), und wählen Sie dann Ja aus.
- Wählen Sie Anwenden > OK aus.
Schritt 1: Reparieren des Standardbenutzerprofils
Um zu verhindern, dass neue Benutzerprofile eine Kopie des Cachecontainers aus dem Standardbenutzerprofil erhalten, löschen Sie die folgenden Dateien und Ordner (sofern vorhanden):
- C:\Users\Default\AppData\Local\Microsoft\Windows\WebCacheLock.dat
- C:\Users\Default\AppData\Local\Microsoft\Windows\WebCache
- C:\Users\Default\AppData\Local\Microsoft\Windows\INetCache
- C:\Users\Default\AppData\Local\Microsoft\Windows\INetCookies
Schritt 2: Reparieren der einzelnen betroffenen Benutzerprofile
Mehrere Dateien und Ordner, die Teil des Benutzerprofils sind, können nicht gelöscht werden, während der Benutzer bei Windows angemeldet ist. Aufgrund dieser Einschränkung muss sich der Benutzer von Windows abmelden, und dann kann sich ein Administrator anmelden und das Profil korrigieren. Um das Profil zu korrigieren, löschen Sie die folgenden Dateien und Ordner (sofern vorhanden):
C:\users \ < Benutzername >\AppData\Local\Microsoft\Windows\WebCacheLock.dat
C:\users \ < Benutzername >\AppData\Local\Microsoft\Windows\WebCache
C:\users \ < Benutzername >\AppData\Local\Microsoft\Windows\INetCache
C:\users \ < Benutzername >\AppData\Local\Microsoft\Windows\INetCookies
Hinweis
In diesen Dateipfaden <user name> ist der Name des Profils des betroffenen Benutzers.
Führen Sie nach dem Löschen dieser Elemente die folgenden Schritte aus:
- Stellen Sie die Ordneransichtsoptionen auf ihre vorherigen Werte wieder her.
- Starten Sie den Computer neu, und lassen Sie dann den betroffenen Benutzer anmelden (oder Sie können sich mit einem neuen Benutzerkonto anmelden).
Weitere Informationen
Die in diesem Artikel aufgeführten Dateien und Ordner bilden Einen Teil von Internet Explorer und Microsoft Edge Browsercache. Diese Inhaltsspeicherorte sind so konzipiert, dass sie für jeden Benutzer einzeln erstellt werden. Daher wird empfohlen, dass Sie nicht versuchen, sie anzupassen, zu ändern oder zu verschieben. Dies wird nicht unterstützt.