WPF-browsergehostete Anwendungen (XBAPs) können während des Startvorgangs abstürzten
Dieser Artikel hilft Ihnen, das Problem zu beheben, bei dem WPF-XBAPs während des Startvorgangs abstürzten.
Ursprüngliche Produktversion: Microsoft .NET Framework 3.5 Service Pack 1
Ursprüngliche KB-Nummer: 972928
Problembeschreibung
WPF-XBAPs können während des Startvorgangs abstürzten.
Ursache
Eine Ursache für dieses Problem ist, dass Schnittstellenregistrierungen auf Systemebene fehlerhaft sind. Insbesondere können Registrierungen für die folgenden Schnittstellen fehlen:
IID_IWebBrowser2IID_IShellBrowser
Dies kann auf fehlgeschlagene Installationen oder Upgrades oder Schadsoftware-Infektionen zurückzuführen sein.
Lösung
Registrieren Sie die fehlerhaften Schnittstellen erneut, indem Sie die folgenden Befehle ausführen:
regsvr32 %SystemRoot%\System32\actxprxy.dll
regsvr32 "%ProgramFiles%\Internet Explorer\ieproxy.dll"
Führen Sie auf 64-Bit-Windows auch die folgenden Befehle aus:
regsvr32 %SystemRoot%\SysWOW64\actxprxy.dll
regsvr32 "%ProgramFiles(x86)%\Internet Explorer\ieproxy.dll"
Auf Windows XP und Windows Server 2003 müssen diese Befehle über ein Benutzerkonto mit Administratorrechten auf dem Computer ausgeführt werden.
Auf Windows Vista oder höher müssen diese Befehle mit erhöhten Rechten ausgeführt werden. Wählen Sie > "Alle Programme > starten" aus. Klicken Sie mit der rechten Maustaste auf "Eingabeaufforderung", und wählen Sie "Als Administrator ausführen" aus. Führen Sie an der Eingabeaufforderung die Befehle aus.
Testen Sie, ob das Problem behoben ist. Wenn das Problem behoben ist, sind Sie mit diesem Abschnitt fertig. Wenn das Problem nicht behoben ist, können Sie sich an den Support wenden.