ClickOnce Anwendungen nicht aktualisiert werden können

Dieser Artikel hilft Ihnen bei der Behebung eines Problems, bei dem ClickOnce Anwendung nicht aktualisiert werden kann.

Ursprüngliche Produktversion:   .NET Framework 3.5 Service Pack 1, 3.5.1
Ursprüngliche KB-Nummer:   2713442

Problembeschreibung

Betrachten Sie dieses Szenario. Sie verfügen über eine ClickOnce Anwendung, die bei der ersten Installation immer erfolgreich ist. Bei nachfolgenden Starts schlägt die ClickOnce Anwendung jedoch fehl, wenn nach Updates gesucht wird. Es scheint zufällig zu sein, aber häufiger, wenn ein Update verfügbar ist.

Eine weitere Möglichkeit, um festzustellen, ob dieser Artikel gilt, besteht darin, ob das Problem auch vorübergehend behoben wird, indem der ClickOnce Dateicache gelöscht wird.

Ursache

Alles, was die Synchronisierung zwischen dem Dateisystem und den Registrierungsdaten unterbricht, kann dazu führen, dass ein ClickOnce Anwendungsupdate fehlschlägt.

  • Eine unvollständige Systemwiederherstellung, die nur die Dateien, aber nicht das Benutzerprofil wiederhergestellt. Der Registrierungsschlüssel HKEY_CURRENT_USER\Software\Classes\Software\Microsoft\Windows\CurrentVersion\Deployment\SideBySide\2.0 sollte sich im selben Zustand wie die Dateien in den folgenden Ordnern befinden:

    • Windows XP:%userprofile%\Local Settings\Apps\2.0\*.*

    • Windows Vista und höher:%userprofile%\AppData\Local\Apps\2.0\*.*

  • Roamingprofile werden aus demselben Grund nicht unterstützt. das Potenzial der Dateien, die nicht mit den Registrierungsdaten übereinstimmen. Siehe Microsoft ClickOnce Bereitstellung wird mit Roamingprofilen nicht unterstützt.

  • Fehlerhaftes Herunterfahren des Betriebssystems, z. B. ein Energieausfall.

  • Fehlerhaftes Abmelden, z. B. Ausschalten des Computers anstatt Abmelden oder Herunterfahren.

Lösung

Neben der Vermeidung der im Abschnitt "Ursache" aufgeführten Szenarien kann eine gewisse Reduzierung der Beschädigung mithilfe der .NET Framework 4.0 oder höher auf den Zielcomputern angezeigt werden. Die .NET Framework 4.0 weist Verbesserungen auf, die sie robuster machen, was zu weniger Updatefehlern im Vergleich zu früheren Frameworkversionen führt. Die Anwendung muss nicht mit dem .NET Framework 4.0 entwickelt werden. Es muss nur auf den Zielcomputern installiert werden.

Die Lösung für diese Probleme ist weiterhin:

  • Versuchen Sie, die Anwendung aus "Programme hinzufügen und entfernen" (ARP, Windows XP) oder "Programme und Features" (Windows Vista und höher) zu deinstallieren.
  • Wenn das Programm nicht erfolgreich deinstalliert wird, löschen Sie den ClickOnce-Dateicache.

Löschen des ClickOnce-Dateicaches

Um den ClickOnce Dateicache zu löschen, löschen Sie den Inhalt dieses Ordners basierend auf dem Betriebssystem.

  • Windows XP und Server 2003 –%userprofile%\Local Settings\Apps\2.0\*.*
  • Windows Vista und Server 2008 und höher –%userprofile%\AppData\Local\Apps\2.0\*.*

Durch das Löschen dieser Dateien werden die Informationen für alle installierten ClickOnce Anwendungen gelöscht. Sie werden neu installiert, wenn ihre Verknüpfung oder URIs (Uniform Resource Identifiers) das nächste Mal verwendet werden.

Es ist nicht erforderlich, die Registrierungsdaten zu löschen. Zur Referenz befindet sich die ClickOnce Registrierungsdaten in HKEY_CURRENT_USER\Software\Classes\Software\Microsoft\Windows\CurrentVersion\Deployment\SideBySide\2.0 .