Seite kann nicht angezeigt werden, wenn Sie eine Verbindung über SSL herstellen

Dieser Artikel hilft Ihnen, das Problem zu beheben, bei dem die Seite nicht angezeigt werden kann, wenn Sie eine Verbindung über SSL herstellen.

Ursprüngliche Produktversion:   Internetinformationsdienste
Ursprüngliche KB-Nummer:   260096

Problembeschreibung

Wenn Sie eine Verbindung mit einem Computer herstellen, auf dem Internetinformationsdienste (IIS) mit Secure Socket Layer (SSL) ausgeführt wird, kann die folgende Fehlermeldung auftreten:

Die Seite kann nicht angezeigt werden.
Die gesuchte Seite ist derzeit nicht verfügbar. Auf der Website treten möglicherweise technische Schwierigkeiten auf, oder Sie müssen Ihre Browsereinstellungen anpassen.

Diese Website ist in der Regel die zweite Website auf dem Server. Die Verbindung mit der Website über HTTP funktioniert ordnungsgemäß.

Ursache

Diese Fehlermeldung kann auftreten, wenn SIE SSL auf der Standardwebsite festgelegt haben, das Zertifikat entfernen und dann versuchen, es auf einer zweiten Website einzurichten.

Wenn Sie einen netstat -an Befehl ausführen, können Sie sehen, dass ein Dienst an Port 443 lauscht, Sie können jedoch keine Verbindung damit herstellen. Dies wird durch eine neue Implementierung in IIS-Versionen 5.0 und höher mit dem Namen Socketpooling verursacht.

Lösung

Hinweis

Im Sinne dieses Artikels werden zwei Websites installiert: die Standardwebsite und die Verwaltungswebsite. Standardmäßig ist SSL auf der Standardwebsite aktiviert.

  1. Öffnen Sie die Security Eigenschaften für die Standardwebsite, und wählen Sie dann Serverzertifikat aus.
  2. Klicken Sie im Assistenten auf "Vorhandenes Zertifikat zuweisen", und wählen Sie dann ein Zertifikat aus der Liste aus.
  3. Klicken Sie nach Abschluss des Assistenten auf die Registerkarte "Website" und dann auf "Erweitert".
  4. Löschen Sie alle Einträge, die im SSL-Fenster aufgeführt sind.
  5. Klicken Sie erneut auf "Serverzertifikat", klicken Sie auf "Aktuelles Zertifikat entfernen", und klicken Sie auf "OK".
  6. Klicken Sie in der Microsoft Management Console (MMC) mit der rechten Maustaste auf den Computernamen, und klicken Sie dann auf "IIS neu starten".

Sie sollten jetzt in der Lage sein, über SSL eine Verbindung mit dem Server herzustellen.

Problemumgehung

Wenn Sie die IIS-Dienste neu starten, wird die Fehlermeldung möglicherweise behoben. Wenn dies nicht der Typ ist, führen Sie die Schritte im Abschnitt "Lösung" dieses Artikels aus.

Weitere Informationen

Nachdem SSL auf einem IIS-Webserver aktiviert wurde, beginnt der IIS-Dienst mit dem Überwachen aller verwendeten und nicht verwendeten IP-Adressen an den Ports 80 und 443. Bei Multi-IP-Adressservern sollten Sie dieses Feature deaktivieren. Dieses Feature wurde dem Produkt zur Leistungsverbesserung hinzugefügt.

Dieses Problem tritt in der Regel auf, wenn Sie versuchen, SSL auf der Verwaltungswebsite einzurichten. IIS findet die SSL-Einstellungen für die Standardwebsite und lauscht an Port 443. Die Standardwebsite verfügt jedoch nicht über ein Zertifikat, das dieser Website entspricht. Daher kann keine Verbindung hergestellt werden, weshalb ein Server an Port 443 lauscht, aber keine Verbindung mit dem Standort herstellen kann.

Schritte zum Reproduzieren dieses Verhaltens

  1. Erstellen Sie auf einem Computer mit der Standardwebsite und der Verwaltungswebsite ein Zertifikat, und legen Sie es dann auf der Standardwebsite fest. Lassen Sie den SSL-Port auf 443.
  2. Klicken Sie in den Standardeigenschaften der Website auf die Registerkarte "Sicherheit", und klicken Sie dann auf "Serverzertifikat".
  3. Klicken Sie auf "Aktuelles Zertifikat entfernen" und dann auf "OK".
  4. Klicken Sie auf der Verwaltungswebsite auf "Serverzertifikat", wählen Sie ein Zertifikat aus, und wählen Sie dann ein Zertifikat aus der Liste aus.
  5. Stellen Sie sicher, dass der Port 443 ist.
  6. Versuchen Sie, eine Verbindung mit der Verwaltungswebsite über SSL ( https://localmachine ) herzustellen. Sie benötigen die Portnummer der Website nicht, da SSL jetzt auf Port 443 lauscht.
  7. Die Seite kann nicht angezeigt werden Fehler tritt im Browser auf.