Fehler beim Ändern der Identität eines Anwendungspools mithilfe des IIS-Managers von einem Remotecomputer: Keyset ist nicht vorhanden
In diesem Artikel wird der Fehler "Keyset nicht vorhanden" behoben. Der Fehler tritt auf, wenn Sie die Identität eines Anwendungspools mithilfe von Microsoft-Internetinformationsdienste (IIS)-Manager von einem Remotecomputer ändern.
Ursprüngliche Produktversion: Windows Server 2008, Windows Server 2008 R2
Ursprüngliche KB-Nummer: 977754
Problembeschreibung
Stellen Sie sich folgendes Szenario vor:
- Auf einem Server, auf dem Windows Server 2008 oder Windows Server 2008 R2 ausgeführt wird, aktivieren Sie die Remoteverwaltung für IIS.
- Auf dem Server sind mehrere Anwendungspools in IIS konfiguriert.
- Einer der Anwendungspools ist für die Verwendung der benutzerdefinierten Benutzeridentität konfiguriert.
- Sie verwenden den IIS-Manager, um von einem Remotecomputer aus eine Verbindung mit dem Server als Administrator herzustellen.
Wenn Sie in diesem Szenario versuchen, die Identität eines beliebigen Anwendungspools zu ändern, wird die folgende Fehlermeldung angezeigt:
Beim Ausführen dieses Vorgangs ist ein Fehler aufgetreten.
Details:
Keyset ist nicht vorhanden (Ausnahme von HRESULT: 0x80090016)
Ursache
Das LOKALE DIENSTkonto ist das Dienstkonto des IIS-Webverwaltungsdienst (auch bekannt als WMSvc). Dieses Problem tritt auf, weil das LOCAL SERVICE-Konto keinen Lesezugriff auf den iisWasKey Schlüssel hat, der sich im Ordner %ALLUSERSPROFILE%\Microsoft\Crypto\RSA\MachineKeys befindet.
Hier ist der Dateiname des iisWasKey Schlüssels:
76944fb33636aeddb9590521c2e8815a_GUID
Lösung
Führen Sie die folgenden Schritte aus, um dieses Problem zu beheben:
- Suchen Sie den
%ALLUSERSPROFILE%\Microsoft\Crypto\RSA\MachineKeysOrdner. - Klicken Sie mit der rechten Maustaste auf die datei 76944fb33636aeddb9590521c2e8815a_GUID, und wählen Sie dann Eigenschaften aus.
- Wählen Sie die Registerkarte "Sicherheit" und dann "Bearbeiten" aus. Wenn Sie gefragt werden, ob Sie den Vorgang fortsetzen möchten, wählen Sie "Weiter" aus. Anschließend wird die Liste der Gruppennamen und Benutzernamen, die Zugriff auf diese Schlüsseldatei haben, im Dialogfeld Berechtigungen angezeigt.
- Wählen Sie Hinzufügen aus. Anschließend wird das Dialogfeld "Benutzer, Computer, Dienstkonten oder Gruppen auswählen" angezeigt.
- Geben Sie LOCAL SERVICE ein, und wählen Sie dann "Namen überprüfen" aus.
- Wählen Sie OK aus.
- Wählen Sie in der Gruppen- oder Benutzernamenliste LOCAL SERVICE aus. Stellen Sie sicher, dass das Kontrollkästchen Lesen in der Liste "Berechtigungen für LOKALEN DIENST" aktiviert ist.
- Wählen Sie OK aus.
Weitere Informationen
Dieses Problem wurde in Windows Server 2008 Service Pack 2 behoben.