Fehler beim Importieren einer SSL-PFX-Datei in den persönlichen Zertifikatspeicher des lokalen Computers mithilfe des IIS-Managers

Dieser Artikel hilft Ihnen bei der Behebung eines Fehlers, der auftritt, wenn Sie versuchen, eine SSL-Datei (Secure Sockets Layer) mit privatem Schlüsselzertifikat (PFX) mithilfe des Microsoft-Internetinformationsdienste -Managers (IIS)-Managers in den persönlichen Zertifikatspeicher des lokalen Computers zu importieren.

Ursprüngliche Produktversion:   Internetinformationsdienste
Ursprüngliche KB-Nummer:   919074

Wichtig

Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Sie sollten eine Sicherungskopie der Registrierung erstellen, bevor Sie die Registrierung bearbeiten. Sie müssen wissen, wie die Registrierung wiederhergestellt werden kann, wenn ein Problem auftritt. Weitere Informationen zum Sichern, Wiederherstellen und Ändern der Registrierung finden Sie unter Windows Registrierungsinformationen für fortgeschrittene Benutzer.

Problembeschreibung

Sie versuchen, eine SSL-PFX-Datei in den persönlichen Zertifikatspeicher des lokalen Computers zu importieren. In dieser Situation kann eines der folgenden Symptome auftreten, je nachdem, wie Sie versuchen, die PFX-Datei zu importieren:

  • Wenn Sie versuchen, die PFX-Datei mithilfe des IIS-Managers zu importieren, wird die folgende Fehlermeldung angezeigt:

    Pfx-Datei kann nicht importiert werden. Entweder haben Sie ein falsches Kennwort für diese Datei eingegeben, oder das Zertifikat ist abgelaufen.

  • Wenn Sie versuchen, die PFX-Datei mithilfe des MMC-Snap-Ins (Certificates Microsoft Management Console) zu importieren, wird die folgende Fehlermeldung angezeigt:

    Ein interner Fehler ist aufgetreten. Dies kann entweder sein, dass auf das Benutzerprofil nicht zugegriffen werden kann, oder der private Schlüssel, den Sie importieren, erfordert möglicherweise einen kryptografischen Dienstanbieter, der nicht auf Ihrem System installiert ist.

Ursache

Dieses Verhalten tritt auf, wenn mindestens eine der folgenden Bedingungen zutrifft:

  • Sie verfügen über unzureichende Berechtigungen für den Zugriff auf den DriveLetter:\Documents and Settings\All Users\Application Data\Microsoft\Crypto\RSA\MachineKeys Ordner auf dem Computer.
  • Es ist ein Registrierungsunterschlüssel eines Drittanbieters vorhanden, der verhindert, dass IIS auf den Kryptografiedienstanbieter zugreift.
  • Sie sind über eine Terminaldienstesitzung remote am Computer angemeldet. Und das Benutzerprofil wird nicht lokal auf dem Server gespeichert, auf dem Terminaldienste aktiviert sind.

Um dieses Verhalten zu beheben, verwenden Sie je nach Situation eine der folgenden Lösungen.

Auflösung 1: Festlegen der richtigen Berechtigungen für den Ordner "MachineKeys"

Wenn Sie nicht über ausreichende Berechtigungen für den Zugriff auf den DriveLetter:\Documents and Settings\All Users\Application Data\Microsoft\Crypto\RSA\MachineKeys Ordner auf dem Computer verfügen, legen Sie die richtigen Berechtigungen für den Ordner fest.

Weitere Informationen zum Festlegen der Berechtigungen für den MachineKeys-Ordner finden Sie unter "Standardberechtigungen" für die MachineKeys-Ordner.

Lösung 2: Löschen des Registrierungsunterschlüssels eines Drittanbieters

Warnung

Die unsachgemäße Verwendung des Registrierungs-Editors oder einer anderen Methode kann schwerwiegende Probleme verursachen. Diese Probleme können eine Neuinstallation des Betriebssystems erforderlich machen. Microsoft gibt keinerlei Garantien dafür ab, dass diese Probleme behoben werden können. Das Ändern der Registrierung erfolgt auf eigenes Risiko.

Wenn der folgende Registrierungsunterschlüssel vorhanden ist, löschen Sie ihn:
HKEY_USERS\Default\Software\Microsoft\Cryptography\Providers\Type 001

Nachdem Sie diesen Registrierungsunterschlüssel gelöscht haben, kann IIS auf den Kryptografiedienstanbieter zugreifen.

Lösung 3: Store des Benutzerprofils für die Terminaldienste-Sitzung lokal

Wenn das Benutzerprofil für die Terminaldienstesitzung nicht lokal auf dem Server gespeichert ist, auf dem Terminaldienste aktiviert sind, verschieben Sie das Benutzerprofil auf den Server, auf dem Terminaldienste aktiviert sind. Alternativ können Sie Roamingprofile verwenden.

Status

Es handelt sich hierbei um ein beabsichtigtes Verhalten.