Fehler beim Versuch, ein Zertifikat mithilfe des IIS 7.0-Managers zu installieren

Dieser Artikel hilft Ihnen bei der Behebung des Problems, bei dem ein unerwarteter Laufzeitfehler ausgelöst werden kann, wenn Sie versuchen, ein Zertifikat mithilfe von Microsoft-Internetinformationsdienste (IIS) 7.0 Manager zu installieren.

Ursprüngliche Produktversion:   Windows Server 2008 Service Pack 2, Internetinformationsdienste 7.0
Ursprüngliche KB-Nummer:   959216

Problembeschreibung

Wenn Sie versuchen, ein Zertifikat aus einer PKCS#7 Datei mithilfe des IIS 7.0-Managers zu installieren, wird möglicherweise eine der folgenden Fehlermeldungen angezeigt:

  • Fehlermeldung 1

    Die dieser Zertifikatdatei zugeordnete Zertifikatanforderung kann nicht gefunden werden. Eine Zertifikatanforderung muss auf dem Computer abgeschlossen werden, auf dem sie erstellt wurde.

  • Fehlermeldung 2

    Beim Ausführen dieses Vorgangs ist ein Fehler aufgetreten.
    Details: CertEnroll::CX509Enrollment::p_InstallResponse: ASN1 bad tag value met.
    0x8009310b (ASN:276)

Hinweis

Das Zertifikat wird trotz der Fehlermeldung ordnungsgemäß installiert.

Ursache

Dieses Problem tritt auf, weil der IIS-Manager während der Installation einen Nachschlagevorgang durchführt, um nach einem Anzeigenamen des Zertifikats zu suchen. Der Code, der diesen Nachschlagevorgang durchführt, fehlt jedoch diesen speziellen Fall, und er weiß nicht, wie der Anzeigename eines Zertifikats in einer Datei abgerufen PKCS#7 wird. Deshalb schlägt der Nachschlagevorgang fehl, und Sie erhalten die Fehlermeldung.

Lösung

Um dieses Problem zu beheben, fügen Sie dem Zertifikat einen Anzeigenamen hinzu. Führen Sie die folgenden Schritte aus, um dieses Problem zu beheben:

  1. Wählen Sie "Start", "Ausführen" aus, geben Sie "certmgr.msc" ein, und wählen Sie dann "OK" aus.
  2. Wählen Sie "Datei", "Span-Ins hinzufügen/entfernen" aus.
  3. Wählen Sie "Zertifikate" und dann "Hinzufügen" und dann "OK" aus.
  4. Wählen Sie "Computerkonto" und dann "Weiter" und dann "Fertig stellen" aus.
  5. Wählen Sie OK aus.
  6. Erweitern Sie Zertifikate (lokaler Computer) und "Persönlich" und dann "Zertifikate".
  7. Klicken Sie mit der rechten Maustaste auf das Zertifikat, und wählen Sie dann Eigenschaften aus.
  8. Bearbeiten Sie das Feld "Anzeigename".

Weitere Informationen

Dieses Problem soll in Windows Server 2008 Service Pack 3 behoben werden.