Fehler "Beim Kerberos-Subsystem ist ein Fehler aufgetreten, der SQL Server instance Name muss mit dem Computernamen identisch sein" bei der Installation von Microsoft Dynamics CRM
In diesem Artikel können Sie das Problem beheben, bei dem der Fehler Das Kerberos-Subsystem ist auf einen Fehler gestoßen, Der SQL Server instance Name muss mit dem Computernamen identisch sein.
Gilt für: Microsoft Dynamics CRM 2011
Ursprüngliche KB-Nummer: 2841195
Problembeschreibung
Bei der Installation von Microsoft Dynamics CRM 2011 Server kann der folgende Fehler auftreten:
Der SQL Server instance Name muss mit dem Computernamen übereinstimmen.
Ursache
Der Computername von Microsoft SQL Server wurde geändert, nachdem die Microsoft-SQL Server installiert wurde.
Lösung
Verwenden Sie die folgenden Schritte, um die Fehlermeldung zu beheben:
Wählen Sie auf dem Microsoft SQL-Server die Option Start aus, und öffnen Sie SQL Server Management Studio.
Stellen Sie eine Verbindung mit dem Server und instance her, der die Microsoft Dynamics CRM Datenbanken enthält.
Wählen Sie auf der Symbolleiste Neue Abfrage aus.
Geben Sie die beiden folgenden Zeilen ein, und wählen Sie dann auf der Symbolleiste die Schaltfläche Ausführen aus.
Select @@SERVERNAME Select * from sysservers
Wenn Sie die Ergebnisse beobachten, wird ein Konflikt angezeigt.
Löschen Sie die vorherigen Zeilen, und geben Sie die zeile darunter ein. Sie müssen durch den
<servername>
Namen in der Spalte svrname aus Schritt 4 ersetzen.sp_dropserver '<servername>'
Löschen Sie die vorherige Zeile, und geben Sie die zeile darunter ein. Sie müssen den
<servername>
durch den Wert vonselect @@servername
aus Schritt 4 ersetzen.sp_addserver '<servername>', 'local'
Geben Sie die beiden folgenden Zeilen ein, und wählen Sie dann auf der Symbolleiste die Schaltfläche Ausführen aus:
sp_helpserver select @@servername
Starten Sie zuletzt den SQL Server-Dienst für diese instance von SQL neu.