Configuration Manager console displays out-of-date Endpoint Protection Definition version and last update time

Dieser Artikel enthält eine Lösung für das Problem, dass die Configuration -Manager-Konsole veraltete Endpoint Protection-Definitionsversion und die uhrzeit des letzten Updates anzeigt, während auf den Clients die neueste Version der Definition installiert ist.

Ursprüngliche Produktversion:   Configuration Manager
Ursprüngliche KB-Nummer:   4528414

Problembeschreibung

Wenn Sie Endpoint Protection zusammen mit Configuration Manager verwenden, werden die folgenden Probleme auftreten:

  • In der Configuration Manager-Konsole öffnen Sie den Arbeitsbereich "Objekte und Kompatibilität" unter dem Knoten "Geräte". In diesem Arbeitsbereich sehen Sie, dass in den Spalten "Endpoint Protection Definition Last Version" und "Endpoint Protection Last Update Time" veraltete Werte für einige Geräte angezeigt werden. Die Clients zeigen jedoch an, dass sie die neuesten Versionen angewendet haben.
  • Der Thementyp 1901 (State_Topictype_Ep_Am_Health) wird auf den Clients nicht in "StateMessage.log" protokolliert.
  • Die folgenden Fehlermeldungen werden in ExternalEventAgent.log auf den Clients protokolliert:

PARSE XML to get the query String SELECT * FROM MSFT_MPComputerStatus
...
Führen Sie alle Initialisierungsaktionen für Richtlinienänderung von CCM_ExternalEventConfig.
Der Registrierungsschlüssel "SOFTWARE\Microsoft\CCM\ExternalEventAgent\Criterias\Entschlüsselung\ComputerStatusStateMessage\SyncStatus mit Fehler" konnte nicht 0x80070002 .
Der Registrierungsschlüssel "SOFTWARE\Microsoft\CCM\ExternalEventAgent\Criterias\Entschlüsselung\ComputerStatusStateMessage mit Fehler" konnte nicht 0x80070002 .
Fehler beim Laden der vorherigen Werte der Bewertungskriterien ComputerStatusStateMessage mit 0x80070002.
Der Registrierungsschlüssel "SOFTWARE\Microsoft\CCM\ExternalEventAgent\Criterias\Entschlüsselung\InfectionStatusStateMessage\SyncStatus" konnte nicht mit dem Fehler "0x80070002" geöffnet werden.
Der Registrierungsschlüssel "SOFTWARE\Microsoft\CCM\ExternalEventAgent\Criterias\Entschlüsselung\InfectionStatusStateMessage mit Fehler" konnte nicht 0x80070002 .
Fehler beim Laden der vorherigen Werte der Bewertungskriterien "InfectionStatusStateMessage" mit 0x80070002.

Darüber hinaus sind die folgenden Registrierungsschlüssel auf dem Client nicht vorhanden:

  • HKLM\SOFTWARE\Microsoft\CCM\ExternalEventAgent\Criterias\Differentiation\ComputerStatusStateMessage
  • HKLM\SOFTWARE\Microsoft\CCM\ExternalEventAgent\Criterias\Differentiation\InfectionStatusStateMessage

Ursache

Dieses Problem tritt auf, weil die Instanz der MSFT_MpComputerStatus Klasse nicht im root\Microsoft\ProtectionManagement Namespace vorhanden ist. Der Client fragt diese Instanz ab, um die zugehörigen Registrierungsschlüssel zu füllen.

Lösung

Führen Sie den folgenden Befehl auf den betroffenen Clientcomputern aus, um das Problem zu beheben, um den Anbieter erneut ProtectionManagement zu registrieren:

Register-CimProvider -ProviderName ProtectionManagement -Namespace root\Microsoft\protectionmanagement -Path <path of ProtectionManagement.dll> -Impersonation True -HostingModel LocalServiceHost -SupportWQL -ForceUpdate

Hinweis

In diesem Befehl <path of ProtectionManagement.dll> ist dies der Platzhalter für den Pfad ProtectionManagement.dll. Zum Beispiel:
C:\ProgramData\Microsoft\Windows Defender\Platform\4.18.1907.4-0\ProtectionManagement.dll

Nachdem Sie diesen Befehl ausgeführt haben, sind die folgenden Bedingungen erfüllt:

  • Die Instanz von MSFT_MpComputerStatus wird im root\Microsoft\ProtectionManagement Namespace aufgefüllt.
  • Der Thementyp 1901 wird in StateMessage.log protokolliert.
  • Die betroffenen Werte in der Configuration Manager-Konsole werden aktualisiert.

Weitere Informationen

Windows Defender können Ihnen helfen, die Ursache dieses Problems zu identifizieren. Der folgende Protokollausschnitt weist beispielsweise auf das Vorhandensein einer anderen Antivirenlösung hin:

2019-09-04T08:00:11.166Z [Minifilter] Zugriff auf Datei verweigert: \ProgramData\Microsoft\Windows Defender\Platform\4.18. 1907.4-0\Powershell \ MSFT_MpComputerStatus.cdxml, from process '\Device\HarddiskVolume2\Program Files (x86)\Symantec \ Symantec Endpoint Protection\14.0.3929.1200.105\Bin\ccSvcHst.exe' (PID: 3408)

Führen Sie zum Sammeln von Diagnoseprotokollen für Windows Defender die Schritte unter "Erfassen von Diagnosedaten zur Updatekonformität für die Windows Defender AV Assessment" aus.

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