Unerwarteter Fehler beim Ausführen des Auftrags, wenn die DPM 2010-Konsistenzprüfung fehlschlägt

Dieser Artikel hilft Ihnen bei der Behebung eines Problems, bei dem die Konsistenzprüfung auf dem primären Data Protection Manager (DPM)-Server fehlschlägt und der Fehler "Zugriff verweigert" (0x80070005) angezeigt wird.

Ursprüngliche Produktversion:   System Center Data Protection Manager 2010
Ursprüngliche KB-Nummer:   2506326

Problembeschreibung

Der Agentstatus auf dem primären System Center Data Protection Manager (DPM) 2010-Server wird für alle Agents als "OK" angezeigt. Es kann jedoch eines oder mehrere der folgenden Symptome auftreten:

  • Die Konsistenzprüfung auf dem primären DPM-Server schlägt mit dem folgenden Fehler fehl:

    Während der Ausführung des Auftrags ist ein unerwarteter Fehler aufgetreten. (ID 104 Details: Zugriff verweigert (0x80070005))

  • Die Erstellung des Wiederherstellungspunkts schlägt mit dem folgenden Fehler fehl:

    DpM konnte nicht mit dem Schutz-Agent kommunizieren, da der Zugriff <Server Name> verweigert wurde. (ID 42 Details: Der Name des Zielprincipals ist falsch (0x80090322))

  • Auf dem sekundären DPM-Server wird der Agentstatus für den primären Server als nicht verfügbar angezeigt.

    Detaillierter Fehlercode: Ein sicherheitspaketspezifischer Fehler ist aufgetreten (0x80070721 Der Schutz-Agent-Vorgang ist fehlgeschlagen, da DPM nicht mit dem Schutz-Agent-Dienst am kommunizieren <Primary DPM Server Name> konnte.
    Detaillierter Fehlercode: Ein sicherheitspaketspezifischer Fehler ist aufgetreten (0x80070721)

Ursache

In einer primären – sekundären Konfiguration von DPM 2010 wird das Dienstkonto des DPMRA auf dem primären DPM-Server vom lokalen Systemkonto in ein Domänenbenutzerkonto geändert, das auch Teil der lokalen Administratorgruppe ist.

Lösung

Um dieses Problem zu beheben, sollten die DpM-Dienste so konfiguriert werden, dass sie mit dem lokalen Systemkonto auf dem primären DPM-Server ausgeführt werden.