Druckerliste leer in der Druckverwaltungskonsole

Dieser Artikel bietet eine Lösung für ein Problem, bei dem die Liste der Drucker leer ist, wenn Sie die Drucker auf einem Remoteserver über die Druckverwaltungskonsole (Print Management Console, PMC) anzeigen.

Ursprüngliche Produktversion:   Windows Server 2012 R2
Ursprüngliche KB-Nummer:   2253813

Problembeschreibung

Beim Anzeigen der Drucker auf einem Remoteserver über die Druckverwaltungskonsole (Print Management Console, PMC) ist die Liste der Drucker leer, die Liste der Treiber und/oder Ports wird jedoch möglicherweise richtig angezeigt.

Pingen des Client-FQDN (z. B. ) vom Druckserver führt zu einem Fehler bei client.subdomain.domain.com der Namensauflösung.

Ursache

Das Clientsystem (das System, auf dem PMC ausgeführt wird) verfügt nicht über einen DNS-A-Eintrag (Forward-Lookup), oder der Eintrag ist falsch.

Lösung

Fügen Sie einen DNS-A-Eintrag für das System hinzu, auf dem PMC ausgeführt wird, oder korrigieren Sie den vorhandenen Eintrag.

Weitere Informationen

Möglicherweise sehen Sie Folgendes request / response in einer Netzwerk-Ablaufverfolgung. Der Grund, warum dies in der Netzwerkverfolgung möglich ist oder nicht, liegt daran, dass die Antwort zwischengespeichert wird, wenn zuvor versucht wurde, die Namensauflösung auf dem Server zu speichern. Um den Cache zu löschen, verwenden ipconfig /flushdns Sie die Ablaufverfolgung, und erfassen Sie sie.

RpcRemoteFindFirstPrinterChangeNotificationEx Anforderung, Lokaler Computer = \\servername.company.com , Drucker lokal = nnnn
RpcRemoteFindFirstPrinterChangeNotificationEx Antwort, Status = RPC_S_SERVER_UNAVAILABLE

In einer Netzwerkverfolgung vom Druckserver wird möglicherweise eine DNS-Abfrage initiiert und dann eine Antwort empfangen:

DNS:QueryId = 0xB19B, QUERY (Standardabfrage), Abfrage nach dem Typ servername.company.com "Host-Addr" im Klassen-Internet
DNS:QueryId = 0xB19B, QUERY (Standardabfrage), Antwort - Name Error

Hinweis

Die Kurznamenauflösung für den Clientnamen kann entweder über die Suchlisten des DNS-Suffixes (wenn sich der DNS-Eintrag in der falschen Domäne befindet) oder WINS funktionieren. Versuchen Sie, den vollqualifizierten Domänennamen des Clients auf dem Druckserver zu suchen. Intern verwendet die Spooler den FQDN zum Rückruf an den Client. Wenn der FQDN also nicht aufgelöst wird, führt der Rückruf zu einem Fehler.