Remote DebuggingRemote Debugging

Sie können eine Visual Studio-Anwendung debuggen, die auf einem anderen Computer bereitgestellt wurde.You can debug a Visual Studio application that has been deployed on a different computer. Dazu verwenden Sie den Visual Studio Remote Debugger.To do so, you use the Visual Studio remote debugger.

Ausführliche Anweisungen zum Remotedebuggen finden Sie in den folgenden Themen.For in-depth instructions on remote debugging, see these topics.

SzenarioScenario LinkLink
Azure App ServiceAzure App Service Remotedebuggen von ASP.NET Core in IIS in Azure in Visual Studio oder Debuggen von aktiven ASP.NET Azure-Apps mit dem Momentaufnahmedebugger für Visual Studio EnterpriseRemote debug ASP.NET on Azure or, for Visual Studio Enterprise, the Snapshot Debugger
Azure VMAzure VM Remotedebuggen von ASP.NET in AzureRemote debug ASP.NET on Azure
Azure Service FabricAzure Service Fabric Debuggen einer Azure Service Fabric-AnwendungDebug an Azure Service Fabric application
ASP.NETASP.NET Remotedebuggen von ASP.NET Core oder Remotedebuggen von ASP.NETRemote debug ASP.NET Core or Remote Debug ASP.NET
C# oder Visual BasicC# or Visual Basic Remotedebuggen eines C#- oder Visual Basic-ProjektsRemote debug a C# or Visual Basic project
C++C++ Remotedebuggen eines C++-ProjektsRemote debug a C++ project
Universelle Windows-Apps (UWP)Universal Windows Apps (UWP) Ausführen von UWP-Apps auf einem Remotecomputer oder Debuggen eines installierten App-PaketsRun UWP apps on a remote machine or Debug an installed app package

Wenn Sie den Remotedebugger nur herunterladen und installieren möchten und keine weiteren Anweisungen für Ihr Szenario benötigen, führen Sie die Schritte in diesem Artikel aus.If you just want to download and install the remote debugger and don't need any additional instructions for your scenario, follow the steps in this article.

Herunterladen und Installieren der RemotetoolsDownload and Install the remote tools

Laden Sie über die Links in der folgenden Tabelle die richtige Version der Remotetools herunter, und installieren Sie sie nicht auf dem Visual Studio-Computer, sondern auf dem Remotegerät oder -server, auf dem Sie das Debugging durchführen möchten.On the remote device or server that you want to debug on, rather than the Visual Studio machine, download and install the correct version of the remote tools from the links in the following table.

  • Laden Sie die aktuellen Remotetools für Ihre Visual Studio-Version herunter.Download the most recent remote tools for your version of Visual Studio. Die aktuelle Version der Remotetools ist mit früheren Versionen von Visual Studio kompatibel, frühere Versionen der Remotetools sind jedoch nicht mit neueren Visual Studio-Versionen kompatibel.The latest remote tools version is compatible with earlier Visual Studio versions, but earlier remote tools versions aren't compatible with later Visual Studio versions. (Beispiel: Laden Sie bei Verwendung von Visual Studio 2017 das aktuelle Update der Remotetools für Visual Studio 2017 herunter.(For example, if you are using Visual Studio 2017, download the latest update of the remote tools for Visual Studio 2017. Laden Sie in diesem Szenario nicht die Remotetools für Visual Studio 2019 herunter.)In this scenario, do not download the remote tools for Visual Studio 2019.)
  • Laden Sie die Remotetools herunter, die die gleiche Architektur wie der Computer aufweisen, auf dem Sie sie installieren.Download the remote tools with the same architecture as the machine you're installing them on. Wenn Sie beispielsweise eine 32-Bit-App auf einem Remotecomputer mit einem 64-Bit-Betriebssystem debuggen möchten, installieren Sie die 64-Bit-Remotetools.For example, if you want to debug a 32-bit app on a remote computer running a 64-bit operating system, install the 64-bit remote tools.
VersionVersion LinkLink HinweiseNotes
Visual Studio 2019Visual Studio 2019 RemotetoolsRemote tools Kompatibel mit allen Visual Studio 2019-Versionen.Compatible with all Visual Studio 2019 versions. Laden Sie die Version herunter, die Ihrem Gerätebetriebssystem entspricht (x86, x64 oder ARM64).Download the version matching your device operating system (x86, x64, or ARM64). Wenn Sie Unterstützung beim Herunterladen der Remotetools unter Windows Server benötigen, lesen Sie die Informationen unter Entsperren des Dateidownloads.On Windows Server, see Unblock the file download for help downloading the remote tools.
Visual Studio 2017Visual Studio 2017 RemotetoolsRemote tools Kompatibel mit allen Visual Studio 2017-Versionen.Compatible with all Visual Studio 2017 versions. Laden Sie die Version herunter, die Ihrem Gerätebetriebssystem entspricht (x86, x64 oder ARM64).Download the version matching your device operating system (x86, x64, or ARM64). Wenn Sie Unterstützung beim Herunterladen der Remotetools unter Windows Server benötigen, lesen Sie die Informationen unter Entsperren des Dateidownloads.On Windows Server, see Unblock the file download for help downloading the remote tools.
Visual Studio 2015Visual Studio 2015 RemotetoolsRemote tools Remotetools für Visual Studio 2015 stehen auf My.VisualStudio.com zur Verfügung.Remote tools for Visual Studio 2015 are available from My.VisualStudio.com. Treten Sie bei entsprechender Aufforderung dem kostenlosen Programm Visual Studio Dev Essentials bei, oder melden Sie sich mit Ihrer Visual Studio-Abonnement-ID an.If prompted, join the free Visual Studio Dev Essentials program, or sign in with your Visual Studio subscription ID. Wenn Sie Unterstützung beim Herunterladen der Remotetools unter Windows Server benötigen, lesen Sie die Informationen unter Entsperren des Dateidownloads.On Windows Server, see Unblock the file download for help downloading the remote tools.
Visual Studio 2013Visual Studio 2013 RemotetoolsRemote tools Downloadseite in der Visual Studio 2013-DokumentationDownload page in Visual Studio 2013 documentation
Visual Studio 2012Visual Studio 2012 RemotetoolsRemote tools Downloadseite in der Visual Studio 2012-DokumentationDownload page in Visual Studio 2012 documentation
VersionVersion LinkLink HinweiseNotes
Visual Studio 2017Visual Studio 2017 RemotetoolsRemote tools Kompatibel mit allen Visual Studio 2017-Versionen.Compatible with all Visual Studio 2017 versions. Laden Sie die Version herunter, die Ihrem Gerätebetriebssystem entspricht (x86, x64 oder ARM64).Download the version matching your device operating system (x86, x64, or ARM64). Wenn Sie Unterstützung beim Herunterladen der Remotetools unter Windows Server benötigen, lesen Sie die Informationen unter Entsperren des Dateidownloads.On Windows Server, see Unblock the file download for help downloading the remote tools. Informationen zur aktuellen Version der Remotetools finden Sie in der Visual Studio 2019-Dokumentation.For the most recent version of the remote tools, open the Visual Studio 2019 doc.
Visual Studio 2015Visual Studio 2015 RemotetoolsRemote tools Remotetools für Visual Studio 2015 stehen auf My.VisualStudio.com zur Verfügung.Remote tools for Visual Studio 2015 are available from My.VisualStudio.com. Treten Sie bei entsprechender Aufforderung dem kostenlosen Programm Visual Studio Dev Essentials bei, oder melden Sie sich mit Ihrer Visual Studio-Abonnement-ID an.If prompted, join the free Visual Studio Dev Essentials program, or sign in with your Visual Studio subscription ID. Wenn Sie Unterstützung beim Herunterladen der Remotetools unter Windows Server benötigen, lesen Sie die Informationen unter Entsperren des Dateidownloads.On Windows Server, see Unblock the file download for help downloading the remote tools.
Visual Studio 2013Visual Studio 2013 RemotetoolsRemote tools Downloadseite in der Visual Studio 2013-DokumentationDownload page in Visual Studio 2013 documentation
Visual Studio 2012Visual Studio 2012 RemotetoolsRemote tools Downloadseite in der Visual Studio 2012-DokumentationDownload page in Visual Studio 2012 documentation

Sie können den Remotedebugger ausführen, indem Sie msvsmon.exe auf den Remotecomputer kopieren, statt die Remotetools zu installieren.You can run the remote debugger by copying msvsmon.exe to the remote computer, rather than installing the remote tools. Der Konfigurations-Assistent für den Remotedebugger (rdbgwiz.exe) ist jedoch nur verfügbar, wenn Sie die Remotetools installieren.However, the Remote Debugger Configuration Wizard (rdbgwiz.exe) is available only when you install the remote tools. Unter Umständen müssen Sie den Assistenten für die Konfiguration verwenden, wenn Sie den Remotedebugger als Dienst ausführen möchten.You may need to use the wizard for configuration if you want to run the remote debugger as a service. Weitere Informationen finden Sie unter (Optional) Konfigurieren des Remotedebuggers als Dienst.For more information, see (Optional) Configure the remote debugger as a service.

Hinweis

  • Verwenden Sie ARM64 (verfügbar mit der aktuellen Version der Remotetools) zum Debuggen von Windows 10-Apps auf ARM-Geräten.To debug Windows 10 apps on ARM devices, use ARM64, which is available with the latest version of the remote tools.
  • Zum Debuggen von Windows 10-Apps auf Windows RT-Geräten verwenden Sie ARM (nur im Download der Visual Studio 2015-Remotetools verfügbar).To debug Windows 10 apps on Windows RT devices, use ARM, which is available only in the Visual Studio 2015 remote tools download.

AnforderungenRequirements

Unterstützte BetriebssystemeSupported Operating Systems

Auf dem Remotecomputer muss eines der folgenden Betriebssysteme ausgeführt werden:The remote computer must be running one of the following operating systems:

  • Windows 10 (nicht Smartphones)Windows 10 (not phone)

  • Windows 8 oder 8.1 (nicht Windows Phone)Windows 8 or 8.1 (not phone)

  • Windows 7 Service Pack 1Windows 7 Service Pack 1

  • Windows Server 2016Windows Server 2016

  • Windows Server 2012 oder Windows Server 2012 R2Windows Server 2012 or Windows Server 2012 R2

  • Windows Server 2008 Service Pack 2, Windows Server 2008 R2 Service Pack 1Windows Server 2008 Service Pack 2, Windows Server 2008 R2 Service Pack 1

Hinweis

Windows Phone erfordert zum Debuggen eine USB-Verbindung (die Remotetools sind nicht erforderlich).Windows Phone requires a USB connection to debug (it does not require the remote tools).

Unterstützte HardwarekonfigurationenSupported Hardware Configurations

  • 1,6-GHz-Prozessor oder schneller1.6 GHz or faster processor

  • 1 GB RAM (1,5 GB bei Ausführung auf einem virtuellen Computer)1 GB of RAM (1.5 GB if running on a virtual machine)

  • 1 GB verfügbarer Festplattenspeicher1 GB of available hard disk space

  • Festplatte mit 5400 U/min5400-RPM hard drive

  • DirectX 9-kompatible Grafikkarte mit einer Auflösung von 1024 x 768 oder höherDirectX 9-capable video card running at 1024 x 768 or higher display resolution

NetzwerkkonfigurationNetwork configuration

Der Remotecomputer und der Visual Studio-Computer müssen über ein Netzwerk, eine Arbeitsgruppe oder eine Heimnetzgruppe verbunden bzw. mit einem Ethernetkabel direkt verbunden werden.The remote computer and the Visual Studio computer must be connected over a network, workgroup, or homegroup, or else connected directly through an Ethernet cable. Das Debuggen zwischen zwei über einen Proxy verbundenen Computern wird nicht unterstützt.Debugging between two computers connected through a proxy is not supported. Das Debuggen über eine Verbindung mit hoher Latenz oder niedriger Bandbreite, z. B. DFÜ-Internetverbindung oder Internetverbindung über mehrere Länder hinweg, wird nicht empfohlen und schlägt möglicherweise fehl oder weist eine unzureichende Geschwindigkeit auf.Debugging over a high latency or low bandwidth connection, such as dialup Internet, or over the Internet across countries is not recommended and may fail or be unacceptably slow.

(Optional) So führen Sie den Remotedebugger über eine Dateifreigabe aus(Optional) To run the remote debugger from a file share

Der Remotedebugger (msvsmon.exe) ist auf einem Computer mit Visual Studio Community, Professional oder Enterprise bereits installiert.You can find the remote debugger (msvsmon.exe) on a computer with Visual Studio Community, Professional, or Enterprise already installed. In einigen Szenarien ist die einfachste Möglichkeit zum Einrichten des Remotedebuggens das Ausführen des Remotedebuggers („msvsmon.exe“) aus einer Dateifreigabe.For some scenarios, the easiest way to set up remote debugging is to run the remote debugger (msvsmon.exe) from a file share. Informationen zu den Nutzungsbeschränkungen finden Sie auf der Hilfeseite des Remotedebuggers (Hilfe > Syntax im Remotedebugger).For usage limitations, see the remote debugger's Help page (Help > Usage in the remote debugger).

  1. Suchen Sie msvsmon.exe in dem Verzeichnis, das Ihrer Version von Visual Studio entspricht:Find msvsmon.exe in the directory matching your version of Visual Studio:

    Programme (x86)\Microsoft Visual Studio\2019\Enterprise\Common7\IDE\Remote Debugger\x86\msvsmon.exeProgram Files (x86)\Microsoft Visual Studio\2019\Enterprise\Common7\IDE\Remote Debugger\x86\msvsmon.exe

    Programme (x86)\Microsoft Visual Studio\2019\Enterprise\Common7\IDE\Remote Debugger\x64\msvsmon.exeProgram Files (x86)\Microsoft Visual Studio\2019\Enterprise\Common7\IDE\Remote Debugger\x64\msvsmon.exe

    Programme (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\Remote Debugger\x86\msvsmon.exeProgram Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\Remote Debugger\x86\msvsmon.exe

    Programme (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\Remote Debugger\x64\msvsmon.exeProgram Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\Remote Debugger\x64\msvsmon.exe

  2. Geben Sie den Ordner Remote Debugger auf dem Computer mit Visual Studio frei.Share the Remote Debugger folder on the Visual Studio computer.

  3. Führen Sie auf dem Remotecomputer msvsmon.exe aus dem freigegebenen Ordner aus.On the remote computer, run msvsmon.exe from the shared folder. Befolgen Sie die Setupanweisungen.Follow the setup instructions.

Tipp

Informationen zur Befehlszeileninstallation und Befehlszeilenreferenz finden Sie auf der Hilfeseite zu msvsmon.exe, indem Sie msvsmon.exe /? in die Befehlszeile auf dem Computer eingeben, auf dem Visual Studio installiert ist (oder wechseln Sie zu Hilfe > Syntax im Remotedebugger).For command line installation and command line reference, see the Help page for msvsmon.exe by typing msvsmon.exe /? in the command line on the computer with Visual Studio installed (or go to Help > Usage in the remote debugger).

Einrichten des RemotedebuggersSet up the remote debugger

  1. Suchen und starten Sie auf dem Remotecomputer im Menü Start den Remotedebugger.On the remote computer, find and start the Remote Debugger from the Start menu.

    Wenn Sie auf dem Remotecomputer nicht über Administratorberechtigungen verfügen, klicken Sie mit der rechten Maustaste auf die App Remotedebugger, und wählen Sie Als Administrator ausführen aus.If you don't have administrative permissions on the remote computer, right-click the Remote Debugger app and select Run as administrator. Starten Sie andernfalls die App auf normale Weise.Otherwise, just start it normally.

    Wenn Sie beabsichtigen, eine Verbindung mit einem Prozess herzustellen, der unter einem Administratorkonto oder einem anderen Benutzerkonto ausgeführt wird (z. B IIS), klicken Sie mit der rechten Maustaste auf die App Remotedebugger, und wählen Sie Als Administrator ausführen aus.If you are planning to attach to a process which is running as an administrator, or is running under a different user account (such as IIS), right-click the Remote Debugger app and select Run as administrator. Weitere Informationen finden Sie unter Ausführen des Remotedebuggers als Administrator.For more information, see Run the remote debugger as an administrator.

  2. Wenn Sie den Remotedebugger zum ersten Mal starten (oder bevor Sie ihn konfiguriert haben), wird das Dialogfeld Konfiguration für Remotedebugging angezeigt.The first time you start the remote debugger (or before you have configured it), the Remote Debugging Configuration dialog box appears.

    Konfiguration des RemotedebuggersRemote Debugger configuration

  3. Wenn die Windows-Webdienste-API nicht installiert ist (geschieht nur unter Windows Server 2008 R2), klicken Sie auf die Schaltfläche Installieren.If the Windows Web Services API is not installed, which happens only on Windows Server 2008 R2, select the Install button.

  4. Wählen Sie mindestens einen Netzwerktyp aus, für den Sie die Remotetools verwenden möchten.Select at least one network type you want to use the remote tools on. Wenn die Computer über eine Domäne verbunden sind, müssen Sie das erste Element auswählen.If the computers are connected through a domain, you must choose the first item. Wenn die Computer über eine Arbeitsgruppe oder eine Heimnetzgruppe verbunden sind, wählen Sie das zweite bzw. dritte Element aus.If the computers are connected through a workgroup or homegroup, choose the second or third item as appropriate.

  5. Wählen Sie Remotedebugging konfigurieren aus, um die Firewall zu konfigurieren und den Remotedebugger zu starten.Select Configure remote debugging to configure the firewall and start the remote debugger.

  6. Wenn die Konfiguration abgeschlossen ist, wird das Fenster Remotedebugger angezeigt.When configuration is complete, the Remote Debugger window appears.

    Fenster des RemotedebuggersRemote Debugger window

    Der Remotedebugger wartet nun auf eine Verbindung.The remote debugger is now waiting for a connection. Verwenden Sie den Servernamen und die Portnummer, die angezeigt werden, um die Remoteverbindungskonfiguration in Visual Studio festzulegen.Use the server name and port number shown to set the remote connection configuration in Visual Studio.

Um den Remotedebugger zu beenden, wählen Sie Datei > Beenden aus.To stop the remote debugger, select File > Exit. Sie können ihn über das Menü Start oder über die Befehlszeile neu starten:You can restart it from the Start menu, or from the command line:

<Remote debugger installation directory>\msvsmon.exe

Konfigurieren des RemotedebuggersConfigure the remote debugger

Sie können einige Aspekte der Konfiguration des Remotedebuggers ändern, nachdem Sie ihn zum ersten Mal gestartet haben.You can change some aspects of the configuration of the remote debugger after you have started it for the first time.

  • Wenn Sie Berechtigungen für andere Benutzer zum Herstellen einer Verbindung mit dem Remotedebugger hinzufügen müssen, wählen Sie Extras > Berechtigungen aus.If you need to add permissions for other users to connect to the remote debugger, choose Tools > Permissions. Sie müssen Administratorrechte besitzen, um Berechtigungen zu gewähren oder zu verweigern.You must have administrator privileges to grant or deny permissions.

    Wichtig

    Sie können den Remotedebugger unter einem anderen Benutzerkonto als dem auf dem Visual Studio-Computer verwendeten Benutzerkonto ausführen, allerdings müssen Sie das andere Benutzerkonto den Berechtigungen des Remotedebuggers hinzufügen.You can run the remote debugger under a user account that differs from the user account you are using on the Visual Studio computer, but you must add the different user account to the remote debugger's permissions.

    Sie können den Remotedebugger mit dem Parameter /allow <username> auch über die Befehlszeile starten: msvsmon /allow <username@computer> .Alternatively, you can start the remote debugger from the command line with the /allow <username> parameter: msvsmon /allow <username@computer>.

  • Wenn Sie den Authentifizierungsmodus oder die Portnummer ändern müssen oder einen Timeoutwert für die Remotetools angeben möchten, wählen Sie Extras > Optionen aus.If you need to change the Authentication mode or the port number, or specify a timeout value for the remote tools: choose Tools > Options.

    Eine Liste der standardmäßig verwendeten Portnummern finden Sie unter Remotedebugger-Portzuweisungen.For a listing of the port numbers used by default, see Remote Debugger Port Assignments.

    Warnung

    Sie haben die Möglichkeit, die Remotetools im Modus "Keine Authentifizierung" auszuführen, hiervon wird jedoch dringend abgeraten.You can choose to run the remote tools in No Authentication mode, but this mode is strongly discouraged. In diesem Modus gibt es keine Netzwerksicherheit.There is no network security when you run in this mode. Wählen Sie den Modus „Ohne Authentifizierung“ nur aus, wenn Sie sicher sind, dass das Netzwerk nicht durch bösartigen oder feindlichen Datenverkehr gefährdet ist.Choose the No Authentication mode only if you are sure that the network is not at risk from malicious or hostile traffic.

(Optional) Konfigurieren des Remotedebuggers als Dienst(Optional) Configure the remote debugger as a service

Zum Debuggen in ASP.NET und anderen Serverumgebungen müssen Sie den Remotedebugger als Administrator ausführen. Wenn Sie möchten, dass er immer ausgeführt wird, müssen Sie den Remotedebugger als Dienst ausführen.For debugging in ASP.NET and other server environments, you must either run the remote debugger as an Administrator or, if you want it always running, run the remote debugger as a service.

Wenn Sie den Remotedebugger als Dienst konfigurieren möchten, führen Sie die folgenden Schritte aus.If you want to configure the remote debugger as a service, follow these steps.

  1. Suchen Sie den Konfigurations-Assistenten für Remote Debugger (rdbgwiz.exe).Find the Remote Debugger Configuration Wizard (rdbgwiz.exe). (Dies ist eine vom Remotedebugger getrennte Anwendung.) Der Konfigurations-Assistent steht nur zur Verfügung, wenn Sie die Remotetools installieren,(This is a separate application from the Remote Debugger.) It is available only when you install the remote tools. und wird nicht mit Visual Studio installiert.It is not installed with Visual Studio.

  2. Starten Sie den Konfigurations-Assistenten.Start running the configuration wizard. Wenn die erste Seite angezeigt wird, klicken Sie auf Weiter.When the first page comes up, click Next.

  3. Aktivieren Sie das Kontrollkästchen Visual Studio 2015 Remote Debugger als Dienst ausführen .Check the Run the Visual Studio 2015 Remote Debugger as a service checkbox.

  4. Fügen Sie den Namen des Benutzerkontos und das Kennwort hinzu.Add the name of the user account and password.

    Sie müssen diesem Konto möglicherweise das Benutzerrecht Anmelden als Dienst hinzufügen (suchen Sie nach Lokale Sicherheitsrichtlinie („secpol.msc“) auf der Startseite oder im Fenster (oder geben Sie secpol an einer Eingabeaufforderung ein).You may need to add the Log on as a service user right to this account (Find Local Security Policy (secpol.msc) in the Start page or window (or type secpol at a command prompt). Wenn das Fenster angezeigt wird, doppelklicken Sie auf Zuweisen von Benutzerrechten, und suchen Sie dann Anmelden als Dienst im rechten Bereich.When the window appears, double-click User Rights Assignment, then find Log on as a service in the right pane. Doppelklicken Sie darauf.Double-click it. Fügen Sie das Benutzerkonto zum Fenster Eigenschaften hinzu, und klicken Sie auf OK.Add the user account to the Properties window and click OK). Klicken Sie auf Weiter.Click Next.

  5. Wählen Sie den Typ des Netzwerks aus, über das die Remotetools kommunizieren sollen.Select the type of network that you want the remote tools to communicate with. Es muss mindestens ein Netzwerktyp ausgewählt werden.At least one network type must be selected. Wenn die Computer über eine Domäne verbunden sind, sollten Sie das erste Element auswählen.If the computers are connected through a domain, you should choose the first item. Wenn die Computer über eine Arbeitsgruppe oder eine Heimnetzgruppe verbunden sind, sollten Sie das zweite bzw. dritte Element auswählen.If the computers are connected through a workgroup or homegroup, you should choose the second or third items. Klicken Sie auf Weiter.Click Next.

  6. Wenn der Dienst gestartet werden kann, wird Der Konfigurations-Assistent für Visual Studio Remote Debugger wurde erfolgreich abgeschlossen angezeigt.If the service can be started, you will see You have successfully completed the Visual Studio Remote Debugger Configuration Wizard. Wenn der Dienst nicht gestartet werden kann, wird Fehler beim Abschließen des Assistenten zum Konfigurieren von Visual Studio Remote Debugger angezeigt.If the service cannot be started, you will see Failed to complete the Visual Studio Remote Debugger Configuration Wizard. Die Seite bietet auch Tipps, wie Sie den Dienst ans Laufen bringen können.The page also gives some tips to follow to get the service to start.

  7. Klicken Sie auf Fertig stellen.Click Finish.

    An diesem Punkt wird der Remotedebugger als Dienst ausgeführt.At this point the remote debugger is running as a service. Sie können dies überprüfen, indem Sie zu Systemsteuerung > Dienste navigieren und nach Visual Studio 2015 Remote Debugger suchen.You can verify this by going to Control Panel > Services and looking for Visual Studio 2015 Remote Debugger.

    Sie können den Remotedebugger-Dienst über Systemsteuerung > Dienste beenden und starten.You can stop and start the remote debugger service from Control Panel > Services.

Einrichten des Debuggens mit RemotesymbolenSet up debugging with remote symbols

Sie sollten Ihren Code mit den auf dem Visual Studio-Computer generierten Symbolen debuggen können.You should be able to debug your code with the symbols you generate on the Visual Studio computer. Die Leistung des Remotedebuggers ist viel besser, wenn Sie lokale Symbole verwenden.The performance of the remote debugger is much better when you use local symbols. Wenn Sie Remotesymbole verwenden müssen, ist es erforderlich, dem Remotedebugmonitor mitzuteilen, dass er auf dem Remotecomputer nach Symbolen suchen soll.If you must use remote symbols, you need to tell the remote debugging monitor to look for symbols on the remote machine.

Ab Visual Studio 2013 Update 2 können Sie über die folgende msvsmon-Befehlszeilenoption Remotesymbole für verwalteten Code verwenden: Msvsmon /FallbackLoadRemoteManagedPdbsStarting in Visual Studio 2013 Update 2, you can use the following msvsmon command-line switch to use remote symbols for managed code: Msvsmon /FallbackLoadRemoteManagedPdbs

Weitere Informationen finden Sie in der Hilfe zum Remotedebugging (drücken Sie F1 im Remotedebuggerfenster, oder klicken Sie auf Hilfe > Verwendung).For more information, please see the remote debugging help (press F1 in the remote debugger window, or click Help > Usage). Weitere Informationen finden Sie unter .NET Remote Symbol Loading Changes in Visual Studio 2012 and 2013 (Änderungen beim Laden von Symbolen in der .NET-Remoteinstanz in Visual Studio 2012 und 2013).You can find more information at .NET Remote Symbol Loading Changes in Visual Studio 2012 and 2013

Siehe auchSee also