Menüs und Befehle für Visual Studio

Befehlssyntax

Übersicht

Im Gegensatz Microsoft Office, bei der es sich um eine Suite handelt, die viele separate Produkte umfasst, enthält Visual Studio viele Produkte, die jeweils ihre Befehlssätze zur globalen Visual Studio beitragen. Die IDE verwaltet die Komplexität von Tausenden von Befehlen, indem die dem Benutzer verfügbaren Funktionen basierend auf dem Kontext gefiltert werden.

Wenn sich der Kontext eines Benutzers ändert , z. B. der Wechsel von einem Entwurfsfenster zu einem Codebearbeitungsfenster, werden Funktionen, die nicht mit dem neuen Kontext in Zusammenhang stehen, nicht mehr angezeigt. Gleichzeitig werden neue Funktionen zusammen mit verwandten dynamischen Informationen wie Eigenschaften und Toolboxoptionen angezeigt. Der Benutzer sollte den Austausch des verfügbaren Befehlssets nicht bemerken. Wenn der Benutzer abgelenkt oder verwirrend ist, wenn Befehle angezeigt oder nicht mehr angezeigt werden, muss der Benutzeroberflächenentwurf angepasst werden. Der aktuelle Kontext des Benutzers wird immer auf eine oder mehrere Arten angegeben, z. B. in der IDE-Titelleiste, im Eigenschaftenfenster oder im Dialogfeld Eigenschaftenseiten.

Befehlsleisten ermöglichen Flexibilität in der Benutzeroberfläche. Die einzigen Befehlsstrukturen, die Visual Studio Umgebung inhärent sind, sind das Hauptmenü und die Hauptbefehlsleiste, die angepasst und sogar ausgeblendet werden können. Andere Befehlsleisten werden basierend auf dem Status der Anwendung angezeigt und werden nicht mehr angezeigt. Toolfenster und Dokument-Editoren können auch eingebettete Symbolleisten in ihren Fensterrändern enthalten.

Grundlegende Richtlinien

Verwenden Sie nach Möglichkeit vorhandene freigegebene Befehle, Befehlsgruppen und Menüs.

Da Befehle in der Regel basierend auf dem Kontext angezeigt werden, stellt die Verwendung vorhandener freigegebener Menüs und Befehlsgruppen sicher, dass die Befehlsstruktur zwischen Kontextänderungen relativ stabil bleibt. Das Wiederverwenden freigegebener Befehle und das Platzieren neuer Befehle in der Nähe verwandter freigegebener Befehle reduziert auch die Komplexität der IDE und sorgt für eine benutzerfreundlichere Benutzeroberfläche. Wenn ein neuer Befehl definiert werden muss, versuchen Sie, ihn in einer vorhandenen freigegebenen Befehlsgruppe zu platzieren. Wenn eine neue Gruppe definiert werden muss, platzieren Sie sie in einem vorhandenen freigegebenen Menü in der Nähe einer verknüpften Befehlsgruppe, bevor Sie ein neues Menü der obersten Ebene erstellen.

Erstellen Sie nicht für jeden Befehl Symbole.

Überlegen Sie sorgfältig, bevor Sie ein Befehlssymbol erstellen. Symbole sollten nur für Befehle erstellt werden, die:

  • wird auf einer Standardsymbolleiste angezeigt.

  • werden wahrscheinlich von Benutzern über das Dialogfeld Anpassen... zu einer Symbolleiste hinzugefügt.

  • ein Symbol haben, das derselben Aktion in einem anderen Microsoft-Produkt zugeordnet ist.

Einschränken des Hinzufügens von Tastenkombinationen

Die große Mehrheit der Benutzer verwendet einen bruchteil aller verfügbaren Tastenkombinationen. Binden Sie Ihr Feature im Zweifelsfall nicht an eine Tastenkombination. Arbeiten Sie mit Ihrem Benutzeroberflächenteam zusammen, bevor Sie neue Tastenkombinationen hinzufügen.

Geben Sie Befehlen eine Standardmenüplatzierung.

Beachten Sie, dass Ihre Befehle von anderen Angepasst werden, und entwerfen Sie sie entsprechend. Es gibt keinen ausgeblendeten Befehl. Alle Visual Studio-Befehle werden im Dialogfeld Extras > Anpassen, im Befehlsfenster, automatisch abgeschlossen, im Dialogfeld Extras > Optionen > Tastatur und in der Entwicklungstoolsumgebung (Development Tools Environment, DTE) angezeigt. Stellen Sie sicher, dass Sie Ihren Befehlen einen Namen und eine QuickInfo in Ihrer CTC-Datei geben, damit Benutzer sie leicht finden können.

Duplizieren Sie freigegebene Befehle nicht auf einer eingebetteten Symbolleiste.

Es ist hilfreich, Befehle in der Nähe des Bereichs des Benutzerfokus zu platzieren. Eine Möglichkeit besteht darin, eine eingebettete Symbolleiste oben im Toolfenster oder Dokument-Editor zu erstellen. Die auf der Symbolleiste platzierten Befehle sollten spezifisch für den Inhaltbereich innerhalb des Fensters sein. Duplizieren Sie keine freigegebenen Befehle auf diesen Symbolleisten. Platzieren Sie z. B. niemals ein Symbol "Speichern" in einer eingebetteten Symbolleiste.

Sichtbarkeit von Inhalten und Befehlen

Befehle sind in den folgenden Bereichen vorhanden: Umgebung, Hierarchie und Dokument. Kennen Sie jeden Bereich, um Vertrauen in die Befehlsplatzierung zu haben.

Befehle im Umgebungsbereich richten den primären Kontext ein und werden von mehreren Kontexten gemeinsam genutzt. Sie ändern die Sichtbarkeit oder Anordnung von Dokumenten und Toolfenstern. Zu den Befehlen im Umgebungsbereich gehören New Project, Verbinden to Server, Attach Process, Cut, Copy, Paste, Find, Options, Customize, New Window und View Help.

Befehle im Hierarchiebereich verwalten Hierarchien in Visual Studio einschließlich Project, Team und Data. Sie beziehen sich auf den Unterkontext eines Projekts, z. B. Debuggen, Erstellen, Testen, Architektur oder Analysieren. Zu den Befehlen im Hierarchiebereich gehören Neues Element hinzufügen, Neue Abfrage , Project Einstellungen , Neue Datenquelle hinzufügen, Leistungsstart-Assistent und Neues Diagramm.

Befehle im Dokumentbereich wirken sich auf den Inhalt eines Dokuments aus, z. B. Code, Entwurf oder arbeitselementabfrage (WIQ). Sie wirken sich auch auf die Ansicht eines Toolfensters aus oder sind anderweitig spezifisch für dieses Toolfenster. Dokumentbereichsbefehle wirken sich auch auf die Dateiobjekte aus, die selbst hierarchiespezifisch sind, z. B. Entfernen aus Project. Zu den Befehlen im Dokumentbereich gehören Refactoring > Umbenennen, Kopie des Arbeitselements erstellen, Alle erweitern, Alle reduzieren und Benutzeraufgabe erstellen.

Entscheidungen zur Befehlsplatzierung

Nachdem Sie sich entschieden haben, einen Befehl zu erstellen, müssen Sie die entsprechende Platzierung bestimmen und festlegen, ob eine Tastenkombination erstellt werden soll. Befolgen Sie diesen Entscheidungspfad, um zu entscheiden, wo der Befehl ausgeführt werden soll:

Entscheidungsdiagramm zur Befehlspositionierung

Entscheidungspfad für die Befehlsplatzierung in Visual Studio

Befehlsplatzierung in Menüs

Die Hauptmenüleiste sollte der Standardspeicherort für Befehle von kontextspezifischen Menüpaketen sein, die zur Benutzeroberfläche beitragen. Die Hauptmenüleiste unterscheidet sich von anderen Befehlsstrukturen, da sie von der Umgebung verwendet wird, um zu steuern, welche Befehle sichtbar sind. Alle anderen Befehlsleisten deaktivieren einfach Befehle, die sich nicht im Kontext befinden, unabhängig davon, ob sie in einem Menü oder auf einer Symbolleiste platziert werden.

Die Umgebung definiert eine Reihe von Befehlen, die in die Hauptmenüleiste integriert sind und für die gesamte IDE und mehrere Aufgabendomänen gelten. Diese Befehle sind immer sichtbar, unabhängig davon, welche VSPackages in die Umgebung geladen werden. Obwohl VSPackages diesen Befehlssatz erweitern kann, liegt der Befehlssatz für jedes Produkt und die Platzierung seiner Befehle in der Verantwortung jedes Teams.

Die Struktur des Hauptmenüs Visual Studio kann in die folgenden Menükategorien unterteilt werden:

Kernmenüs
  • Datei

  • Bearbeiten

  • Sicht

  • Tools

  • Fenster

  • Hilfe

Project-spezifische Menüs
  • Project

  • Entwickeln

  • Debuggen

Kontextspezifische Menüs
  • Team

  • Daten

  • Test

  • Architektur

  • Analysieren

Dokumentspezifische Menüs
  • Format

  • Tabelle

Beachten Sie beim Entwerfen von Hauptmenüs die folgenden Regeln:
  • Maximal 25 Elemente der obersten Ebene in einem bestimmten Kontext

  • Menüs sollten nie eine Höhe von 600 Pixel überschreiten.

  • Werten Sie ein Hauptmenü in mehreren Kontexten aus, z. B. in der Ultimate-SKU und im allgemeinen Profil.

  • Flyoutmenüs sind akzeptabel.

  • Flyoutmenüs sollten mindestens drei Elemente und nicht mehr als sieben Elemente enthalten.

  • Flyoutmenüs sollten nur eine Ebene tief gehen. Einige Visual Studio menüelemente verfügen über kaskadierenden Untermenüs, aber dieses Muster wird nicht empfohlen.

  • Verwenden Sie nicht mehr als sechs Trennzeichen. Gruppierungen sollten der folgenden Abbildung folgen:

    Richtlinien für die Gruppierung des Hauptmenüs

  • Obwohl es nicht erforderlich ist, dass jede Gruppierung in der Abbildung vorliegt, ist das Hinzufügen zusätzlicher Gruppierungen eingeschränkt.

  • Jede Gruppierung sollte über zwei bis sieben Menüelemente verfügen.

Bevor Sie ein neues Element der obersten Ebene hinzufügen, sollten Sie den Befehl in einem vorhandenen Menü der obersten Ebene platzieren. Wenn Sie ein neues Menü der obersten Ebene hinzufügen, achten Sie darauf, es an der richtigen Position zu platzieren. Entscheiden Sie, ob das Menü projekt-, kontext- oder dokumentspezifisch ist. Halten Sie den Namen des Menüs der obersten Ebene kurz, und verwenden Sie nur ein Wort.

Die Hauptmenüs sollten die restlichen Befehle buchen. Datei, Bearbeiten und Ansicht sollten immer links und Tools, Fenster und Hilfe immer auf der rechten Seite angezeigt werden.

Kontextmenüs

Das Platzieren von zu vielen Funktionen in den Kontextmenüs führt zu einer schwer zu erlernenden Schnittstelle. Alle Hauptfunktionen sollten über die Hauptmenüleiste verfügbar sein. Die Platzierung von Befehlen sollte mit vorhandenen Befehlen abgeglichen werden, um doppelte Befehle zu vermeiden. Für Kontextmenüs definiert die Shell Standardmenügruppen, die eingeschlossen werden sollten, je nachdem, ob das Kontextmenü für die Projektmappe, einen Projektknoten oder ein Projektelement bestimmt ist.

Befolgen Sie beim Entwerfen von Kontextmenüs die gleichen Regeln wie für das Hauptmenü, und beachten Sie außerdem Folgendes:

  • 25 Menüelemente der obersten Ebene dürfen nicht überschritten werden.

  • Flyoutmenüs sind akzeptabel, dürfen aber eine Ebene nicht überschreiten. Verwenden Sie niemals kaskadierende Flyouts.

  • Verwenden Sie nicht mehr als sechs Trennzeichen.

Befehlsplatzierung in Symbolleisten

Symbolleisten "Allgemein"

Befolgen Sie beim Entwerfen und Anordnen von Symbolleisten die folgenden Standards:

  • Verwenden Sie nicht mehr als ein Verb pro Schaltfläche. Eine Schaltfläche = eine Aktion.

  • Verwenden Sie Text zusammen mit dem Symbol nur, wenn er mit der Bezeichnung versehen werden muss.

  • Verwenden Sie ein Kombinationsfeld ausschließlich für Eigenschaften, die in einer Sitzung mehrmals gewechselt werden. Andernfalls machen Sie die Eigenschaft an anderer Stelle verfügbar.

  • Die Breite eines Kombinationsfelds sollte der Breite des längsten Elements innerhalb des Felds + 30 % entsprechen. Wenn das längste Element beispielsweise 200 Pixel beträgt, sollte das Kombinationsfeld 260 Pixel breit sein.

  • Beschränken Sie die Verwendung von Trennzeichen. Die Verwendung eines Trennzeichens neben einer Dropdownliste ist ein Antimuster, da die Form der Dropdownliste selbst als visuelles Trennzeichen fungiert.

  • Symbolgruppen sollten zwischen drei und sechs Symbole enthalten.

  • Wenn Qualifizierer zu mehreren nützlichen Befehlen führen, verwenden Sie eine unterteilte Schaltfläche, die die letzte Einstellung speichert:

    Unterteilte Schaltflächen in Visual Studio

    Beispiel für eine unterteilte Schaltfläche. Die sechs Befehle auf der linken Seite können stattdessen in eine einzelne Schaltfläche passen.

Produktspezifische Symbolleisten

Jedes Produkt kann eine Standardsymbolleiste bereitstellen, die häufig verwendete und wichtige Befehle enthält. Die Standardsymbolleiste jedes Produkts sollte beim ersten Starten Visual Studio nach der Installation des Produkts angezeigt werden.

Produkte sollten auch freigegebene Befehlsgruppen und Menüs nutzen, die von der IDE bereitgestellt werden. Jede freigegebene Befehlsgruppe wird in einem freigegebenen Menü platziert, um verwandte Befehle auf sinnvolle Weise für den Benutzer zu organisieren. Es ist wichtig, diese gemeinsame Befehlsstruktur zu nutzen, um die Komplexität zu reduzieren.

Globale Symbolleisten

Globale Symbolleisten müssen direkt in eine Zeile passen. Befolgen Sie beim Erstellen einer neuen globalen Symbolleiste die Richtlinien für diesen Symbolleistentyp.

Allgemeine Richtlinien für Symbolleisten:

  • Jede Symbolleiste verfügt über 24 Pixel in allgemeinen Steuerelementen (Steuerelement, Überlauf).

  • Jede Symbolleistenschaltfläche ist 22 Pixel breit, einschließlich Auffüllung. Wenn Sie das Symbol zu einer unterteilten Schaltfläche machen, wird eine Breite von weiteren 11 Pixeln hinzugefügt.

  • Duplizierung von Befehlen über Symbolleisten hinweg ist zulässig.

    Dokumentspezifische Symbolleisten werden angezeigt, wenn ein bestimmter Dateityp aktiv ist, und verschwinden, wenn ein anderer Dateityp aktiv wird.

  • Dokumentspezifische Symbolleisten dürfen nicht mehr als 12 Schaltflächen enthalten.

  • Die Gesamtbreite der Symbolleiste darf 300 Pixel nicht überschreiten.

  • Jeder Dateityp kann entweder eine eingebettete Symbolleiste oder eine dokumentspezifische globale Symbolleiste aufweisen, aber nicht beide.

    Kontextspezifische Symbolleisten werden angezeigt, wenn ein bestimmter Kontext festgelegt ist und für längere Zeiträume aktiv bleibt.

  • Das Schaltflächenlimit für alle kontextspezifischen Symbolleisten beträgt 18.

  • Wenn die meisten Benutzer die Befehle dieser Symbolleiste nicht konsistent verwenden, wenn der Kontext aktiv ist, ordnen Sie diese Symbolleiste keinem Kontext zu.

  • Stellen Sie sicher, dass die Symbolleiste beim Beenden des Kontexts nicht mehr angezeigt wird. Keine dieser Symbolleisten sollte beim Start angezeigt werden.

    Symbolleisten ohne Kontext werden nie automatisch angezeigt. Diese werden nur angezeigt, wenn der Benutzer sie aktiviert. Behalten Sie die maximale Breite unter 200 Pixel bei.

Allgemeine Organisation und shelldefinierte Gruppen

Verwenden Sie vorhandene freigegebene Befehle, Befehlsgruppen und Menüs. Wenn ein neuer Befehl definiert werden muss, versuchen Sie, ihn in einer vorhandenen freigegebenen Befehlsgruppe zu platzieren. Wenn eine neue Gruppe definiert werden muss, versuchen Sie, sie in einem vorhandenen freigegebenen Menü in der Nähe einer verknüpften Befehlsgruppe zu platzieren, bevor Sie ein neues Menü der obersten Ebene erstellen. Dadurch wird die Befehlskomplexität reduziert und gleichzeitig eine konsistente Befehlsplatzierung in der IDE sichergestellt.

Das freigegebene Menü Format, das normalerweise im Kontext von Dokumentfenstern im Designerformat angezeigt wird, ist in der folgenden Abbildung dargestellt:

Visual Studio-Menü "Format" mit Beschriftungen

Menügruppen in Visual Studio

Reduzieren und Wiederverwenden von Befehlen

Befehle werden in der Regel basierend auf dem Kontext angezeigt, um die Anzahl der Befehle zu reduzieren, die dem Benutzer zu einem bestimmten Zeitpunkt angezeigt werden. Sie sollten jedoch auch vorhandene freigegebene Menüs und Befehlsgruppen wiederverwenden, um sicherzustellen, dass die Befehlsstruktur zwischen Kontextänderungen relativ stabil bleibt.

Das Wiederverwenden freigegebener Befehle und das Platzieren neuer Befehle in der Nähe verwandter freigegebener Befehle verringern die Komplexität der IDE und schaffen eine benutzerfreundlichere Oberfläche.

Benennungsbefehle

Benennungskonventionen

Eine konsistente Befehlsbenennung ist wichtig, damit Benutzer Befehle entweder über die Befehlszeile oder durch Bindung an eine Tastenkombination suchen und ausführen können. Befehlsnamen helfen dem Benutzer auch zu verstehen, welchem Zweck ein Befehl dient, wenn er auf einer Symbolleiste oder in einem kaskadierenden Oder Kontextmenü angezeigt wird.

Beim Benennen von Befehlen:

  • Erstellen Sie Text, sodass er leicht lokalisierbar ist. Weitere Informationen zum Lokalisieren von Text finden Sie unter Bewährte Methoden für die Lokalisierung.

  • Seien Sie präzise. Befehle dürfen nicht mehr als drei Wörter verwenden.

  • Groß-/Groß-/Großschreibung verwenden: Der erste Buchstabe jedes Worts sollte groß geschrieben werden. Weitere Informationen zur Textformatierung in Visual Studio finden Sie unter Textformat.

  • Berücksichtigen Sie, wo der Befehl platziert wird. Befindet sie sich in einem Menü der obersten Ebene oder in einem Flyout? Wenn Sie beispielsweise Ausrichtungsbefehle in einem Flyout gruppieren, sollte der Befehl der obersten Ebene "Align" und die Flyoutbefehle "Left", "Right", "Center", "Justify" usw. sein. Es wäre redundant, die Flyoutbefehle "Align Left" (Links ausrichten) oder "Align Right" (Rechts ausrichten) zu benennen.

    Visual Studio-Menü "Format"

Verwenden von Symbolen mit Befehlen

Sparen Sie bei der Verwendung von Symbolpaaren mit Befehlen. Obwohl das Zuordnen eines eindeutigen Bilds zu einem Befehl die Fähigkeit des Benutzers, diesen Befehl zu identifizieren, überladen ist, treten visuelle Überladenheit und Ineffizienz bei überladenem Bild auf. Die folgenden Regeln helfen bei der Entscheidung, ob ein Befehlssymbol erstellt werden soll.

Verwenden Sie ein Symbol mit einem Befehl nur, wenn:

  • Demselben Befehl ist ein Symbol in einem anderen bekannten Microsoft-Produkt zugeordnet, z. B. einer der Microsoft Office Anwendungen.

  • Der Befehl wird auf einer Standardsymbolleiste platziert.

  • Der Befehl ist ein spezieller Befehl, den Benutzer wahrscheinlich mithilfe des Dialogfelds "Anpassen..." zu einer Symbolleiste hinzufügen.

Zugriffs- und Tastenkombinationen

Übersicht

Es gibt zwei Arten von Tastenzuweisungen:

  • Zugriffsschlüssel (auch als Zugriffstasten bezeichnet) ermöglichen den Tastaturzugriff über die Menüs für Befehle und auf jede Bezeichnung in der Benutzeroberfläche des Dialogfelds. Zugriffsschlüssel dienen hauptsächlich zu Barrierefreiheitszwecken, werden allen Menüs zugewiesen, und die meisten Dialogfeldsteuerelemente sind nicht dafür vorgesehen, sich zu merken, wirken sich nur auf das aktuelle Fenster aus und werden lokalisiert.

  • Tastenkombinationen verwenden hauptsächlich Strg- und Funktionstastensequenzen (Fn). Sie sind eher für fortgeschrittene Benutzer konzipiert und helfen bei der Produktivität. Sie werden nur den am häufigsten verwendeten Befehlen zugewiesen und ermöglichen schnellen Zugriff, während das Hauptmenü umgangen wird. Tastenkombinationen sollen auswendig verwendet werden und müssen daher mit dem Profilschema konsistent zugewiesen werden. Tastenkombinationsschemas können von Profil zu Profil variieren. Ein Benutzer kann Tastenkombinationen über Extras > Optionen > Tastatur anpassen.

Zuweisen von Zugriffsschlüsseln

Zugriffsschlüssel bestehen aus alt plus alphanumerischen Schlüsseln. Weisen Sie jedem Menüelement ohne Ausnahme einen Zugriffsschlüssel zu. Befolgen Windows und allgemeinen Konventionen zum Zuweisen von Zugriffsschlüsseln. Der Zugriffsschlüssel für File > New sollte z. B. immer ALT, F, N sein.

Verwenden Sie keine Buchstaben mit einer Breite von einem Pixel wie "i" (in Groß- oder Kleinbuchstaben) oder klein geschriebene "l", und vermeiden Sie die Verwendung von Zeichen mit absteigenden Zeichen (g, j, p, q und y), da diese schwer zu unterscheiden sind.

Vermeiden Sie nach Möglichkeit die Verwendung doppelter Schlüssel. In Fällen, in denen eine Duplizierung unvermeidbar ist, behandelt das Menüsystem Konflikte, indem es alle Befehle durchfing, die den Schlüssel verwenden. Beispiel: Für einen hypothetischen "Number"-Befehl im Menü Datei, der die Zugriffsschlüssel "N" dupliziert, würden ALT, F, N eine neue Datei erstellen, und Alt, F, N, N würde den Befehl "Number" ausführen.

Zuweisen von Tastenkombinationen

Vermeiden Sie das Zuweisen neuer Tastenkombinationen, da sie nicht für jeden Befehl erforderlich sind, und steuern Sie das System (und den Benutzerspeicher), wenn sie überlastet sind. Daten aus dem Programm zur Verbesserung der Benutzerfreundlichkeit (CEIP) geben an, dass Visual Studio Benutzer nur eine kleine Teilmenge der integrierten Tastenkombinationen verwenden.

Befolgen Sie beim Definieren von Verknüpfungen die folgenden Regeln:

  • Verwenden Sie Strg- und Funktionstastensequenzen (Fn).

  • Behalten Sie häufig verwendete Tastenkombinationen bei. Verwalten Sie die beliebtesten Tastenkombinationen.

  • Einfaches Eingeben von Editorverknüpfungen. Binden Sie einfach zu schreibende Tastenkombinationen an Befehle, die Entwickler beim Schreiben von Code am meisten benötigen. Beispielsweise muss Edit.InvokeSmartTag eine Tastenkombination wie STRG+/ und nicht ALT+UMSCHALT+F10 haben.

  • Setzen Sie sich für versierte Tastenkombinationen ein.

  • Befolgen Windows Richtlinien, um zu bestimmen, welche Modifiziererschlüssel verwendet werden sollen. Verwenden Sie STRG-Tastenkombinationen für Befehle, die umfangreiche Auswirkungen haben, z. B. Befehle, die für ein gesamtes Dokument gelten. Verwenden Sie UMSCHALTTASTEnkombinationen für Befehle, die die Aktionen der Standardtastenkombination erweitern oder ergänzen. Verwenden Sie keine TASTENG+ALT-Kombinationen.

  • Entfernen Sie unnentfernte Tastenkombinationen. Wenn Sie über ein Legacyfeature verfügen, können Sie Verknüpfungen entfernen, die mit extremer Seltenheit (weniger als 10-mal aus den CEIP-Daten) oder mäßiger Seltenheit (weniger als 100-mal aus den CEIP-Daten) verwendet werden, wenn ein Zugriffsschlüssel schnellen Zugriff auf denselben Befehl bietet. Beispiel: Alt, H, C öffnet Hilfe/Inhalt.

    Es gibt keine einfache Möglichkeit, die Verfügbarkeit von Verknüpfungen zu überprüfen. Wenn Sie eine Verknüpfung hinzufügen möchten, führen Sie die folgenden Schritte aus:

  1. Überprüfen Sie die Liste Visual Studio 2013 Tastenkombinationen, um zu ermitteln, ob ähnliche Befehle zum Gruppen Ihrer Befehle verfügbar sind.

  2. Wechseln Sie zu Extras > Optionen > Umgebung > Tastatur, und testen Sie die Tastenkombination. Überprüfen Sie jedes Tastaturzuordnungsschema, das unter "Anwenden des folgenden zusätzlichen Tastaturzuordnungsschemas" aufgeführt ist. Aktivieren Sie die Profile Allgemein, C#, VB und C++, da diese eindeutige Verknüpfungen verwenden. Die Verknüpfung ist verfügbar, wenn sie an keinen dieser Stellen zugeordnet ist.