Tutorial: Erste Schritte mit C# und ASP.NET Core in Visual StudioTutorial: Get started with C# and ASP.NET Core in Visual Studio

In diesem Tutorial für die C#-Entwicklung mit ASP.NET Core in Visual Studio werden wir eine C#-ASP.NET Core-Web-App erstellen, Änderungen daran vornehmen, einige Funktionen der IDE kennenlernen und die App dann ausführen.In this tutorial for C# development with ASP.NET Core using Visual Studio, you'll create a C# ASP.NET Core web app, make changes to it, explore some features of the IDE, and then run the app.

VorbereitungenBefore you begin

Installieren von Visual StudioInstall Visual Studio

Wenn Sie Visual Studio noch nicht installiert haben, können Sie es auf der Seite Visual Studio-Downloads kostenlos herunterladen.If you haven't already installed Visual Studio, go to the Visual Studio downloads page to install it for free.

Wenn Sie Visual Studio noch nicht installiert haben, können Sie es auf der Seite Visual Studio-Downloads kostenlos herunterladen.If you haven't already installed Visual Studio, go to the Visual Studio downloads page to install it for free.

Aktualisieren von Visual Studio 2017Update Visual Studio

Wenn Sie Visual Studio bereits installiert haben, stellen Sie sicher, dass Sie das aktuelle Release ausführen.If you've already installed Visual Studio, make sure that you're running the most recent release. Weitere Informationen zum Aktualisieren Ihrer Installation finden Sie auf der Seite Aktualisieren von Visual Studio auf die aktuelle Version.For more information about how to update your installation, see the Update Visual Studio to the most recent release page.

Auswählen eines Designs (optional)Choose your theme (optional)

Die Screenshots in diesem Tutorial verwenden das dunkle Design.This tutorial includes screenshots that use the dark theme. Wenn Sie ebenfalls das dunkle Design verwenden möchten, finden Sie auf der Seite Personalisieren der Visual Studio-IDE und des Editors entsprechende Anweisungen.If you aren't using the dark theme but would like to, see the Personalize the Visual Studio IDE and Editor page to learn how.

Erstellen eines ProjektsCreate a project

Zunächst erstellen Sie ein ASP.NET Core-Projekt.First, you'll create a ASP.NET Core project. Schon bevor Sie mit der Bearbeitung beginnen, enthält der Projekttyp alle Vorlagendateien, die Sie für eine voll funktionsfähige Website benötigen.The project type comes with all the template files you'll need for a fully functional website, before you've even added anything!

  1. Öffnen Sie Visual Studio 2017.Open Visual Studio 2017.

  2. Klicken Sie oben in der Menüleiste auf Datei > Neu > Projekt.From the top menu bar, choose File > New > Project.

  3. Erweitern Sie im Dialogfeld Neues Projekt links den Eintrag Visual C# und anschließend Web, und klicken Sie auf .NET Core.In the New Project dialog box in the left pane, expand Visual C#, expand Web, and then choose .NET Core. Klicken Sie im mittleren Bereich auf ASP.NET Core-Web-App.In the middle pane, choose ASP.NET Core Web Application. Nennen Sie die Datei MyCoreApp, und klicken Sie auf OK.Then, name the file MyCoreApp and choose OK.

    Projektvorlage „ASP.NET Core-Webanwendung“ im Dialogfeld „Neues Projekt“ in der Visual Studio-IDE

Hinzufügen einer Workload (optional)Add a workload (optional)

Wenn Ihnen die Projektvorlage ASP.NET Core-Webanwendung fehlt, fügen Sie einfach die Workload ASP.NET und Webentwicklung hinzu.If you don't see the ASP.NET Core Web Application project template, you can get it by adding the ASP.NET and web development workload. Sie haben folgende Möglichkeiten für das Hinzufügen der Workload, je nachdem, welche Visual Studio 2017-Updates auf dem Computer installiert sind.You can add this workload in one of the two following ways, depending on which Visual Studio 2017 updates are installed on your machine.

Option 1: Verwenden des Dialogfelds „Neues Projekt“Option 1: Use the New Project dialog box

  1. Klicken Sie im Dialogfeld Neues Projekt im linken Bereich auf den Link Visual Studio-Installer öffnen.Select the Open Visual Studio Installer link in the left pane of the New Project dialog box. (Abhängig von Ihren Anzeigeeinstellungen müssen Sie zur Anzeige möglicherweise scrollen.)(Depending on your display settings, you might have to scroll to see it.)

    Link „Visual Studio-Installer öffnen“ im Dialogfeld „Neues Projekt“

  2. Der Visual Studio-Installer wird gestartet.The Visual Studio Installer launches. Klicken Sie auf die Workload ASP.NET und Webentwicklung und anschließend auf Ändern.Choose the ASP.NET and web development workload, and then choose Modify.

    Workload für die plattformübergreifende .NET Core-Entwicklung im Visual Studio-Installer

    (Möglicherweise müssen Sie Visual Studio schließen, bevor Sie die Installation des neuen Workloads fortsetzen können.)(You might have to close Visual Studio before you can continue installing the new workload.)

Option 2: Verwenden der Menüleiste „Extras“Option 2: Use the Tools menu bar

  1. Schließen Sie das Dialogfeld Neues Projekt.Cancel out of the New Project dialog box. Wählen Sie dann in der oberen Menüleiste Extras > Get Tools and Features (Tools und Features abrufen) aus.Then, from the top menu bar, choose Tools > Get Tools and Features.

  2. Der Visual Studio-Installer wird gestartet.The Visual Studio Installer launches. Klicken Sie auf die Workload ASP.NET und Webentwicklung und anschließend auf Ändern.Choose the ASP.NET and web development workload, and then choose Modify.

    (Möglicherweise müssen Sie Visual Studio schließen, bevor Sie die Installation des neuen Workloads fortsetzen können.)(You might have to close Visual Studio before you can continue installing the new workload.)

Hinzufügen einer ProjektvorlageAdd a project template

  1. Klicken Sie im Dialogfeld Neue ASP.NET Core-Webanwendung auf die Projektvorlage Webanwendung.In the New ASP.NET Core Web Application dialog box, choose the Web Application project template.

  2. Überprüfen Sie, ob ASP.NET Core 2.1 im oberen Dropdownmenü angezeigt wird.Verify that ASP.NET Core 2.1 appears in the top drop-down menu. Klicken Sie dann auf OK.Then, choose OK.

    Dialogfeld „Neue ASP.NET Core-Webanwendung“

    Hinweis

    Wenn ASP.NET Core 2.1 im oberen Dropdownmenü nicht angezeigt wird, stellen Sie sicher, dass Sie das neueste Release von Visual Studio ausführen.If you don't see ASP.NET Core 2.1 from the top drop-down menu, make sure that you are running the most recent release of Visual Studio. Weitere Informationen zum Aktualisieren Ihrer Installation finden Sie auf der Seite Aktualisieren von Visual Studio auf die aktuelle Version.For more information about how to update your installation, see the Update Visual Studio to the most recent release page.

  1. Wählen Sie im Startfenster Neues Projekt erstellen aus.On the start window, choose Create a new project.

    Fenster „Neues Projekt erstellen“ anzeigen

  2. Geben Sie im Fenster Neues Projekt erstellen im Suchfeld ASP.NET ein.On the Create a new project window, enter or type ASP.NET in the search box. Wählen Sie anschließend in der Liste der Sprachen C# und dann aus der Liste der Plattformen Windows aus.Next, choose C# from the Language list, and then choose Windows from the Platform list.

    Nachdem Sie die Sprach- und Plattformfilter angewendet haben, wählen Sie die Vorlage ASP.NET Core-Webanwendung und dann Weiter aus.After you apply the language and platform filters, choose the ASP.NET Core Web Application template, and then choose Next.

    Wählen Sie die C#-Vorlage für die ASP.NET Core-Webanwendung aus

    Hinweis

    Wenn die Vorlage ASP.NET Core-Webanwendung nicht angezeigt wird, können Sie sie über das Fenster Neues Projekt erstellen installieren.If you don't see the ASP.NET Core Web Application template, you can install it from the Create a new project window. Wählen Sie in der Meldung Sie finden nicht, wonach Sie suchen? den Link Weitere Tools und Features installieren aus.In the Not finding what you're looking for? message, choose the Install more tools and features link.

    Link „Weitere Tools und Features installieren“ aus der Meldung „Sie finden nicht, wonach Sie suchen“ im Fenster „Neues Projekt erstellen“

    Wählen Sie anschließend im Visual Studio-Installer die Workload ASP.NET- und Webentwicklung aus.Then, in the Visual Studio Installer, choose the ASP.NET and web development workload.

    Workload für die plattformübergreifende .NET Core-Entwicklung im Visual Studio-Installer

    Wählen Sie anschließend die Schaltfläche Ändern im Visual Studio-Installer aus.After that, choose the Modify button in the Visual Studio Installer. Speichern Sie Ihre Arbeit, wenn Sie dazu aufgefordert werden.If you're prompted to save your work, do so. Wählen Sie als Nächstes Weiter aus, um die Workload zu installieren.Next, choose Continue to install the workload. Kehren Sie dann zu Schritt 2 in dieser Vorgehensweise "Projekt erstellen" zurück.Then, return to step 2 in this "Create a project" procedure.

  3. Geben Sie im Fenster Neues Projekt konfigurieren im Feld *Projektname***MyCoreApp ein.In the Configure your new project window, type or enter MyCoreApp in the Project name box. Wählen Sie anschließend Erstellen aus.Then, choose Create.

    Benennen Sie Ihr Projekt im Fenster „Neues Projekt konfigurieren“ „MyCoreApp“

  4. Überprüfen Sie im Fenster Neue ASP.NET Core-Webanwendung erstellen, ob ASP.NET Core 3.0 im oberen Dropdownmenü angezeigt wird.In the Create a new ASP.NET Core Web Application window, verify that ASP.NET Core 3.0 appears in the top drop-down menu. Wählen Sie dann Webanwendung aus; diese Option beinhaltet Razor Pages-Beispielseiten.Then, choose Web Application, which includes example Razor Pages. Wählen Sie als Nächstes Erstellen aus.Next, choose Create.

    Fenster „Neue ASP.NET Core-Webanwendung erstellen“

    Visual Studio öffnet Ihr neues Projekt.Visual Studio opens your new project.

Die ProjektmappeAbout your solution

Diese Lösung verwendet das Razor Pages-Entwurfsmuster.This solution follows the Razor Page design pattern. Dieses unterscheidet sich vom Entwurfsmuster Model View Controller (MVC) dadurch, dass es optimiert ist und den Modell- und Controllercode in die Razor Pages-Seite selbst einfügt.It's different than the Model-View-Controller (MVC) design pattern in that it's streamlined to include the model and controller code within the Razor Page itself.

Kennenlernen der ProjektmappeTour your solution

  1. Die Projektvorlage erstellt eine Projektmappe mit einem einzelnen ASP.NET Core-Projekt namens MyCoreApp.The project template creates a solution with a single ASP.NET Core project that is named MyCoreApp. Wählen Sie die Registerkarte Projektmappen-Explorer aus, um den Inhalt anzuzeigen.Choose the Solution Explorer tab to view its contents.

    ASP.NET-Projektmappen-Explorer in Visual Studio für die Razor Pages-Lösung namens MyCoreApp

  2. Erweitern Sie den Ordner Seiten und dann About.cshtml.Expand the Pages folder, and then expand About.cshtml.

    Datei „About.cshtml“ im Projektmappen-Explorer in Visual Studio

  3. Zeigen Sie die Datei About.cshtml im Code-Editor an.View the About.cshtml file in the code editor.

    Anzeigen der Datei „About.cshtml“ im Visual Studio-Code-Editor

  4. Wählen Sie die Datei About.cshtml.cs aus.Choose the About.cshtml.cs file.

    Auswählen der Datei „About.cshtml.cs“ im Visual Studio-Code-Editor

  5. Zeigen Sie die Datei About.cshtml.cs im Code-Editor an.View the About.cshtml.cs file in the code editor.

    Anzeigen der Datei „About.cshtml“ im Visual Studio-Code-Editor

  6. Das Projekt enthält den Ordner wwwroot, der das Stammverzeichnis Ihrer Website ist.The project contains a wwwroot folder that is the root for your website. Erweitern Sie den Ordner, um den Inhalt anzuzeigen.Expand the folder to view its contents.

    Ordner „wwwroot“ im Projektmappen-Explorer in Visual Studio

    Sie können statische Websiteinhalte wie CSS, Bilder und JavaScript-Bibliotheken direkt in die gewünschten Pfade einfügen.You can put static site content—such as CSS, images, and JavaScript libraries—directly in the paths where you want them.

  7. Das Projekt enthält auch Konfigurationsdateien, die die Web-App zur Laufzeit verwalten.The project also contains configuration files that manage the web app at run time. Die Standardkonfiguration der Anwendung befindet sich in der Datei appsettings.json.The default application configuration is stored in appsettings.json. Sie können diese Einstellungen jedoch auch mit appsettings.Development.json überschreiben.However, you can override these settings by using appsettings.Development.json. Erweitern Sie die Datei appsettings.json, um die Datei appsettings.Development.json anzuzeigen.Expand the appsettings.json file to view the appsettings.Development.json file.

    Konfigurationsdateien im Projektmappen-Explorer in Visual Studio

Ausführen, Debuggen und Vornehmen von ÄnderungenRun, debug, and make changes

  1. Klicken Sie in der IDE auf die Schaltfläche IIS Express, um die App im Debugmodus zu erstellen und auszuführen.Choose the IIS Express button in the IDE to build and run the app in Debug mode. (Alternativ können Sie F5 drücken oder in der Menüleiste Debuggen > Debuggen starten auswählen.)(Alternatively, press F5, or choose Debug > Start Debugging from the menu bar.)

    Die Schaltfläche „IIS Express“ in Visual Studio

    Hinweis

    Wenn Sie die Fehlermeldung Es kann keine Verbindung mit dem Webserver "IIS Express" hergestellt werden. erhalten, schließen Sie Visual Studio. Öffnen Sie dann Visual Studio, indem Sie im Kontextmenü auf die Option Als Administrator ausführen klicken.If you get an error message that says Unable to connect to web server 'IIS Express', close Visual Studio and then open it by using the Run as administrator option from the right-click or context menu. Führen Sie die Anwendung anschließend erneut aus.Then, run the application again.

    Möglicherweise wird auch eine Meldung angezeigt, die Sie fragt, ob Sie ein IIS-SSL-Expresszertifikat akzeptieren möchten.You might also get a message that asks if you want to accept an IIS SSL Express certificate. Wählen Sie Ja aus, um den Code in einem Webbrowser anzuzeigen, und dann erneut Ja, wenn im Anschluss eine Sicherheitswarnung angezeigt wird.To view the code in a web browser, choose Yes, and then choose Yes if you receive a follow-up security warning message.

  2. Visual Studio startet ein Browserfenster.Visual Studio launches a browser window. In der Menüleiste sollten die Seiten Startseite, Info und Kontakt angezeigt werden.You should then see Home, About, and Contact pages in the menu bar. (Wenn dies nicht der Fall ist, wählen Sie das Menüelement „Hamburger“ aus, um sie anzuzeigen.)(If you don't, choose the "hamburger" menu item to view them.)

    Auswählen des Menüelements „Hamburger“ in der Menüleiste der Web-App

  3. Wählen Sie in der Menüleiste Info aus.Choose About from the menu bar.

    Auswählen von „Info“ in der Menüleiste im Browserfenster der App

    Auf der Seite Info im Browser wird u.a. der Text gerendert, der in der Datei About.cshtml festgelegt ist.Among other things, the About page in the browser renders the text that is set in the About.cshtml file.

    Text auf der Seite „About“

  4. Wechseln Sie zurück zu Visual Studio, und drücken Sie UMSCHALT+F5, um den Debugmodus zu beenden.Return to Visual Studio, and then press Shift+F5 to stop Debug mode. Dadurch wird auch das Projekt im Browserfenster geschlossen.This also closes the project in the browser window.

  5. Wählen Sie in Visual Studio About.cshtml aus.In Visual Studio, choose About.cshtml. Löschen Sie das Wort additional, und fügen Sie an derselben Stelle file and directory ein.Then, delete the word additional and in its place, add the words file and directory.

    Ändern des Texts in der Datei „About.cshtml“

  6. Wählen Sie About.cshtml.cs aus.Choose About.cshtml.cs. Bereinigen Sie dann die using-Anweisungen oben in der Datei mithilfe der folgenden Verknüpfung.Then, clean up the using directives at the top of the file by using the following shortcut:

    Wählen Sie eine der ausgegrauten using-Anweisungen aus, damit die Glühbirne für Schnelle Aktionen unter dem Caretzeichen oder am linken Rand angezeigt wird.Choose any of the grayed-out using directives and a Quick Actions light bulb will appear just below the caret or in the left margin. Klicken Sie zunächst auf die Glühbirne und anschließend auf Nicht benötigte Using-Direktiven entfernen.Choose the light bulb, and then choose Remove Unnecessary Usings.

    Entfernen unnötiger Using-Anweisungen in der Datei „About.cshtml.cs“

    Visual Studio löscht die unnötigen using-Anweisungen aus der Datei.Visual Studio deletes the unnecessary using directives from the file.

  7. Ändern Sie dann in der OnGet()-Methode den Text in den folgenden Code:Next, in the OnGet() method, change the body to the following code:

    public void OnGet()
    {
        string directory = Environment.CurrentDirectory;
        Message = String.Format("Your directory is {0}.", directory);
    }
    
  8. Environment und String werden wellenförmig unterstrichen.Notice that two wavy underlines appear under Environment and String. Die Wellenlinien zeigen an, dass sich diese Typen nicht im gültigen Bereich befinden.The wavy underlines appear because these types aren't in scope.

    Mit wellenförmigen Unterstrichen markierte Fehler in der OnGet-Methode

    Öffnen Sie die Symbolleiste Fehlerliste. Dort werden dieselben Fehler aufgelistet.Open the Error List toolbar to see the same errors listed there. (Wenn Ihnen die Symbolleiste Fehlerliste nicht angezeigt wird, klicken Sie in der oberen Menüleiste auf Ansicht > Fehlerliste.)(If you don't see the Error List toolbar, choose View > Error List from the top menu bar.)

    Fehlerliste in Visual Studio

  9. Korrigieren wir dies.Let's fix this. Platzieren Sie den Cursor im Code-Editor auf einer Zeile, die den Fehler enthält, und wählen Sie anschließend am linken Rand die Glühbirne für schnelle Aktionen aus.In the code editor, place your cursor on either line that contains the error, and then choose the Quick Actions light bulb in the left margin. Wählen Sie im Dropdownmenü using System; aus, um diese Anweisung am Anfang der Datei hinzuzufügen und die Fehler zu beheben.Then, from the drop-down menu, choose using System; to add this directive to the top of your file and resolve the errors.

    Hinzufügen der „using System;“-Anweisung

  10. Drücken Sie STRG+S, um Ihre Änderungen zu speichern, und drücken Sie dann F5, um Ihr Projekt im Webbrowser zu öffnen.Press Ctrl+S to save your changes, and then press F5 to open your project in the web browser.

  11. Klicken Sie oben auf der Website auf Info, um die Änderungen anzuzeigen.At the top of the web site, choose About to view your changes.

    Anzeigen der aktualisierten „Info“-Seite mit den gemachten Änderungen

  12. Schließen Sie den Webbrowser, drücken Sie UMSCHALT+F5, um den Debugmodus zu beenden, und schließen Sie dann Visual Studio.Close the web browser, press Shift+F5 to stop Debug mode, and then close Visual Studio.

Kennenlernen der ProjektmappeTour your solution

  1. Die Projektvorlage erstellt eine Projektmappe mit einem einzelnen ASP.NET Core-Projekt namens MyCoreApp.The project template creates a solution with a single ASP.NET Core project that is named MyCoreApp. Wählen Sie die Registerkarte Projektmappen-Explorer aus, um den Inhalt anzuzeigen.Choose the Solution Explorer tab to view its contents.

    ASP.NET-Projektmappen-Explorer in Visual Studio für die Razor Pages-Lösung namens MyCoreApp

  2. Erweitern Sie den Ordner Seiten.Expand the Pages folder.

    Ordner „Seiten“ im Projektmappen-Explorer

  3. Zeigen Sie die Datei Index.cshtml im Code-Editor an.View the Index.cshtml file in the code editor.

    Anzeigen der Datei „Index.cshtml“ im Code-Editor von Visual Studio

  4. Jede CSHTML-Datei verfügt über eine zugeordnete Codedatei.Each .cshtml file has an associated code file. Erweitern Sie zum Öffnen der Codedatei im Editor den Knoten Index.cshtml im Projektmappen-Explorer, und klicken Sie auf die Datei Index.cshtml.cs.To open the code file in the editor, expand the Index.cshtml node in Solution Explorer, and choose the Index.cshtml.cs file.

    Auswählen der Datei „Index.cshtml.cs“ im Code-Editor von Visual Studio

  5. Zeigen Sie die Datei Index.cshtml.cs im Code-Editor an.View the Index.cshtml.cs file in the code editor.

    Anzeigen der Datei „About.cshtml“ im Visual Studio-Code-Editor

  6. Das Projekt enthält den Ordner wwwroot, der das Stammverzeichnis Ihrer Website ist.The project contains a wwwroot folder that is the root for your website. Erweitern Sie den Ordner, um den Inhalt anzuzeigen.Expand the folder to view its contents.

    Ordner „wwwroot“ im Projektmappen-Explorer in Visual Studio

    Sie können statische Websiteinhalte wie CSS, Bilder und JavaScript-Bibliotheken direkt in die gewünschten Pfade einfügen.You can put static site content—such as CSS, images, and JavaScript libraries—directly in the paths where you want them.

  7. Das Projekt enthält auch Konfigurationsdateien, die die Web-App zur Laufzeit verwalten.The project also contains configuration files that manage the web app at run time. Die Standardkonfiguration der Anwendung befindet sich in der Datei appsettings.json.The default application configuration is stored in appsettings.json. Sie können diese Einstellungen jedoch auch mit appsettings.Development.json überschreiben.However, you can override these settings by using appsettings.Development.json. Erweitern Sie die Datei appsettings.json, um die Datei appsettings.Development.json anzuzeigen.Expand the appsettings.json file to view the appsettings.Development.json file.

    Konfigurationsdateien im Projektmappen-Explorer in Visual Studio

Ausführen, Debuggen und Vornehmen von ÄnderungenRun, debug, and make changes

  1. Klicken Sie in der IDE auf die Schaltfläche IIS Express, um die App im Debugmodus zu erstellen und auszuführen.Choose the IIS Express button in the IDE to build and run the app in Debug mode. (Alternativ können Sie F5 drücken oder in der Menüleiste Debuggen > Debuggen starten auswählen.)(Alternatively, press F5, or choose Debug > Start Debugging from the menu bar.)

    Die Schaltfläche „IIS Express“ in Visual Studio

    Hinweis

    Wenn Sie die Fehlermeldung Es kann keine Verbindung mit dem Webserver "IIS Express" hergestellt werden. erhalten, schließen Sie Visual Studio. Öffnen Sie dann Visual Studio, indem Sie im Kontextmenü auf die Option Als Administrator ausführen klicken.If you get an error message that says Unable to connect to web server 'IIS Express', close Visual Studio and then open it by using the Run as administrator option from the right-click or context menu. Führen Sie die Anwendung anschließend erneut aus.Then, run the application again.

    Möglicherweise wird auch eine Meldung angezeigt, die Sie fragt, ob Sie ein IIS-SSL-Expresszertifikat akzeptieren möchten.You might also get a message that asks if you want to accept an IIS SSL Express certificate. Wählen Sie Ja aus, um den Code in einem Webbrowser anzuzeigen, und dann erneut Ja, wenn im Anschluss eine Sicherheitswarnung angezeigt wird.To view the code in a web browser, choose Yes, and then choose Yes if you receive a follow-up security warning message.

  2. Visual Studio startet ein Browserfenster.Visual Studio launches a browser window. In der Menüleiste sollten die Seiten Startseite und Datenschutz angezeigt werden.You should then see Home, and Privacy pages in the menu bar.

  3. Wählen Sie in der Menüleiste die Option Datenschutz aus.Choose Privacy from the menu bar.

    Im Browser wird auf der Seite Datenschutz der in der Datei Privacy.cshtml festgelegte Text gerendert.The Privacy page in the browser renders the text that is set in the Privacy.cshtml file.

    Anzeigen des Texts auf der Seite „Datenschutz“

  4. Wechseln Sie zurück zu Visual Studio, und drücken Sie UMSCHALT+F5, um den Debugmodus zu beenden.Return to Visual Studio, and then press Shift+F5 to stop Debug mode. Dadurch wird auch das Projekt im Browserfenster geschlossen.This also closes the project in the browser window.

  5. Öffnen Sie in Visual Studio die Datei Privacy.cshtml, um sie zu bearbeiten.In Visual Studio, open Privacy.cshtml for editing. Löschen Sie den Satz Verwenden Sie diese Seite, um Details über die Datenschutzrichtlinie Ihrer Website anzugeben, und fügen Sie stattdessen die Worte Diese Seite wird aktuell überarbeitet (Stand @ViewData["TimeStamp"]) hinzu.Then, delete the words Use this page to detail your site's privacy policy and in its place, add the words This page is under construction as of @ViewData["TimeStamp"].

    Ändern des Texts in der Datei „Privacy.cshtml“

  6. Nehmen Sie nun eine Codeänderung vor.Now, let's make a code change. Wählen Sie die Datei Privacy.cshtml.cs aus.Choose Privacy.cshtml.cs. Bereinigen Sie dann die using-Anweisungen oben in der Datei mithilfe der folgenden Verknüpfung.Then, clean up the using directives at the top of the file by using the following shortcut:

    Wählen Sie eine der ausgegrauten using-Anweisungen aus, damit die Glühbirne für Schnelle Aktionen unter dem Caretzeichen oder am linken Rand angezeigt wird.Choose any of the grayed-out using directives and a Quick Actions light bulb will appear just below the caret or in the left margin. Klicken Sie zunächst auf die Glühbirne, und zeigen Sie anschließend auf Nicht benötigte Using-Direktiven entfernen.Choose the light bulb, and then hover over Remove unnecessary usings.

    Entfernen nicht benötigter Using-Direktiven in der Datei „Privacy.cshtml.cs“

    Klicken Sie auf Vorschau der Änderungen, um die Änderungen anzuzeigen.Now choose Preview changes to see what will change.

    Vorschau der Änderungen

    Wählen Sie Anwenden aus.Choose Apply. Visual Studio löscht die unnötigen using-Anweisungen aus der Datei.Visual Studio deletes the unnecessary using directives from the file.

  7. Ändern Sie dann in der OnGet()-Methode den Text in den folgenden Code:Next, in the OnGet() method, change the body to the following code:

    public void OnGet()
    {
       string dateTime = DateTime.Now.ToShortDateString();
       ViewData["TimeStamp"] = dateTime;
    }
    
  8. Beachten Sie, dass DateTime wellenförmig unterstrichen wird.Notice that two wavy underlines appear under DateTime. Die Wellenlinie zeigt an, dass sich dieser Typ nicht im gültigen Bereich befindet.The wavy underlines appear because these type isn't in scope.

    Mit wellenförmigen Unterstrichen markierte Fehler in der OnGet-Methode

    Öffnen Sie die Symbolleiste Fehlerliste. Dort werden dieselben Fehler aufgelistet.Open the Error List toolbar to see the same errors listed there. (Wenn Ihnen die Symbolleiste Fehlerliste nicht angezeigt wird, klicken Sie in der oberen Menüleiste auf Ansicht > Fehlerliste.)(If you don't see the Error List toolbar, choose View > Error List from the top menu bar.)

    Fehlerliste in Visual Studio

  9. Korrigieren wir dies.Let's fix this. Platzieren Sie den Cursor im Code-Editor auf einer Zeile, die den Fehler enthält, und wählen Sie anschließend am linken Rand die Glühbirne für schnelle Aktionen aus.In the code editor, place your cursor on either line that contains the error, and then choose the Quick Actions light bulb in the left margin. Wählen Sie im Dropdownmenü using System; aus, um diese Anweisung am Anfang der Datei hinzuzufügen und die Fehler zu beheben.Then, from the drop-down menu, choose using System; to add this directive to the top of your file and resolve the errors.

    Hinzufügen der „using System;“-Anweisung

  10. Drücken Sie F5, um das Projekt im Webbrowser zu öffnen.Press F5 to open your project in the web browser.

  11. Klicken Sie oben auf der Website auf Datenschutz, um die Änderungen anzuzeigen.At the top of the web site, choose Privacy to view your changes.

    Anzeigen der aktualisierten Seite „Datenschutz“ mit den vorgenommenen Änderungen

  12. Schließen Sie den Webbrowser, drücken Sie UMSCHALT+F5, um den Debugmodus zu beenden, und schließen Sie dann Visual Studio.Close the web browser, press Shift+F5 to stop Debug mode, and then close Visual Studio.

Schnelle Antworten zu häufig gestellten FragenQuick answers FAQ

Im folgenden kurzen Abschnitt zu häufig gestellten Fragen werden einige wichtige Konzepte besprochen.Here's a quick FAQ to highlight some key concepts.

Was ist C#?What is C#?

C# ist eine typsichere und objektorientierte Programmiersprache, die nicht nur stabil, sondern auch einfach zu erlernen ist.C# is a type-safe and object-oriented programming language that's designed to be both robust and easy to learn.

Was ist ASP.NET Core?What is ASP.NET Core?

ASP.NET Core ist ein plattformübergreifendes Open Source-Framework zum Erstellen von Anwendungen mit Internetverbindung, wie etwa Web-Apps und -dienste.ASP.NET Core is an open-source and cross-platform framework for building internet-connected applications, such as web apps and services. ASP.NET Core-Apps können unter .NET Core oder .NET Framework ausgeführt werden.ASP.NET Core apps can run on either .NET Core or the .NET Framework. Sie können Ihre ASP.NET Core-Apps plattformübergreifend unter Windows, macOS und Linux ausführen und entwickeln.You can develop and run your ASP.NET Core apps cross-platform on Windows, Mac, and Linux. ASP.NET Core ist auf GitHub verfügbar.ASP.NET Core is open source at GitHub.

Was ist Visual Studio?What is Visual Studio?

Visual Studio ist eine integrierte Zusammenstellung von Entwicklertools, die die Produktivität fördern.Visual Studio is an integrated development suite of productivity tools for developers. Es ist also ein Programm zum Erstellen von Programmen und Anwendungen.Think of it as a program you can use to create programs and applications.

Nächste SchritteNext steps

Damit haben Sie das Tutorial erfolgreich abgeschlossen.Congratulations on completing this tutorial! Wir hoffen, dass Sie etwas über C#, ASP.NET Core und die Visual Studio-IDE gelernt haben.We hope you learned a little bit about C#, ASP.NET Core, and the Visual Studio IDE. Weitere Informationen zum Erstellen einer Web-App oder Website mit C# und ASP.NET Core finden Sie in den folgenden Tutorials:To learn more about creating a web app or website with C# and ASP.NET, continue with the following tutorials:

Siehe auchSee also

Veröffentlichen Ihrer Web-App in Azure App Service mit Visual StudioPublish your web app to Azure App Service by using Visual Studio