Erstellen von Projektmappen und ProjektenCreate solutions and projects

Projekte enthalten die Elemente, die zum Erstellen Ihrer App in Visual Studio erforderlich sind. Dabei handelt es sich z. B. um Quellcodedateien, Bitmaps, Symbole sowie Verweise auf Komponenten und Dienste.Projects hold the items needed to build your app in Visual Studio, such as source code files, bitmaps, icons, and component and service references. Wenn Sie ein neues Projekt erstellen, erstellt Visual Studio dafür eine Projektmappe.When you create a new project, Visual Studio creates a solution to contain the project. Danach können Sie der Projektmappe nach Bedarf weitere neue oder vorhandene Projekte hinzufügen.You can then add other new or existing projects to the solution if you want. Projektmappen können außerdem Dateien enthalten, die zu keinem bestimmten Projekt gehören.Solutions can also contain files that aren't connected to any specific project.

Hierarchie der Projektmappe bzw. des Projekts

Hinweis

Dieses Thema gilt für Visual Studio unter Windows.This topic applies to Visual Studio on Windows. Informationen zu Visual Studio für Mac finden Sie unter Erstellen von Projekten in Visual Studio für Mac.For Visual Studio for Mac, see Create projects in Visual Studio for Mac.

Sie können Ihre Projektmappen und Projekte in dem Toolfenster Projektmappen-Explorer abrufen.You can view your solutions and projects in a tool window called Solution Explorer. Im untenstehenden Screenshot wird ein Beispiel für eine Projektmappe im Projektmappen-Explorer (BikeSharing.Xamarin-UWP) angezeigt, die zwei Projekte enthält: BikeSharing.Clients.Core und BikeSharing.Clients.Windows.The following screenshot shows an example solution in Solution Explorer (BikeSharing.Xamarin-UWP) that contains two projects: BikeSharing.Clients.Core and BikeSharing.Clients.Windows. In jedem Projekt sind mehrere Dateien, Ordner und Verweise enthalten.Each project contains multiple files, folders, and references. Der Name des Startprojekts – also das Projekt, das gestartet wird, wenn Sie die App ausführen – ist fett gedruckt.The project name in bold is the startup project; that is, the project that starts when you run the app. Sie können das Startprojekt selbst festlegen.You can specify which project is the startup project.

Projektmappen-Explorer mit Projekten

Visual Studio bietet eine Auswahl von Projektvorlagen, die Sie beim Starten unterstützen sollen. Sie können Projekte aber auch selbst gestalten, indem Sie alle notwendigen Dateien hinzufügen.While you can construct a project yourself by adding the necessary files to it, Visual Studio offers a selection of project templates to give you a head start. Wenn Sie ein neues Projekt aus einer Vorlage erstellen, entsteht ein Projekt, dass alle für den Projekttyp benötigten Bestandteile enthält. Außerdem können Sie die Dateien umbenennen und nach Bedarf neuen oder vorhandenen Code sowie andere Ressourcen hinzufügen.Creating a new project from a template gives you a project with the essentials for that project type, and you can rename the files or add new or existing code and other resources to it as needed.

An dieser Stelle sollte erwähnt werden, dass Projektmappen und Projekte nicht unbedingt zum Entwickeln von Apps in Visual Studio benötigt werden.That being said, solutions and projects are not required to develop apps in Visual Studio. Sie können auch einfach nur den Code öffnen, den Sie aus Git geklont oder an anderer Stelle heruntergeladen haben.You can also just open code that you have cloned from Git or downloaded elsewhere. Weitere Informationen finden Sie unter Entwickeln von Code in Visual Studio ohne Projekte oder Projektmappen.For more information, see Develop code in Visual Studio without projects or solutions.

Erstellen eines Projekts aus einer ProjektvorlageCreate a project from a project template

Informationen zum Erstellen eines neuen Projekts aus einer Vorlage finden Sie unter Erstellen eines neuen Projekts in Visual Studio.For information about creating a new project from a template, see Create a new project in Visual Studio.

Erstellen eines Projekts aus vorhandenen CodedateienCreate a project from existing code files

Auflistungen von Quellcodedateien können Sie dem Projekt bei Bedarf hinzufügen.If you have a collection of code source files, you can easily add them to a project.

  1. Wählen Sie in der Menüleiste Datei > Neu > Projekt aus vorhandenem Code aus.On the menu, choose File > New > Project From Existing Code.

  2. Wählen Sie im Assistenten Create Project from Existing Code Files („Projekt aus vorhandenen Codedateien erstellen“) den gewünschten Projekttyp im Dropdown-Listenfeld Welchen Typ von Projekt möchten Sie erstellen? aus, und klicken Sie dann auf die Schaltfläche Weiter.In the Create Project from Existing Code Files wizard, choose the project type you want in the What type of project would you like to create? drop-down list box, and then choose the Next button.

  3. Wechseln Sie im Assistenten zum Speicherort der Dateien, und geben Sie dann einen Namen für das neue Projekt in das Feld Name ein.In the wizard, browse to the location of the files and then enter a name for the new project in the Name box. Wenn Sie diesen Vorgang abschlossen haben, klicken Sie auf die Schaltfläche Fertig stellen.When you are done, choose the Finish button.

Hinweis

Diese Option funktioniert am besten für relativ einfache Sammlungen von Dateien.This option works best for a relatively simple collection of files. Derzeit werden nur die Projekttypen C++, Apache Cordova, Visual Basic und C# unterstützt.Currently, only C++, Apache Cordova, Visual Basic, and C# project types are supported.

Hinzufügen von Dateien zu einer ProjektmappeAdd files to a solution

Dateien, die für mehrere Projekt gelten, wie Infodateien zur Projektmappe oder andere Dateien, die eher auf Projektmappenebene als auf Projektebene abgelegt werden sollten, können Sie zur Projektmappe hinzufügen.If you have a file that applies to multiple projects, such as a readme file for the solution, or other files that logically belong at the solution level rather than under a specific project, then you can add them to the solution itself. Öffnen Sie das Kontextmenü des Projektmappenknotens im Projektmappen-Explorer mit einem Rechtsklick, und wählen Sie Hinzufügen > Neues Element oder Hinzufügen > Vorhandenes Element aus, um der Projektmappe ein Element hinzuzufügen.To add an item to a solution, on the context (right-click) menu of the solution node in Solution Explorer, choose Add > New Item, or Add > Existing Item.

Erstellen eines .NET-Projekts, das für eine bestimmte Version von .NET Framework vorgesehen istCreate a .NET project that targets a specific version of the .NET Framework

Bei der Erstellung eines .NET Framework-Projekts können Sie angeben, welche Version von .NET Framework Sie verwenden möchten.When you create a .NET Framework project, you can specify a specific version of the .NET Framework that you want the project to use. (Wenn Sie ein .NET Core-Projekt erstellen, geben Sie keine Frameworkversion an.)(When you create a .NET Core project, you don't specify a framework version.)

Wählen Sie das Framework-Dropdownmenü im Dialogfeld Neues Projekt aus, um eine .NET Framework-Version anzugeben.To specify a .NET Framework version, choose the Framework drop-down menu in the New Project dialog box.

Framework-Dropdownliste im Dialogfeld „Neues Projekt“

Hinweis

Sie müssen auf dem System .NET Framework 3.5 installiert haben, um auf frühere Frameworkversionen als .NET Framework 4 zugreifen zu können.You must have .NET Framework 3.5 installed on your system to access .NET Framework versions earlier than .NET Framework 4.

Wählen Sie das Framework-Dropdownmenü auf der Seite Neues Projekt erstellen aus, um eine .NET Framework-Version anzugeben.To specify a .NET Framework version, choose the Framework drop-down menu on the Create a new project page.

Frameworkauswahl in „Neues Projekt konfigurieren“

Erstellen von leeren ProjektmappenCreate empty solutions

Sie können auch leere Projektmappen ohne Projekt erstellen.You can also create empty solutions that have no projects. Dies erweist sich unter Umständen als nützlich, wenn Sie die Projektmappe und Projekte von Grund auf neu erstellen möchten.This might be preferable in cases where you want to construct your solution and projects from scratch.

So erstellen Sie eine leere ProjektmappeTo create an empty solution

  1. Klicken Sie auf der Menüleiste auf Datei > Neu > Projekt.On the menu bar, choose File > New > Project.
  1. Klicken Sie im linken Bereich (Vorlagen) auf Andere Projekttypen > Visual Studio-Projektmappen in der erweiterten Liste.In the left (Templates) pane, choose Other Project Types > Visual Studio Solutions in the expanded list.

  2. Wählen Sie im mittleren Bereich die Option Leere Projektmappe aus.In the middle pane, choose Blank Solution.

  3. Geben Sie für die Projektmappe die Werte Name und Speicherort ein, und klicken Sie dann auf OK.Enter Name and Location values for your solution, and then choose OK.

  1. Geben Sie auf der Seite Neues Projekt erstellen Projektmappe in das Suchfeld ein.On the Create a new project page, type solution into the search box.

  2. Wählen Sie die Vorlage Leere Projektmappe aus, und klicken Sie dann auf Weiter.Select the Blank Solution template, and then click Next.

  3. Geben Sie für die Projektmappe die Werte Name und Speicherort ein, und klicken Sie dann auf Erstellen.Enter Name and Location values for your solution, and then choose Create.

Nachdem Sie eine leere Projektmappe erstellt haben, können Sie dieser neue oder vorhandene Projekte oder Elemente hinzufügen, indem Sie im Menü Projekt den Befehl Neues Element hinzufügen oder Vorhandenes Element hinzufügen auswählen.After you create an empty solution, you can add new or existing projects or items to it by choosing Add New Item or Add Existing Item on the Project menu.

Wie zuvor bereits erwähnt, können Sie Codedateien auch ohne Projekt oder Projektmappe öffnen.As mentioned earlier, you can also open code files without needing a project or solution. Weitere Informationen zu dieser Entwicklungsmethode finden Sie unter Entwickeln von Code in Visual Studio ohne Projekte oder Projektmappen.To learn about developing code in this way, see Develop code in Visual Studio without projects or solutions.

Erstellen eines temporären ProjektsCreate a temporary project

(Nur C# und Visual Basic)(C# and Visual Basic only)

Wenn Sie ein.NET-basiertes Projekt erstellen, ohne einen Speicherort auf einem Datenträger anzugeben, handelt es sich dabei automatisch um ein temporäres Projekt.If you create a .NET-based project without specifying a disk location, it is a temporary project. Mithilfe von temporären Projekten können Sie mit .NET-Projekten experimentieren.Temporary projects enable you to experiment with .NET projects. Während Sie an dem temporären Projekt arbeiten, können Sie es jederzeit speichern oder verwerfen.At any time while you are working with a temporary project, you can choose to save it or discard it.

Gehen Sie zunächst zu Extras > Optionen > Projekte und Projektmappen > Allgemein, und deaktivieren Sie das Feld Neue Projekte beim Erstellen speichern, um ein temporäres Projekt zu erstellen.To create a temporary project, first go to Tools > Options > Projects and Solutions > General, and uncheck the Save new projects when created checkbox. Öffnen Sie wie gewohnt das Dialogfeld Neues Projekt.Then open the New Project dialog box as usual.

Löschen einer Projektmappe, eines Projekts oder eines ElementsDelete a solution, project, or item

Sie können zwar Projektmappen und deren Inhalte dauerhaft löschen, jedoch funktioniert dies nicht über die Visual Studio-IDE.You can delete solutions and their contents permanently, but not by using the Visual Studio IDE. Wenn Sie Elemente aus Visual Studio löschen, werden sie nur aus der aktuellen Projektmappe oder dem aktuellen Projekt entfernt.Deleting items within Visual Studio only removes them from the current solution or project. Wenn Sie eine Projektmappe oder andere Komponenten dauerhaft von Ihrem System löschen möchten, verwenden Sie den Datei-Explorer, um den Ordner zu löschen, der die SLN- und SUO-Projektmappendateien enthält.To permanently delete a solution or other component from your system, use File Explorer to delete the folder that contains the .sln and .suo solution files. Bevor Sie allerdings eine Projektmappe dauerhaft löschen, wird empfohlen, dass Sie sämtliche Projekte oder Dateien sichern, falls Sie diese noch einmal benötigen sollten.However, before permanently deleting a solution, it's recommended that you back up any projects or files in case you need them again.

Hinweis

Die SUO-Datei wird ausgeblendet und nicht in den Standardeinstellungen des Datei-Explorers angezeigt.The .suo file is a hidden file that is not displayed under the default File Explorer settings. Aktivieren Sie das Feld Ausgeblendete Elemente in der Menüansicht des Datei-Explorers, damit ausgeblendete Dateien angezeigt werden.To show hidden files, on the View menu in File Explorer, select the Hidden Items checkbox.

Endgültiges Löschen einer ProjektmappePermanently delete a solution

  1. Wählen Sie im Projektmappen-Explorer im Kontextmenü die zu löschende Projektmappe aus, und wählen Sie dann Ordner in Datei-Explorer öffnen.In Solution Explorer, on the right-click menu (context menu) of the solution you want to delete, choose Open folder in File Explorer.

  2. Navigieren Sie im Datei-Explorer eine Ebene höher.In File Explorer, navigate up one level.

  3. Klicken Sie auf den Ordner, der die Projektmappe enthält, und drücken Sie dann die Taste ENTF.Choose the folder containing the solution and then press the Delete key.

Weitere InformationenSee also