Git-Benutzeroberfläche in Visual StudioGit experience in Visual Studio

Git ist nun die Standardressource für die Versionskontrolle in Visual Studio 2019.Git is now the default version control experience in Visual Studio 2019. Seit Version 16.6 wurde das Featurespektrum anhand des Benutzerfeedbacks weiter ausgearbeitet und verbessert.Since version 16.6, we've worked on building out the feature set and iterating on it based on your feedback. Die neue Git-Benutzeroberfläche ist seit dem Release von Version 16.8 standardmäßig für alle Benutzer aktiviert.The new Git experience is turned on by default for everyone with the release of version 16.8.

Tipp

Git ist das am häufigsten verwendete moderne Versionskontrollsystem. Unabhängig davon, ob Sie ein professioneller Entwickler sind oder erst die Grundlagen des Programmierens erlernen, kann Git sehr nützlich für Sie sein.Git is the most widely used modern version control system, so whether you’re a professional developer or if you’re learning how to code, Git can be very useful to you. Wenn Sie noch nicht mit Git vertraut sind, ist die Website https://git-scm.com/ ein guter Startpunkt.If you are new to Git, the https://git-scm.com/ website is a good place to start. Dort finden Sie Spickzettel, ein beliebtes E-Book sowie Videos zu den Git-Grundlagen.There, you’ll find cheat sheets, a popular online book, and Git Basics videos.

Verwenden von Git in Visual StudioHow to use Git in Visual Studio

In diesem Artikel erhalten Sie eine detaillierte Anleitung zur Verwendung der neuen Git-Benutzeroberfläche in Visual Studio 2019. Wenn Sie jedoch vorab bereits einen kurzen Blick darauf werfen möchten, können Sie sich das folgende Video ansehen:We'll walk you through how to use the new Git experience in Visual Studio 2019, but if you'd like to take a quick tour first, check out the following video:

Länge des Videos: 5,27 MinutenVideo length: 5.27 minutes

Es gibt drei Möglichkeiten, Ihre Produktivität mit Git in Visual Studio zu steigern:There are three ways to start using Git with Visual Studio to be more productive:

Hinweis

Ebenfalls ab Version 16.8 steht Ihnen in Visual Studio 2019 eine vollständig integrierte GitHub-Kontobenutzeroberfläche zur Verfügung.Starting also with version 16.8, Visual Studio 2019 includes a fully integrated GitHub account experience. Sie können Ihrer Keychain nun sowohl GitHub- als auch GitHub Enterprise-Konten hinzufügen.You can now add both GitHub and GitHub Enterprise accounts to your keychain. Sie können sie genauso wie Microsoft-Konten hinzufügen und nutzen. Dies vereinfacht den Zugriff auf GitHub-Ressourcen in Visual Studio für Sie.You’ll be able to add and leverage them just as you do with Microsoft accounts, which means that you’ll have an easier time accessing your GitHub resources across Visual Studio. Weitere Informationen finden Sie auf der Seite Arbeiten mit GitHub-Konten in Visual Studio.For more information, see the Work with GitHub accounts in Visual Studio page.

Erstellen eines neuen Git-RepositorysCreate a new Git repository

Wenn Ihr Code Git nicht zugeordnet ist, können Sie zunächst ein neues Git-Repository erstellen.If your code is not associated with Git, you can start by creating a new Git repository. Klicken Sie hierzu in der Menüleiste auf Git > Git-Repository erstellen.To do so, select Git > Create Git Repository from the menu bar. Geben Sie dann in im Dialogfeld Neues Git-Repository erstellen Ihre Informationen ein.Then, in the Create a Git repository dialog box, enter your information.

Dialogfeld „Git-Repository erstellen“ in Visual Studio.

Durch das Dialogfeld Git-Repository erstellen können Sie Ihr neues Repository einfach mithilfe von Push an GitHub übertragen.The Create a Git repository dialog box makes it easy to push your new repository to GitHub. Ihr neues Repository ist standardmäßig privat. Dies bedeutet, dass Sie die einzige Person sind, die darauf zugreifen kann.By default, your new repository is private, which means that you are the only one who can access it. Wenn Sie das Kontrollkästchen deaktivieren, ist Ihr Repository öffentlich, sodass es von jedem auf GitHub angezeigt werden kann.If you uncheck the box, your repository will be public, which means that anyone on GitHub can view it.

Tipp

Unabhängig davon, ob Ihr Repository privat oder öffentlich ist, ist es am besten, über eine auf GitHub gespeicherte Remotesicherung Ihres Codes zu verfügen, auch wenn Sie nicht mit einem Team zusammenarbeiten.Whether your repository is public or private, it's best to have a remote backup of your code stored securely on GitHub even if you are not working with a team. Dies macht Ihren Code auch für Sie verfügbar, unabhängig davon, welchen Computer Sie verwenden.This also makes your code available to you no matter what computer you're using.

Sie können ein lokales Git-Repository erstellen, indem Sie die Option Nur lokal verwenden.You can choose to create a local-only Git repository by using the Local only option. Sie können Ihr lokales Projekt auch mit einem vorhandenen leeren Remoterepository auf Azure DevOps oder einem anderen Git-Anbieter verknüpfen, indem Sie die Option Vorhandenes Remote verwenden.Or, you can link your local project with an existing empty remote repository on Azure DevOps or any other Git provider by using the Existing Remote option.

Klonen eines vorhandenen Git-RepositorysClone an existing Git repository

Visual Studio bietet eine direkte Funktion zum Klonen.Visual Studio includes a straightforward clone experience. Wenn Sie die URL des Repositorys kennen, das Sie klonen möchten, können Sie die URL im Abschnitt Repositoryspeicherort einfügen und dann den Speicherort auf dem Datenträger auswählen, an dem Visual Studio das Repository klonen soll.If you know the URL of the repository that you would like to clone, you can paste the URL in the Repository location section and then choose the disk location you would like Visual Studio to clone to.

Dialogfeld „Repository klonen“ in Visual Studio.

Wenn Sie die Repository-URL nicht kennen, können Sie mit Visual Studio problemlos Ihr vorhandenes GitHub- oder Azure DevOps-Repository suchen und anschließend klonen.If you don’t know the repository URL, Visual Studio makes it easy to browse to and then clone your existing GitHub or Azure DevOps repository.

Öffnen eines vorhandenen lokalen RepositorysOpen an existing local repository

Nachdem Sie ein Repository geklont oder eines erstellt haben, erkennt Visual Studio das Git-Repository und fügt es der Liste der Local Repositories (Lokale Repositorys) im Git-Menü hinzu.After you’ve cloned a repository or created one, Visual Studio detects the Git repository and adds it to your list of Local Repositories in the Git menu. Von hier aus können Sie schnell auf Ihre Git-Repositorys zugreifen oder zwischen diesen wechseln.From here, you can quickly access and switch between your Git repositories.

Option „Local Repositories“ (Lokale Repositorys) im Git-Menü in Visual Studio

Anzeigen von Dateien im Projektmappen-ExplorerView files in Solution Explorer

Wenn Sie ein Repository klonen oder ein lokales Repository öffnen, wechselt Visual Studio in diesen Git-Kontext, indem alle zuvor geöffneten Lösungen und Projekte gespeichert und geschlossen werden.When you clone a repository or open a local repository, Visual Studio switches you into that Git context by saving and closing any previously open solutions and projects. Der Projektmappen-Explorer lädt den Ordner im Stammverzeichnis des Git-Repositorys und scannt die Verzeichnisstruktur auf beliebige Ansichtsdateien.Solution Explorer loads the folder at the root of the Git repository and scans the directory tree for any View files. Hierzu gehören Dateien wie „CMakeLists.txt“ oder solche mit der Dateierweiterung „.sln“.These include files such as CMakeLists.txt or those with the .sln file extension.

Visual Studio passt die Ansicht an, je nachdem, welche Ansichtsdatei Sie im Projektmappen-Explorer laden:Visual Studio adjusts its View based on which View file you load in Solution Explorer:

  • Wenn Sie ein Repository klonen, das eine einzelne SLN-Datei enthält, lädt der Projektmappen-Explorer diese Lösung direkt für Sie.If you clone a repository that contains a single .sln file, then Solution Explorer directly loads that solution for you.
  • Wenn der Projektmappen-Explorer keine SLN-Dateien in Ihrem Repository erkennt, wird standardmäßig die Ordneransicht geladen.If Solution Explorer doesn’t detect any .sln files in your repository, then by default it loads Folder View.
  • Wenn Ihr Repository mehr als eine SLN-Datei enthält, zeigt der Projektmappen-Explorer die Liste der verfügbaren Ansichten an, aus denen Sie eine auswählen können.If your repository has more than one .sln file, then Solution Explorer shows you the list of available Views for you to choose from.

Sie können mithilfe der Schaltfläche Ansicht umschalten auf der Symbolleiste des Projektmappen-Explorers zwischen der aktuell geöffneten Ansicht und den Optionen in der Liste der Ansichten wechseln.You can toggle between the currently open View and the list of Views by using the Switch Views button in the Solution Explorer toolbar.

Ausgewählte Projektmappen-Explorer-Option „Ansicht umschalten“ in Visual Studio.

Fenster „Git-Änderungen“Git Changes window

Git verfolgt Dateiänderungen in Ihrem Repository, während Sie arbeiten, und unterteilt die Dateien in Ihrem Repository in drei Kategorien.Git tracks file changes in your repo as you work, and separates the files in your repo into three categories. Diese Änderungen sind gleichbedeutend mit dem, was Sie sehen, wenn Sie den Befehl git status in der Befehlszeile eingeben:These changes are equivalent to what you would see when you enter the git status command in the command line:

  • Unveränderte Dateien: Diese Dateien wurden seit dem letzten Commit nicht geändert.Unmodified files: These files haven't changed since your last commit.
  • Geänderte Dateien: Diese Dateien weisen Änderungen seit dem letzten Commit auf, aber Sie haben sie noch nicht für den nächsten Commit gestaget.Modified files: These files have changes since your last commit, but you haven't yet staged them for the next commit.
  • Gestagete Dateien: Diese Dateien weisen Änderungen auf, die mit dem nächsten Commit hinzugefügt werden.Staged files: These files have changes that will be added to the next commit.

Während Ihrer Arbeit werden Änderungen an Dateien in Ihrem Projekt von Visual Studio im Abschnitt Änderungen des Fensters Git-Änderungen nachverfolgt.As you do your work, Visual Studio keeps track of the file changes to your project in the Changes section of the Git Changes window.

Fenster „Git-Änderungen“ in Visual Studio.

Wenn Sie bereit sind, Änderungen zu stagen, klicken Sie für jede zu stagende Datei auf die Schaltfläche + (Pluszeichen). Alternativ können Sie mit der rechten Maustaste auf eine Datei und dann auf Stufe klicken.When you are ready to stage changes, click the + (plus) button on each file you want to stage, or right-click a file and then select Stage. Sie können auch alle geänderten Dateien mit einem Mausklick stagen, indem Sie die Schaltfläche + (Pluszeichen) oben im Abschnitt Änderungen zum Stagen aller Dateien verwenden.You can also stage all your modified files with one click by using the stage all + (plus) button at the top of the Changes section.

Wenn Sie eine Änderung stagen, erstellt Visual Studio den Abschnitt Gestagete Änderungen.When you stage a change, Visual Studio creates a Staged Changes section. Nur Änderungen im Abschnitt Gestagete Änderungen werden beim nächsten Commit hinzugefügt. Klicken Sie hierzu auf Gestageter Commit.Only changes in the Staged Changes section are added to the next commit, which you can do by selecting Commit Staged. Der entsprechende Befehl für diese Aktion ist git commit -m "Your commit message".The equivalent command for this action is git commit -m "Your commit message". Die Bereitstellung von Änderungen kann auch aufgehoben werden, indem Sie auf die Schaltfläche (Minuszeichen) klicken.Changes can also be unstaged by clicking the (minus) button. Der entsprechende Befehl für diese Aktion ist git reset <file_path>, um die Bereitstellung einer einzelnen Datei aufzuheben, oder git reset <directory_path>, um die Bereitstellung aller Dateien in einem Verzeichnis aufzuheben.The equivalent command for this action is git reset <file_path> to unstage a single file or git reset <directory_path> to unstage all the files in a directory.

Sie können sich auch dazu entscheiden, Ihre geänderten Dateien nicht zu stagen, indem Sie den Stagingbereich überspringen.You can also choose not to stage your modified files by skipping the staging area. In diesem Fall ermöglicht Visual Studio das Committen Ihrer Änderungen direkt ohne Staging.In this case, Visual Studio allows you to commit your changes directly without having to stage them. Geben Sie einfach Ihre Commitnachricht ein, und klicken Sie auf Alle committen.Just enter your commit message and then select Commit All. Der entsprechende Befehl für diese Aktion ist git commit -a.The equivalent command for this action is git commit -a.

Visual Studio erleichtert mithilfe der Verknüpfungen Commit für alle und Push und Commit für alle und Sync auch das Committen und Synchronisieren mit nur einem Mausklick.Visual Studio also makes it easy to commit and sync with one click by using the Commit All and Push and Commit All and Sync shortcuts. Wenn Sie in den Abschnitten Änderungen und Gestagete Änderungen auf eine beliebige Datei doppelklicken, wird ein zeilenweiser Vergleich mit der nicht geänderten Version der Datei angezeigt.When you double-click any file in the Changes and the Staged changes sections, you can see a line-by-line comparison with the unmodified version of the file.

Zeilenweiser Vergleich der Dateiversionen in Visual Studio

Tipp

Wenn Sie eine Verbindung mit dem Azure DevOps-Repository hergestellt haben, können Sie ein Azure DevOps-Arbeitselement mithilfe des Zeichens „#“ committen.You can associate an Azure DevOps work item with a commit by using the "#" character if you are connected to the Azure DevOps repository. Sie können Ihr Azure DevOps-Repository über Team Explorer > Verbindungen verwalten verbinden.You can connect your Azure DevOps repository through Team Explorer > Manage Connections.

Auswählen eines vorhandenen BranchsSelect an existing branch

Visual Studio zeigt den aktuellen Branch im Selektor am oberen Rand des Fensters Git-Änderungen an.Visual Studio displays the current branch in the selector at the top of the Git Changes window.

Aktuelle Branches, die über den Selektor am oberen Rand des Fensters „Git-Änderungen“ in Visual Studio angezeigt werden können

Der aktuelle Branch ist auch auf der Statusleiste in der rechten unteren Ecke der Visual Studio-IDE verfügbar.The current branch is also available in the status bar on the bottom-right corner of the Visual Studio IDE.

Aktuelle Branches, die mithilfe der Statusleiste in der unteren rechten Ecke in der Visual Studio-IDE angezeigt werden können

An beiden Speicherorten können Sie zwischen vorhandenen Branches wechseln.From both locations, you can switch between existing branches.

Neuen Branch erstellenCreate a new branch

Sie können auch einen neuen Branch erstellen.You can also create a new branch. Der entsprechende Befehl für diese Aktion ist git checkout -b <branchname>.The equivalent command for this action is git checkout -b <branchname>.

Das Erstellen eines neuen Branchs ist so einfach wie das Eingeben des Branchnamens und Verwenden eines vorhandenen Branchs als Basis.Creating a new branch is as simple as entering the branch name and basing it off an existing branch.

Dialogfeld „Neuen Branch erstellen“ in Visual Studio

Sie können einen vorhandenen lokalen Branch oder einen Remotebranch als Basis verwenden.You can choose an existing local or remote branch as the base. Das Kontrollkästchen Branch auschecken leitet Sie automatisch zum neu erstellten Branch weiter.The Checkout branch checkbox automatically switches you to the newly created branch. Der entsprechende Befehl für diese Aktion ist git checkout -b <new-branch><existing-branch>.The equivalent command for this action is git checkout -b <new-branch><existing-branch>.

Fenster „Git-Repository“Git Repository window

Visual Studio verfügt über das neue Fenster Git-Repository, bei dem es sich um eine konsolidierte Ansicht aller Details in Ihrem Repository einschließlich aller Verläufe in Bezug auf Branches, Remoterepositorys und Commits handelt.Visual Studio has a new Git Repository window, which is a consolidated view of all the details in your repository, including all of the branches, remotes, and commit histories. Sie können entweder über die Optionen Git oder Ansicht auf der Menüleiste oder über die Statusleiste direkt auf dieses Fenster zugreifen.You can access this window directly from either Git or View on the menu bar or from the status bar.

Verwalten von BranchesManage branches

Wenn Sie im Menü Git auf Branches verwalten klicken, wird im Fenster Git-Repository die Branchstrukturansicht angezeigt.When you select Manage Branches from the Git menu, you’ll see the branches tree-view in the Git Repository window. Im linken Bereich können Sie das Kontextmenü (Klick mit der rechten Maustaste) unter anderem verwenden, um Branches zu überprüfen, neue Branches zu erstellen oder diese zusammenzuführen. Außerdem können Sie Rebases und Cherry-Picks ausführen.From the left pane, you can use the right-click context menu to checkout branches, create new branches, merge, rebase, cherry-pick, and more. Wenn Sie auf den Branch klicken, wird im rechten Bereich eine Vorschau des zugehörigen Commitverlaufs angezeigt.When you click the branch, you can see a preview of its commit history in the right pane.

Eingehende und ausgehende CommitsIncoming and outgoing commits

Wenn Sie einen Branch fetchen, verfügt das Fenster Git-Änderungen unter dem Dropdownmenü für den Branch über einen Indikator, der die Anzahl nicht gepullter Commits aus dem Remotebranch anzeigt.When you fetch a branch, the Git Changes window has an indicator under the branch drop-down, which displays the number of unpulled commits from the remote branch. Dieser Indikator zeigt außerdem die Anzahl der nicht mithilfe von Push übertragenen lokalen Commits an.This indicator also shows you the number of unpushed local commits.

Fenster „Git-Änderungen“ mit dem Benutzeroberflächenelement für das Indikatordropdownmenü in Visual Studio

Der Indikator fungiert auch als Verlinkung zum Commitverlauf des Branchs im Fenster Git-Repository.The indicator also functions as a link to take you to the commit history of that branch in the Git Repository window. Oben im Verlauf werden nun die Details dieser eingehenden und ausgehenden Commits angezeigt.The top of the history now displays the details of these incoming and outgoing commits. Von hier aus können Sie die Commits auch pullen oder mithilfe von Push übertragen.From here, you can also decide to Pull or Push the commits.

Fenster „Git-Repository“ mit dem Commitverlauf eines Branchs in Visual Studio

CommitdetailsCommit Details

Wenn Sie auf einen Commit doppelklicken, zeigt Visual Studio die entsprechenden Details in einem separaten Toolfenster an.When you double-click a Commit, Visual Studio opens its details in a separate tool window. Von hier aus können Sie den Commit rückgängig machen, zurücksetzen, die Commitnachricht ändern oder ein Tag für den Commit erstellen.From here you can revert the commit, reset the commit, amend the commit message, or create a tag on the commit. Wenn Sie auf eine geänderte Datei im Commit klicken, öffnet Visual Studio die parallele Diff-Ansicht des Commits und des übergeordneten Elements.When you click a changed file in the commit, Visual Studio opens the side-by-side Diff view of the commit and its parent.

Dialogfeld „Commitdetails“ in Visual Studio

Behandeln von MergekonfliktenHandle merge conflicts

Während eines Mergevorgangs können Konflikte auftreten, wenn zwei Entwickler die gleichen Zeilen in einer Datei ändern und Git nicht automatisch weiß, welche Zeile korrekt ist.Conflicts can occur during a merge if two developers modify the same lines in a file and Git doesn’t automatically know which is correct. Git hält den Merge an und informiert Sie darüber, dass ein Konflikt besteht.Git halts the merge and informs you that you are in a conflicted state.

Visual Studio erleichtert das Identifizieren und Lösen von Mergekonflikten.Visual Studio makes it easy to identify and resolve a merge conflict. Zuerst zeigt das Fenster Git-Repository am oberen Rand eine goldene Infoleiste an.First, the Git Repository window shows a gold info bar at the top of the window.

Meldung „Der Merge in Repository (...) wurde mit Konflikten abgeschlossen.“ in Visual Studio

Das Fenster Git-Änderungen zeigt auch die Meldung "Merge wird mit Konflikten ausgeführt." mit den nicht gemergten Dateien in einem separaten Abschnitt darunter an.The Git Changes window also displays a ‘Merge is in progress with conflicts’ message, with the unmerged files in their separate section below it.

Meldung „Der Merge wird mit Konflikten ausgeführt.“ in Visual Studio

Wenn keines dieser Fenster geöffnet ist und Sie stattdessen zu der Datei mit Mergekonflikten navigieren, müssen Sie nicht nach dem folgenden Text suchen:But if you have neither of these windows open, and instead you go to the file that has merge conflicts, you won’t have to search for the following text:

    <<<<<<< HEAD
    =======
    >>>>>>> main

Stattdessen zeigt Visual Studio oben auf der Seite eine goldene Infoleiste an, die angibt, dass im Zusammenhang mit der geöffneten Datei Konflikte bestehen.Instead, Visual Studio displays a gold info bar on the top of the page that indicates that the opened file has conflicts. Anschließend können Sie auf die Verlinkung klicken, um den Merge-Editor zu öffnen.Then, you can click the link to open the Merge Editor.

Screenshot: Meldung &quot;File contains merge conflicts.&quot; (Im Zusammenhang mit dieser Datei bestehen Mergekonflikte.) in Visual Studio

Merge-EditorThe Merge Editor

Der Merge-Editor in Visual Studio ist ein Drei-Wege-Mergetool, das die eingehenden Änderungen, die aktuellen Änderungen und das Ergebnis des Merges anzeigt.The Merge Editor in Visual Studio is a three-way merge tool that displays the incoming changes, your current changes, and the result of the merge. Sie können die Symbolleiste oben im Merge-Editor verwenden, um zwischen Konflikten und automatisch gemergten Unterschieden in der Datei zu navigieren.You can use the tool bar at the top level of the Merge Editor to navigate between conflicts and auto-merged differences in the file.

Merge-Editor in Visual Studio

Sie können auch die Umschaltflächen zum Anzeigen bzw. Ausblenden von Unterschieden und Wortunterschieden oder das Anpassen des Layouts verwenden.You can also use the toggles to show/hide differences, show/hide word differences, and customize the layout. Oben auf jeder Seite befinden sich Kontrollkästchen, die Sie verwenden können, um alle Änderungen von der einen Seite für die andere Seite zu übernehmen.There are checkboxes on the top of each side that you can use to take all the changes from one side or the other. Wenn Sie jedoch einzelne Änderungen vornehmen möchten, können Sie auf beiden Seiten auf die Kontrollkästchen links neben den in Konflikt stehenden Zeilen klicken.But to take individual changes, you can click the checkboxes to the left of the conflicting lines on either side. Wenn Sie schließlich die Konflikte beseitigt haben, können Sie im Merge-Editor auf die Schaltfläche Merge akzeptieren klicken.Finally, when you finish resolving the conflicts, you can select the Accept Merge button in the Merge Editor. Anschließend schreiben Sie eine Commitnachricht und committen die Änderungen, um den Vorgang abzuschließen.You then write a commit message and commit the changes to complete the resolution.

Personalisieren der Git-EinstellungenPersonalize your Git settings

Navigieren Sie auf der Menüleiste entweder zu Git > Einstellungen oder zu Extras > Optionen > Quellcodeverwaltung, um Ihre Git-Einstellungen sowohl auf Repositoryebene als auch auf globaler Ebene zu personalisieren und anzupassen.To personalize and customize your Git settings at a repository level as well as at a global level, go to either Git > Settings on the menu bar, or to Tools > Options > Source Control on the menu bar. Wählen Sie anschließend die gewünschten Optionen aus.Then, choose the options you want.

Dialogfeld „Optionen“ zum Personalisieren und Anpassen von Einstellungen in der Visual Studio-IDE

Verwenden der vollständigen Version von Team Explorer in Visual StudioHow to use the full Team Explorer experience in Visual Studio

Die neue Git-Benutzeroberfläche stellt ab Version 16.8 das Standardsystem für die Versionskontrolle in Visual Studio 2019 bereit.The new Git experience is the default version control system in Visual Studio 2019 from version 16.8 onwards. Wenn Sie sie deaktivieren möchten, können Sie dies jedoch auch tun.However, if you want to turn it off, you can. Wechseln Sie zu Extras > Optionen > Umgebung > Vorschaufeatures, und aktivieren Sie das Kontrollkästchen New Git user experience (Neue Git-Benutzeroberfläche), wodurch Sie zu Team Explorer für Git zurückkehren.Go to Tools > Options > Environment > Preview Features and then toggle the New Git user experience checkbox, which will switch you back to Team Explorer for Git.

Abschnitt „Vorschaufeatures“ des Dialogfelds „Optionen“ in Visual Studio

Nächste SchritteWhat's next

Die neue Git-Benutzeroberfläche ist in Visual Studio 2019, Version 16.8, zwar standardmäßig aktiviert, wird aber weiterhin um neue Features erweitert, um die Leistung zu verbessern.While the new Git experience is now on by default in Visual Studio 2019 version 16.8, we continue to add new features to enhance the experience. Wenn Sie neue Updates der Git-Benutzeroberfläche in einem Vorschaurelease ausprobieren möchten, können Sie diese über die Seite Visual Studio Preview herunterladen und installieren.If you'd like to check out new updates to the Git experience in a Preview release, you can download and install it from the Visual Studio Preview page.

Wichtig

Wenn Sie einen Vorschlag haben, können Sie uns diesen gerne mitteilen.If you have a suggestion for us, please let us know! Wir freuen uns, Entwurfsentscheidungen im Portal für die Entwicklercommunity diskutieren zu können.We appreciate the opportunity to engage with you on design decisions via the Developer Community portal.

Weitere InformationenSee also