Funktionen des Code-EditorsFeatures of the code editor

Der Visual Studio-Editor bietet viele Funktionen, die Ihnen das Schreiben und die Verwaltung von Code und Text erleichtern.The Visual Studio editor provides many features that make it easier for you to write and manage your code and text. Sie können mithilfe der Gliederung verschiedene Codeblöcke reduzieren und erweitern.You can expand and collapse different blocks of code by using outlining. Wenn Sie IntelliSense, den Objektkatalog und die Aufrufhierarchie verwenden, können Sie mehr über Ihren Code erfahren.You can learn more about the code by using IntelliSense, the Object Browser, and the Call Hierarchy. Sie können Code finden, indem Sie Funktionen wie Gehe zu, Gehe zu Definitionund Alle Verweise suchen verwenden.You can find code by using features such as Go To, Go To Definition, and Find All References. Mit Codeausschnitten können Sie Codeblöcke einfügen und Code mithilfe von Funktionen wie Generate From Usagegenerieren.You can insert blocks of code with code snippets, and you can generate code by using features such as Generate From Usage. Wenn Sie noch nie mit dem Visual Studio-Editor gearbeitet haben, lesen Sie Informationen zur Verwendung des Code-Editors.If you have never used the Visual Studio editor before, see Learn to use the code editor.

Hinweis

Dieses Thema gilt für Visual Studio unter Windows.This topic applies to Visual Studio on Windows. Informationen zu Visual Studio für Mac finden Sie unter Quellcode-Editor (Visual Studio für Mac).For Visual Studio for Mac, see Source editor (Visual Studio for Mac).

Code kann auf unterschiedliche Weise angezeigt werden.You can view your code in a number of different ways. Standardmäßig wird Ihr Code im Projektmappen-Explorer nach Dateien geordnet angezeigt.By default, Solution Explorer shows your code organized by files. Sie können auf die Registerkarte Klassenansicht im unteren Bereich des Fensters klicken, damit Ihr Code nach Klassen geordnet angezeigt wird.You can click on the Class View tab at the bottom of the window to view your code organized by classes.

Sie können Text in einzelnen oder mehreren Dateien suchen und ersetzen.You can search and replace text in single or multiple files. Weitere Informationen finden Sie unter Suchen und Ersetzen von Text.For more information, see Find and replace text. Sie können reguläre Ausdrücke zum Suchen und Ersetzen von Text verwenden.You can use regular expressions to find and replace text. Weitere Informationen finden Sie unter Verwenden von regulären Ausdrücken in Visual Studio.For more information, see Use regular expressions in Visual Studio.

Für die verschiedenen Visual Studio-Sprachen werden unterschiedliche Funktionssätze angeboten, und in einigen Fällen verhalten sich die Funktionen in verschiedenen Sprachen unterschiedlich.The different Visual Studio languages offer different sets of features, and in some cases the features behave differently in different languages. Viele dieser Unterschiede werden in den Beschreibungen der Funktionen erläutert. Weitere Informationen können Sie den Abschnitten über einzelne Visual Studio-Sprachen entnehmen.Many of these differences are specified in the descriptions of the features, but for more information you can see the sections on specific Visual Studio languages.

Editor-FunktionenEditor features

Farben für SyntaxSyntax Coloring Einige Syntaxelemente in den Code- und Markupdateien sind unterschiedlich gefärbt, damit sie unterschieden werden können.Some syntax elements of code and markup files are colored differently to distinguish them. Beispielsweise sind Schlüsselwörter (wie using in C# und Imports in Visual Basic) in einer Farbe gehalten, jedoch Typen (wie Console und Uri) haben eine andere Farbe.For example, keywords (such as using in C# and Imports in Visual Basic) are one color, but types (such as Console and Uri) are another color. Andere Syntaxelemente werden auch farbig hervorgehoben, wie zum Beispiel Zeichenfolgenliterale und Kommentare.Other syntax elements are also colorized, such as string literals and comments. In C++ werden Farben verwendet, um Typen, Enumerationen und Makros von anderen Token zu unterscheiden.C++ uses color to differentiate among types, enumerations, and macros, among other tokens.

Sie können die Standardfarbe für jeden Typ sehen und die Farbe für spezifische Syntaxelemente unter Schriftarten und Farben, Umgebung, Dialogfeld „Optionen“ ändern, das Sie über das Menü Extras öffnen können.You can see the default color for each type, and you can change the color for any specific syntax element in the Fonts and Colors, Environment, Options dialog box, which you can open from the Tools menu.
Markierungen für Fehler und WarnungenError and Warning Marks Wenn Sie Code hinzufügen und Ihre Projektmappe erstellen, werden möglicherweise (a) verschiedenfarbige Unterstreichungen (sogenannte Wellenlinien) oder (b) Glühbirnen in Ihrem Code angezeigt.As you add code and build your solution, you may see (a) different-colored wavy underlines (known as squiggles) or (b) light bulbs appearing in your code. Rote Wellenlinien kennzeichnen Syntaxfehler, blaue kennzeichnen Compilerfehler, grüne kennzeichnen Warnungen und lila Wellenlinien kennzeichnen alle anderen Arten von Fehlern.Red squiggles denote syntax errors, blue denotes compiler errors, green denotes warnings, and purple denotes other types of errors. Unter Schnelle Aktionen werden Fehlerbehebungen für Probleme vorgeschlagen. Sie vereinfachen das Anwenden der jeweiligen Fehlerbehebung.Quick Actions suggest fixes for problems and make it easy to apply the fix.

Sie können die Standardfarbe der jeweiligen Wellenlinien für Fehler und Warnungen im Dialogfeld Tools > Optionen > Umgebung > Schriftarten und Farben anzeigen.You can see the default color for each error and warning squiggle in the Tools > Options > Environment > Fonts and Colors dialog box. Suchen Sie nach Syntaxfehler, Compilerfehler, Warnungund Anderer Fehler.Look for Syntax Error, Compiler Error, Warning, and Other Error.
Überprüfung des KlammergleichgewichtsBrace Matching Bei Platzierung der Einfügemarke auf eine öffnende geschweifte Klammer in einer Codedatei werden die öffnende und die schließende Klammer hervorgehoben.When the insertion point is placed on an open brace in a code file, both it and the closing brace are highlighted. Durch diese Funktion erhalten Sie unmittelbar Feedback zu falsch platzierten oder fehlenden geschweiften Klammern.This feature gives you immediate feedback on misplaced or missing braces. Sie können die Anzeige der zugehörigen Klammer mit der Einstellung Trennzeichen automatisch hervorheben aktivieren und deaktivieren (Tools > Optionen > Text-Editor).You can turn brace matching on or off with the Automatic Delimiter Highlighting setting (Tools > Options > Text Editor). Sie können die Hervorhebungsfarbe in der Einstellung Schriftarten und Farben ändern (Tools > Optionen > Umgebung).You can change the highlight color in the Fonts and Colors setting (Tools > Options > Environment). Suchen Sie nach Zugehörige Klammer (Hervorhebung) oder Zugehörige Klammer (Rechteck) .Look for Brace Matching (Highlight) or Brace Matching (Rectangle).
StrukturschnellansichtStructure Visualizer Gepunktete Linien verbinden passende Klammern in Codedateien, wodurch sich öffnende und schließende Klammerpaare leichter erkennen lassen.Dotted lines connect matching braces in code files, making it easier to see opening and closing brace pairs. Das hilft Ihnen bei der schnelleren Suchen von Code in Ihrer Codebasis.This can help you find code in your codebase more quickly. Sie können diese Linien mit der Einstellung Strukturlinien anzeigen im Abschnitt Anzeige auf der Seite Tools > Optionen > Text-Editor > Allgemein aktivieren und deaktivieren.You can turn these lines on or off with the Show structure guidelines in the Display section of the Tools > Options > Text Editor > General page.
ZeilennummernLine Numbers Zeilennummern können im linken Rand des Codefensters angezeigt werden.Line numbers can be displayed in the left margin of the code window. Standardmäßig werden sie nicht angezeigt.They are not displayed by default. Sie können diese Option in den Einstellungen Text-Editor –> Alle Sprachen aktivieren (Tools > Optionen > Text-Editor > Alle Sprachen).You can turn this option on in the Text Editor All Languages settings (Tools > Options > Text Editor > All Languages). Sie können Zeilennummern für einzelne Programmiersprachen anzeigen, indem Sie die Einstellungen für diese Sprachen ändern (Tools > Optionen > Text-Editor > <Sprache> ).You can display line numbers for individual programming languages by changing the settings for those languages (Tools > Options > Text Editor > <language>). Damit die Zeilennummern ausgedruckt werden, müssen Sie im Dialogfeld Drucken die Option Zeilennummern einschließen auswählen.For line numbers to print, you must select Include line numbers in the Print dialog box.
ÄnderungsnachverfolgungChange Tracking Durch die Farbe am linken Rand können Sie die Änderungen verfolgen, die Sie an einer Datei vorgenommen haben.The color of the left margin allows you to keep track of the changes you have made in a file. Änderungen, die Sie seit dem Öffnen der Datei vorgenommen, jedoch nicht gespeichert haben, werden durch eine gelbe Leiste am linken Rand gekennzeichnet (auch als "Auswahlrand" bezeichnet).Changes you have made since the file was opened but not saved are denoted by a yellow bar on the left margin (known as the selection margin). Nach dem Speichern der Änderungen (jedoch vor dem Schließen der Datei), wird die Statusleiste grün.After you have saved the changes (but before closing the file), the bar turns green. Wenn Sie eine Änderung rückgängig machen, nachdem Sie die Datei gespeichert haben, wird die Leiste orange.If you undo a change after you have saved the file, the bar turns orange. Um diese Funktion zu aktivieren und zu deaktivieren, ändern Sie die Option Änderungen nachverfolgen in den Text-Editor-Einstellungen (Tools > Optionen > Text-Editor).To turn this feature off and on, change the Track changes option in the Text Editor settings (Tools > Options > Text Editor).
Auswählen von Text und CodeSelecting Code and Text Sie können Text entweder im standardmäßigen fortlaufenden Streammodus oder im Feldmodus auswählen, indem Sie einen rechteckigen Bereich des Texts anstelle eines Zeilensatzes auswählen.You can select text either in the standard continuous stream mode or in box mode, in which you select a rectangular portion of text instead of a set of lines. Um eine Auswahl im Feldmodus vorzunehmen, drücken Sie ALT, während Sie die Maus über die Auswahl ziehen (oder drücken Sie ALT+UMSCHALTTASTE+ <Pfeiltaste> ).To make a selection in box mode, press Alt as you drag the mouse over the selection (or press Alt+Shift+<arrow key>). Die Auswahl umfasst alle Zeichen innerhalb des Rechtecks, das durch das erste und das letzte Zeichen in der Auswahl definiert wird.The selection includes all of the characters within the rectangle defined by the first character and the last character in the selection. Eingaben oder Einfügungen im ausgewählten Bereich werden in jeder Zeile am gleichen Punkt eingefügt.Anything typed or pasted into the selected area is inserted at the same point on each line.
ZoomZoom Sie können die Anzeige in jedem Codefenster vergrößern oder verkleinern, indem Sie die STRG-TASTE gedrückt halten und das Mausrad drehen (oder zum Vergrößern STRG+UMSCHALT+ .You can zoom in or out in any code window by pressing and holding the Ctrl key and moving the scroll wheel on the mouse (or Ctrl+Shift+. und zum Verkleinern STRG+UMSCHALT+ , drücken).to increase and Ctrl+Shift+, to decrease). Sie können auch über das Zoomfelds links unten im Codefenster einen bestimmten Zoomprozentsatz festlegen.You can also use the Zoom box in the lower left corner of the code window to set a specific zoom percentage. Die Zoomfunktion funktioniert nicht in Toolfenstern.The zoom feature does not work in tool windows.
Virtueller BereichVirtual Space Standardmäßig enden Zeilen in Visual Studio-Editoren nach dem letzten Zeichen, sodass der Cursor am Ende einer Zeile mit der NACH RECHTS-TASTE an den Anfang der nächsten Zeile verschoben werden kann.By default, lines in Visual Studio editors end after the last character, so that the Right Arrow key at the end of a line moves the cursor to the beginning of the next line. In einigen Editoren endet eine Zeile nicht nach dem letzten Zeichen, und Sie können den Cursor an einer beliebigen Stelle in der Zeile platzieren.In some other editors a line does not end after the last character, and you can place your cursor anywhere on the line. Sie können den virtuellen Bereich im Editor in den Einstellungen Tools > Optionen > Text-Editor > Alle Sprachen aktvieren.You can enable virtual space in the editor in the Tools > Options > Text Editor > All Languages settings. Beachten Sie, dass Sie entweder Virtueller Bereich oder Zeilenumbruchaktivieren können, jedoch nicht beide Optionen gleichzeitig.Note that you can enable either Virtual Space or Word Wrap, but not both.
DruckenPrinting Beim Drucken einer Datei können Sie über die Optionen im Dialogfeld Drucken Zeilennummern einschließen oder reduzierte Bereiche des Codes ausblenden.You can use the options in the Print dialog box to include line numbers or hide collapsed regions of code when you print a file. Im Dialogfeld Seite einrichten können Sie auch festlegen, dass der vollständige Pfad und der Dateiname gedruckt werden, indem Sie Kopfzeileauswählen.In the Page Setup dialog box, you can also choose to print the full path and the name of the file by choosing Page header.

Sie können Farbdruckoptionen im Dialogfeld Tools > Optionen > Umgebung > Schriftarten und Farben festlegen.You can set color printing options in the Tools > Options > Environment > Fonts and Colors dialog box. Wählen Sie Drucker in der Liste Einstellungen anzeigen für aus, um den Farbdruck anzupassen.Choose Printer in the Show settings for list to customize color printing. Sie können zum Drucken einer Datei andere Farben als beim Bearbeiten der Datei angeben.You can specify different colors for printing a file than for editing a file.
Globales Rückgängigmachen und WiederholenGlobal Undo and Redo Mithilfe der Befehle Letzte globale Aktion rückgängig machen und Letzte globale Aktion wiederholen im Menü Bearbeiten werden globale Aktionen, die sich auf mehrere Dateien auswirken, rückgängig gemacht oder wiederholt.The Undo Last Global Action and Redo Last Global Action commands on the Edit menu undo or redo global actions that affect multiple files. Globale Aktionen beinhalten das Umbenennen einer Klasse oder eines Namespaces, das Durchführen eines Such- und Ersetzungsvorgangs in einer Projektmappe, die Umgestaltung einer Datenbank oder eine beliebige andere Aktion, die mehrere Dateien ändert.Global actions include renaming a class or namespace, performing a find-and-replace operation across a solution, refactoring a database, or any other action that changes multiple files. Sie können die Befehle zum globalen Rückgängigmachen und Wiederholen auf Aktionen in der aktuellen Visual Studio-Sitzung anwenden, sogar nachdem Sie die Projektmappe geschlossen haben, in der eine Aktion angewendet wurde.You can apply the global undo and redo commands to actions in the current Visual Studio session, even after you close the solution in which an action was applied.

Erweiterte BearbeitungsfunktionenAdvanced editing features

Einige erweiterte Funktionen befinden sich auf der Symbolleiste im Menü Bearbeiten > Erweitert.You can find a number of advanced features on the Edit > Advanced menu on the toolbar. Nicht alle diese Funktionen sind für alle Arten von Codedateien verfügbar.Not all of these features are available for all types of code files.

Dokument formatierenFormat Document Legt den richtigen Einzug von Codezeilen fest und verschiebt geschweifte Klammern in separate Zeilen im Dokument.Sets the proper indentation of lines of code and moves curly braces to separate lines in the document.
Auswahl formatierenFormat Selection Legt den richtigen Einzug von Codezeilen fest und verschiebt geschweifte Klammern in separate Zeilen in der Auswahl.Sets the proper indentation of lines of code and moves curly braces to separate lines in the selection.
Ausgewählte Zeilen mit Tabstopps versehenTabify Selected Lines Ändert führende Leerzeichen ggf. in Tabstopps.Changes leading spaces to tabs where appropriate.
Tabstopps aus ausgewählten Zeilen entfernenUntabify Selected Lines Ändert führende Tabstopps in Leerzeichen.Changes leading tabs to spaces. Wenn Sie in einer Datei alle Leerzeichen in Tabstopps (oder alle Tabstopps in Leerzeichen) konvertieren möchten, können Sie dazu die Befehle Edit.ConvertSpacesToTabs und Edit.ConvertTabsToSpaces verwenden.If you want to convert all the spaces in your file to tabs (or all the tabs to spaces), you can use the Edit.ConvertSpacesToTabs and Edit.ConvertTabsToSpaces commands. Diese Befehle werden nicht in Visual Studio-Menüs angezeigt. Sie können sie jedoch über das Schnellzugriffsfenster oder das Befehlsfenster aufrufen.These commands do not appear in Visual Studio menus, but you can call them from the Quick Access window or the command window.
In Großbuchstaben umwandelnMake Uppercase Wandelt alle Zeichen in der Auswahl in Großbuchstaben um. Wenn keine Auswahl vorhanden ist, wird das Zeichen an der Einfügemarke in Großbuchstaben dargestellt.Changes all characters in the selection to uppercase, or if there is no selection, changes the character at the insertion point to uppercase. Tastenkombination: STRG+UMSCHALT+U.Shortcut: Ctrl+Shift+U.
In Kleinbuchstaben umwandelnMake Lowercase Wandelt alle Zeichen in der Auswahl in Kleinbuchstaben um. Wenn keine Auswahl vorhanden ist, wird das Zeichen an der Einfügemarke in Kleinbuchstaben dargestellt.Changes all characters in the selection to lowercase, or if there is no selection, changes the character at the insertion point to lowercase. Tastenkombination: STRG+U.Shortcut: Ctrl+U.
Ausgewählte Zeilen nach oben verschiebenMove selected Lines Up Verschiebt die ausgewählte Zeilen um eine Zeile nach obenMoves the selected line up one line. Tastenkombination: ALT+NACH-OBEN-TASTEShortcut: Alt+Up Arrow.
Ausgewählte Zeilen nach unten verschiebenMove Selected Lines Down Verschiebt die ausgewählte Zeile um eine Zeile nach unten.Moves the selected line down one line. Tastenkombination: ALT+NACH-UNTEN-TASTEShortcut: Alt+Down Arrow.
Horizontale Leerstelle löschenDelete Horizontal White Space Löscht Tabstopps oder Leerzeichen am Ende der aktuellen Zeile.Deletes tabs or spaces at the end of the current line. Tastenkombination: STRG+K, STRG+ \Shortcut: Ctrl+K, Ctrl+\
Leerstelle anzeigenView White Space Zeigt Leerzeichen als Hochpunkte und Tabstopps als Pfeile an.Displays spaces as raised dots, and tabs as arrows. Das Ende einer Datei wird als rechteckiges Symbol angezeigt.The end of a file is displayed as a rectangular glyph. Wenn die Option Tools > Optionen > Text-Editor > Alle Sprachen > Zeilenumbruch > Sichtbare Glyphen für Zeilenumbruch anzeigen ausgewählt ist, wird diese Glyphe ebenfalls angezeigt.If Tools > Options > Text Editor > All Languages > Word Wrap > Show visible glyphs for word wrap is selected, that glyph is also displayed.
ZeilenumbruchWord Wrap Bewirkt, dass alle Zeilen in einem Dokument im Codefenster sichtbar sind.Causes all the lines in a document to be visible in the code window. Sie können den Zeilenumbruch in den Text-Editor-Einstellungen für alle Sprachen aktivieren und deaktivieren (Extras > Optionen > Text-Editor > Alle Sprachen).You can turn word wrap off and on in the Text Editor All Languages settings (Tools > Options > Text Editor > All Languages).
Auswahl kommentierenComment Selection Fügt Kommentarzeichen zur Auswahl oder aktuellen Zeile hinzu.Adds comment characters to the selection or the current line. Tastenkombination: STRG+K, STRG+CShortcut: Ctrl+K, Ctrl+C
Kommentar aus Auswahl entfernenUncomment Selection Entfernt Kommentarzeichen aus der Auswahl oder der aktuellen Zeile.Removes comment characters from the selection or the current line. Tastenkombination: STRG+K, STRG+UShortcut: Ctrl+K, Ctrl+U
Zeileneinzug vergrößernIncrease Line Indent Fügt eine Registerkarte (oder die entsprechenden Leerzeichen) zu den ausgewählten Zeilen oder zur aktuellen Zeile hinzu.Adds a tab (or the equivalent spaces) to the selected lines or the current line.
Zeileneinzug verkleinernDecrease Line Indent Entfernt eine Registerkarte (oder die entsprechenden Leerzeichen) aus den ausgewählten Zeilen oder der aktuellen Zeile.Removes a tab (or the equivalent spaces) from the selected lines or the current line.
Tag auswählenSelect Tag Wählt das Tag in einem Dokument aus, das Tags enthält (zum Beispiel XML oder HTML).In a document that contains tags (for example, XML or HTML), selects the tag.
Tag-Inhalt auswählenSelect Tag Content Wählt den Tag-Inhalt in einem Dokument aus, das Tags enthält (zum Beispiel XML oder HTML).In a document that contains tags (for example, XML or HTML), selects the content.

Es gibt verschiedene Möglichkeiten, um im Code-Editor zu navigieren: Sie können zwischen den Einfügepunkten vor- und zurückgehen, die Definition eines Typs oder Members abrufen und über die Navigationsleiste auf eine bestimmte Methode springen.You can move around in the code editor in several different ways, including navigating backwards and forwards to previous insertion points, viewing the definition of a type or member, and jumping to a specific method using the navigation bar. Weitere Informationen finden Sie unter Navigieren durch den Code.For more information see Navigate code.

Suchen von Verweisen in der CodebasisFind references in your code base

Um den Ort zu finden, an dem bestimmte Codeelemente in Ihrer gesamten Codebasis verwiesen werden, können Sie den Befehl Alle Verweise suchen oder UMSCHALT+F12 verwenden.To find where particular code elements are referenced throughout your codebase, you can use the Find All References command or press Shift+F12. Wenn Sie außerdem auf einen Typ oder Member klicken, hebt die Funktion Reference Highlighting („Hervorheben von Verweisen“) automatisch alle Verweise auf diesen Typ oder Member hervor.Also, when you click on a type or member, the reference highlighting feature automatically highlights all references to that type or member. Weitere Informationen finden Sie unter Suchen von Verweisen im Code.For more information, see Find references in your code.

Anpassen des EditorsCustomize the editor

Sie können im Menü Extras unter Assistent zum Importieren und Exportieren von Einstellungen Ihre Visual Studio-Einstellungen für einen anderen Entwickler freigeben, die Einstellungen an einen Standard anpassen oder zu den Visual Studio-Standardeinstellungen zurückkehren.You can share your Visual Studio settings with another developer, have your settings conform to a standard, or return to Visual Studio default settings by using the Import and Export Settings Wizard command on the Tools menu. Im Assistent zum Importieren und Exportieren von Einstellungen können Sie ausgewählte allgemeine Einstellungen oder Sprachen sowie projektspezifische Einstellungen ändern.In the Import and Export Settings Wizard, you can change selected general settings or language and project-specific settings.

Um neue Hotkeys zu definieren oder vorhandene Hotkeys neu zu definieren, wechseln Sie zu Tools > Optionen > Umgebung > Tastatur.To define new hotkeys or redefine existing hotkeys, go to Tools > Options > Environment > Keyboard. Weitere Informationen zu Hotkeys finden Sie unter Standardtastenkombinationen.For more information about hotkeys, see Default keyboard shortcuts.

Informationen zu JavaScript-spezifischen Editor-Optionen finden Sie unter JavaScript-Editor-Optionen.For JavaScript-specific editor options, see JavaScript editor options.

Siehe auchSee also