IntelliCode-Vorschläge

IntelliCode-Vorschläge unterstützen Sie bei ähnlichen Änderungen an mehreren Stellen in Ihrem Code. Die Änderungen werden lokal nachverfolgt, und Wiederholungen werden erkannt. Anschließend wird angeboten, diese Änderungen an anderen Stellen anzuwenden, an denen diese ggf. erforderlich sind. Wenn Sie z. B. Stellen übersehen haben, an denen ein Refactoring angewendet werden könnte, können Sie diese mit IntelliCode-Vorschlägen finden und korrigieren.

IntelliCode kennt die semantische Struktur Ihres Codes. Mithilfe dieser Struktur können Sie erkennen, wann und wo Änderungen angewendet werden können, auch wenn sich die Variablennamen unterscheiden.

Angenommen, Sie ersetzen eine wiederholte Temperaturumrechnung mithilfe von hartcodierten lokalen Werten durch eine Hilfsfunktion, die diese Werte abstrahiert. IntelliCode erkennt die wiederholte Änderung und schlägt vor, diese Änderung an anderen Stellen vorzunehmen.

Abbildung von Vorschlägen, die zeigt, wie sich wiederholende Änderungen zum Auffinden weiterer Vorschläge führen

Vorschläge werden als Schnellaktionen im Visual Studio-Editor angezeigt. Für IntelliCode-Vorschläge sind die Menüoptionen Apply suggestion (Vorschlag anwenden) und Ignore suggestions like this (Vorschläge wie diese ignorieren) verfügbar. Wenn Sie die vorgeschlagene Änderung übernehmen möchten, klicken Sie auf Vorschlag anwenden.

Glühbirne für IntelliCode-Vorschläge

In Visual Studio 2019 16.9 und späteren Versionen werden Vorschläge während der Texteingabe in der Vervollständigungsliste angezeigt:

IntelliCode-Vorschläge in der Vervollständigungsliste

Da diese von den wiederholten Änderungen in einer Sitzung lernt, entsprechen IntelliCode-Vorschläge manchmal nicht genau Ihren Vorstellungen. Wenn Sie die vorgeschlagene Änderung nicht übernehmen möchten, klicken Sie einfach auf Ignore suggestions like this (Vorschläge wie diese ignorieren). IntelliCode schlägt dieses Muster nicht mehr vor, sofern Sie es nicht in nachfolgenden Änderungen neu erstellen.

Hinweis

IntelliCode-Vorschläge sind sitzungsbezogen und werden nicht angezeigt, wenn Sie Visual Studio schließen und dann erneut öffnen.

Wenn Sie die Lister aller vorgeschlagenen Änderungen anzeigen möchten, navigieren Sie zu Ansicht > Weitere Fenster > IntelliCode-Vorschläge.

Glühbirnensymbol für weitere Vorschläge

Wenn Sie einen Vorschlag aus der Vervollständigungsliste akzeptieren und weitere Stellen vorhanden sind, an denen die gleiche Änderung angewendet werden kann, sehen Sie ein Glühbirnensymbol mit einer Aktion, die eine Liste der gefundenen Vorschläge anzeigt. Dadurch wird das Fenster mit den IntelliCode-Vorschlägen geöffnet, sodass Sie die Vorschläge suchen und bearbeiten können.

IntelliCode-Vorschläge suchen

Deaktivieren von IntelliCode-Vorschlägen

Die Vorschläge sind für Visual Studio 16.7 und höher automatisch aktiviert.

Sie können diese aktivieren, indem Sie unter Extras > Optionen auf die Registerkarte IntelliCode – Allgemein klicken und dann C# suggestions (C#-Vorschläge) auf Deaktiviert festlegen: