Anpassen der IDE

Visual Studio für Mac kann so angepasst werden, dass Benutzer Apps in einer Umgebung entwickeln können, die ihren Bedürfnissen nach Effizienz und Ästhetik entspricht. In diesem Artikel werden die verschiedenen Arten erläutert, auf die Visual Studio für Mac Ihren Bedürfnissen angepasst werden kann.

Dunkles Design

Ansicht des dunklen Designs

Sie können die Designs in Visual Studio für Mac wechseln, indem Sie zu Visual Studio > Einstellungen > Umgebung > Visueller Stil navigieren und Ihr gewünschtes Design aus dem Dropdownmenü User Interface Theme (Design der Benutzeroberfläche) wie in der folgenden Abbildung dargestellt auswählen:

Auswahl des dunklen Designs

Lokalisierung

Visual Studio für Mac ist in den folgenden 14 Sprachen lokalisiert, sodass mehr Entwickler darauf zugreifen können:

  • Chinesisch (China)
  • Chinesisch (Taiwan)
  • Tschechisch
  • Französisch
  • Deutsch
  • Englisch
  • Italienisch
  • Japanisch
  • Koreanisch
  • Polnisch
  • Portugiesisch (Brasilien)
  • Russisch
  • Spanisch
  • Türkisch

Navigieren Sie zum Ändern der Anzeigesprache in Visual Studio für Mac zu Visual Studio > Einstellungen > Umgebung > Visueller Stil, und wählen Sie im Dropdownmenü Sprache der Benutzeroberfläche wie in der folgenden Abbildung dargestellt Ihre gewünschte Sprache aus:

Sprachauswahl

Autoreninformationen

Der Bereich „Autoreninformationen“ ermöglicht Ihnen, wichtige Informationen über sich selbst hinzuzufügen, zum Beispiel Ihren Namen, Ihre E-Mail-Adresse, den Urheberrechtsinhaber Ihrer Arbeit, Ihr Unternehmen und Ihre Marke:

Abschnitt „Bearbeiten von Autoreninformationen“

Diese Informationen werden verwendet, um Standard-Dateiheader (z.B. eine Lizenz) zu füllen, die Sie zu neuen Dateien hinzufügen möchten:

Optionen für Standard-Header

Die aufgefüllten Felder für Name und E-Mail werden bei jedem Commit verwendet, der über die Versionskontrolle in Visual Studio für Mac ausgeführt wird. Wenn Sie diese Felder nicht aufgefüllt haben, werden Sie von Visual Studio für Mac dazu aufgefordert, sobald Sie die Versionskontrolle verwenden möchten.

Schlüsselbindungen

Durch Tastenzuordnungen oder -kombinationen können Sie Ihre Entwicklungsumgebung so anpassen, dass Sie sich effizienter durch Visual Studio für Mac bewegen können. Es stellt vertraute Tastenbindungen für viele beliebte IDEs bereit, zum Beispiel Visual Studio (unter Windows), ReSharper, Visual Studio Code und Xcode.

Tastenbindungen können festgelegt werden, indem Sie zu Visual Studio > Einstellungen > Umgebung > Tastenbindungen navigieren, wie in der folgenden Abbildung dargestellt:

Festlegen von Tastenbindungen

Von hier aus können Sie nach Kombinationen für Tastenbindungen suchen, im Konflikt stehende Bindungen anzeigen lassen, neue Bindungen hinzufügen und die bestehenden Bindungen bearbeiten.

Diese Zuordnungen können auch während der ersten Einrichtung von Visual Studio für Mac über den Bildschirm Tastaturauswahl festgelegt werden:

Festlegen von Tastenzuordnungen (erste Ausführung)

Arbeitsbereichlayout

Der Arbeitsbereich von Visual Studio für Mac besteht aus einem Bereich für das Hauptdokument (normalerweise der Editor, die Designeroberfläche oder die Optionsdatei), der von ergänzenden Toolfenstern umgeben ist, die nützliche Informationen zum Zugreifen auf und Verwalten von Anwendungsdateien, Testen und Debuggen enthalten.

Arbeitsbereichlayout

Anzeigen und Anordnen von Toolfenstern

Wenn Sie eine neue Projektmappe oder Datei in Visual Studio für Mac öffnen, sollten Sie einige Toolfenster im Arbeitsbereich bemerken, darunter das Projektmappen-, Dokumentgliederungs- und Fehlerfenster:

Toolfenster

Visual Studio für Mac stellt Toolfenster bereit, die zusätzliche Informationen enthalten, sowie Tools und Navigationshilfen. Auf diese kann zugegriffen werden, indem Sie zum Menüelement Ansicht navigieren und auf ein Toolfenster klicken, um es hinzuzufügen:

Auswählen eines neuen Toolfensters

Toolfenster können auch automatisch durch verschiedene Befehle geöffnet werden, zum Beispiel durch den Befehl Suchen in Dateien (UMSCHALT + CMD + F), durch den ein getrenntes Fenster mit Suchergebnissen geöffnet wird.

Toolfenster können innerhalb Ihres Arbeitsbereich ganz nach Ihrem Wunsch bewegt und angeordnet werden. Sie können beispielsweise an jede Seite des Dokument-Editors angedockt und neben, über oder unter einem anderen Toolfenster angeordnet werden. Auch eine Reihe von Fenstern im Registerkartenformat ist möglich, sodass Sie schnell zwischen diesen wechseln können.

Sie können häufig verwendete Toolfenster auch vollständig vom Fenster von Visual Studio für Mac trennen und ein eigenes, neues Fenster erstellen.

Toolfenster können mithilfe der Steuerelemente in der oberen rechten Ecke jedes Fensters angeheftet und geschlossen werden:

Verwenden der Steuerelemente zum Anheften oder Schließen von Toolfenstern

Angeheftete Fenster werden an die Seiten des Arbeitsbereichs angedockt und bleiben für schnelleren Zugriff geöffnet, wenn Sie diese benötigen. Nicht angeheftete Fenster werden angedockt, aber nicht angezeigt, bis Sie mit dem Mauszeiger auf die Registerkarte für das Fenster zeigen oder mit der Tastatur zum Fenster wechseln. Die Fenster werden ausgeblendet, wenn der Fokus der Maus und Tastatur diese verlässt.

Organisieren von Layouts

Welche Toolfenster jeweils angezeigt werden, hängt vom aktuellen Kontext ab. Wenn Sie beispielsweise den visuellen Designer verwenden, sind die Fenster „Toolbox“ und „Eigenschaftenraster“ am wichtigsten. Beim Debuggen sind die Debuggerfenster zum Anzeigen der Stapel und lokalen Variablen besonders hilfreich.

Der Status eines geöffneten Toolfensters wird durch ein Layout dargestellt. Die Layouts können wie in der folgenden Abbildung dargestellt manuell im Menü „Ansicht“ gewechselt werden. Alternativ werden sie automatisch gewechselt, wenn Sie eine Aktion (z. B. Debuggen) ausführen oder ein Storyboard öffnen:

Auswählen neuer Layouts

Sie können ein neues Layout mithilfe der Menüelemente Ansicht > Layout > Aktuelles Layout speichern erstellen. Mit diesem Befehl wird dem Menü das aktuelle Layout hinzugefügt, sodass Sie es jederzeit auswählen können:

Speichern aktueller Layouts

Parallele Bearbeitungsunterstützung

In Visual Studio für Mac können Sie Text-Editoren parallel öffnen oder einen Editor als getrenntes, unverankertes Fenster öffnen.

Der 2-Spalten-Modus kann über das Menüelement „Ansicht“ aktiviert werden. Klicken Sie hierzu auf Ansicht > Editorspalten > 2 Spalten, oder ziehen Sie eine Registerkarte des Editors an einen der Ränder des Editorbereichs:

Paralleler Modus für zwei Spalten

Die Registerkarten des Editors können aus dem Dokumentbereich gezogen werden, um ein unverankertes Editorfenster zu erstellen. Dieses unverankerte Fenster unterstützt auch parallele Editoren und kann mehrere Editorregisterkarten enthalten:

Erstellen eines neuen Fensters

Zwei parallele Spalten mit zusätzlichen Registerkarten

Klicken Sie auf View > Editor Columns > 1 column (Ansicht > Editor-Spalten > 1 Spalte), um zu einem einzigen geöffneten Editor zurückzukehren.

Siehe auch