Definieren eines Profils zum Erweitern von UMLDefine a profile to extend UML

Note

Dieser Artikel gilt für Visual Studio 2015.This article applies to Visual Studio 2015. Wenn Sie nach der neuesten Dokumentation zu Visual Studio suchen, verwenden Sie die Versionsauswahl in der linken oberen Ecke.If you're looking for the latest Visual Studio documentation, use the version selector at the top left. Es wird ein Upgrade auf Visual Studio 2019 empfohlen.We recommend upgrading to Visual Studio 2019. Laden Sie es hier herunter.Download it here

Sie können definieren, eine UML-Profil auf die standardmäßigen Modellelemente für bestimmte Zwecke anzupassen.You can define a UML profile to customize the standard model elements for specific purposes. Ein Profil definiert eine oder mehrere UML-Stereotype.A profile defines one or more UML stereotypes. Ein Stereotyp kann verwendet werden, um einen Typ als Darstellung einer bestimmten Art Objekt zu markieren.A stereotype can be used to mark a type as representing a particular kind of object. Ein Stereotyp kann außerdem verwendet werden, um die Liste der Eigenschaften eines Elements zu erweitern.A stereotype can also extend an element's list of properties.

Mehrere Profile werden mit unterstützten Editionen von Visual Studio installiert.Several profiles are installed with supported editions of Visual Studio. Welche Versionen von Visual Studio dieses Feature unterstützen, erfahren Sie unter Versionsunterstützung für Architektur- und Modellierungstools.To see which versions of Visual Studio support this feature, see Version support for architecture and modeling tools. Weitere Informationen zu diesen Profilen und zur Anwendung von Stereotypen finden Sie unter Anpassen des Modells mit Profilen und Stereotypen.For more information about those profiles and about how to apply stereotypes, see Customize your model with profiles and stereotypes.

Sie können eigene Profile definieren, um UML an Ihren eigenen Geschäftsbereich oder Ihre Architektur anzupassen und bei Bedarf zu erweitern.You can define your own profiles to adapt and extend UML to your own business area or architecture. Zum Beispiel:For example:

  • Wenn Sie häufig Websites definieren, können Sie ein eigenes Profil definieren, das ein Stereotyp "Webseite" bereitstellt, das in Klassendiagrammen auf Klassen angewendet werden kann.If you frequently define Web sites, you could define your own profile that provides a «WebPage» stereotype that can be applied to classes in class diagrams. Sie können mithilfe von Klassendiagrammen dann eine Website planen.You could then use class diagrams to plan a Web site. Jede "Webseite"-Klasse enthält zusätzliche Eigenschaften für Seiteninhalt, Format usw.Every «WebPage» class would have extra properties for page content, style, and so on.

  • Wenn Sie Banksoftware entwickeln, können Sie ein Profil definieren, das ein "Konto"-Stereotyp bereitstellt.If you develop banking software, you could define a profile that provides an «Account» stereotype. Sie können dann Klassendiagramme verwenden, um andere Kontotypen zu definieren und die Beziehungen zwischen ihnen anzuzeigen.You could then use class diagrams to define different types of account and show the relationships between them.

    Sie können eigene Profile an das Team verteilen.You can distribute your own profiles to your team. Jedes Teammitglied kann das Profil installieren.Each team member can install your profile. Auf diese Weise können die Teammitglieder Modelle bearbeiten und erstellen, die die Stereotype verwenden.This enables them to edit and create models that use its stereotypes.

Note

Wenn Sie die Stereotype eines Profils in einem Modell anwenden, das Sie bearbeiten, und das Modell dann für andere Personen freigeben, sollten diese Personen auf ihren Computern das gleiche Profil installieren.If you apply the stereotypes of a profile in a model that you are editing, and then share the model with other people, they should install the same profile on their own computers. Andernfalls sind sie nicht in der Lage, die Stereotype anzuzeigen, die Sie verwendet haben.Otherwise, they will not be able to see the stereotypes that you have used.

Ein Profil ist häufig Teil einer größeren Visual StudioVisual Studio Erweiterung.A profile is often part of a larger Visual StudioVisual Studio extension. Sie können z. B. einen Befehl definieren, der einige Teile eines Modells in Code übersetzt.For example, you could define a command that translates some parts of a model to code. Sie können ein Profil definieren, das Benutzer auf Pakete anwenden müssen, die sie übersetzen möchten.You could define a profile that users must apply to packages that they want to translate. In diesem Fall verteilen Sie den neuen Befehl gemeinsam mit dem Profil in einer einzelnen Visual StudioVisual Studio-Erweiterung.You would distribute your new command together with the profile in a single Visual StudioVisual Studio extension.

Sie können auch lokalisierte Varianten eines Profils definieren.You can also define localized variants of a profile. Benutzer, die die Erweiterung laden, sehen die Variante, die für ihre eigene Kultur geeignet ist.Users loading your extension see the variant that is appropriate to their own culture.

Gewusst wie: Definieren eines ProfilsHow to Define a Profile

So definieren Sie ein UML-ProfilTo define a UML Profile

  1. Erstellen Sie eine neue XML-Datei mit der Dateinamenerweiterung .profile.Create a new XML file with the file name extension .profile.

  2. Fügen Sie Stereotypdefinitionen gemäß den Richtlinien unter die Struktur eines Profils.Add stereotype definitions according to the guidelines described in The Structure of a Profile.

  3. Fügen Sie das Profil einer Visual Studio-Erweiterung hinzu (.vsix-Datei).Add the profile to a Visual Studio Extension (.vsix file). Sie können entweder eine neue Erweiterung für das Profil erstellen oder dem Profil eine vorhandene Erweiterung hinzufügen.You can either create a new extension for your profile, or add the profile to an existing extension.

    Im nächsten Abschnitt, Gewusst wie: Hinzufügen eines Profils zu einer Visual Studio-Erweiterung.See the next section, How to Add a Profile to a Visual Studio Extension.

  4. Installieren Sie die Erweiterung auf dem Computer.Install the extension on your computer.

    1. Doppelklicken Sie auf die Erweiterungsdatei mit der Dateierweiterung .vsix.Double-click the extension file, which has a file name extension .vsix.

    2. Starten Sie Visual Studio neu.Restart Visual Studio.

  5. Überprüfen Sie, ob das Profil installiert wurde.Verify that the profile has been installed.

    1. Wählen Sie das Modell in UML-Explorer aus.Select the model in UML Explorer.

    2. Klicken Sie im Eigenschaftenfenster auf die Profile Eigenschaft.In the Properties window, click the Profiles property. Das Profil wird im Menü angezeigt.Your profile will appear in the menu. Setzen Sie das Häkchen neben dem Profil.Set the check mark next to the profile.

    3. Wählen Sie ein Element aus, für welches das Profil Stereotype definiert.Select an element for which your profile defines stereotypes. Klicken Sie im Eigenschaftenfenster auf die Stereotype Eigenschaft.In the Properties window, click the Stereotypes property. Die Stereotype werden in der Liste aufgeführt.Your stereotypes will appear in the list. Setzen bei einem der Stereotype ein Häkchen.Set the check mark against one of the stereotypes.

    4. Wenn das Profil zusätzliche Eigenschaften für dieses Stereotyp definiert, erweitern Sie die Stereotypeigenschaft, um sie anzuzeigen.If your profile defines additional properties for this stereotype, expand the stereotype property to see them.

  6. Senden Sie die Erweiterungsdatei an andere Benutzer von Visual StudioVisual Studio, damit diese sie auf ihren Computern installieren können.Send the extension file to other users of Visual StudioVisual Studio to install on their computers.

Gewusst wie: Hinzufügen eines Profils zu einer Visual Studio-ErweiterungHow to Add a Profile to a Visual Studio Extension

Um ein Profil zu installieren und das Senden an andere Benutzer zu ermöglichen, müssen Sie das Profil einer Visual Studio-Erweiterung hinzufügen.To install a profile, and to allow you to send it to other users, you must add the profile to a Visual Studio extension. Weitere Informationen finden Sie unter Bereitstellen von Visual Studio-Erweiterungen.For more information, see Deploying Visual Studio Extensions.

So definieren Sie ein Profil in einer neuen Visual Studio-ErweiterungTo define a profile in a new Visual Studio Extension

  1. Erstellen Sie ein Visual Studio-Erweiterungsprojekt.Create a Visual Studio Extension project.

    Note

    Um dieses Verfahren durchführen zu können, muss Visual Studio SDKVisual Studio SDK installiert sein.You must have installed Visual Studio SDKVisual Studio SDK to use this procedure.

    1. Zeigen Sie im Menü Datei auf Neu, und klicken Sie dann auf Projekt.On the File menu, point to New, and then click Project.

    2. In der neues Projekt Dialogfeld installierte Vorlagen, erweitern Sie Visual C#-, klicken Sie auf Erweiterbarkeit, und klicken Sie dann auf VSIX-Projekt.In the New Project dialog box, under Installed Templates, expand Visual C#, click Extensibility, and then click VSIX project. Legen Sie den Namen des Projekts, und klicken Sie auf OK.Set the project name and click OK.

  2. Fügen Sie das Profil dem Projekt hinzu.Add your profile to the project.

    • Klicken Sie im Projektmappen-Explorer mit der Maustaste des Projekts, zeigen Sie auf hinzufügen, und klicken Sie dann auf vorhandenes Element.In Solution Explorer, right-click the project, point to Add, and then click Existing Item. Suchen Sie im Dialogfeld nach der Profildatei.In the dialog box, locate your profile file.
  3. Legen Sie der Profildatei in Ausgabeverzeichnis kopieren Eigenschaft.Set the profile file's Copy to Output property.

    1. Klicken Sie im Projektmappen-Explorer mit der rechten Maustaste in der Profildatei, und klicken Sie dann auf Eigenschaften.In Solution Explorer, right-click the profile file, and then click Properties.

    2. Legen Sie im Fenster Eigenschaften die in Ausgabeverzeichnis kopieren Eigenschaft immer kopieren.In the Properties window, set the Copy to Output Directory property to Copy Always.

  4. Öffnen Sie im Projektmappen-Explorer die Erweiterung source.extension.vsixmanifest.In Solution Explorer, open source.extension.vsixmanifest.

    Die Datei wird im Erweiterungsmanifest-Editor geöffnet.The file opens in the extension manifest editor.

  5. Auf der Assets Seite, fügen Sie eine Zeile, die das Profil beschreibt:On the Assets page, add a row describing the profile:

    • Klicken Sie auf neue.Click New. Legen Sie die Felder in der neue Anlage hinzufügen Dialogfeld wie folgt.Set the fields in the Add New Asset dialog as follows.

    • Legen Sie Typ auf Microsoft.VisualStudio.UmlProfileSet Type to Microsoft.VisualStudio.UmlProfile

      Dies ist keine der Dropdown-Auswahlmöglichkeiten.This is not one of the drop-down choices. Geben Sie diesen Namen über die Tastatur ein.Enter this name from the keyboard.

    • Klicken Sie auf Datei im Dateisystem , und wählen Sie den Namen der Profildatei aus, z. B. MyProfile.profileClick File on filesystem and select the name of your profile file, for example MyProfile.profile

  6. Erstellen Sie das Projekt.Build the project.

  7. So debuggen Sie das Profil, drücken Sie F5.To debug the profile, press F5.

    Eine experimentelle Instanz von Visual Studio wird geöffnet.An experimental instance of Visual Studio opens. Öffnen Sie in dieser Instanz ein Modellierungsprojekt.In this instance, open a modeling project. Wählen Sie im UML-Explorer das Stammelement des Modells und im Eigenschaftenfenster das Profil aus.In UML Explorer, select the root element of the model, and in the Properties window, select your profile. Wählen Sie dann Elemente innerhalb der Modell- und Satzstereotypen aus, die Sie dafür definiert haben.Then select elements inside the model and set stereotypes that you have defined for them.

  8. Extrahieren Sie VSIX für die BereitstellungTo extract the VSIX for deployment

    1. Öffnen Sie im Windows-Explorer den Ordner .\bin\Debug oder .\bin\Release finden die VSIX Datei.In Windows Explorer, open the folder .\bin\Debug or .\bin\Release to find the .vsix file. Dies ist eine Visual StudioVisual Studio-Erweiterungsdatei.This is a Visual StudioVisual Studio Extension file. Sie kann auf dem Computer installiert und an andere Visual Studio-Benutzer gesendet werden.It can be installed on your computer and sent to other Visual Studio users.

    2. So installieren Sie die Erweiterung:To install the extension:

      1. Doppelklicken Sie auf die .vsix-Datei.Double-click the .vsix file. Der Installer für Visual Studio-Erweiterungen wird gestartet.The Visual Studio Extension Installer will start.

      2. Starten Sie alle Instanzen von Visual Studio neu, die ausgeführt werden.Restart any instances of Visual Studio that are running.

    Sie können das folgende alternative Verfahren für kleine Erweiterungen verwenden, falls Sie Visual Studio SDKVisual Studio SDK nicht installiert haben.The following alternative procedure can be used for small extensions if you have not installed Visual Studio SDKVisual Studio SDK.

So definieren Sie eine Profilerweiterung ohne Visual Studio SDKTo define a profile extension without using Visual Studio SDK

  1. Erstellen Sie ein Windows-Verzeichnis, das die folgenden drei Dateien enthält:Create a Windows directory that contains the following three files:

    • YourProfile .profileYourProfile .profile

    • extension.vsixmanifest

    • [Content_Types].xml – Geben Sie diesen Namen wie hier gezeigt mit den eckigen Klammern ein.[Content_Types].xml - type this name as shown here, with the square brackets

  2. Bearbeiten Sie [Content_Types].xml so, dass darin der folgende Text enthalten ist.Edit [Content_Types].xml to contain the following text. Beachten Sie, dass ein Eintrag für jede Dateinamenerweiterung enthalten ist.Notice that it contains an entry for each file name extension.

    <?xml version="1.0" encoding="utf-8"?>  
    <Types xmlns="http://schemas.openxmlformats.org/package/2006/content-types">  
      <Default Extension="profile" ContentType="application/octet-stream" />  
      <Default Extension="vsixmanifest" ContentType="text/xml" />  
    </Types>  
    
  3. Kopieren Sie ein vorhandenes extension.vsixmanifest-Element, und bearbeiten Sie es mit einem XML-Editor.Copy an existing extension.vsixmanifest and edit it with an XML editor. Ändern Sie die Knoten für ID, Name und Inhalt.Alter the ID, Name, and Content nodes.

    • Sie finden ein Beispiel für extension.vsixmanifest in diesem Verzeichnis:You can find an example of extension.vsixmanifest in this directory:

      Laufwerk : \Programme\Microsoft Visual Studio [Version] \Common7\IDE\Extensions\Microsoft\Architecture Tools\UmlProfilesdrive :\Program Files\Microsoft Visual Studio [version]\Common7\IDE\Extensions\Microsoft\Architecture Tools\UmlProfiles

    • Der Knoten "Inhalt" sollte wie folgt aussehen:The Content node should be like this:

      <Content>  
        <CustomExtension Type="Microsoft.VisualStudio.UmlProfile"  
        >YourProfile.Profile</CustomExtension>  
      </Content>  
      
  4. Komprimieren Sie die drei Dateien in einer ZIP-Datei.Compress the three files into a zipped file.

    Wählen Sie im Windows-Explorer die drei Dateien, mit der rechten Maustaste, zeigen Sie auf senden an, und klicken Sie dann auf komprimierten (gezippten) Ordner.In Windows Explorer, select the three files, right-click, point to Send To, and then click Compressed (zipped) folder.

  5. Benennen Sie die ZIP-Datei um, und ändern Sie die Dateierweiterung von .zip in .vsix.Rename the zipped file, and change its file name extension from .zip to .vsix.

  6. Um das Profil auf einem Computer mit den geeigneten Editionen von Visual Studio zu installieren, doppelklicken Sie auf die .vsix-Datei.To install the profile on any computer with appropriate editions of Visual Studio, double-click the .vsix file.

So installieren Sie ein UML-Profil aus einer Visual Studio-ErweiterungTo install a UML Profile from a Visual Studio Extension

  1. Doppelklicken Sie im Windows-Explorer auf die .vsix-Datei, oder öffnen Sie diese in Visual Studio.Double-click the .vsix file in Windows Explorer, or open it within Visual Studio.

  2. Klicken Sie auf installieren im Dialogfeld, das angezeigt wird.Click Install in the dialog box that appears.

  3. Öffnen Sie zum Deinstallieren oder vorübergehend deaktivieren Sie die Erweiterung, Erweiterungen und Updates aus der Tools Menü.To uninstall or temporarily disable the extension, open Extensions and Updates from the Tools menu.

Definieren lokalisierter ProfileHow to Define Localized Profiles

Sie können verschiedene Profile für andere Kulturen oder Sprachen definieren und alle in derselben Erweiterung verpacken.You can define different profiles for different cultures or languages, and package them all into the same extension. Wenn Benutzer die Erweiterung laden, sehen diese das Profil, das Sie für die jeweilige Kultur definiert haben.When a user loads your extension, they will see the profile that you have defined for their culture.

Sie müssen immer ein Standardprofil bereitstellen.You must always provide a default profile. Wenn Sie kein Profil für die Kultur eines Benutzers definiert haben, wird das Standardprofil angezeigt.If you have not defined a profile for the user's culture, they will see the default profile.

So definieren Sie ein lokalisiertes ProfilTo define a localized profile

  1. Erstellen Sie ein Profil aus, in den vorherigen Abschnitten beschriebenenGewusst wie: Definieren eines Profils und Gewusst wie: Hinzufügen eines Profils zu einer Visual Studio-Erweiterung.Create a profile as described in the previous sectionsHow to Define a Profile and How to Add a Profile to a Visual Studio Extension. Dies ist das Standardprofil, das für alle Installationen verwendet wird, für die Sie kein lokalisiertes Profil bereitstellen.This is the default profile, and will be used in any installation for which you do not provide a localized profile.

  2. Fügen Sie im Verzeichnis, in dem sich die Datei mit dem Standardprofil befindet, ein neues Verzeichnis hinzu.Add a new directory in the same directory as your default profile file.

    Note

    Falls Sie die Erweiterung mithilfe eines Visual Studio-Erweiterungsprojekts erstellen, verwenden Sie den Projektmappen-Explorer, um dem Projekt einen neuen Ordner hinzuzufügen.If you are building the extension by using a Visual Studio Extension project, use Solution Explorer to add a new folder to the project.

  3. Ändern Sie den Namen des neuen Verzeichnisses in den ISO-Kurzcode für die lokalisierte Kultur, z. B. bg für Bulgarisch oder fr für Französisch.Change the new directory's name to the ISO short code for the localized culture, such as bg for Bulgarian, or fr for French. Sie sollten einen neutralen Kulturcode verwenden, also in der Regel zwei Buchstaben. Verwenden Sie keine speziellen Kulturcodes wie fr-CA.You should use a neutral culture code, typically two letters, not a specific culture such as fr-CA. Weitere Informationen zu kulturcodes finden Sie unter CultureInfo.GetCultures-Methode, die eine vollständige Liste der kulturcodes bereitstellt.For more information about culture codes, see CultureInfo.GetCultures method, which provides a complete list of culture codes.

  4. Fügen Sie dem neuen Verzeichnis eine Kopie des Standardprofils hinzu.Add a copy of your default profile to the new directory. Ändern Sie den Dateinamen nicht.Do not change its file name.

    Ein Beispiel für Visual StudioVisual Studio Erweiterungsordner, bevor sie Build oder eine in Komprimierung einer .vsix Datei, die folgenden Ordner und Dateien enthält:A sample Visual StudioVisual Studio Extension folder, before it is built or compressed into a .vsix file, would contain the following folders and files:

    extension.vsixmanifest

    MyProfile.profile

    fr\MyProfile.profile

    de\MyProfile.profile

    Note

    Sie sollten in extension.vsixmanifest keinen Verweis auf die lokalisierten Versionen der Profile einfügen.You should not insert into extension.vsixmanifest a reference to the localized versions of the profiles. Die kopierten Profildateien müssen den gleichen Namen wie das Profil im übergeordneten Ordner haben.The copied profile files must have the same name as the profile in the parent folder.

  5. Bearbeiten Sie die neue Kopie des Profils, indem Sie alle für Benutzer sichtbaren Elemente in die Zielsprache übersetzen, z. B. die displayName-Attribute.Edit the new copy of the profile, translating to the target language all the parts that will be visible to the user, such as the displayName attributes.

  6. Sie können zusätzliche Kulturordner und lokalisierte Profile für beliebig viele Kulturen erstellen.You can create additional culture folders and localized profiles for as many cultures as you want.

  7. Erstellen Sie die Visual Studio-Erweiterung, indem Sie entweder das Erweiterungsprojekt erstellen oder alle Dateien komprimieren, wie in den vorherigen Abschnitten beschrieben.Build the Visual Studio extension, either by building the Extension Project or compressing all the files, as described in the previous sections.

Die Struktur eines ProfilsThe Structure of a Profile

Die XSD-Datei für UML-Profile finden Sie im folgenden Beispiel: Festlegen von Stereotypen und Profile XSD.The XSD file for UML profiles can be found in the following sample: Setting Stereotypes and Profiles XSD. Installieren Sie die .xsd-Datei zur Unterstützung der Bearbeitung von Profildateien in:To help you edit profile files, install the .xsd file in:

%ProgramFiles%\Microsoft visual Studio [Version] \Xml\Schemas%ProgramFiles%\Microsoft Visual Studio [version]\Xml\Schemas

Dieser Abschnitt verwendet als Beispiel das C#-Profil.This section uses the C# profile as an example. Sie finden die vollständige Profildefinition unter:The complete profile definition can be seen in:

Laufwerk : \Programme\Microsoft Visual Studio [Version] \Common7\IDE\Extensions\Microsoft\Architecture Tools\UmlProfiles\CSharp.profiledrive :\Program Files\Microsoft Visual Studio [version]\Common7\IDE\Extensions\Microsoft\Architecture Tools\UmlProfiles\CSharp.profile

Die ersten Teile dieses Pfads können in Ihrer Installation ggf. abweichen.The first parts of this path might differ in your installation.

Weitere Informationen zum .NET-Profil finden Sie unter Standardstereotype für UML-Modelle.For more information about the .NET profile, see Standard stereotypes for UML models.

Hauptabschnitte der UML-ProfildefinitionMain sections of the UML Profile definition

Jedes Profil enthält den folgenden Inhalt:Every profile contains the following content:

<?xml version="1.0" encoding="utf-8"?>  
<profile dslVersion="1.0.0.0"   
       name="CSharpProfile" displayName="C# Profile"   
       xmlns="http://schemas.microsoft.com/UML2.1.2/ProfileDefinition">  
  <stereotypes>...</stereotypes>  
  <metaclasses>...</metaclasses>  
  <propertyTypes>...</propertyTypes>  
</profile>  

Note

Das Attribut name darf keine Leerzeichen oder Interpunktionszeichen enthalten.The attribute called name must not contain spaces or punctuation. Das Attribut displayName wird auf der Benutzeroberfläche angezeigt und sollte eine gültige XML-Zeichenfolge sein.The attribute displayName, which appears in the user interface, should be a valid XML string.

Jedes Profil enthält drei Hauptabschnitte.Every profile contains three main sections. Dies sind in umgekehrter Reihenfolge:In reverse order, they are as follows:

  • <propertyTypes> – Eine Liste von Typen, die für Eigenschaften verwendet werden, die im Abschnitt mit den Stereotypen definiert sind.<propertyTypes> - a list of types that are used for properties defined in the stereotypes section.

  • <metaclasses> – Eine Liste mit Modellelementtypen, für die die Stereotype in diesem Profil gelten, z. B. IClass, IInterface, IOperation, IDependency.<metaclasses> - a list of model element types to which the stereotypes in this profile apply, such as IClass, IInterface, IOperation, IDependency.

  • <stereotypes> – Die Stereotypdefinitionen.<stereotypes> - the stereotype definitions. Jede Definition enthält die Namen und die Typen von Eigenschaften, die dem Zielmodellelement hinzugefügt werden.Each definition includes the names and types of properties that are added to the target model element.

EigenschaftentypenProperty Types

Die <propertyTypes> -Abschnitt deklariert eine Liste von Typen, die verwendet werden, für Eigenschaften in der <stereotypes> Abschnitt.The <propertyTypes> section declares a list of types that are used for properties in the <stereotypes> section. Es gibt zwei Arten von Eigenschaftentypen: extern und Enumeration.There are two kinds of property types: external and enumeration.

Ein externer Typ deklariert den vollqualifizierten Namen eines .NET-Standardtyps:An external type declares the fully qualified name of a standard .NET type:

<externalType name="System.String" />  

Ein Enumerationstyp definiert einen Satz von Literalwerten:An enumeration type defines a set of literal values:

<enumerationType name="PackageVisibility">  
  <enumerationLiterals>  
    <enumerationLiteral name="internal" displayName="internal"  />  
    <enumerationLiteral name="protectedinternal" displayName="protected internal" />  
  </enumerationLiterals>  
</enumerationType>  

MetaklassenMetaclasses

Der <metaclasses>-Abschnitt ist eine Liste von Modellelementtypen, für die Stereotype in diesem Profil definiert werden können:The <metaclasses> section is a list of model element types to which stereotypes in this profile can be defined:

<metaclass   
      name="Microsoft.VisualStudio.Uml.Classes.IClass" />  
<metaclass  
      name="Microsoft.VisualStudio.Uml.Classes.IInterface" />  
<metaclass  
      name="Microsoft.VisualStudio.Uml.Components.IComponent" />  

Die vollständige Liste der Modellelement- und Beziehungstypen Modelltypen, die Sie als Metaklassen verwenden können, finden Sie unter Modellelementtypen.For the full list of model element and relationship types that you can use as metaclasses, see Model Element Types.

StereotypdefinitionStereotype definition

Der <stereotypes>-Abschnitt enthält eine oder mehrere Stereotypdefinitionen:The <stereotypes> section contains one or more stereotype definitions:

<stereotype name="CSharpClass" displayName="C# Class"> ...  

Jedes Stereotyp führt einen oder mehrere Modellelement- oder Beziehungstypen auf, auf die es angewendet werden kann.Each stereotype lists one or more model element or relationship types to which it can be applied. Sie können den Namen eines Basistyps angeben, um alle abgeleiteten Typen einzubeziehen.You can give the name of a base type, to include all its derived types. Wenn Sie z. B. Microsoft.VisualStudio.Uml.Classes.IType angeben, kann das Stereotyp auf IClass, IInterface, IEnumeration und verschiedene andere Typen von Elementen angewendet werden.For example, if you specify Microsoft.VisualStudio.Uml.Classes.IType, the stereotype can be applied to IClass, IInterface, IEnumeration, and several other types of element.

<metaclasses>  
  <metaclassMoniker name=  
   "/CSharpProfile/Microsoft.VisualStudio.Uml.Classes.IClass" />  
</metaclasses>  

Das name-Attribut von metaclassMoniker ist ein Link zu einem Element im <metaClasses>-Abschnitt.The name attribute of metaclassMoniker is a link to an element in the <metaClasses> section.

Note

Der Monikername muss mit /yourProfileName/ beginnen, wobei yourProfileName im name-Attribut des Profils definiert ist ("CSharpProfile" in diesem Beispiel).The moniker name must begin with /yourProfileName/, where yourProfileName is defined in the name attribute of the profile ("CSharpProfile" in this example). Der Moniker endet mit dem Namen von einem der Einträge im metaclasses-Abschnitt.The moniker ends with the name of one of the entries in the metaclasses section.

Jedes Stereotyp kann keine oder mehrere Eigenschaften aufführen, die es jedem Modellelement hinzufügt, auf das es angewendet wird.Each stereotype can list zero or more properties that it adds to any model element to which it is applied. Die <propertyType> enthält einen Link zu einer der Typen, die definiert sind die <propertyTypes> Abschnitt.The <propertyType> contains a link to one of the types that are defined in the <propertyTypes> section. Der Link muss entweder <externalTypeMoniker> sein, um auf <externalType>, zu verweisen, oder <enumerationTypeMoniker>, um auf <enumerationType> zu verweisen.The link must be either an <externalTypeMoniker> to refer to an <externalType>, or an <enumerationTypeMoniker> to refer to an <enumerationType>. Der Link beginnt wieder mit dem Namen des Profils.Again, the link begins with the name of your profile.

  <properties>  
    <property name="IsStatic"   
            displayName="Is Static" defaultValue="false">  
      <propertyType>  
<externalTypeMoniker   
               name="/CSharpProfile/System.Boolean" />  
      </propertyType>  
    </property>  
    <property name="PackageVisibility"   
              displayName="Package Visibility"  
              defaultValue="internal">  
      <propertyType>  
        <enumerationTypeMoniker   
              name="/CSharpProfile/PackageVisibility"/>  
      </propertyType>  
    </property>  
  </properties>  
</stereotype>  

ModellelementtypenModel Element Types

Der Satz von Typen, die für die Stereotype definiert werden können finden Sie UML-Modellelementtypen.The set of types for which you can define stereotypes is listed in UML model element types.

ProblembehandlungTroubleshooting

Meine Stereotype werden nicht in den UML-Modellen angezeigt.My stereotypes do not appear my UML models.
Das Profil muss als Paket oder Modell ausgewählt werden.You have to select your profile in a package or model. Anschließend werden die Stereotype auf Elementen in dem Paket oder Modell angezeigt.The stereotypes will then appear on elements inside the package or model. Weitere Informationen finden Sie unter Hinzufügen von Stereotypen zu UML-Modellelemente.For more information, see Add stereotypes to UML model elements.

Der folgende Fehler angezeigt wird, wenn ich ein UML-Modell zu öffnen: VS1707: Die folgenden Profile können nicht geladen werden, weil Fehler bei der Serialisierung: MyProfile.profileThe following error appears when I open a UML model: VS1707: The following profiles cannot be loaded because a serialization error occurred: MyProfile.profile

  1. Überprüfen Sie, ob die grundlegende XML-Syntax der PROFILE-Datei korrekt ist.Verify that the basic XML syntax of the .profile is correct.

  2. Stellen Sie sicher, dass jeder Monikername das Format "/Profilname/Knotenname" besitzt.Ensure that each Moniker name is in the form /profileName/nodeName. Der "Profilname" ist der Wert des name-Attributs im Stammprofilknoten.The profileName is the value of the name attribute in the root profile node. Der "Knotenname" ist der Wert des name-Attributs einer Metaklasse (metaclass), eines externen Typs (externalType) oder eines Enumerationstyps (enumerationType).The nodeName is the value of the name attribute of a metaclass, externalType, or enumerationType.

  3. Sicherstellen, dass die Syntax ist, wie hier beschrieben und wie in Laufwerk: \Programme\Microsoft Visual Studio [Version] \Common7\IDE\Extensions\Microsoft\Architecture Tools\UmlProfiles\ .Ensure the syntax is as described here, and as demonstrated in drive:\Program Files\Microsoft Visual Studio [version]\Common7\IDE\Extensions\Microsoft\Architecture Tools\UmlProfiles\.

  4. Deinstallieren Sie die fehlerhafte Erweiterung.Uninstall the faulty extension. Klicken Sie im Menü Extras auf Erweiterungen und Updates.On the Tools menu, click Extensions and Updates.

    • Wenn die Erweiterung nicht angezeigt wird, gehen Sie wie im Folgenden beschrieben vor.If the extension does not appear, see the next item.
  5. Erstellen Sie die VSIX-Datei neu, und öffnen Sie sie in Windows-Explorer, um sie erneut zu installieren.Rebuild the VSIX file and open it in Windows Explorer to re-install it. Starten Sie Visual StudioVisual Studioneu.Restart Visual StudioVisual Studio.

    Die Erweiterung wird nicht im Erweiterungs-Manager angezeigt, aber wenn Sie versuchen, sie erneut zu installieren, wird die folgende Meldung angezeigt: Die Erweiterung ist bereits für alle entsprechenden Produkte installiert.The extension does not appear in Extension Manager, but when you try to re-install it, the following message appears: The extension is already installed to all applicable products.

    1. Entfernen Sie die Erweiterungsdatei aus einem Unterordner des LocalAppData\Microsoft\VisualStudio\[Version] \Extensions\Remove the extension file from a subfolder of LocalAppData\Microsoft\VisualStudio\[version]\Extensions\
    • Um finden Sie unter LocalAppData, müssen Sie versteckte Dateien und Ordner in der Registerkarte Ansicht der Optionen für die Windows-Explorer festlegen.To see LocalAppData, you must set Show Hidden Files and Folders in the View tab of the Windows Explorer Folder Options.

    • LocalAppData umfasst i. d. r. C:\Users\Benutzername\AppData\Local\LocalAppData is typically in C:\Users\userName\AppData\Local\

  6. Starten Sie Visual StudioVisual Studioneu.Restart Visual StudioVisual Studio.

Siehe auchSee Also

Hinzufügen von Stereotypen zu UML-Modellelementen Add stereotypes to UML model elements
Anpassen des Modells mit Profilen und Stereotypen Customize your model with profiles and stereotypes
Standardstereotype für UML-Modelle Standard stereotypes for UML models
Beispiel: Farbe von UML-Elementen nach Stereotyp Sample: Color UML Elements by Stereotype
Beispiel: Festlegen von Stereotypen, XSD-ProfilenSample: Setting Stereotypes, Profiles XSD