Visual Studio 2017 für Mac, Version 7.4 Visual Studio 2017 for Mac version 7.4


Entwicklercommunity | Systemvoraussetzungen | Kompatibilität | Verteilbarer Code | Xamarin | Blogs | WartungDeveloper Community | System Requirements | Compatibility | Distributable Code | Xamarin | Blogs | Servicing


Hinweis

Wenn Sie auf diese Seite über eine nicht englischen Sprachversion zugreifen und den neuesten Inhalt sehen möchten, besuchen Sie die englischsprachige Seite mit den Anmerkungen zu der Version.If you are accessing this page from a non-English language version, and want to see the most up-to-date content, please visit this Release Notes page in English.

Tipp

Sie können die Sprache der Seite unten auf dieser Seite ändern.You can switch the page language at the bottom of this page. Klicken Sie auf die SchaltflächeClick the -Symbol, suchen Sie nach Ihrer Sprache, oder treffen Sie eine Auswahl aus der Liste der verfügbaren Sprachen. icon, search for your language, or select from the list of available languages.


Verwenden Sie Visual Studio 2017 für Mac, um Apps für mobile Geräte, das Web und die Cloud mit Xamarin und .NET Core sowie Spiele mit Unity zu erstellen.Use Visual Studio 2017 for Mac to build apps for mobile, web, and the cloud with Xamarin and .NET Core, as well as games with Unity.

Herunterladen des aktuellen Release von Visual Studio 2017 für MacDownload the Current Release of Visual Studio for Mac 2017

Download Visual Studio 2017 for Mac

Weitere Informationen zu Visual Studio 2017 für Mac finden Sie unter Mac – Systemanforderungen und Mac – Zielplattformen und Kompatibilität.To learn more about Visual Studio 2017 for Mac, see Mac System Requirements and Mac Platform Targeting and Compatibility.

Weitere Informationen zu verwandten Downloads finden Sie auf der Seite Downloads.To learn more about other related downloads, see the Downloads page.

FeedbackFeedback

Wir freuen uns auf Ihr Feedback!We’d love to hear from you! Sie können ein Problem über die Option Ein Problem melden der Visual Studio für Mac-IDE melden und Ihr Feedback im Portal Entwicklercommunity verfolgen.You can report a problem via the Report a Problem option the Visual Studio for Mac IDE and track your feedback in the Developer Community portal. Vorschläge können Sie uns über UserVoice mitteilen.For suggestions, let us know through UserVoice.

ReleaseverlaufRelease History


5. März 2018: Visual Studio 2017 für Mac, Version 7.4 (7.4.0.1033)March 5, 2018 - Visual Studio 2017 for Mac 7.4 (7.4.0.1033)

Bei Version 7.4 von Visual Studio für Mac lag der Schwerpunkt darauf, einige der wichtigsten Speicherlecks sowie Leistungs- und Stabilitätsprobleme zu beheben, die uns gemeldet wurden.For the Visual Studio for Mac 7.4 release, we've taken time to focus on fixing some of the top memory leaks, performance problems, and stability issues that have been reported to us. Diese Version bietet auch Unterstützung für die Android Oreo 8.1-Entwicklung sowie einige Produktivitätsverbesserungen für Xamarin-Entwickler.This release also brings support for Android Oreo 8.1 development and several productivity enhancements for Xamarin developers.

Highlights in diesem ReleaseRelease Highlights

  • macOS High Sierra wird nun offiziell unterstützt.macOS High Sierra is now officially supported.
  • Unterstützung für Xcode 9.3.Support for Xcode 9.3.
  • C# 7.1 wird jetzt unterstützt (siehe Neuerungen in C# 7.1).C# 7.1 is now supported (see what's new in C# 7.1).
  • Android 8.1. Oreo wird unterstützt.Support for Android 8.1 Oreo.
  • Drahtloses Bereitstellen und Debuggen ist für Xamarin.iOS verfügbar.Wireless deployment and debugging for Xamarin.iOS.
  • Im C#-Editor wurden grundlegende Änderungen an der Architektur vorgenommen, wodurch sowohl die IntelliSense-Leistung und -Zuverlässigkeit als auch die Reaktionsfähigkeit bei der Eingabe verbessert wurden.Core architectural changes were made to the C# editor; both IntelliSense performance/reliability and typing responsiveness are improved as a result.

In diesem Release behobene ProblemeIssues fixed in this release

Einzelheiten zum ReleaseRelease in Detail

  • Das Menüelement Bearbeiten > In den Vorschlagsmodus wechseln wurde hinzugefügt, um zwischen dem IntelliSense-Vorschlagsmodus und dem Vervollständigungsmodus zu wechseln.Added an Edit > Switch to Suggestion Mode menu, to toggle between IntelliSense suggestion mode and completion mode. Im Vorschlagsmodus überschreibt die automatische Vervollständigung von IntelliSense den von Ihnen geschriebenen Text nicht, es sei denn, Sie wählen ihn manuell aus der IntelliSense-Vorschlagsliste aus.In suggestion mode, IntelliSense auto-complete suggestions will not override the text you've written unless you manually choose them from the IntelliSense suggestion list. Um wieder in den Vervollständigungsmodus zu wechseln, können Sie das Menü „Bearbeiten > In den Vervollständigungsmodus wechseln“ wählen.To switch back to Completion Mode you can choose the Edit | Switch to Completion Mode menu. Die Standardtastenkombination Strg+Alt+Leertaste ist verfügbar, wenn Sie Tastenzuordnungschemata von Visual Studio (Gemischt) oder Visual Studio (Windows) verwenden.A default keyboard shortcut of Ctrl+Alt+Space is provided if you're using Visual Studio (Mixed) or Visual Studio (Windows) key binding schemes.

  • Es wurde die Tastenkombination Cmd+UMSCHALT+P hinzugefügt, die das Suchfeld „Navigieren zu“ öffnet. Dies ist gefiltert, sodass Sie passend zu Ihrem aktuellen Kontext nach verfügbaren Befehlen suchen können.Added a Cmd+Shift+P shortcut that will open the Navigate To search box, filtered so you can search for available commands based on your current context.

Debug source files option
(Abbildung 1) Filtern von Befehlen(Figure 1) Command Filtering
  • Suche nach Debuggerquelle.Debugger source lookup.

    • Ab sofort wird in den Projektmappenoptionen die Registerkarte Quelldateien debuggen unterstützt (Abbildung 2).Added support for the Debug Source Files tab in solution options (Figure 2). Für eine übersichtlichere Benutzeroberfläche wird dieses Menü erst eingeblendet, nachdem Sie den ersten Ordner hinzugefügt haben.To keep the UI clean, this menu appears only after you add the first folder.

      Debug source files option
      (Abbildung 2) Option zum Debuggen von Quelldateien(Figure 2) Debug source files option
    • Wenn Sie versuchen, zu einem Stapelrahmen zu navigieren oder eine Methode schrittweise auszuführen, und der Debugger keine Quelldateien findet, wird ein neues Dokument Quelle nicht gefunden (Abbildung 3) angezeigt.If you try to navigate to a stack frame or step into a method and the debugger doesn't find source files, a new Source Not Found document (Figure 3) is shown. Dieses Dokument weist auf einige Möglichkeiten hin, die Sie haben, um vorhandene Quelldateien zu finden.This document helps to provide some options to locate source files if you have them. Dies ist nützlich, wenn Assemblies gedebuggt werden, die auf CI kompiliert wurden, und der Benutzer Zugriff auf Quelldateien und .pdb-Dateien hat.This is useful when debugging assemblies that were compiled on CI and user has access to source files and .pdb file.

      New 'source not found' dialog
      (Abbildung 3) Neues Dialogfeld "„Quelle nicht gefunden“"(Figure 3) New "source not found" dialog
  • Ein Dateiwatcher zum Erkennen von Dateien wurde zum Projekt hinzugefügt.File watcher to detect files added to the project.

    Visual Studio für Mac erkennt nun Dateien, die zu einem .NET Core-Projekt hinzugefügt oder aus diesem entfernt wurden, und aktualisiert das Projektmappenfenster dynamisch mit den Änderungen.Visual Studio for Mac will now detect files added to or removed from a .NET Core project and update the Solution window with the changes dynamically. Diese Verbesserung betraf das in der Entwicklercommunity berichtete Problem mit dem Entladen/Aufladen, das nach EF-Migrationen erforderlich war.This improvement addressed the unload/reload required after EF migrations issue reported in the Developer Community.

  • Verwenden des .vs-Verzeichnisses für .userprefsUse .vs directory for .userprefs

    • Um die Kompatibilität mit Visual Studio unter Windows zu verbessern, wird die von Visual Studio für Mac generierte Datei mit Benutzereinstellungen nicht mehr im Projektmappenverzeichnis gespeichert, sondern unter .vs/SolutionName/xs/UserPrefs.xml.To improve compatibility with Visual Studio on Windows the user preferences file generated by Visual Studio for Mac are no longer stored in the solution directory but are now stored in .vs/SolutionName/xs/UserPrefs.xml.

XamarinXamarin

  • Die Funktion „Upload in Xamarin-Testcloud“ in Visual Studio für Mac (aufgerufen durch Rechtsklick auf den Komponententestbaum) wird nicht mehr unterstützt.We no longer support the “Upload to Xamarin Test Cloud” function in Visual Studio for Mac (invoked by right-clicking the Unit test tree). Weiterführende Tests können über die Visual Studio App Center-CLI eingereicht werden.Moving forwards tests can be submitted through the Visual Studio App Center CLI.

  • Die Unterstützung für Komponenten in der IDE wurde entfernt.We have removed the support for components in IDE. Wenn Sie ein Projekt mit bereits referenzierten Komponenten öffnen, wird ein Fehler angezeigt.If you open a project that has components already referenced, you will be met with an error. Um diesen Fehler zu beheben, müssen Sie die .csproj-Datei manuell bearbeiten und alle Informationen aus den <XamarinComponentReference/>-Tags entfernen.The fix this error, you must edit the .csproj file manually and remove all information in the <XamarinComponentReference/> tags. Weitere Informationen finden Sie im Migrationshandbuch für Komponenten.For more information see the Components migration guide.

iOSiOS

  • Ab sofort wird das drahtlose Bereitstellen und Debuggen für iOS- oder AppleTV-Geräte unterstützt.We've added support for wireless deployment and debugging for iOS or AppleTV devices. Wenn ein Gerät über ein Netzwerk verbunden und bereit für die Bereitstellung ist, wird es nun in der Gerätezielliste angezeigt, als ob das Gerät über USB angeschlossen wäre.When a device is connected via a network and ready to be used for deployment, it now shows up in the device target list, as if the device were connected through USB. (Abbildung 4):(Figure 4):

    Apple device connected over Wi-Fi selected in device list
    (Abbildung 4) In der Geräteliste angezeigtes Apple-Gerät, das über ein Netzwerk verbunden ist.(Figure 4) Apple device connected over a network is displayed in device list

    Weitere Informationen zu diesem Feature finden Sie im Handbuch zur drahtlosen Bereitstellung.For more information on this feature, see the Wireless Deployment guide.

  • Visual Studio für Mac fordert Sie nun auf, das Bereitstellungsgerät zu entsperren, bevor Sie die App starten (Abbildung 5). Dabei wird die Debuggingsitzung nicht unterbrochen:Visual Studio for Mac now asks to unlock the deployment device before launching the app (Figure 5) and does not interrupt the debugging session:

    Alert advising user to unlock iOS device
    (Abbildung 5) Aufforderung des Benutzers zum Entsperren des iOS-Geräts(Figure 5) Alert advising user to unlock iOS device
  • Visual Studio für Mac generiert jetzt automatisch C#-Bindungen für CoreML-Modelle, wenn sie zu einem Projekt hinzugefügt werden. Dies ermöglicht eine schnelle und einfache Nutzung von CoreML-Modellen.Visual Studio for Mac now auto-generates C# bindings for CoreML models when they are added to a project allowing for quick and easy usage of CoreML models.

  • Verbesserungen bei der Bereitstellung:Provisioning Improvements:

    • Mit diesem Release wird ein besserer „fastlane“-Installationsworkflow eingeführt.This release introduces a better fastlane installation workflow. Wenn „fastlane“ nicht installiert ist, wurde zuvor ein Fehlerdialogfeld angezeigt, in dem Sie aufgefordert werden, die Bereitstellungsdokumentation zu lesen und „fastlane“ zu installieren. Jetzt können Sie dies innerhalb der IDE erledigen.If fastlane is not installed, instead of showing an error dialog asking you to read the provisioning documentation and install fastlane, we provide a way to do it within the IDE.
    • Abhängig von der Internetgeschwindigkeit und den Computerparametern kann die Installation bis zu zwei Minuten dauern.Depending on the internet speed and computer parameters the installation can take up to two minutes. Aus diesem Grund wird „fastlane“ im Hintergrund heruntergeladen.For this reason, fastlane will be downloaded in the background for your convenience.
    • Es wurden eine Reihe von Verbesserungen an der Benutzeroberfläche für das Widget zur automatischen Bereitstellung im Info.plist-Editor vorgenommen.We made a number of UI improvements to the automatic provisioning widget in Info.plist editor. Das neue Widget unterscheidet eindeutig zwischen manuellen und automatischen Bereitstellungsmodi und informiert den Benutzer über den Bereitstellungsstatus.The new widget draws a definite distinction between manual and automatic provisioning modes and communicates provisioning status to the user.

AndroidAndroid

Android 8.1 Oreo ist die neueste Version von Android, die bei Google erhältlich ist.Android 8.1 Oreo is the latest version of Android available from Google. Android 8.1 Oreo bietet viele neue Funktionen, die für Xamarin.Android-Entwickler interessant sind, wie z.B. Android Go, Neural Networks API, Autofill Framework-Updates, SharedMemory API und viele mehr.Android 8.1 Oreo offers many new features of interest to Xamarin.Android developers such as Android Go, Neural Networks API, Autofill Framework updates, SharedMemory API, and many more. Diese APIs sind für Xamarin.Android-Apps verfügbar, wenn Sie Xamarin.Android 8.2 oder höher verwenden.These APIs are available to Xamarin.Android apps when you use Xamarin.Android 8.2 and later.

  • Die Integration für den Xamarin Android Device Manager (Vorschau) wurde für Benutzer hinzugefügt, die SDK Tools 26 installiert haben.We've added integration for the Xamarin Android Device Manager (preview) for users with SDK Tools 26 installed. Weitere Informationen finden Sie in der Dokumentation.For more information, refer to the documentation.

  • Sie werden nun gewarnt, wenn der Android-Emulator kein HAXM verwendet.You'll now be warned if the Android emulator is not using HAXM.

Visuelle DesignerVisual Designers

iOS-DesigneriOS Designer
  • Tastenzuordnungen für eingeschränkten Modus:Constraints Mode Key Bindings:

    Neue Tastenzuordnungen erleichtern die Arbeit mit dem neuen eingeschränkten Modus (eingeführt in 15.5).New key bindings make it easier to work with the new constraints mode (introduced in 15.5). Zum Beispiel:For example:

    • Umschalten in den bzw. aus dem eingeschränkten Modus: ⌘ EToggle constraints mode: ⌘ E
    • Temporäre Aktivierung des eingeschränkten Modus: ^ haltenTemporarily enable constraints mode: Hold ⌃
    • Im eingeschränkten Modus Einschränkungen aktualisieren; ansonsten Frames aktualisieren: ⇧ ⌘ RIn constraints mode, update constraints; else update frames: ⇧ ⌘ R
  • Neue Möglichkeit zur Eigenschaftenvariation für tvOS:Trait Variations can now be enabled for tvOS :

    Es gibt eine neue Möglichkeit zur Eigenschaftenvariation für tvOS-Storyboards und XIBs für die Verwendung eines hellen bzw. eines dunklen Stils.Trait variations can now be enabled for tvOS storyboards and XIBs, which enables variation by light style or dark style.

  • Automatisches Verkleinern beim Ziehen großer Elemente aus der Toolbox:Automatic Zoom Out when dragging large items from the Toolbox:

    Die Designoberfläche wird nun automatisch verkleinert, wenn Sie ein großes Element aus der Toolbox ziehen.The design surface now automatically zooms out when you drag a large item from the toolbox. Dies macht es einfacher, große Elemente auf Ihrem XIB oder Storyboard zu platzieren.This makes it easier to place large items on your XIB or storyboard.

  • Zoomindikator und -auswahlzeiger:Zoom Indicator and Selector:

    Zeigt Prozentzahl zum aktuellen Zoomfaktor an und ermöglicht die Auswahl des Zoomfaktors aus einer Popupliste.Indicates current zoom level percentage and enables selecting zoom levels from a pop up list.

Android DesignerAndroid Designer
  • Das Parsen und Verarbeiten von Android-Ressourcen wurde in diesem Release grundlegend überarbeitet, was zu einer gesteigerten Leistung und Genauigkeit in allen Bereichen führt.Android resource parsing and processing has been vastly revamped in this release resulting in increased performance and accuracy across the board.
  • Ab sofort wird Android Oreo-Rendering (API 26) unterstützt.Added Android Oreo (API 26) rendering support.
  • Oreo-Features wie benutzerdefinierte Schriften und adaptive Symbole werden ebenfalls unterstützt.Oreo features like custom fonts and adaptive icons are now supported.
  • Das Rendern erfolgt mit höherer Geschwindigkeit.Rendering speed improvements.
  • Die IntelliSense-Vervollständigung wurde verbessert.Improved IntelliSense completion experience.

Xamarin.FormsXamarin.Forms

Zur Verbesserung der XAML-Bearbeitung wurde eine Reihe von Fehlern behoben:We fixed a number of bugs to improve XAML editing:

  • [BEHOBEN] Inkonsistentes Verhalten im XML/XAML-Editor zwischen vs und vsmac beim Drücken der Eingabetaste, um einem Element ein neues Attribut hinzuzufügen.[FIXED] Inconsistent behavior in XML/XAML editor between vs/vsmac when hitting "ENTER" in to add a new attribute to an element.
  • [BEHOBEN] Viele Elemente fehlen bei der Vervollständigung: ResourceDictionary, x:Double, x:Key usw.[FIXED] Many elements are missing from completion: ResourceDictionary, x:Double, x:Key etc.
  • [BEHOBEN] Keine IntelliSense nach Eingabe eines Punkts im Namen.[FIXED] No IntelliSense after typing period in name.
  • [BEHOBEN] Eine Plattform fehlt in IntelliSense.[FIXED] One Platform is missing from IntelliSense.
  • [BEHOBEN] Über die Tabulatortaste werden Leerzeichen und über den Einzug werden Tabulatoren eingefügt.[FIXED] Tab key inserts spaces, indenter inserts tabs.
  • [BEHOBEN] XAML IntelliSense listet Elementeigenschaften sortiert nach der Länge des Namens auf.[FIXED] XAML IntelliSense lists element properties sorted by length of name.

Xamarin Workbooks und InstallationsprogrammXamarin Workbooks and Installer

Xamarin Inspector wurde vollständig von Xamarin Workbooks getrennt.We have fully split Xamarin Inspector from Xamarin Workbooks. Zur Nutzung der Inspector-Erweiterung ist keine Workbooks-Installation mehr erforderlich.The Inspector extension no longer requires a Workbooks installation to function.

Alle Versionsanmerkungen für Xamarin-ProdukteAll Xamarin Product release notes


26. März 2018: Visual Studio 2017 für Mac, Version 7.4.1 (7.4.1.48)March 26, 2018 - Visual Studio 2017 for Mac 7.4.1 (7.4.1.48)


3. April 2018: Visual Studio 2017 für Mac, Version 7.4.2 (7.4.2.12)April 3, 2018 - Visual Studio 2017 for Mac 7.4.2 (7.4.2.12)

Diese Version bietet Unterstützung für Xcode 9.3 und behandelt die folgenden Probleme:This release includes support for Xcode 9.3 and addresses the following issues:


18. April 2018: Visual Studio 2017 für Mac, Version 7.4.3 (7.4.3.10)April 18, 2018 - Visual Studio 2017 for Mac 7.4.3 (7.4.3.10)

In diesem Release wird auf die folgenden Probleme eingegangen:This release addresses the following issues:


Visual Studio 2017 für Mac: Bekannte ProblemeVisual Studio 2017 for Mac Known Issues


Versionsanmerkungsverlauf für Visual Studio 2017 für MacVisual Studio 2017 for Mac Release Notes History

Anmerkungen zur Version Visual Studio 2017 für Mac 7.3Visual Studio 2017 for Mac version 7.3 Release Notes

Anmerkungen zur Version Visual Studio 2017 für Mac 7.2Visual Studio 2017 for Mac version 7.2 Release Notes

Anmerkungen zur Version Visual Studio 2017 für Mac 7.1Visual Studio 2017 for Mac version 7.1 Release Notes

Anmerkungen zur Version Visual Studio 2017 für Mac 7.0Visual Studio 2017 for Mac version 7.0 Release Notes


Seitenanfang
Top of Page