Visual Studio 2017 (Version 15.3) – Versionsanmerkungen Visual Studio 2017 version 15.3 Release Notes

Entwicklercommunity | Systemvoraussetzungen | Kompatibilität | Verteilbarer Code | Lizenzbedingungen | Blogs | Bekannte ProblemeDeveloper Community | System Requirements | Compatibility | Distributable Code | License Terms | Blogs | Known Issues


Hinweis

Dies ist nicht die neueste Version von Visual Studio 2017This is not the latest version of Visual Studio 2017. Weitere Informationen zur aktuellsten Version von Visual Studio 2017 finden Sie auf der Seite zu den aktuellsten Anmerkungen zu dieser Version.To see information on the latest version of Visual Studio 2017, please visit the current Release Notes page.

Tipp

Sie können die Sprache der Seite unten auf dieser Seite ändern.You can switch the page language at the bottom of this page. Klicken Sie auf die SchaltflächeClick the -Symbol, suchen Sie nach Ihrer Sprache, oder treffen Sie eine Auswahl aus der Liste der verfügbaren Sprachen. icon, search for your language, or select from the list of available languages.


Dieser Artikel enthält Informationen zu den Releases für Visual Studio 2017 (Version 15.3).This article contains information about releases for Visual Studio 2017 version 15.3.

FeedbackFeedback

Wir freuen uns auf Ihr Feedback!We’d love to hear from you! Wenn Probleme auftreten, können Sie uns über die Option Ein Problem melden im Installationsprogramm oder in der Visual Studio-IDE selbst informieren.You can report a problem from the Report a Problem option in either the installer or the Visual Studio IDE itself. DieThe Feedback Icon Symbol befindet sich in der oberen rechten Ecke.icon is located in the upper right hand corner. Sie können Ihr Feedback im Portal der Entwicklercommunity verfolgen.You can track your feedback in the Developer Community portal. Vorschläge können Sie uns über die Seite UserVoice mitteilen.For suggestions, let us know through the UserVoice site.

ReleaseverlaufRelease History

Tipp

In der Dokumentation zum Visual Studio 2017-Releaserhythmus erfahren Sie mehr zur Auslieferung der Releases.You can learn more about how we ship our releases in the Visual Studio 2017 Release Rhythm document.

Herunterladen des aktuellen Release von Visual Studio 2017Download the Current Release of Visual Studio 2017

Klicken Sie auf die Schaltfläche, um die aktuelle Version von Visual Studio 2017 herunterzuladen.Click the button to download the latest version of Visual Studio 2017. Anweisungen finden Sie unter Installieren von Visual Studio 2017.For instructions, see Install Visual Studio 2017.

Hinweis: Die Größe des Installationspakets variiert abhängig von Ihrer aktuellen Visual Studio-Konfiguration.Note: Installation package size will vary depending on your current Visual Studio configuration.


Veröffentlichungsdatum: 19. September 2017 – Visual Studio 2017 Version 15.3.5Release Date: September 19, 2017 - Visual Studio 2017 version 15.3.5

Im Release vom 19. September 2017 behobene ProblemeIssues Fixed in September 19, 2017 Release

Diese Probleme wurden von Kunden für diese Version gemeldet:These are the customer-reported issues addressed in this version:

  • Führt die Unterstützung für Xcode 9, iOS 11, tvOS 11 und watchOS 4 von Apple einIntroduced support for Apple's Xcode 9, iOS 11, tvOS 11 and watchOS 4

Veröffentlichungsdatum: 12. September 2017 – Visual Studio 2017 Version 15.3.4Release Date: September 12, 2017 - Visual Studio 2017 version 15.3.4

Im Release vom 12. September 2017 behobene ProblemeIssues Fixed in September 12, 2017 Release

Diese Probleme wurden von Kunden für diese Version gemeldet:These are the customer-reported issues addressed in this version:


Veröffentlichungsdatum: 29. August 2017 – Visual Studio 2017 Version 15.3.3Release Date: August 29, 2017 - Visual Studio 2017 version 15.3.3

Im Release vom 29. August 2017 behobene ProblemeIssues Fixed in August 29, 2017 Release

Diese Probleme wurden von Kunden für diese Version gemeldet:These are the customer-reported issues addressed in this version:


Veröffentlichungsdatum: 22. August 2017 – Visual Studio 2017 Version 15.3.2Release Date: August 22, 2017 - Visual Studio 2017 version 15.3.2

Im Release vom 22. August 2017 behobene ProblemeIssues Fixed in August 22, 2017 Release

Diese Probleme wurden von Kunden für diese Version gemeldet:These are the customer-reported issues addressed in this version:

Zusätzliche Problembehebungen in dieser Version:Additional fixes included in this release:

  • Toolsupdate von Service FabricService Fabric tooling update.
  • AccessDenied-Fehler beim Visual Studio-Upgrade während der VSIX-Installation/DeinstallationVisual Studio upgrade fails with AccessDenied failure during VSIX install / uninstall.
  • Problem bei der Projektgenerierung unter Unity Version <= 5.5Project generation issue on Unity version <= 5.5.
  • Speicherabbilderfassung für verknüpfte DateienDump capture for linked files.
  • Lautlose, ungültige Codegenerierung aufgrund einer SchleifenoptimierungSilent bad codegen due to loop optimization.

Release-Datum: 18. August 2017 – Visual Studio 2017 Version 15.3.1Release Date: August 18, 2017 - Visual Studio 2017 version 15.3.1

In diesem Release behobene ProblemeIssues Fixed in this Release

Diese Probleme wurden von Kunden für diese Version gemeldet:These are the customer-reported issues addressed in this version:


Veröffentlichungsdatum: 14. August 2017 – Visual Studio 2017 Version 15.3Release Date: August 14, 2017 - Visual Studio 2017 version 15.3

Zusammenfassung: Neues in diesem ReleaseSummary: What's New in this Release

  • Verbesserungen der Barrierefreiheit machen Visual Studio leichter zugänglich als je zuvor.Accessibility Improvements make Visual Studio more accessible than ever.
  • Azure Function Tools sind in der Workload „Azure-Entwicklung“ enthalten.Azure Function Tools are included in the Azure development workload. Sie können Azure Function-Anwendungen lokal entwickeln und direkt in Azure veröffentlichen.You can develop Azure Function applications locally and publish directly to Azure.
  • Sie können in Visual Studio 2017 nun Anwendungen erstellen, die in Azure Stack und in Government-Clouds wie Azure in China ausgeführt werden.You can now build applications in Visual Studio 2017 that run on Azure Stack and government clouds, like Azure in China.
  • Wir haben die Unterstützung der .NET Core-Entwicklung für .NET Core 2.0 sowie Windows Nano Server-Container verbessert.We improved .NET Core development support for .NET Core 2.0, and Windows Nano Server containers.
  • In der Visual Studio-IDE haben wir die Anmeldung und Identität, die Startseite, den Lightweight-Ladevorgang für Projektmappen sowie das Einrichten der CLI verbessert.In Visual Studio IDE, we improved Sign In and Identity, the start page, Lightweight Solution Load, and setup CLI. Zudem haben wir das Refactoring, die Codegenerierung und schnelle Aktionen verbessert.We also improved refactoring, code generation and Quick Actions.
  • Der Visual Studio-Editor verfügt über eine verbesserte Barrierefreiheit aufgrund des neuen Designs „Blau (zusätzlicher Kontrast)“ und der verbesserten Sprachausgabenunterstützung.The Visual Studio Editor has better accessibility due to the new ‘Blue (Extra Contrast)’ theme and improved screen reader support.
  • Wir haben die Benutzeroberfläche von Debugger und Diagnose verbessert.We improved the Debugger and diagnostics experience. Diese Verbesserung umfasst das Zeigen und Klicken auf „Festlegen der nächsten Anweisung“.This includes Point and Click to Set Next Statement. Wir haben auch alle geschachtelten Werte im Variablenfenster aktualisiert und Verbesserungen beim Debuggen bei „Ordner öffnen“ vorgenommen.We've also refreshed all nested values in variable window, and made Open Folder debugging improvements.
  • Xamarin verfügt über einen neuen eigenständigen Editor zum Bearbeiten von App-Berechtigungen.Xamarin has a new standalone editor for editing app entitlements.
  • Die Benutzeroberfläche von „Ordner öffnen“ und CMake-Tools wurde aktualisiert.The Open Folder and CMake Tooling experience is updated. Sie können nun CMake 3.8 verwenden.You can now use CMake 3.8.
  • Wir haben Verbesserungen am IntelliSense-Modul sowie an den Projekt- und Code-Assistenten für C++-Sprachdienste vorgenommen.We made improvements to the IntelliSense engine, and to the project and the code wizards for C++ Language Services.
  • Das Visual C++-Toolset unterstützt die Ausrichtung der Befehlszeileninitialisierung.Visual C++ Toolset supports command-prompt initialization targeting.
  • Wir haben die Möglichkeit zum Verwenden von C# 7.1-Sprachfunktionen hinzugefügt.We added the ability to use C# 7.1 Language features.
  • Sie können Versionen von TypeScript unabhängig von Visual Studio-Updates installieren.You can install TypeScript versions independent of Visual Studio updates.
  • Wir haben Unterstützung für das Debuggen von Node 8 hinzugefügt.We added support for Node 8 debugging.
  • NuGet verfügt über zusätzliche Unterstützung für neue TFMs (netcoreapp2.0, netstandard2.0, Tizen), Semantic Versioning 2.0.0 und die MSBuild-Integration von NuGet-Warnungen und -Fehlern.NuGet has added support for new TFMs (netcoreapp2.0, netstandard2.0, Tizen), Semantic Versioning 2.0.0, and MSBuild integration of NuGet warnings and errors.
  • Visual Studio bietet nun Entwicklungstools von .NET Framework 4.7 auf allen unterstützten Plattformen, wobei die 4.7-Laufzeit enthalten ist.Visual Studio now offers .NET Framework 4.7 development tools to supported platforms with 4.7 runtime included.
  • Wir haben Cluster von verknüpften Ereignissen zu den Suchabfrageergebnissen in der Suchfunktion von Application Insights hinzugefügt.We added clusters of related events to the search query results in the Application Insights Search tool.
  • Wir haben die Syntaxunterstützung für SQL Server 2016 in Redgate SQL Search verbessert.We improved syntax support for SQL Server 2016 in Redgate SQL Search.
  • Wir haben die Unterstützung für Microsoft Graph-APIs in Verbundene Dienste aktiviert.We enabled support for Microsoft Graph APIs in Connected Services.

In diesem Release behobene HauptproblemeTop Issues Fixed in this Release

Wir haben uns in der Entwicklercommunity umgehört.The Developer Community spoke and we listened. Diese Liste enthält die 10 am höchsten gevoteten Probleme, die in dieser Version behoben wurden.This list provides the 10 highest voted issues fixed in this release.

The Developer Community Portal Erfahren Sie mehr über die von Kunden gemeldeten Probleme, die in Visual Studio 2017 (Version 15.3) behoben wurden. Learn more about customer-reported issues addressed in Visual Studio 2017 version 15.3.


Details: Neues in diesem ReleaseDetails: What's New in this Release

Barrierefreiheit Accessibility

Wir haben über 1.700 Probleme bei der Barrierefreiheit in dieser Versionsanmerkung behandelt und haben Visual Studio so zugreifbar wie noch nie gemacht.We addressed over 1,700 accessibility issues in this release and made Visual Studio more accessible than ever. Sie haben Zugriff auf das neue Design „Blau (zusätzlicher Kontrast)“ (Abbildung 1).You have access to the new “Blue (Extra Contrast)” theme (Figure 1). Dieses Design bietet Ihnen mehr Kontrast als das reguläre Design „Blau“, wenn Sie den vollständigen Modus für hohe Kontraste nicht möchten oder nicht benötigen.This theme offers you more contrast than the regular "Blue" theme if you don't want or need the full High Contrast mode.

Blue (Extra Contrast) theme
(Abbildung 1) Design Blau (zusätzlicher Kontrast)(Figure 1) Blue (Extra Contrast) theme

Mit dem Visual Studio-Editor können Sie über den neuen Befehlssatz „Zeilenanmerkungen anzeigen“ Text-Randsteuerelemente entdecken und zwischen diesen navigieren.With Visual Studio Editor, you can discover and navigate between text adornments via the new "Show Line Annotations" command set. Sie finden die neue Funktion im Editor-Kontextmenü (Abbildung 2).You can find the new feature on the Editor context menu (Figure 2). Weitere Informationen finden Sie im Abschnitt Visual Studio-Editor.See the Visual Studio Editor section for more information.

Show Line Annotations
(Abbildung 2) Zeilenanmerkungen anzeigen(Figure 2) Show Line Annotations

Weitere Neuigkeiten zur Barrierefreiheit finden Sie im Blogbeitrag Accessibility improvements in Visual Studio 2017 version 15.3 (Verbesserungen der Barrierefreiheit in Visual Studio 2017 (Version 15.3)).For more accessibility news, visit the Accessibility improvements in Visual Studio 2017 version 15.3 blog post.


Azure Stack und Azure Government Clouds Azure Stack and Azure Government Clouds

Verwenden Sie dieselben Tools in Visual Studio – wie Cloud-Explorer, Verbundene Dienste und ASP.NET Publish – zum Verbinden von Azure Stack und Government-Clouds.Use all the same tools in Visual Studio — like Cloud Explorer, Connected Services and ASP.NET Publish — to connect Azure Stack and government clouds. Wählen Sie eine vorhandene Government-Cloud wie Azure in China (Abbildung 3) aus, oder geben Sie den Ermittlungsendpunkt von Azure Stack Ihrer Organisation ein.Pick an existing government cloud, like Azure in China (Figure 3), or enter the discovery endpoint for your organization’s Azure Stack.

Azure Stack
(Abbildung 3) Azure Stack(Figure 3) Azure Stack

Azure Function ToolsAzure Function Tools

  • Tools zum Entwickeln von C#-Azure Functions sind als Teil der Workload „Azure-Entwicklung“ enthalten.Tools for developing C# Azure Functions are included as part of the “Azure development” workload.
  • Sie können Azure-Funktionen mithilfe von vorkompilierten C#-Klassenbibliotheken und Attributen zum Angeben von Triggern entwickeln.You can develop Azure functions by using pre-compiled C# class libraries, and attributes to specify triggers.
  • Sie können auf Ihrem lokalen Entwicklungscomputer erstellen, ausführen und debuggen.You can build, run, and debug on your local development machine.
  • Sie können von Visual Studio aus direkt in Azure veröffentlichen.You can publish directly to Azure from Visual Studio.

Weitere Informationen finden Sie im Blogbeitrag Visual Studio 2017 Tools for Azure Functions (Visual Studio 2017-Tools für Azure Functions).For more details, see the Visual Studio 2017 Tools for Azure Functions blog post.


.NET Core und ASP.NET Core .NET Core and ASP.NET Core

  • Sie können das .NET Core 2.0 SDK über einen separaten Download installieren, um die .NET Core 2.0-Entwicklung in Visual Studio 2017 (Version 15.3) zu ermöglichen.You can install .NET Core 2.0 SDK via a separate download to enable .NET Core 2.0 development in Visual Studio 2017 version 15.3. Visual Studio bietet nun die parallele Unterstützung mehrerer .NET Core SDKs.Visual Studio now provides side-by-side support of multiple .NET Core SDKs. Sie können mit dem täglichen Build des .NET Core SDKs experimentieren, während Sie zudem mit dem aktuellen öffentlichen Release des SDKs entwickeln.You can experiment with the latest daily build of the .NET Core SDK while you develop with the latest public release of the SDK. Weitere Details finden Sie im .NET-Blog.See .NET blog for details.
  • Mit Visual Basic-Unterstützung haben Sie nun die Möglichkeit, .NET Core-Konsolenanwendungen und .NET Core- sowie .NET Standard-Klassenbibliotheken in Visual Basic zu erstellen.With Visual Basic support, you now have the ability to create .NET Core console applications, and .NET Core, and .NET Standard class libraries in Visual Basic.
  • .NET Framework- und .NET Standard-/Core-Interop erlaubt Ihnen, nun von .NET Framework-Projekten auf .NET Core-/.NET Standard-Bibliotheken zu verweisen und umgekehrt..NET Framework and .NET Standard/Core interop allows you to refer to .NET Core/.NET Standard libraries from .NET Framework projects and vice versa. Es ist nicht mehr nötig, Interop-NuGet-Pakete manuell hinzuzufügen: Visual Studio übernimmt dies automatisch für Sie.No need to manually add interop NuGet packages – Visual Studio does this for you automatically.
  • Mit der Verbesserung der Unterstützung für mehrere Zielframeworks können Sie Ihr Projekt für mehrere Zielframeworks erstellen und die Zielframeworkauswahl unter Debug/Run (Debuggen/Ausführen) verwenden, um das auszuführende Zielframework auszuwählen.Multiple target framework support enhancement allows you to build your project for multiple target frameworks (TFM), and use the TFM picker in Debug/Run to pick the TFM to run.
  • Wir haben den Image-Support für Windows Nano Server zum Containerisieren von ASP.NET Core-Apps als Windows Nano Server-Images hinzugefügt.We added Windows Nano Server image support for containerizing ASP.NET Core apps as Windows Nano Server images. Sie können Windows Nano Server jetzt als Containerplattform auswählen.You can now select Windows Nano Server as the container platform. Sie können dies unter Datei > Neues Projekt für ASP.NET Core-Projekte durchführen.You can do this under File->New Project for ASP.NET Core projects. Zu Ihren vorhandenen Projekten können Sie dies über das Kontextmenü des Projekts hinzufügen.For your existing projects, it can be added using the Project Context Menu.
  • Lokale IIS-Unterstützung: Sie können nun mithilfe von IIS von Visual Studio entwickeln und debuggen.Local IIS support: You can now develop and debug using IIS from Visual Studio.
  • ASP.NET Core in .NET Framework: Verwenden Sie das Dropdownmenü im Dialogfeld „One ASP.NET“, wenn Sie ein ASP.NET Core-Projekt erstellen, das das vollständige .NET Framework (nur Windows) unterstützt.ASP.NET Core on .NET Framework – When you create an ASP.NET Core project targeting the full .NET Framework (Windows only), you will use the dropdown on the One ASP.NET dialog.
  • Die Funktion „Live Unit Testing“ kann für .NET Standard-, .NET Core- und ASP.NET Core-Projekte aktiviert werden.The Live Unit Testing feature can be enabled for your .NET Standard, .NET Core, and ASP.NET Core projects.

Service Fabric-ToolsService Fabric Tools

Dieses Release bietet eine neue zustandsbehaftete ASP.NET Core-Projektvorlage, Unterstützung für sowohl 2.5 als auch 2.6 SDKs (und die dazugehörigen Laufzeiten) von Service Fabric sowie mehrere Korrekturen.This release provides a new stateful ASP.NET Core project template, support for both 2.5 and 2.6 SDK's (and corresponding runtimes) of Service Fabric, as well as several bug fixes.

Continuous Delivery-ToolsContinuous Delivery Tools

Wir haben diese Funktion von der CD4VS-Erweiterung (Microsoft Continuous Delivery-Tools für Visual Studio) in Visual Studio verschoben:We moved these features from the CD4VS (Microsoft Continuous Delivery Tools for Visual Studio) extension into Visual Studio:

  • Konfigurieren Sie Continuous Delivery für Projektmappen, die ASP.NET-Projekte enthalten, die einen Azure App Service ansteuern.Configure continuous delivery for solutions that contain ASP.NET projects targeting an Azure App Service.
  • Konfigurieren Sie Continuous Delivery für Projektmappen, die ASP.NET Core-Projekte enthalten, die einen Azure App Service ansteuern.Configure continuous delivery for solutions that contain ASP.NET Core projects targeting an Azure App Service.

Visual Studio-IDE Visual Studio IDE

  • Wir haben den Menübefehl Tastaturzugriff im Menü „Hilfe“ hinzugefügt.We added the Keyboard Accessibility menu command under the "Help" menu. Dies bietet Ihnen eine Verknüpfung zur Onlinedokumentation über Tipps und Tricks zu Barrierefreiheit.This provides you with a shortcut to online documention about Accessibility Tips and Tricks.
  • Das Diagnosesystem informiert Sie über die Infoleiste über Erweiterungen, die an einem unerwarteten Beenden von Visual Studio beteiligt gewesen sein könnten (Abbildung 4).The diagnostic system informs you via the InfoBar about extensions that might have been involved in an unexpected termination of Visual Studio (Figure 4). Die Infoleiste bietet diese Informationen zum Beenden und fragt, ob Sie die verdächtige Erweiterung deaktivieren möchten.The InfoBar provides this information about the termination and asks if you would like to disable the suspected extension.
InfoBar notification
(Abbildung 4) Infoleistenbenachrichtigung(Figure 4) InfoBar notification
  • In „Ordner öffnen“-Szenarios können Sie Ihren gewünschten Debugger über die dedizierte Benutzeroberfläche auswählen.In open folder scenarios, you can select your desired debugger via dedicated UI.
  • Wir haben die Freigabe bestimmter Einstellungen wie das Toolfensterlayout zwischen verschiedenen parallelen Installationen von Visual Studio 2017 beendet.We’ve stopped sharing certain settings, like tool window layout, between different side-by-side installations of Visual Studio 2017. Weitere Informationen finden Sie in der Dokumentation zum Synchronisieren der Einstellungen in Visual Studio.For more information, see the Synchronize your settings in Visual Studio documentation.
  • Wir haben den Fehler „ausgeblendetes Fenster“ behoben, durch den Visual Studio den Eindruck gemacht hat, als würde es hängen, bevor das Hauptfenster erschienen ist.We fixed the "hidden window" bug that made Visual Studio appear to hang before its main window appeared.
  • Wir haben den klickbaren Zielbereich erweitert, um das Verwerfen von Benachrichtigungstipps zu vereinfachen.We increased the clickable target area to make it easier to dismiss notification tips.

.NET-IDE.NET IDE

  • Wir haben mehrere neue Refactorings und schnelle Korrekturen hinzugefügt, wie das Auflösen von Zusammenführungskonflikten, das Hinzufügen von Überprüfungen auf NULL, das Hinzufügen von Parametern u.v.m.We added several new refactorings and quick fixes, like "Resolve merge conflicts", "Add null checks", "Add parameter", and many more. Sehen Sie sich unsere Seite Umgestaltung, Codegenerierung und schnelle Aktionen in Visual Studio an, um die vollständige Liste zu sehen.Take a look at our Refactoring, Code Generation and Quick Actions in Visual Studio page to see the full list.
  • Wir empfehlen Variablennamen in IntelliSense zum schnellen Benennen Ihrer Variablen, z.B. Person person.We suggest variable names in IntelliSense to help you name your variables quickly, for example, Person person.
  • Bearbeiten und Fortfahren unterstützt C# 7.0-Funktionen (ausgenommen lokale Funktionen).Edit and Continue supports C# 7.0 features (except local functions).
  • Wir haben Unterstützung für das Verwenden von Platzhaltern außerhalb Ihres Projektordners für .NET Core hinzugefügt.We added support for file globbing outside of your project folder for .NET Core.

Anmeldung und IdentitätSign In and Identity

Wir haben das Kontoauswahl-Steuerelement korrigiert, damit das erneute Eingeben von Anmeldeinformationen verlässlicher funktioniert.We fixed the account picker control so "Re-enter credentials" works more reliably. In einigen Fällen hat die Kontoauswahl beim erneuten Eingeben von Anmeldeinformationen Konten gelöscht.In some cases, the account picker would clear accounts upon re-entering credentials.

StartseiteStart Page

Wir haben den klickbaren Zielbereich auf angeheftete Elemente im MRU-Menü der Startseite erweitert.We increased the clickable target area on Start Page MRU “pins”. Es ist einfacher, Elemente, die für Sie wichtig sind, oben an das MRU-Menü anzuheften.It's easier to pin items you care about to the top of the MRU.

Lightweight-Lösung ladenLightweight Solution Load

  • Wir haben die Buildgeschwindigkeit und -stabilität verbessert.We increased build speed and stability.
  • Wir haben die Anzahl geladener Projekte reduziert.We reduced the number of loaded projects.
  • Wir haben eine neue Option (Abbildung 5) hinzugefügt, durch die Visual Studio entscheiden kann, was am besten zu Ihrer Projektmappe passt.We added a new option (Figure 5) that allows Visual Studio to decide what’s best for your solution.
Lightweight Solution Load Options
(Abbildung 5) Optionen für Lightweight-Ladevorgang für Projektmappen(Figure 5) Lightweight Solution Load Options
  • Wir haben Lösungen für Dateisuchergebnisse für die Suche nach zurückgestellten Projekten anstatt nur nach geladenen Projekten hinzugefügt.We added file search results solutions to search for deferred projects, instead of just loaded projects.
    • Wenn Sie ein Projekt laden, werden alle vorhandenen Suchvorgänge aktualisiert, um Fortschrittsergebnisse hinzuzufügen.When you load a project, all existing searches are refreshed to add progression results.
    • Hierfür gelten Beschränkungen:There are limits to this:
      • Die Suche wird nicht innerhalb der Datei durchgeführt und enthält keine progressiven Ergebnisse, d.h. Klassen, Methoden usw.Search does not extend within the file and does not include progressive results, i.e. classes, methods, etc.
      • Dateien, die zu einem Projekt gehören, werden als flache Liste dargestellt.Files that belong to a project are shown as a flat list. Wenn Dateien zu einem Ordner gehören, wird der relative Pfad anstatt nur der Dateiname angezeigt.When files belong to a folder, the relative path is shown instead of just the file name.
      • Es gibt keine Kontextmenüs für die Dateielemente in der Suchansicht.There are no context menus for the file items in the search view.
  • Gehe zu allen und Gehe zu Dateien zeigen Inhalt aus externen Elementen im Arbeitsbereich an.GoTo All and GoTo Files show content from external items in the workspace.
  • Wir haben die Batcherstellung in Projekten verbessert, die den Lightweight-Ladevorgang für Projektmappen verwenden.We improved Batch build in projects that use Lightweight Solution Load.

SetupSetup

  • Der Visual Studio-Installer unterstützt nun die High-DPI-Skalierung in Stufen unter 150%.Visual Studio Installer now supports high-DPI scaling at levels less than 150%.
  • Die ausführbare Datei vswhere.exe wurde aktualisiert, um Vorschauinstanzen standardmäßig auszuschließen, allerdings wird sie diese einschließen, wenn --prerelease in der Befehlszeile enthalten ist.The vswhere.exe executable file has been updated to exclude preview instances by default, and includes them when --prerelease is included on the command line.
  • Die CLI kann --verify, --fix und --clean verarbeiten.CLI is able to handle --verify, --fix and --clean.
    • --verify überprüft das Layout und informiert Sie über fehlende und ungültige Nutzlasten.--verify verifies layout and informs you of missing and invalid payloads.
    • --fix überprüft das Layout und lädt die Pakete erneut herunter, die entweder fehlen oder ungültig sind.--fix verifies the layout and re-downloads packages that are either missing or invalid.
    • --clean löscht veraltete Pakete und ermöglicht es Ihnen, das Layout auf einen bestimmten Versionsbereich zuzuschneiden.--clean deletes obsolete packages and allows you to trim layout to a specific version range.
  • Wir haben zur Installationsdetailseite Details hinzugefügt, die die Auswirkung pro Laufwerk in Nettogröße anzeigen.We added details that show the net size impact per drive to the installation details page. (Abbildung 6).(Figure 6).
Drive Sizes listed in the Installer
(Abbildung 6) Laufwerkgrößen aufgelistet im Installer(Figure 6) Drive Sizes listed in the Installer

Visual Studio-Editor Visual Studio Editor

  • Das manuelle Scrollen und Auswählen beim Hinzufügen von großen Anzahlen von Fehlern ist nicht mehr schwierig.Manual scroll and selection are no longer difficult when a large numbers of errors are being added.
  • Wir haben eine neue Variante des Designs „Blau“ hinzugefügt, das sich besonders für Benutzer eignet, die mehr Kontrast im Visual Studio-Editor benötigen.We added a new variant of the "Blue" theme, which caters specifically to users who need more contrast in the Visual Studio Editor. Dieses Design bietet Ihnen mehr Kontrast als das reguläre Design „Blau“, wenn Sie den vollständigen Modus für hohe Kontraste nicht möchten oder nicht benötigen.This theme offers you more contrast than the regular "Blue" theme if you don't want or need the full High Contrast mode. Sie können es über Werkzeuge > Optionen > Umgebung > Allgemein testen.You can try it out via Tools -> Options -> Environment -> General.
  • Wenn Sie die Sprachausgabe verwenden, können Sie nun über den neuen Befehl Zeilenanmerkungen anzeigen zwischen Randsteuerelementen navigieren.If you use a screen-reader, you can now navigate between adornments by using the new "Show Line Annotations" command.
    • Um diesen zu aktivieren, klicken Sie im Kontextmenü des Editors auf „Zeilenanmerkungen anzeigen“ (Ctrl+K, Ctrl+M).To activate, select "Show Line Annotations" (Ctrl+K, Ctrl+M) on the Editor context menu. Dadurch erscheint ein Popup im Editor, das die Randsteuerelemente in dieser Zeile erklärt.A popup will appear in the editor describing the adornments on that line.
    • Navigieren Sie durch mehrere Anmerkungen in der Zeile, indem Sie Ctrl+K, Ctrl+ Right/Left Arrow verwenden.Navigate through multiple annotations on the line using Ctrl+K, Ctrl+ Right/Left Arrow.
    • Sie können auch einfach Kontext in Code über den Befehl „Struktur anzeigen“ finden, Ctrl+K, Ctrl+G.You can also easily find context in code through the "Show Structure" command Ctrl+K, Ctrl+G. Dadurch wird der strukturelle Kontext der Codezeile im Popup angezeigt, in dem das Caretzeichen zu finden ist, und kann mithilfe der Bildschirmsprachausgabe gelesen werden.This shows the structural context of the line of code in the popup where the caret is located, and can be read by the screen reader.

Debuggen und Diagnose Debugging and Diagnostics

Debuggerunterstützung für die Symbolserver von Visual Studio Team ServicesDebugger Support for Visual Studio Team Services Symbol Servers

  • Sie können Symbole von Symbolservern von Visual Studio Team Services abfragen und herunterladen (Abbildung 7).You can query and download symbols (Figure 7) from Visual Studio Team Services Symbol Servers. Sie können Symbolpfade von Visual Studio Team Services mithilfe der Seite Tools > Optionen > Debugger > Symbole auswählen und zu Ihrer Visual Studio-Umgebung hinzufügen.You can select and add Visual Studio Team Services symbol paths to your Visual Studio environment using the Tools->Options->Debugger->Symbols page. Informationen zum Einrichten eines Symbolservers von Visual Studio Team Services finden Sie unter Use Symbol Server in Team Services (Verwenden von Symbolservern in Team Services).To set up a Visual Studio Team Services Symbol Server, see the Use Symbol Server in Team Services page.
Add VSTS Symbol Server
(Abbildung 7) Hinzufügen von VSTS-Symbolservern(Figure 7) Add VSTS Symbol Server
  • Die SetThreadDescription-API wird beim Debuggen mithilfe von „Debuggen starten“ (F5) oder „An den Prozess anhängen“ (Ctrl+Alt+P) unterstützt.The SetThreadDescription API is supported while debugging when you use Start Debugging (F5) or Attach to Process (Ctrl+Alt+P). Die Threadnamen, die über diese API festgelegt werden, werden nun im Fenster „Threads“ und im Dropdownmenü „Threads“ in der Symbolleiste „Debugspeicherort“ angezeigt.The thread names that are set via this API now show up in the Threads window and in the Thread dropdown in the Debug Location toolbar. Dies wird derzeit beim Debuggen von Abbildern nicht unterstützt.This is not currently supported while dump debugging.
  • Das Ausgabefenster zeigt Ihnen nun die Konsolenausgabe einer Anwendung an, die beim Debuggen innerhalb eines Windows-Containers ausgeführt wird.The Output Window now shows you the console output of an application running inside a Windows Container while debugging.
  • Wir haben neue Unterstützung für das Debuggen von .NET Core-Apps hinzugefügt, die Sie innerhalb von Windows-Containern basierend auf Windows Nano Server ausführen.We added new support for debugging .NET Core apps you run inside Windows Containers based on Windows Nano Server.

Zeigen und Klicken auf „Festlegen der nächsten Anweisung“Point and Click to Set Next Statement

Sie können die Taste Ctrl gedrückt halten, während beim Debuggen an einem Haltepunkt angehalten wird.You can hold down the Ctrl key while stopped at a breakpoint when debugging. Das Symbol Run to Click (Ausführung bis hier ausführen) neben Ihrer Codezeile wird in die Funktion „Nächste Anweisung festlegen“ geändert (Abbildung 8).The Run to Click (Run execution to here) icon next to your line of code changes to “Set Next Statement” functionality (Figure 8). Klicken Sie auf das Symbol, um den gelben Anweisungszeiger in diese Zeile zu verschieben und die nächste Anweisung festzulegen, die der Debugger ausführen soll.Click the icon to move the yellow instruction pointer to that line and set the next statement for the debugger to execute.

Click to set Next Statement
(Abbildung 8) Klicken zum Festlegen der nächsten Anweisung(Figure 8) Click to set Next Statement

Der Quelllink wird nun für das Windows-PDB-Dateiformat (zusätzlich zu portablen PDB-Dateien) unterstützt.Source Link is now supported for Windows PDB file format (in addition to Portable PDBs). Compiler, die diesen unterstützen, können die erforderlichen Informationen in das Windows-PDB-Dateiformat einfügen, und der Debugger kann Quelldateien basierend auf diesen Informationen abrufen.Compilers that support it can put the necessary information in the Windows PDB file format and the debugger can retrieve source files based on that information.

Debuggen bei „Ordner öffnen“Open Folder Debugging

Wir haben das Debuggen bei der Verwendung von Vorlagen für „Ordner öffnen“ vereinfacht.We have made your debugging experience easier when you use our new templates for Open Folder. Wenn Sie den Core-Debugger installiert haben, können Sie mithilfe unserer neuen Vorlagen den Debuggertyp auswählen, den Sie verwenden möchten.If you have the core debugger installed, our new templates allow you to choose the type of debugger you want to use. Im Dialogfeld „Debugger auswählen“ der Menüoption „Debug- und Starteinstellungen“ im Projektmappen-Explorer können die Optionen „Verwaltet“, „Nativ“ oder „Gemischt“ ausgewählt werden.Managed, Native, or Mixed can be chosen from the "Select a Debugger" dialog in the "Debug and Launch Settings" menu option in Solution Explorer. Wenn Sie C++-MDD installiert haben (Android C++, Linux-Debuggen usw.), werden Ihnen nun Optionen für MinGW- und Cygwin-Unterstützung angezeigt, wobei GDB zum Anfügen und Starten innerhalb derselben Menüoption verwendet wird.If you have a C++ MDD experience installed (Android C++, Linux Debugging, etc.), you now see options for MinGW and Cygwin support by using GDB for attach and launch within the same menu option.

Aktualisieren aller verschachtelten Werte in VariablenfensternRefresh All Nested Values in Variable Windows

Wenn Sie auf die Schaltfläche „Aktualisieren“ des übergeordneten Knotens einer Variable oder eines Ausdrucks in den Fenstern „Überwachung“, „Auto“ und „Lokal“ klicken, werden alle Variablen und Ausdrücke, die diesem Knoten untergeordnet sind, ebenfalls aktualisiert und neu ausgewertet.When you click the refresh button for the parent node of a variable or expression in the Watch, Autos, and Locals windows, all visible variables and expressions that are children of that node also refresh and re-evaluate. Sie müssen nicht mehr für jedes untergeordnete Element auf die Schaltfläche „Aktualisieren“ klicken.You no longer need to click on the refresh button for each of the children.

Live Unit Testing-Unterstützung für .NET CoreLive Unit Testing Support for .NET Core

Sie können die Funktion „Live Unit Testing“ für .NET Standard-, .NET Core- und ASP.NET Core-Projekte aktivieren.You can enable the Live Unit Testing feature for .NET Standard, .NET Core, and ASP.NET Core projects.


Xamarin Xamarin

  • Eigenschaftenseiten und App-Manifest-Neuentwürfe: Wir haben weiter daran gearbeitet, die Verwendung von Eigenschaftenseiten für iOS- und Android-Projekte zu vereinfachen.Property Pages & App Manifest Redesigns - We have continued our work on making property pages for iOS and Android projects easier to use.
  • Editor „Neue Berechtigungen“: Wir haben einen eigenständigen Editor zum Bearbeiten von App-Berechtigungen hinzugefügt.New Entitlements Editor - We added a standalone editor for editing app entitlements.

Eine vollständige Übersicht der Änderungen finden Sie unter developer.xamarin.com.For a complete overview of changes, be sure to check out developer.xamarin.com for more details.


Ordner und -CMake-Tools öffnenOpen Folder and CMake Tools

  • Wir haben die Stabilität beim Umschalten zwischen Projektmappe und Ordner verbessert.We improved stability for toggling between folder and solution.
  • „Ordner öffnen“-Extender können das Symbol „Quellcodeverwaltung“ zu Ihren Ordnern hinzufügen.Open folder extenders can add a source control icon to your folders. Dadurch können Sie schnell den Quellcodeverwaltungsstatus Ihrer Dateien im Projektmappen-Explorer einsehen, der derzeit durch SVN implementiert wird.This allows you to quickly see the source control state of your files in Solution Explorer, which is currently implemented by SVN.
  • Die CMake-Benutzeroberfläche in Visual Studio wird auf CMake 3.8 aktualisiert.The CMake experience in Visual Studio is upgraded to CMake 3.8.
  • Wir haben die Unterstützung für das Bearbeiten, Erstellen und Debuggen bei „Ordner öffnen“ für C++-Projekte verbessert, die MinGW oder Cygwin verwenden.We improved editing, building, and debugging support in "Open Folder" for C++ projects that use MinGW or Cygwin.
  • Wir haben Unterstützung für das Definieren von globalen und konfigurationsspezifischen Umgebungsvariablen in „CppProperties.json“ und „CMakeSettings.json“ hinzugefügt.We added support to define global and configuration-specific environment variables in "CppProperties.json" and "CMakeSettings.json". Diese Umgebungsvariablen können von in „launch.vs.json“ definierten Debugkonfigurationen und von Aufgaben in „tasks.vs.json“ verwendet werden.These environment variables can be consumed by debug configurations defined in "launch.vs.json" and tasks in "tasks.vs.json".
  • Wir haben CMake-Tools für Visual Studio erweitert, um eine Unterstützung für die CTest-Integration für Sie bereitzustellen.We enhanced CMake tools for Visual Studio to provide you with support for CTest integration.
  • Sie können nun den Ninja-Generator von CMake verwenden, um einfach 64-Bit-Plattformen anzusteuern sowie mit IntelliSense zu erstellen, debuggen und bearbeiten.You can now use the CMake's Ninja generator to easily target 64-bit platforms, build, debug, and edit with IntelliSense.

C++-Sprachdienste C++ Language Services

Die Option „Schnelleres Laden von Projekten aktivieren“ unter experimentellen Optionen wurde in „Zwischenspeichern des Projekts aktivieren“ umbenannt und in die VC++-Projekteinstellungen verschoben.The “Enable Faster Project Load” option under Experimental options has been renamed “Enable Project Caching” and moved under VC++ Project Settings. Der alte Eigenschaftswert wird nicht an die neue Option weitergegeben.The old property value is not propagated to the new option.

IntelliSense-ModulIntelliSense Engine

  • C++ IntelliSense unterstützt nun neue C++17-Funktionen, die dem Release des Batchcompilers entsprechen.C++ IntelliSense supports new C++17 features matching the batch compiler release.
  • Wir haben eine Kontextmenüoption im C++-Editor hinzugefügt, um eine Datei neu einzulesen, die verwendet werden könnte, wenn IntelliSense nicht ordnungsgemäß funktioniert.Added context menu option in C++ editor to Rescan File, which can be used if IntelliSense is not working correctly.
  • Die CPU-Auslastung beim Ausführen von „Alle Verweise suchen“ oder der Aufrufhierarchie für C++-Code wurde reduziert.Reduced CPU usage when running Find All References or Call Hierarchy for C++ code.
  • Wir haben die gesamte Erfahrung für das C++ IntelliSense-Modul verbessert.We've improved the overall C++ IntelliSense engine experience.

Projekt- und Code-AssistentProject and Code Wizard

  • Wir haben verschiedene Projekt- und Code-Assistenten im Signaturdialogstil umgeschrieben.We have rewritten several project and code wizards in the signature dialogue style.
  • „Klasse hinzufügen“ startet direkt den Assistenten zum Hinzufügen von Klassen.Add Class launches the Add Class wizard directly. Alle anderen Elemente, die hier zuvor verfügbar waren, finden Sie unter „Hinzufügen > Neues Element“.All of the other items that were previously here are available under "Add > New Item".
  • Win32-Projekte sind in der Windows Desktop-Kategorie im Dialogfeld „Neues Projekt“ zu finden.Win32 projects are under the Windows Desktop category in the New Project dialog.
  • Die Windows-Konsole und Desktopanwendungsvorlagen erstellen die Projekte nun, ohne einen Assistenten anzuzeigen.The Windows Console and Desktop Application templates now create the projects without displaying a wizard. Es gibt einen neuen Windows Desktop-Assistenten in der gleichen Kategorie, der die gleichen Optionen wie zuvor anzeigt.There's a new Windows Desktop Wizard under the same category that displays the same options as before.

Visual C++-Toolset und -Bibliotheken Visual C++ Toolset and Libraries

  • Der Developer-Eingabeaufforderung für Visual Studio (und der Visual C++-Eingabeaufforderung) wurde Unterstützung zum Initialisieren einer Eingabeaufforderungsumgebung hinzugefügt, die das Visual C++ 2015-Toolset (v140) über das Argument -vcvars_ver=14.0 ansteuert.The Developer Command Prompt for Visual Studio (and the Visual C++ Command Prompt) have added support for initializing a command-prompt environment targeting the Visual C++ 2015 Toolset (v140) via the -vcvars_ver=14.0 argument.
  • Visual C++ Redist-Dateiverzeichnisse wurden in „Microsoft.VC141.*“ umbenannt, damit sie der Versionsverwaltung mit dem Toolset (14.1x) entsprechen.Visual C++ Redist file directories have been renamed to Microsoft.VC141.* to match versioning with the toolset (14.1x). In Visual Studio 2017 RTM wurden diese Verzeichnisse fälschlicherweise „Microsoft.VC150.*“ benannt.In Visual Studio 2017 RTM, these directories were incorrectly named Microsoft.VC150.*.
  • Visual C++-Dateiversion und -Verzeichnisse (Visual Studio 2017 15.3):Visual C++ File Version and Directories (Visual Studio 2017 15.3) :
    • VC++-Toolset-Dateiversion: 14.11.25506.0 oder 19.11.25506.0VC++ Toolset File Version : 14.11.25506.0 or 19.11.25506.0
    • VC++-Tools-Verzeichnis: VC\Tools\MSVC\14.11.25503 (Verzeichnisort wurde in einem Preview-Release gesperrt)VC++ Tools Directory : VC\Tools\MSVC\14.11.25503 (directory location was locked in a Preview release)
    • VC++ Redist-Verzeichnis [a]: VC\Redist\MSVC\14.11.25325 (alle Laufzeiten mit Ausnahme von MFC und OneCore)VC++ Redist Directory [a] : VC\Redist\MSVC\14.11.25325 (All runtimes except for MFC and OneCore)
    • VC++ Redist-Verzeichnis [b]: VC\Redist\MSVC\14.11.25415 (MFC- und OneCore-Laufzeiten)VC++ Redist Directory [b] : VC\Redist\MSVC\14.11.25415 (MFC and OneCore runtimes)

C# 7.1-SprachenunterstützungC# 7.1 Language Support


JavaScript und TypeScriptJavaScript & TypeScript

  • Wir haben von einem 64-Bit-Knoten zu einem 32-Bit-Knoten beim Starten von tsserver gewechselt und den Verbrauch des Sprachdienstspeichers um die Hälfte reduziert.We switched from 64-bit node to 32 bit-node when launching tsserver and cut language service memory consumption in half.
  • Der Dateipfad IntelliSense in Importanweisungen ist nun schneller.File path IntelliSense in import statements is now faster.
  • TypeScript-Versionen können unabhängig von Visual Studio-Updates installiert und projektweise ausgewählt werden.TypeScript versions can be installed independent of Visual Studio updates and selected on a per project basis. Weitere Informationen finden Sie in der Dokumentation Updating TypeScript in Visual Studio 2017 (Aktualisieren von TypeScript in Visual Studio 2017).For more information see the Updating TypeScript in Visual Studio 2017 documentation.

Node.jsNode.js

  • Wir haben Unterstützung für das Debuggen von Node 8 hinzugefügt.We added support for Node 8 debugging.
  • Eine Leistungsverbesserungen am Unit Test Runner wurde durchgeführt.We made unit test runner performance enhancements.
  • Wir haben die Benutzeroberfläche des npm-Paketinstallationsprogramms vereinfacht.We simplified the npm package installer UI.

NuGet NuGet

  • Wir haben Unterstützung für die folgenden TFMs hinzugefügt: netcoreapp2.0, netstandard2.0 und Tizen.We have added support for the following TFMs - netcoreapp2.0, netstandard2.0, and Tizen.
  • Wir haben NuGet-Warnungen und -Fehler in MSBuild integriert, sodass Sie vorhandene MSBuild-Eigenschaften verwenden können, um bestimmte Warnungen zu unterdrücken oder diese zu einem Fehler heraufzustufen.We have integrated NuGet warnings and errors with MSBuild so you can use existing MSBuild properties to suppress certain warnings or elevate them to errors.
  • Wir haben Unterstützung für Semantic Versioning 2.0.0 hinzugefügt.We have added support for Semantic Versioning 2.0.0.

Weitere Informationen zu diesen Verbesserungen und die vollständige Liste der Fehlerbehebungen finden Sie in den NuGet-Versionsanmerkungen.You can find more details about these improvements and the complete list of bug fixes in the NuGet release notes.


.NET Framework 4.7 .NET Framework 4.7

Visual Studio 2017 Version 15.3 bietet nun die Entwicklungstools von .NET Framework 4.7 auf allen unterstützten Plattformen, wobei die 4.7-Laufzeit enthalten ist.Visual Studio 2017 version 15.3 now offers the .NET Framework 4.7 development tools to all supported platforms with the 4.7 runtime included. .NET Framework 4.7 bietet mehrere neue Features und Verbesserungen sowie zahlreiche Korrekturen in puncto Zuverlässigkeit, Stabilität, Sicherheit und Leistung.The .NET Framework 4.7 offers several new features and improvements as well as numerous reliability, stability, security, and performance fixes.

Weitere Einzelheiten zu .NET 4.7 finden Sie in diesen Artikeln:You can find more details about .NET 4.7 in these articles:

ContainerentwicklungstoolsContainer Development Tools

Visual Studio 2017 Version 15.3 unterstützt nun die Breite der Containerentwicklung für vorhandene .NET Framework-Apps mit Windows-Containern, zu .NET Core mit Windows sowie für Linux Support.Visual Studio 2017 version 15.3 now supports the breadth of container development across existing .NET Framework apps with Windows Containers, to .NET Core with Windows, and Linux Support. Aktuelle Erweiterungen enthalten die Unterstützung für Ihre .NET Core-Anwendungen in Containern, die Windows Nano Server ausführen, sowie Verbesserungen des Debuggens für .NET Framework-Anwendungen in Containern.Recent additions include support for your .NET Core applications in containers running Windows Nano Server, as well as debugging improvements for .NET Framework applications in containers.


Wir haben Cluster von verknüpften Ereignissen zu den Suchabfrageergebnissen in der Application Insights-Suche hinzugefügt.We added clusters of related events to the search query results in the Application Insights Search tool. Diese Cluster helfen Ihnen beim Entdecken von überraschenden Mustern im Verhalten Ihrer Anwendung, z.B. einer großen Anzahl von Ausnahmen, die von einem einzigen Land, einer einzigen Version oder einem einzigen Benutzer stammen.These clusters can help you discover surprising patterns in your application's behavior, like a large volume of exceptions coming from a single country, version, or user.


SQL Server Data Tools (SSDT) SQL Server Data Tools (SSDT)

Visual Studio 2017 (Version 15.3) umfasst nun SQL Server Data Tools, die SQL Server 2017, ausgeführt unter Windows, Linux und Docker in macOS, vollständig unterstützen.Visual Studio 2017 version 15.3 now ships with SQL Server Data Tools that fully supports SQL Server 2017 running on Windows, Linux and Docker in macOS. SSDT unterstützt nun alle Versionen von SQL Server, SQLDB und DW in Azure.SSDT now supports all versions of SQL Server, SQLDB and DW on Azure.

Fehlerbehebungen für die am meisten von Kunden gemeldeten Probleme:Fixes for top customer reported issues:

  • Wir haben die Option „Spaltenreihenfolge ignorieren“ hinzugefügt, um unnötige Verschiebungen von Tabellendaten aufgrund einer Änderung der Spaltenreihenfolge zu vermeiden.We added Ignore Column Order option to prevent unnecessary table data movement due to a column order change.
  • Wir haben in Visual Studio 2017 den ESENT-Buildfehler behoben und die Buildstabilität und Leistung von Datenbankprojekten erhöht.We fixed ESENT build error and increased the database project build stability and performance in Visual Studio 2017.
  • Wir haben viele weitere von Kunden gemeldete Probleme behoben.We addressed many more customer reported issues. Weitere Informationen zu behobenen Problemen finden Sie unter Änderungsprotokoll für SQL Server Data Tools (SSDT).See SSDT changelog for more details of fixed issues.

Redgate Data Tools Redgate Data Tools

Alle Redgate Data ToolsAll Redgate Data Tools

Wir haben das Einführungsdialogfeld entfernt, das bei der ersten Verwendung von Redgate Data Tools erschienen ist.We removed the introduction dialog that appeared upon first use of Redgate Data Tools.

Redgate SQL PromptRedgate SQL Prompt

Wir haben Verbesserungen an der Formatierung vorgenommen.We made formatting improvements.

Redgate ReadyRollRedgate ReadyRoll

  • Das ReadyRoll-Fenster „Projekt öffnen“ wurde neu gestaltet.The ReadyRoll open project window has been redesigned.
  • Wir haben die Ladezeit von Projekteigenschaften verbessert.We improved the loading time of Project Properties.
  • Wir haben das Skriptstatuswidget durch eine Aktionsleiste ersetzt.We replaced the script status widget with an action bar.
  • Wir haben die Verbindungsprobleme mit Azure behoben.We fixed the connectivity problems with Azure.
  • Wir haben die Syntaxunterstützung für SQL Server 2016 verbessert.We improved the syntax support for SQL Server 2016.

PythonPython

  • Wir haben die Barrierefreiheit bei der Sprachausgabe, der Tastaturnavigation und im hohen Kontrast verbessert.We improved accessibility in screen readers, keyboard navigation and high contrast.
  • Wir haben die Lokalisierung verbessert, damit Benutzer, deren Muttersprache nicht Englisch ist, weniger englischen Text auf der Benutzeroberfläche sehen.We improved localization so that non-English users will see less English text in the UI.

R ToolsR Tools

  • Die IntelliSense-Benutzeroberfläche wurde verbessert.The IntelliSense experience is improved.
  • Sie verfügen über eine bessere Azure-Verbindung mit Ihren Computern, die Ping blockieren.You have better Azure connectivity to your machines that are blocking ping.
  • Wenn Sie eine Remotedienstinstallation ausführen, benötigen Sie keine Dienstverwaltungsberechtigungen mehr.When you perform a remote services install, you are no longer required to have service management rights.
  • Wir haben die allgemeine Barrierefreiheit und Lokalisierung verbessert.We improved overall accessibility, and localization.

Microsoft Graph-Anbieter in Verbundene DiensteMicrosoft Graph Provider in Connected Services

Wir haben die Unterstützung für Microsoft Graph-APIs in Connected Services aktiviert.We have enabled support for Microsoft Graph APIs in Connected Services. Wir haben die Installation vereinfacht.We've made Installation easier. Öffnen Sie einfach das Dialogfeld „Verbundene Dienste“ für den Zugriff und die Installation (Abbildung 9).Just open the Connected Services dialog to access and install (Figure 9).

Install Microsoft Graph provider
(Abbildung 9) Installieren des Microsoft Graph-Anbieters(Figure 9) Install Microsoft Graph provider

Bekannte ProblemeKnown Issues

Visual Studio 2017 Known Issues Sehen Sie sich alle vorhandenen bekannten Probleme und verfügbaren Problemumgehungen in Visual Studio 2017 Version 15.3 an. See all existing known issues and available workarounds in Visual Studio 2017 version 15.3.

Ihr Feedback ist uns sehr wichtig.We are fully committed to listening to your feedback. Besuchen Sie die Entwicklercommunity, um nach den aktuellsten Problemen zu suchen, neue Probleme zu melden und bereits vorhandene Probleme nach oben zu voten.Visit the Developer Community site to find the latest issues, log new issues, and upvote existing issues.


Visual Studio 2017 – Verlauf der Anmerkungen zu dieser VersionVisual Studio 2017 Release Notes History

Weitere Informationen finden Sie auf der Seite Visual Studio 2017: Verlauf der Anmerkungen zu dieser Version.Please see the Visual Studio 2017 Release Notes History page.


Seitenanfang
Top of Page