Visual Studio Icon Visual Studio 2019, Version 16.7: VersionshinweiseVisual Studio 2019 version 16.7 Release Notes



Entwicklercommunity | Systemanforderungen | Kompatibilität | Verteilbarer Code | Lizenzbedingungen | Blogs | Bekannte Probleme im aktuellen ReleaseDeveloper Community | System Requirements | Compatibility | Distributable Code | License Terms | Blogs | Latest Release Known Issues


Klicken Sie auf eine Schaltfläche, um die aktuelle Version von Visual Studio 2019 herunterzuladen.Click a button to download the latest version of Visual Studio 2019. Anweisungen zum Installieren und Aktualisieren von Visual Studio 2019 finden Sie unter Aktualisieren von Visual Studio 2019 auf die neueste Version.For instructions on installing and updating Visual Studio 2019, see the Update Visual Studio 2019 to the most recent release. Sehen Sie sich auch die Anweisungen zur Offlineinstallation an.Also, see instructions on how to install offline.

Community Download Button Professional Download Button Enterprise Download Button


Neues in Visual Studio 2019, Version 16.7What's New in Visual Studio 2019 version 16.7

SupportzeitrahmenSupport Timeframe

Visual Studio 2019 16.7 ist die dritte unterstützte Wartungsbaseline für Visual Studio 2019.Visual Studio 2019 version 16.7 is the third supported servicing baseline for Visual Studio 2019. Enterprise- und Professional-Kunden, die eine langfristig stabile und sichere Entwicklungsumgebung einführen müssen, wird empfohlen, diese Version als Standard zu etablieren.Enterprise and Professional customers needing to adopt a long term stable and secure development environment are encouraged to standardize on this version.   Wie in unserer Lebenszyklus- und Supportrichtlinie ausführlich erläutert wird, wird Version 16.7 nach Veröffentlichung der nächsten Wartungsbaseline ein Jahr lang mit Fixes und Sicherheitsupdates unterstützt.As explained in more detail in our lifecycle and support policy, version 16.7 will be supported with fixes and security updates for one year after the release of the next servicing baseline.

Darüber hinaus wird ab der Veröffentlichung von Version 16.7 die letzte Wartungsbaseline (Version 16.4) für weitere zwölf Monate (bis Oktober 2021) unterstützt.In addition, now that version 16.7 is available, version 16.4, which was the last servicing baseline, will be supported for an additional 12 months and will go out of support in October 2021.  Beachten Sie auch, dass die Versionen 16.5 und 16.6 nicht mehr unterstützt werden.Note as well that versions 16.5 and 16.6 are no longer under support. Für diese Zwischenversionen werden Wartungsfixes nur noch bis zur Veröffentlichung des nächsten geringfügigen Updates veröffentlicht.These intermediary releases received servicing fixes only until the next minor update released.

Sie können die neueste und sicherste Version von Visual Studio 2019 16.7 im Downloadbereich von my.visualstudio.com herunterladen.You can acquire the latest most secure version of Visual Studio 2019 version 16.7 in the downloads section of my.visualstudio.com.   Weitere Informationen zu den unterstützten Visual Studio-Baselines finden Sie in der Supportrichtlinie für Visual Studio 2019.For more information about Visual Studio supported baselines, please review the support policy for Visual Studio 2019.

Releases von Visual Studio 2019 16.7Visual Studio 2019 version 16.7 Releases

Archivierte Versionsanmerkungen von Visual Studio 2019Visual Studio 2019 Archived Release Notes

Visual Studio 2019-BlogVisual Studio 2019 Blog

Im Visual Studio 2019-Blog finden Sie alle wichtigen Informationen zu Produkten direkt vom Visual Studio-Engineeringteam.The Visual Studio 2019 Blog is the official source of product insight from the Visual Studio Engineering Team. In den folgenden Beiträgen finden Sie ausführliche Informationen zu den Visual Studio 2019-Releases:You can find in-depth information about the Visual Studio 2019 releases in the following posts:


Release Notes Icon Visual Studio 2019, Version 16.7.7Visual Studio 2019 version 16.7.7 New release icon

Veröffentlichung: 27. Oktober 2020released October 27, 2020

In diesem Release von Visual Studio 2019, Version 16.7.7In this Release of Visual Studio 2019 version 16.7.7



Release Notes Icon Visual Studio 2019, Version 16.7.6Visual Studio 2019 version 16.7.6

Veröffentlichung: 13. Oktober 2020released October 13, 2020

In diesem Release von Visual Studio 2019, Version 16.7.6In this Release of Visual Studio 2019 version 16.7.6



Release Notes Icon Visual Studio 2019 Version 16.7.5Visual Studio 2019 version 16.7.5

Veröffentlicht: 29. September 2020released September 29, 2020

Inhalte dieses Release von Visual Studio 2019 Version 16.7.5In this Release of Visual Studio 2019 version 16.7.5



Release Notes Icon Visual Studio 2019, Version 16.7.4Visual Studio 2019 version 16.7.4

veröffentlicht am 21. September 2020released September 21, 2020

Inhalte dieses Release von Visual Studio 2019 Version 16.7.4In this Release of Visual Studio 2019 version 16.7.4


  • Xcode 12.0 GM-Unterstützung hinzugefügt.Adds Xcode 12.0 GM support.
  • Unterstützung für das Festlegen einer Farbpalette als Akzentfarbe im Info.plist-Editor hinzugefügt.Adds support for setting a Color set as Accent Color in the Info.plist editor.

Release Notes Icon Visual Studio 2019, Version 16.7.3Visual Studio 2019 version 16.7.3

Veröffentlicht am 08. September 2020released September 08, 2020

Inhalte dieses Release von Visual Studio 2019 16.7.3In this Release of Visual Studio 2019 version 16.7.3


SicherheitshinweisSecurity Advisory Notice

CVE-2020-1130 Sicherheitsrisiko durch Rechteerweiterungen beim Diagnosehub-Standardcollector CVE-2020-1130 Diagnostics Hub Standard Collector Elevation of Privilege Vulnerability

Wenn der Diagnosehub-Standardcollector bestimmte Datenvorgänge nicht ordnungsgemäß verarbeitet, besteht ein Sicherheitsrisiko durch Rechteerweiterungen.An elevation of privilege vulnerability exists when the Diagnostics Hub Standard Collector improperly handles data operations. Ein Angreifer, der dieses Sicherheitsrisiko erfolgreich ausnutzt, könnte Prozesse in einem Kontext mit erhöhten Rechten ausführen.An attacker who successfully exploited this vulnerability could run processes in an elevated context.

CVE-2020-1133 Sicherheitsrisiko durch Rechteerweiterungen beim Diagnosehub-Standardcollector CVE-2020-1133 Diagnostics Hub Standard Collector Elevation of Privilege Vulnerability

Wenn der Diagnosehub-Standardcollector bestimmte Dateivorgänge nicht ordnungsgemäß verarbeitet, besteht ein Sicherheitsrisiko durch Rechteerweiterungen.An elevation of privilege vulnerability exists when the Diagnostics Hub Standard Collector improperly handles file operations. Ein Angreifer, der dieses Sicherheitsrisiko erfolgreich ausnutzt, könnte Prozesse in einem Kontext mit erhöhten Rechten ausführen.An attacker who successfully exploited this vulnerability could run processes in an elevated context.

CVE-2020-16856: Sicherheitsrisiko durch Remotecodeausführung in Visual Studio CVE-2020-16856 Visual Studio Remote Code Execution Vulnerability

In Visual Studio ist ein Sicherheitsrisiko für Remotecodeausführung vorhanden, wenn Objekte im Arbeitsspeicher nicht ordnungsgemäß verarbeitet werden.A remote code execution vulnerability exists in Visual Studio when it improperly handles objects in memory. Ein Angreifer, der dieses Sicherheitsrisiko erfolgreich ausgenutzt hat, kann beliebigen Code im Kontext des aktuellen Benutzers ausführen.An attacker who successfully exploited the vulnerability could run arbitrary code in the context of the current user.

CVE-2020-16874: Sicherheitsrisiko durch Remotecodeausführung in Visual Studio CVE-2020-16874 Visual Studio Remote Code Execution Vulnerability

In Visual Studio ist ein Sicherheitsrisiko für Remotecodeausführung vorhanden, wenn Objekte im Arbeitsspeicher nicht ordnungsgemäß verarbeitet werden.A remote code execution vulnerability exists in Visual Studio when it improperly handles objects in memory. Ein Angreifer, der dieses Sicherheitsrisiko erfolgreich ausgenutzt hat, kann beliebigen Code im Kontext des aktuellen Benutzers ausführen.An attacker who successfully exploited the vulnerability could run arbitrary code in the context of the current user.

CVE-2020-1045 Sicherheitsrisiko durch Microsoft ASP.NET Core Sicherheitsfunktionsumgehung CVE-2020-1045 Microsoft ASP.NET Core Security Feature Bypass Vulnerability

Ein Sicherheitsrisiko durch eine Sicherheitsfunktionsumgehung besteht durch die Art und Weise, wie Microsoft ASP.NET Core verschlüsselte Cookienamen analysiert.A security feature bypass vulnerability exists in the way Microsoft ASP.NET Core parses encoded cookie names. Der ASP.NET Core-Cookieparser decodiert ganze Cookiezeichenfolgen, wodurch ein böswilliger Angreifer ein zweites Cookie mit dem prozentcodierten Namen festlegen kann.The ASP.NET Core cookie parser decodes entire cookie strings which could allow a malicious attacker to set a second cookie with the name being percent encoded.

In dieser Version behobene zusätzliche ProblemeAdditional Issues Fixed in this Release

  • Es wurde ein Compilerabsturz für switch-Anweisungen oder switch-Ausdrücke korrigiert, die Musterabgleich verwenden.Fixed a compiler crash for switch statements or switch expressions that use pattern matching.
  • Der Workflow zum Beenden des Debuggens (UMSCHALT+F5) für Komponententests wurde durch Beenden des Testlaufs wiederhergestellt.Restored the "Stop Debugging(Shift +F5)" workflow for Unit Testing by terminating the test run.
  • Verhindern des VS-Absturzes beim Wechseln der Projektkonfiguration, wenn der WinForms .NET Core-Designer nicht gespeicherte Änderungen aufweist.Prevent VS crash on switching project configuration when WinForms .NET Core designer has unsaved changes.
  • Nicht mehr unterstützte Versionen von .NET Core werden während einer Reparatur oder eines Upgrades nicht mehr erneut installiert, wenn Sie außerhalb des VS-Setups entfernt wurden.Out of support versions of .NET Core will no longer be reinstalled during a repair or upgrade if they were removed outside of VS setup.
  • Es wurde ein Problem behoben, bei dem externe Abhängigkeiten beim Suchen in Dateien nicht genau gesucht wurden.Fixed an issue where External Dependencies weren't accurately searched in Find in Files.
  • Schaltfläche „Commit...“ im Git-Untermenü im Kontextmenü des Projektmappen-Explorers erneut eingeführt.Reintroduced the "Commit..." button in the Git submenu in Solution Explorer's context menu.
  • Es wurde ein Fehler behoben, der dazu geführt hat, dass die TFVC-Bezeichnung der Eincheckhinweise unsichtbar war.Fixed a bug that caused the TFVC Check-in Notes label to be invisible.
  • Absturz bei der Verwendung des WinForm-Designers in CSPROJ-Dateien im SDK-Stil mit mehreren Zielframeworks behoben.Fix crash when using WinForm designer in SDK-style csproj with multiple target frameworks.
  • Problem behoben, bei dem <d:Style.DataContext> einen ungültigen Markupfehler gemeldet hat.Fixed issue where <d:Style.DataContext> was reporting an invalid markup error.

Wichtigste durch die Entwicklercommunity in Visual Studio 2019 Version 16.7.3 behobene ProblemeTop Issues Fixed from Developer Community in Visual Studio 2019 version 16.7.3


Release Notes Icon Visual Studio 2019 16.7.2Visual Studio 2019 version 16.7.2

Veröffentlichung: 18. August 2020released August 18, 2020

Inhalte dieses Releases von Visual Studio 2019 16.7.2In This Release of Visual Studio 2019 version 16.7.2


Die wichtigsten in Visual Studio 2019 16.7.2 behobenen Probleme aus der EntwicklercommunityTop Issues Fixed from Developer Community in Visual Studio 2019 version 16.7.2


Release Notes Icon Visual Studio 2019 16.7.1Visual Studio 2019 version 16.7.1

Veröffentlichung: 11. August 2020released August 11, 2020

Inhalte dieses Releases von Visual Studio 2019 16.7.1In This Release of Visual Studio 2019 version 16.7.1


Die wichtigsten in Visual Studio 2019 16.7.1 behobenen Probleme aus der EntwicklercommunityTop Issues Fixed from Developer Community in Visual Studio 2019 version 16.7.1


Release Notes Icon Visual Studio 2019, Version 16.7.0Visual Studio 2019 version 16.7.0

Veröffentlichung: 5. August 2020released August 5, 2020

Inhalte dieses Releases von Visual Studio 2019, Version 16.7.0In This Release of Visual Studio 2019 version 16.7.0


C++C++

  • Unsere Remoteunterstützung für C++ umfasst jetzt mehr Linux-Distributionen und Shells, einschließlich sh, csh, bash, tsch, ksh, zsh und dash.Our remote C++ support now supports a wider range of Linux distros and shells, including sh, csh, bash, tsch, ksh, zsh, and dash. Sie können die Auswahl einer Shell für eine Remoteverbindung überschreiben, indem Sie die neue Shelleigenschaft über „ConnectionManager.exe“ ändern.You can override the choice of a shell for a remote connection by modifying the new "shell" property via ConnectionManager.exe. Diese Unterstützung wurde sowohl mit MSBuild-basierten Linux-Projekten als auch mit CMake-Projekten getestet, die auf ein Linux-Remotesystem oder WSL ausgerichtet sind.This support has been tested with both MSBuild-based Linux projects and CMake projects targeting a remote Linux system or WSL.
  • Sie können jetzt Ninja verwenden (ein Buildsystem, das inkrementelle Builds sehr schnell evaluiert), um inkrementelle Buildzeiten für MSBuild-basierte Linux-Projekte zu optimieren.You can now use Ninja (a build system that evaluates incremental builds very quickly) to improve incremental build times for MSBuild-based Linux projects. Sie können dieses Feature aktivieren, indem Sie auf der Eigenschaftenseite „Allgemein“ für die Option „Inkrementelle Builds aktivieren“ „With Ninja“ (Mit Ninja) festlegen.You can opt into this feature by setting "Enable Incremental Build" to "With Ninja" in the General Property Page. Ninja (ninja-build) muss auf Ihrem Linux-Remotesystem oder WSL installiert sein.Ninja (ninja-build) must be installed on your remote Linux system or WSL.
  • Neue Funktionen der C++20-Standardbibliothek wurden implementiert.New C++20 Standard Library features have been implemented. Eine ausführliche Liste finden Sie im STL-Änderungsprotokoll auf GitHub.Please refer to the STL Changelog on GitHub for a detailed list.
  • Sie können nun SSH-Standardremoteverbindungen im Verbindungs-Manager bearbeiten und festlegen.You can now edit and set default remote SSH connections in the Connection Manager. Dies bedeutet, dass Sie eine vorhandene Remoteverbindung bearbeiten (z. B. wenn sich die IP-Adresse geändert hat) und zu verwendende Standardverbindungen in „CMakeSettings.json“ und „launch.vs.json“ festlegen können.This means you can edit an existing remote connection (e.g. if its IP address changed) and set default connections to be consumed in CMakeSettings.json and launch.vs.json. SSH-Remoteverbindungen ermöglichen es Ihnen, C++ Projekte direkt aus Visual Studio in einem Linux-Remotesystem zu erstellen und zu debuggen.Remote SSH connections allow you to build and debug C++ projects on a remote Linux system directly from Visual Studio.
Edit remote connections in the Connection Manager
Bearbeiten von Remoteverbindungen im Verbindungs-ManagerEdit remote connections in the Connection Manager
  • Verbesserte IntelliSense-Unterstützung für Clang unter Windows (clang-cl) in Visual Studio.Enhanced IntelliSense support for Clang on Windows (clang-cl) in Visual Studio. Der Clang-Includepfad enthält jetzt die Clang-Bibliotheken. Wir haben die Wellenlinienanzeige im Editor verbessert, wenn die std-Bibliothek verwendet wird, und wir haben Unterstützung für C++2a im Clang-Modus hinzugefügt.The clang include path now includes the clang libraries, we've improved in-editor squiggle display when using the std library, and we've added support for C++2a in clang mode.
  • Sie können nun das Unterstreichen von Codefehlern ausprobieren und weitere vorgeschlagene Schnellkorrekturen in C++-Projekten entdecken.You can now try out underlining code errors and see more suggested quick fixes in C++ projects.  Aktivieren Sie dieses Feature unter „Extras > Optionen > Text-Editor > C/C++ > Experimentell“, und legen Sie dabei „Disable Experimental Code Linter“ (Experimentellen Codelinter deaktivieren) auf „False“ fest.Enable this feature under Tools > Options > Text Editor > C/C++ > Experimental > Set 'Disable Experimental Code Linter' to false. Weitere Informationen finden Sie im C++-Teamblog.Learn more on the C++ Team Blog.
IntelliSense code linter
IntelliSense-CodelinterIntelliSense code linter
  • Wir haben vier neue Codeanalyseregeln hinzugefügt, um zusätzliche Sicherheitsfunktionen in C++ zu integrieren: C26817, C26818, C26819 und C26820.We've added four new code analysis rules to incorporate additional safety features into C++: C26817, C26818, C26819, and C26820.
  • Wir haben erstklassige Unterstützung für das Debuggen von CMake-Projekten auf Remotesystemen mit gdbserver hinzugefügt.We've added first-class support for debugging CMake projects on remote systems with gdbserver.
  • Sie können Speicherbeschädigungsfehler mit einer experimentellen Implementierung von AddressSanitizer für C++ in Visual Studio einfach ermitteln, die jetzt für native x64-Projekte verfügbar ist.Find memory corruption errors easily with an experimental implementation of AddressSanitizer for C++ in Visual Studio, now available for x64 native projects. Wir unterstützen jetzt auch die Verwendung von Debuglaufzeiten (/MTd,/MDd,/LDd).We also now support the use of debug runtimes (/MTd, /MDd, /LDd).
  • IntelliSense bietet jetzt grundlegende Unterstützung für Konzepte, festgelegte Initialisierer und andere C++20-Features.IntelliSense now has basic support for Concepts, designated initializers, and several other C++20 features.
  • IXX- und CPPM-Dateien werden jetzt als C++-Dateien erkannt und von der Syntaxhervorhebung und IntelliSense als solche behandelt..ixx and .cppm files are now recognised as C++ and will be treated as such by the syntax highlighter and IntelliSense.

Dynamisches Definieren von WiedergabelistenDefine playlists dynamically

Sie können jetzt Wiedergabelisten dynamisch auf der Grundlage von Projekt, Klasse oder Namespace definieren.You can now define playlists dynamically based on Project, Class, or Namespace. Dies bedeutet, dass Sie eine Wiedergabeliste so konfigurieren können, dass sie alles in einem bestimmten Projekt/einer bestimmten Klasse/einem bestimmten Namespace enthält. Jeder neue Test, der zu dieser Gruppe hinzugefügt wird, wird automatisch in Ihre Wiedergabeliste aufgenommen!This means you can configure a playlist to include everything in a certain project/class/namespace; any new test added to that group will automatically be included in your playlist!

  • Erstellen Sie eine Wiedergabeliste, indem Sie mit der rechten Maustaste auf ein Projekt, einen Namespace oder eine Klassengruppierung im Test-Explorer klicken.Create a playlist by right clicking on a project, namespace, or class grouping in the Test Explorer.
Test Explorer: Create a playlist
Test-Explorer: Erstellen einer WiedergabelisteTest Explorer: Create a playlist
  • Bearbeiten Sie die Gruppen, die in der Wiedergabeliste enthalten sind, indem Sie auf der Symbolleiste auf die Schaltfläche „Bearbeiten“ klicken.Edit what groups are included in the playlist by clicking on the edit button in the tool bar. Kontrollkästchen werden angezeigt.Check boxes will appear. Bearbeiten Sie Gruppen wie gewünscht.Edit groups as desired.
Test Explorer: Edit a playlist
Test-Explorer: Bearbeiten einer WiedergabelisteTest Explorer: Edit a playlist
  • Anstatt eine statische Liste von Tests anzugeben, werden diese Wiedergabelisten dynamisch basierend auf Regeln aktualisiert.Instead of being a static list of tests these playlists dynamically update based on rules. Wenn Sie besser verstehen möchten, welche Regeln Ihre dynamischen Wiedergabeliste generieren, speichern Sie die Wiedergabelistendatei auf dem Datenträger mit der Schaltfläche „Speichern“, und zeigen Sie die generierten Regeln im XML-Code an.If you want to better understand what rules are generating your dynamic playlist, save the playlist file to disk with the save button and view the rules generated in the xml.
PlayList file dynamic rule set
Dynamischer Regelsatz für PlayList-DateiPlayList file dynamic rule set
  • Sie können auch weiterhin einzelne Tests einschließen bzw. ausschließen. Die Wiedergabeliste kann entweder die dynamischen Regeln aktualisieren oder dazu zurückkehren, Tests als statische Liste nachzuverfolgen.You can continue to include/exclude individual tests and the playlist will be able to either update its dynamic rules or switch back to keeping track of tests as a static list. Sie können auch Merkmale verwenden, um eine dynamische Gruppe zu definieren, indem Sie die XML-Wiedergabelistendatei direkt bearbeiten.You can also use traits to define a dynamic group by editing the playlist xml file directly.

Git-ProduktivitätGit Productivity

Aktivieren Sie das Vorschaufeature „New Git User Experience“ (Neue Git-Benutzeroberfläche) unter „Extras > Optionen > Umgebung“, um diese zu testen.Toggle on the 'New Git user experience' Preview Feature in Tools | Options | Environment to use this experience.

  • Erstellen Sie ein neues Git-Repository in einem beliebigen bereits vorhandenen Ordner oder einem neuen Ordner.Create a new Git repository, starting from any folder or a brand new folder
  • Speichern und Schließen eines geöffneten Ordners oder einer Projektmappe vor dem Starten eines neuen KlonvorgangsSave and close an open folder or solution before starting a new clone operation
  • Klare Anzeige von Commit- oder Stash-Nachrichtenfehlern im CommittextfeldView commit or stash message errors clearly in the commit text box
  • Anzeigen und Verwalten von Git-Verzweigungen in einer Strukturansicht in einem neuen Git Repository-FensterView and manage Git branches in a tree view within a new Git Repository window
  • Wechseln zwischen und Interagieren mit dem Verlaufsdiagramm jedes Branches im Fenster „Git-Repository“Switch between and interact with the history graph of each branch in the Git Repository window
  • Anzeige eingehender und ausgehender Commits im Fenster „Git-Repository“View incoming and outgoing commits in the Git Repository window
  • Blog des Git-Produktivitätsteams mit weiteren Informationen zu den neuesten FeaturesGit Productivity team blog with more details of recent features
Manage branches and view history in a focused Git Repository window
Verwalten von Verzweigungen und Anzeigen des Verlaufs in einem Git-Repository-Fenster mit FokusManage branches and view history in a focused Git Repository window

Auflösen von Mergekonflikten mit einem Git-zentrierten Merge-Editor mit:Resolve merge conflicts with a Git focused merge editor using:

  • Infoleiste in Dateien, die Mergekonflikte enthalten, die Sie auffordert, den Merge-Editor zu öffnenAn info bar in files containing merge conflicts that prompts you to open the merge editor
  • Weitere informative Titel und Beschriftungen und Übersichtlichkeit im Merge-EditorMore informative titles and captions, and less clutter in the merge editor
  • Diffs innerhalb von Konflikten, die übereinstimmende Zeilen abgleichen, Unterschiede auf Wortebene anzeigen und sichtbare Leerzeichen anzeigen, wenn dies der einzige Unterschied ist.Diffs within conflicts that align matching lines, show word level differences, and display visible whitespace when it is the only difference.
  • Bidirektionale Merges für Add/Add-Konflikte auf DateiebeneTwo-way merges for file level add/add conflicts
  • Möglichkeit, alle Konflikte mit einem einzigen Klick auf die eine oder die andere Weise aufzulösenThe ability to resolve all conflicts to one side or the other with a single click
  • Umschalter, um sich ausschließlich auf Konflikte zu konzentrieren und Unterschiede zu ignorieren, die keinen Konflikt verursachen.A toggle to focus on just conflicts, ignoring non-conflicting differences
New Merge Editor Experience
Auflösen von Mergekonflikten mit dem Merge-EditorResolve Merge Conflicts with the Merge Editor

JavaScript/TypeScriptJavaScript/TypeScript

  • Die Implementierungen von Vervollständigung und QuickInfo wurden aktualisiert, um LiveShare-Szenarien besser zu unterstützen.The implementations of Completion and Quick Info have been updated to better support LiveShare scenarios.

Lokaler Prozess mit KubernetesLocal Process with Kubernetes

Local Process with Kubernetes
Lokaler Prozess mit KubernetesLocal Process with Kubernetes

Lokaler Prozess mit Kubernetes ermöglicht es Ihnen, Ihren .NET-Code auf Ihrer Entwicklungsarbeitsstation zu schreiben, zu testen und zu debuggen, während Sie mit dem Rest Ihrer Anwendung oder Dienste mit Ihrem Kubernetes-Cluster verbunden sind.Local Process with Kubernetes allows you to write, test and debug your .NET code on your development workstation while connected to your Kubernetes cluster with the rest of your application or services. Durch Verbinden Ihrer Entwicklungsarbeitsstation mit Ihrem Cluster entfällt die Notwendigkeit, abhängige Dienste manuell auf Ihrem Entwicklungscomputer auszuführen und zu konfigurieren.By connecting your development workstation to your cluster, you eliminate the need to manually run and configure dependent services on your development machine. Umgebungsvariablen, Verbindungszeichenfolgen und Volumes aus dem Cluster sind für Ihren Microservicecode verfügbar, der lokal ausgeführt wird.Environment variables, connection strings and volumes from the cluster are available to your microservice code running locally. Zusätzliche Ressourcen, etwa Dockerfile- oder Kubernetes-Manifeste, sind nicht erforderlich.There is no need for extra assets, such as a Dockerfile or Kubernetes manifests. Sie können Ihren .NET-Code wie gewohnt ausführen, debuggen und testen.Run, debug, and test your .NET code as you normally would.

Um „Lokaler Prozess mit Kubernetes“ zu aktivieren, navigieren Sie zu „Extras > Optionen > Umgebung > Vorschaufunktionen“ und wählen „Lokales Debuggen für Kubernetes Services aktivieren“ aus.To enable Local Process with Kubernetes, go to Tools > Options > Envrionment > Preview Features and select "Enable local debugging for Kubernetes services".

Enable Preview Features
Aktivieren von VorschaufunktionenEnable Preview Features

Für .NET-Konsolenanwendungen ist ein zusätzlicher Schritt erforderlich.For .NET console applications, an additional step is required. Installieren Sie das NuGet-Paket „Microsoft.VisualStudio.Azure.Kubernetes.Tools.Targets“.Install the "Microsoft.VisualStudio.Azure.Kubernetes.Tools.Targets" Nuget Package.

.NET-Produktivität.NET Productivity

Es gibt jetzt eine Warnung und einen Codefix, wenn ein Operator zum Unterdrücken vorhanden ist, aber keinerlei Auswirkungen hat.There is now a warning and code fix when a suppression operator is present but has no effect. Es ist auch ein zweiter Codefix verfügbar, der den richtigen Ausdruck zum Negieren vorschlägt.A second code fix suggesting the correct negating expression is also available. Platzieren Sie den Cursor auf dem Operator zum Unterdrücken.Place your cursor on the suppression operator. Drücken Sie ( Ctrl + . ), um das Menü Schnellaktionen und Refactorings zu öffnen.Press ( Ctrl + . ) to trigger the Quick Actions and Refactorings menu. Wählen Sie als Nächstes eine der folgenden Optionen aus:Next, select from one of the following:

  • Sie können den Operator vollständig entfernen, indem Sie die Option Remove operator (preserves semantics) (Operator entfernen (Semantik bleibt erhalten)) auswählen:To remove the operator completely, select Remove operator (preserves semantics) :
Code fix to remove suppression operator
Codefix zum Entfernen des Operators zum UnterdrückenCode fix to remove suppression operator
  • Sie können den Ausdruck negieren, indem Sie die Option Negate expression (change semantics) (Ausdruck negieren (Semantik ändern)) auswählen:To negate the expression, select Negate expression (change semantics) :
Code fix to negate expression
Codefix zum Negieren von AusdrückenCode fix to negate expression
  • Sie können den Ausdruck auch mit dem neuen not-Muster für C# 9 negieren, wenn dieses in Ihrem Projekt verfügbar ist:You can also negate the expression with the new C# 9 not pattern if it is available in your project:
Code fix to negate expression using not
Codefix zum Negieren von Ausdrücken mithilfe des Not-OperatorsCode fix to negate expression using not

Sie können jetzt Eigenschaften generieren, wenn Sie einen Konstruktor in einem Typ generieren.You can now generate properties when generating a constructor in a type. Platzieren Sie den Cursor auf der Instanz.Place your cursor on the instance. Drücken Sie ( Ctrl + . ), um das Menü Schnellaktionen und Refactorings zu öffnen.Press ( Ctrl + . ) to trigger the Quick Actions and Refactorings menu. Klicken Sie auf Generate constructor in <QualifiedName> (with properties) (Konstruktor in <QualifiedName> generieren (mit Eigenschaften)).Select Generate constructor in <QualifiedName> (with properties) .

Generate properties when generating constructor
Generieren von Eigenschaften beim Generieren eines KonstruktorsGenerate properties when generating constructor
  • QuickInfo zeigt nun die Diagnose-ID zusammen mit einem Hilfelink an, über den Sie problemlos zu unserer Dokumentation navigieren können, um mehr über Warnungen und Fehler in Ihrem Code zu erfahren.Quick Info now displays the diagnostic ID along with a help link where you can easily navigate to our documentation to learn more about warnings and errors in your code.
Quick Info Diagnostic ID and Help Link
QuickInfo-Diagnose-ID und HilfelinkQuick Info Diagnostic ID and Help Link
  • Es gibt jetzt eine schnelle Aktion zum Hinzufügen eines DebuggerDisplay-Attributs zu einer Klasse.There is now a quick action to add a debugger display attribute to a class. Dadurch können Sie Eigenschaften im Debugger programmgesteuert in Ihrem Code anheften.This allows you to pin properties within the debugger programmatically in your code. Platzieren Sie Ihren Cursor auf dem Klassennamen.Place your cursor on the class name. Drücken Sie ( Ctrl+ . ), um das Menü Schnellaktionen und Refactorings zu öffnen.Press ( Ctrl+. ) to trigger the Quick Actions and Refactorings menu. Wählen Sie DebuggerDisplay-Attribut hinzufügen aus.Select Add ‘DebuggerDisplay` attribute . Dadurch wird das DebuggerDisplay-Attribut am Anfang der Klasse hinzugefügt und eine automatische Methode generiert, die ToString() zurückgibt. Diese Angabe können Sie bearbeiten, um den Eigenschaftswert zurückzugeben, der im Debugger angeheftet werden soll.This will add the debugger display attribute to the top of your class and generate an auto method that returns ToString() which you can edit to return the property value you want pinned in the debugger.
Add Debugger Display Attribute
DebuggerDisplay-Attribut hinzufügenAdd Debugger Display Attribute
  • Es gibt jetzt eine Codekorrektur für versehentliche Zuweisungen oder Vergleiche mit derselben Variablen.There is now a code fix for accidental assignments or comparisons to the same variable. Platzieren Sie den Cursor auf der Warnung.Place your cursor on the warning. Drücken Sie ( Ctrl+ . ), um das Menü Schnellaktionen und Refactorings zu öffnen.Press ( Ctrl+. ) to trigger the Quick Actions and Refactorings menu. Wählen Sie für versehentliche Zuweisungen .wert zuweisen aus.For accidental assignments, select Assign to .value . Wählen Sie für versehentliche Vergleiche Mit .wert vergleichen aus.For accidental comparisons, select Compare to .value .
Accidental Assignments Code Fix
Codekorrektur für versehentliche ZuweisungenAccidental Assignments Code Fix
Accidental Comparisons Code Fix
Codekorrektur für versehentliche VergleicheAccidental Comparisons Code Fix
  • Sie können jetzt Vergleichsoperatoren für Typen generieren, die IComparable implementieren.You can now generate comparison operators for types that implement IComparable. Platzieren Sie den Cursor entweder innerhalb der Klasse oder auf IComparable.Place your cursor either inside the class or on IComparable. Drücken Sie ( Ctrl+ . ), um das Menü Schnellaktionen und Refactorings zu öffnen.Press ( Ctrl+. ) to trigger the Quick Actions and Refactorings menu. Wählen Sie Vergleichsoperatoren generieren aus.Select Generate comparison operators . Mit den Vergleichsoperatoren wird ein Textbaustein für Sie generiert.A boiler plate will be generated for you with the comparison operators.
Generate Comparison Operators
Vergleichsoperatoren generierenGenerate Comparison Operators
  • Sie können jetzt IEquatable-Operatoren generieren, wenn Sie .Equals für Strukturen generieren.You can now generate IEquatable operators when generating .Equals for structs. Es war bereits ein Refactoring zum Generieren von Equals und GetHashCode für Werttypen verfügbar.We already had a refactoring to Generate Equals and GetHashCode for value types. Nun fügen wir mit Strukturen automatisch die IEquatable- sowie die Gleichheits- und Ungleichheitsoperatoren hinzu.Now with structs we will automatically add the IEquatable as well as the equals and not equals operators for you. Platzieren Sie den Cursor in der Struktur.Place your cursor within the struct. Drücken Sie ( Ctrl+ . ), um das Menü Schnellaktionen und Refactorings zu öffnen.Press ( Ctrl+. ) to trigger the Quick Actions and Refactorings menu. Wählen Sie Equals(object) generieren aus.Select Generate Equals(object) .
Generate IEquatable Operators
IEquatable-Operatoren generierenGenerate IEquatable Operators
  • Sie können jetzt Eigenschaften oder Felder für alle nicht verwendeten Konstruktorparameter erstellen und zuweisen.You can now create and assign properties or fields for all unused constructor parameters. Es war bereits eine schnelle Aktion verfügbar, die es ihnen ermöglichte, diesen Vorgang für einen einzelnen Parameter durchzuführen, aber jetzt ist dies für alle nicht verwendeten Parameter gleichzeitig möglich.We already had a quick action that allowed you to do this on an individual parameter, but now you can do it for all unused parameters at once. Platzieren Sie den Cursor auf einem der verbleibenden Parameter.Place your cursor on any of the remaining parameters. Drücken Sie ( Ctrl+ . ), um das Menü Schnellaktionen und Refactorings zu öffnen.Press ( Ctrl+. ) to trigger the Quick Actions and Refactorings menu. Um Eigenschaften zu erstellen und zu initialisieren, wählen Sie Verbleibende Parameter als Eigenschaften erstellen und zuweisen aus.To create and initialize properties, select Create and assign remaining as properties . Um Felder zu erstellen und zu initialisieren, wählen Sie Verbleibende Parameter als Felder erstellen und zuweisen aus.To create and initialize fields, select Create and assign remaining as fields .
Create and Assign Remaining Fields
Verbleibende Parameter als Felder erstellen und zuweisenCreate and Assign Remaining Fields
Create and Assign Remaining Properties
Verbleibende Parameter als Eigenschaften erstellen und zuweisenCreate and Assign Remaining Properties
  • IntelliSense-Vervollständigung in DateTime- und TimeSpan-Zeichenfolgenliteralen ist jetzt verfügbar.There is now IntelliSense completion in DateTime and TimeSpan string literals. Platzieren Sie den Cursor innerhalb des DateTime- oder TimeSpan-Zeichenfolgenliterals, und drücken Sie ( STRG+LEERTASTE ).Place your cursor inside the DateTime or TimeSpan string literal and press ( Ctrl+Space ). Anschließend werden Vervollständigungsoptionen und eine Erläuterung zur Bedeutung der einzelnen Zeichen angezeigt.You will then see completion options and an explanation as to what each character means. Sowohl das Datums-/Uhrzeitformat als auch ein Beispiel werden bereitgestellt.Both the date time format and an example will be provided.
IntelliSense Completion in DateTime and TimeSpan
IntelliSense-Vervollständigung in DateTime- und TimeSpan-ZeichenfolgenliteralenIntelliSense Completion in DateTime and TimeSpan string literals
  • Sie können nun im Dialogfeld Signatur ändern einen Parameter hinzufügen.You can now add a parameter within the Change Signature dialog. Platzieren Sie den Cursor in der Signatur der Methode.Place your cursor within the method’s signature. Drücken Sie ( Ctrl+ . ), um das Menü Schnellaktionen und Refactorings zu öffnen.Press ( Ctrl+. ) to trigger the Quick Actions and Refactorings menu. Wählen Sie Signatur ändern aus.Select Change signature . Das folgende Dialogfeld wird geöffnet, in dem Sie nun Hinzufügen auswählen können, um einen Parameter hinzuzufügen.The following dialog will open where you can now select Add to add a parameter. Nachdem Sie Hinzufügen ausgewählt haben, wird das neue Dialogfeld Parameter hinzufügen geöffnet.Once you select Add , the new Add Parameter dialog will open. Mit dem Dialogfeld Parameter hinzufügen können Sie einen Typnamen und einen Parameternamen hinzufügen.The Add Parameter dialog allows you to add a type name and a parameter name. Sie können mit einem Standardwert festlegen, ob der Parameter erforderlich oder optional ist.You can choose to make the parameter required or optional with a default value. Sie können dann auf der Aufrufsite einen Wert hinzufügen und ein benanntes Argument für diesen Wert auswählen, oder Sie können eine TODO-Variable einführen.You can then add a value at the call site and choose a named argument for that value or you can introduce a TODO variable. Die TODO-Variable fügt ein TODO in Ihren Code ein, sodass Sie jeden Fehler untersuchen und jede Aufrufsite unabhängig durchlaufen und entscheiden können, was übergeben werden soll.The TODO variable puts a TODO in your code so you can visit each error and go through each call site independently and decide what to pass. Für optionale Parameter besteht die Möglichkeit, die Aufrufsite vollständig auszulassen.For optional parameters you have the option to omit the call site completely.
Change Signature Dialog
Dialogfeld „Signatur ändern“Change Signature Dialog
Add Parameter Dialog
Dialogfeld „Parameter hinzufügen“Add Parameter Dialog
  • Autoren von Analysetools können nun CompletionProviders für IntelliSense-Vervollständigungen verwenden, wenn sie ihre Analysetools mit NuGet ausliefern.Analyzer authors can now use CompletionProviders for IntelliSense completions when shipping their analyzers with NuGet. Zuvor mussten Autoren von Bibliotheken eine separate VSIX-Datei erstellen, da CompletionProviders nur in VSIX verfügbar waren.Before, library authors would have to create a separate VSIX since CompletionProviders was only available in VSIX. Autoren von Bibliotheken können nun IntelliSense-Vervollständigungen im NuGet-Paket implementieren, in dem ihre Analysetools enthalten sind, und sie müssen dies nicht separat durchführen.Now library authors can implement IntelliSense completions in the NuGet package where their analyzers are, and they don’t need to do it separately. In NuGet-Paketen implementierte Vervollständigungsanbieter bieten auch Vorschläge speziell für einzelne Projekte und funktionieren automatisch in jeder IDE, die diese Funktion unterstützt.Completion providers implemented in NuGet packages will also provide suggestions specific to individual projects and will automatically work in each IDE supporting the feature.

RazorRazor

Testen Sie den neuen, experimentellen Razor-Editor mit Sprachserverprotokoll (Language Server Protocol, LSP), der alle Razor-Dateien (CSHTML/RAZOR) unterstützt, indem Sie die Previewfunktion Enable experimental Razor editor (Experimentellen Razor-Editor aktivieren) aktivieren.Try out the new experimental Language Server Protocol (LSP) powered Razor editor with all Razor files (.cshtml/.razor) by selecting the Enable experimental Razor editor preview feature.

Test-ExplorerTest Explorer

Die Option Run/Debug All Tests In View (Alle Tests in Ansicht ausführen/debuggen) wurde dem Test-Explorer hinzugefügt.Run/Debug All Tests In View have been added to the Test Explorer. Diese Befehle ersetzen die Befehle Alle Tests ausführen und Alle Tests debuggen im Test-Explorer.These commands replace where the Run All Tests and Debug All Tests commands appeared in the Test Explorer. Diese Änderung verdeutlicht, dass diese Befehle die Filter des Test-Explorers beachten, sodass nur die im Fenster sichtbaren Tests ausgeführt werden.This change clarifies that these commands honor the filters of the Test Explorer so that only tests visible in window are run. Dabei werden Spaltenfilter und Suchfeldfilter eingeschlossen.This includes both column filters and search box filters.

Test Explorer Run/Debug All Tests in View commands
Befehle „Alle Tests ausführen“ und „Alle Tests debuggen“Test Explorer Run/Debug All Tests in View commands

Die Befehle Global Run/Debug All (Alles global ausführen/debuggen) werden jetzt nur im Testmenü der obersten Ebene angezeigt.The Global Run/Debug All commands will now only appear in the top-level Test menu. Sie sind nicht mehr auf der Symbolleiste des Test-Explorers oder im Kontextmenü der Testfenster vorhanden.They are no longer included in the Test Explorer toolbar or context menu of any test window view. Wenn Code Coverage für alle Tests analysieren über den Test-Explorer ausgelöst wird, gilt die Option nun auch für die Testfensteransichten.When triggered from the Test Explorer, the Analyze Code Coverage for All Tests now applies to the test window views as well.

Tastenkombinationen:Short-cut Keys:

  • STRG+R, A ( Alle Tests ausführen ): globaler Befehl, der immer alle Tests ausführtCtrl R, A - Run All Test - Global command always runs all tests
  • STRG+R, V ( Alle Tests in Ansicht ausführen ): nur gültig, wenn ein Testfenster (Test-Explorer, Wiedergabeliste, Live Unit Testing-Fenster) aktiv istCtrl R, V - Run All Tests In View - Only a valid command when a test window (Test Explorer, Playlist, Live Unit Testing Window) are active windows
  • STRG+R, STRG+A ( Alle Tests debuggen ): globaler Befehl, der immer alle Tests debuggtCtrl R, Ctrl A - Debug All Test - Global command always debugs all tests
  • STRG+R, STRG+V ( Alle Tests in Ansicht debuggen ): nur gültig, wenn ein Testfenster (Test-Explorer, Wiedergabeliste, Live Unit Testing-Fenster) aktiv istCtrl R, Ctrl V - Debug All Tests In View - Only a valid command when a test window (Test Explorer, Playlist, Live Unit Testing Window) are active windows

DebuggerDebugger

Anzeigen verwalteter COM-Objekte über native ZeigerViewing Managed COM Objects Through Native Pointers

Dieses Feature decodiert verwaltete COM-Objekte automatisch, auf die über native Zeiger verwiesen wird, sodass Sie sämtliche Werte im Fenster „Lokal“ untersuchen können.This feature automatically decodes managed COM objects referenced by native pointers allowing you to fully inspect values in the Locals window. Weitere Informationen finden Sie auf dem Visual Studio-Blog.You can find more details here at the Visual Studio blog.

ProfilerProfiler

Neues Tool für .NET-LeistungsindikatorenNew .NET Performance Counters Tool

.NET Performance Counters Tool
Tool für .NET-Leistungsindikatoren.NET Performance Counters Tool

Visualisieren Sie dotnet-counters direkt im Visual Studio-Profiler, indem Sie das Tool für .NET-Leistungsindikatoren verwenden.Visualize dotnet counters right from within the Visual Studio Profiler using the .NET Performance Counters Tool. Testen Sie das Tool, indem Sie unter Debuggen > Leistungs-Profiler das Kontrollkästchen für das Tool für .NET-Leistungsindikatoren aktivieren.To try out the tool go to Debug -> Performance Profiler -> Checkmark .NET Performance Counters Tool .

XamarinXamarin

  • Für häufig von Benutzern bezüglich Android-Layoutdateien gemeldete Probleme wurden Codefixes hinzugefügt.Code fixers have been introduced for the most common types of problems experienced by users with Android layout files.
  • Die Benutzeroberfläche der Vorlagenauswahl für Xamarin.Forms wurde aktualisiert und ist nun illustrativer. Darüber hinaus verwenden die Vorlagen „Flyout“ und „Tabbed“ (Mit Registerkarten) nun die Shell.The Xamarin.Forms template selection experience now has a fresh and more illustrative look, and the Flyout and Tabbed templates now utilize Shell. Weitere Informationen zur Shell finden Sie hier.Read more about Shell here. Wenn Sie die Shell aus irgendeinem Grund nicht verwenden möchten, verwenden Sie die leere Vorlage.If for some reason you don't wish to use Shell, use the Blank template.
New Xamarin.Forms template selection experience
Auswählen einer Xamarin.Forms-VorlageChoosing a Xamarin.Forms template

XAML-Tools (WPF, UWP und Xamarin.Forms)XAML Tools (WPF, UWP & Xamarin.Forms)

XAML Hot Reload:XAML Hot Reload:

  • Verbesserungen der In-App-Symbolleiste: Wir haben die Funktionen der In-App-Symbolleiste weiter optimiert, die Bestandteil des Toolworkflows von XAML Hot Reload für WPF und UWP ist.In-app Toolbar Improvements: We have further refined the in-app toolbar experience that is part of the XAML Hot Reload tooling workflow for WPF & UWP. Unter anderem wurde die Symbolleiste verkürzt, sodass diese die ausgeführte Anwendung nicht mehr verdeckt, und es wurde eine Änderung am Zuklappmechanismus vorgenommen. Wenn nun auf diesen geklickt wird, wird zunächst der XAML Hot Reload-Text ausgeblendet und dann nach einem zweiten Klick die gesamte Leiste.Changes include a shorter toolbar so that it no longer covers the running application, and a change in the collapse mechanism which when clicked will now collapse the XAML Hot Reload text first, then collapse the bar fully on the second click.

XAML-Designer:XAML Designer:

  • Erweiterte Unterstützung für Entwurfszeitdaten für WPF und UWP: Mit dieser Version wird ein neues Feature für Entwurfszeitdaten für WPF .NET Core- und UWP-Entwickler eingeführt.Expanded Design-time Data Support for WPF & UWP: In this release we are introducing a new design-time data feature for WPF .NET Core and UWP developers. Mit diesem neuen Feature wird die aktuelle Liste der verfügbaren Entwurfszeiteigenschaften durch die Verwendung des Präfixes „d:“ erweitert.This new capability will extend the current list of accessible design-time properties through the use of the d: prefix. Dieses Feature sollte Xamarin.Forms-Entwicklern vertraut sein, da es den gleichen Ansatz für die Verwendung des Präfixes „d:“ ermöglicht, um eine Eigenschaft anzugeben, die nur zur Entwurfszeit gerendert und niemals in die ausgeführte App kompiliert werden soll. Dadurch kann sie sicher zur Benutzeroberflächenüberprüfung zur Entwurfszeit eingesetzt werden.This feature will be familiar to Xamarin.Forms developers, as it makes available the same approach of using a “d:” prefix to indicate a property that should only be rendered at design-time and never gets compiled into the running app making it very safe to use for design time UI validation. In diesem Release werden alle WPF- und UWP-Standardsteuerelemente unterstützt. In zukünftigen Releases sollen benutzerdefinierte Steuerelemente und Steuerelemente von Drittanbietern unterstützt werden.In this release we support all the out-of-the-box controls for WPF and UWP and plan to support 3rd party and custom controls in future releases.
  • Schaltfläche „Aktualisieren“ im XAML-Designer: Wir haben dem XAML-Designer eine Schaltfläche zum Aktualisieren hinzugefügt. Dieses neue Symbol finden Sie unten links im Symbolbereich neben dem Indikator für den Zoomfaktor.XAML Designer Refresh Button: We have added a refresh button to the XAML designer, this new icon can be found in the bottom-left icon area near the zoom level indicator. Durch die Aktualisierung erfolgt ein entsprechender Zurücksetzungsvorgang, indem die Designeransicht geschlossen und in den seltenen Situationen wieder geöffnet wird, in denen sie benötigt wird, um ein Problem beim Rendern zu beheben.This refresh action does the equivalent reset of closing the designer view and re-opening it for the rare situations where this is required to resolve a rendering issue. Dieses Feature ist für WPF .NET Core- und UWP-Entwickler verfügbar.This feature is available for WPF .NET Core and UWP developers.

XAML-Code-Editor:XAML Code Editor:

  • Farbvisualisierer: Wir haben unseren neuen Farbvisualisierer im XAML-Code-Editor für WPF .NET Core-, WPF .NET Framework- und Xamarin.Forms-Projekte weiter optimiert.Color Visualizer: We have further refined our new color visualizer in the XAML code editor for WPF .NET Core, WPF .NET Framework and Xamarin.Froms projects. In dieser Version haben wir Unterstützung für das Visualisieren von Farben aus Ressourcen hinzugefügt, die in der letzten Vorschauversion noch nicht unterstützt wurden.In this release we have added support for visualizing colors coming from resources, which was previously not supported in the last preview.
Inline Color Previews in XAML Code Editor
Inlinefarbvorschau im XAML-Code-EditorInline Color Previews in XAML Code Editor

Anzeigen von Toolboxelementen aus einem NuGet-Paket ohne über einen Paketverweis zu verfügenShow Toolbox items from a NuGet package without having a package reference

Viele Autoren von Steuerelementbibliotheken möchten, dass ihre Steuerelemente in der Toolbox angezeigt werden, auch wenn das aktuelle Projekt noch nicht auf die Bibliothek verwiesen hat, da dies die Auffindbarkeit unterstützt.Many control library authors want their controls to be seen in the Toolbox even when the current project hasn't referenced the library yet, as this helps with discoverability. WPF .NET Framework SDKs haben dies in der Vergangenheit mithilfe von Registrierungseinträgen erreicht, dies wird jedoch von .NET Core nicht unterstützt.WPF .NET Framework SDKs have historically accomplished this using registry entries, but this is not supported by .NET Core. Für WPF .NET Core kann die Toolbox nun mit Steuerelementen aus VisualStudioToolsManifest.xml-Dateien aus WPF .NET Core NuGet-Paketen in NuGet-Fallbackordnern aufgefüllt werden.For WPF .NET Core, Toolbox can now be populated with controls from VisualStudioToolsManifest.xml files found within WPF .NET Core NuGet packages in NuGet fallback folders. Weitere Informationen finden Sie in der Dokumentation im GitHub-Repository zur Erweiterbarkeit des XAML-Designers.For more details, see the documentation in the XAML Designer Extensibility GitHub repo.

Windows FormsWindows Forms

Windows Forms-Designer für .NET CoreWindows Forms Designer for .NET Core

Der Windows Forms-Designer für .NET Core-Projekte ist jetzt verfügbar.The Windows Forms designer for .NET Core projects is now available. Um den Designer in Visual Studio zu aktivieren, navigieren Sie zu „Extras > Optionen> Umgebung > Previewfunktionen“, und wählen Sie die Option „Use the preview Windows Forms designer for .NET Core apps“ (Vorschauversion des Windows Forms-Designers für .NET Core-Apps verwenden) aus.To enable the designer in Visual Studio, go to Tools > Options > Environment > Preview Features and select the Use the preview Windows Forms designer for .NET Core apps option.

In diesem Release werden nun die folgenden Steuerelemente zusammen mit anderen Verbesserungen unterstützt:In this release the following controls are now supported along with other improvements:

  • UserControl und Infrastruktur benutzerdefinierter SteuerelementeUserControl and custom controls infrastructure
  • TableLayoutPanelTableLayoutPanel
  • Grundlagen für die Unterstützung von Steuerelementen von DrittanbieternFundamentals for third-party controls support
  • Grundlagen der Unterstützung von DatenbindungFundamentals for data binding support
  • Verbesserungen bei der Designer-Interaktion mit TableLayoutPanelImprovements in designer interaction with the TableLayoutPanel

FehlerkorrekturenBug Fixes

Wichtige in Visual Studio 2019 16.7.0 behobene ProblemeTop Issues Fixed in Visual Studio 2019 version 16.7.0

  • Fehler beim Installieren der WMI-Anbieterkomponente behoben.Fixed WMI Provider component installation failure.
  • Es wurde ein Problem behoben, bei dem Benutzern der Fortschritt des Testlaufs nicht angezeigt werden konnte, indem unten auf der Leiste auf die linke Schaltfläche geklickt wird.Fixed an issue where users were not able to see test run progress by clicking the left button at the bottom of the bar.
  • Verbesserte Leistung beim Ermitteln verfügbarer Visual Studio Codespace-Abrechnungspläne.Improved performance of discovering available Visual Studio Codespace billing plans.
  • Beim Erstellen einer Visual Studio Codespace-Instanz wurde der Standardwert für die Anhaltezeit von 30 Minuten in 3 Stunden geändert.When creating a Visual Studio Codespace, we changed the default suspend time from 30minutes to 3 hours.
  • Es wurde ein Fehler behoben, bei dem das Fenster „Git-Änderungen“ Benutzer informiert hat, dass eingehende/ausgehende Commits vorhanden sind, obwohl dort keine sind.Fix bug where the Git Changes window informs the user they have incoming/outgoing commits, when in fact they have none.
  • Die Stabilität der Diagnosetools und des Leistungs-Profilers wurden optimiert.Improved stability of the Diagnostic Tools and Performance Profiler.
  • Es wurde ein Problem behoben, bei dem die Visual Studio-Erweiterung von Azure Sphere aufgrund einer geringfügigen Versionsabweichung nicht automatisch aktualisiert werden kann.Addressed an issue where Azure Sphere Visual Studio extension will not be automatically updated due to a minor version mismatch. Mit der Behebung kann Azure Sphere jetzt automatisch aktualisiert werden, wenn die automatische VSIX-Aktualisierung ausgeführt wird.With the fix, Azure Sphere will be able to get automatically updated when the VSIX auto updater runs.

Aus der EntwicklercommunityFrom Developer Community


Bekannte ProblemeKnown Issues

Unter dem folgenden Link können Sie sich über alle offenen Probleme und verfügbaren Problemumgehungen in Visual Studio 2019 informieren.See all open issues and available workarounds in Visual Studio 2019 by following the below link.


Feedback und VorschlägeFeedback and suggestions

Wir freuen uns auf Ihr Feedback!We would love to hear from you! Informieren Sie uns über die Option Ein Problem melden in der oberen rechten Ecke im Installer oder direkt in der Visual Studio-IDE über mögliche Probleme.For issues, let us know through the Report a Problem option in the upper right-hand corner of either the installer or the Visual Studio IDE itself. DieThe Feedback Icon Symbol befindet sich in der oberen rechten Ecke.icon is located in the upper right-hand corner. Sie können einen Vorschlag zu einem Produkt einreichen oder Ihre Probleme in der Entwicklercommunity für Visual Studio nachverfolgen, in der Sie auch Fragen stellen und nach Antworten suchen sowie neue Features vorschlagen können.You can make a product suggestion or track your issues in the Visual Studio Developer Community, where you can ask questions, find answers, and propose new features. Über unseren Livechatsupport erhalten Sie zudem kostenlose Hilfe bei der Installation.You can also get free installation help through our Live Chat support.


BlogsBlogs

Profitieren Sie von den Einblicken und Empfehlungen auf der Webseite mit Blogs zu Entwicklertools, um sich bei allen Releases auf dem neuesten Stand zu halten und Zugang zu ausführlichen Beiträgen zu zahlreichen Funktionen zu erhalten.Take advantage of the insights and recommendations available in the Developer Tools Blogs site to keep you up-to-date on all new releases and include deep dive posts on a broad range of features.


Verlauf der Versionshinweise zu Visual Studio 2019Visual Studio 2019 Release Notes History

Weitere Informationen bezüglich der früheren Versionen von Visual Studio 2019 finden Sie auf der Seite Verlauf der Versionshinweise zu Visual Studio 2019.For more information relating to past versions of Visual Studio 2019, see the Visual Studio 2019 Release Notes History page.


Seitenanfang

Top of Page