Visual Studio Icon Visual Studio 2019: Anmerkungen zur VorschauversionVisual Studio 2019 Preview Release Notes


| Entwicklercommunity | Systemanforderungen | Kompatibilität | Verteilbarer Code | Lizenzbedingungen | Blogs | Bekannte Probleme im aktuellen Release || Developer Community | System Requirements | Compatibility | Distributable Code | License Terms | Blogs | Latest Release Known Issues |


Wichtig

Diese Version befindet sich nicht in der endgültigen Phase und ist nicht für die Verwendung auf Produktionscomputern oder zur Erstellung von Produktionscode vorgesehen.This release is not "go-live" and not intended for use on production computers or for creating production code. Anweisungen zum Installieren und Aktualisieren von Visual Studio 2019 finden Sie in dieser Dokumentation zum Aktualisieren von Visual Studio 2019 auf das aktuelle Release.For instructions on installing and updating Visual Studio 2019, see this documentation on updating Visual Studio 2019 to the most recent release.


Neues in Visual Studio 2019What's New in Visual Studio 2019

Visual Studio 2019-VorschauversionenVisual Studio 2019 Preview Releases

Visual Studio 2019-BlogVisual Studio 2019 Blog

Im Visual Studio 2019-Blog finden Sie alle wichtigen Informationen zu Produkten direkt vom Visual Studio-Engineeringteam.The Visual Studio 2019 Blog is the official source of product insight from the Visual Studio Engineering Team. In den folgenden Beiträgen finden Sie ausführliche Informationen zu den Visual Studio 2019-Releases:You can find in-depth information about the Visual Studio 2019 releases in the following posts:


Release Notes Icon Visual Studio 2019, Version 16.7, Vorschau 2Visual Studio 2019 version 16.7 Preview 2 New release icon

Veröffentlicht: 02. Juni 2020released June 02, 2020

Inhalte des Release von Visual Studio 2019, Version 16.7, Vorschau 2In This Release of Visual Studio 2019 version 16.7 Preview 2


C++C++

  • Neue Funktionen der C++20-Standardbibliothek wurden implementiert.New C++20 Standard Library features have been implemented. Eine ausführliche Liste finden Sie im  STL-Änderungsprotokoll auf GitHub .Please refer to the STL Changelog on GitHub for a detailed list.
  • Sie können nun SSH-Standardremoteverbindungen im Verbindungs-Manager bearbeiten und festlegen.You can now edit and set default remote SSH connections in the Connection Manager. Dies bedeutet, dass Sie eine vorhandene Remoteverbindung bearbeiten (z. B. wenn sich die IP-Adresse geändert hat) und zu verwendende Standardverbindungen in „CMakeSettings.json“ und „launch.vs.json“ festlegen können.This means you can edit an existing remote connection (e.g. if its IP address changed) and set default connections to be consumed in CMakeSettings.json and launch.vs.json. SSH-Remoteverbindungen ermöglichen es Ihnen, C++ Projekte direkt aus Visual Studio in einem Linux-Remotesystem zu erstellen und zu debuggen.Remote SSH connections allow you to build and debug C++ projects on a remote Linux system directly from Visual Studio.
Edit remote connections in the Connection Manager
Bearbeiten von Remoteverbindungen im Verbindungs-ManagerEdit remote connections in the Connection Manager
  • Verbesserte IntelliSense-Unterstützung für Clang unter Windows (clang-cl) in Visual Studio.Enhanced IntelliSense support for Clang on Windows (clang-cl) in Visual Studio. Der Clang-Includepfad enthält jetzt die Clang-Bibliotheken. Wir haben die Wellenlinienanzeige im Editor verbessert, wenn die std-Bibliothek verwendet wird, und wir haben Unterstützung für C++2a im Clang-Modus hinzugefügt.The clang include path now includes the clang libraries, we've improved in-editor squiggle display when using the std library, and we've added support for C++2a in clang mode.
  • Sie können nun das Unterstreichen von Codefehlern ausprobieren und weitere vorgeschlagene Schnellkorrekturen in C++-Projekten entdecken.You can now try out underlining code errors and see more suggested quick fixes in C++ projects. Aktivieren Sie diese Funktion unter Extras > Optionen > Umgebung > Vorschaufunktionen > IntelliSense-Codelinter für C++. Enable this feature under Tools > Options > Environment > Preview Features > IntelliSense code linter for C++. Weitere Informationen finden Sie im C++-Teamblog.Learn more on the C++ Team Blog.
IntelliSense code linter
IntelliSense-CodelinterIntelliSense code linter
  • Wir haben vier neue Codeanalyseregeln hinzugefügt, um zusätzliche Sicherheitsfunktionen in C++ zu integrieren: C26817, C26818, C26819 und C26820.We've added four new code analysis rules to incorporate additional safety features into C++: C26817, C26818, C26819, and C26820.

.NET-Produktivität.NET Productivity

  • QuickInfo zeigt nun die Diagnose-ID zusammen mit einem Hilfelink an, über den Sie problemlos zu unserer Dokumentation navigieren können, um mehr über Warnungen und Fehler in Ihrem Code zu erfahren.Quick Info now displays the diagnostic ID along with a help link where you can easily navigate to our documentation to learn more about warnings and errors in your code.
Quick Info Diagnostic ID and Help Link
QuickInfo-Diagnose-ID und HilfelinkQuick Info Diagnostic ID and Help Link

Git-ProduktivitätGit Productivity

Speichern und Schließen eines geöffneten Ordners oder einer Projektmappe vor dem Starten eines neuen KlonvorgangsSave and close an open folder or solution before starting a new clone operation

Klare Anzeige von Commit- oder Stash-Nachrichtenfehlern im CommittextfeldView commit or stash message errors clearly in the commit text box

Auflösen von Mergekonflikten mit einem Git-zentrierten Merge-Editor mit:Resolve merge conflicts with a Git focused merge editor using:

  • Infoleiste in Dateien, die Mergekonflikte enthalten, die Sie auffordert, den Merge-Editor zu öffnenAn info bar in files containing merge conflicts that prompts you to open the merge editor
  • Weitere informative Titel und Beschriftungen und Übersichtlichkeit im Merge-EditorMore informative titles and captions, and less clutter in the merge editor
  • Diffs innerhalb von Konflikten, die übereinstimmende Zeilen abgleichen, Unterschiede auf Wortebene anzeigen und sichtbare Leerzeichen anzeigen, wenn dies der einzige Unterschied ist.Diffs within conflicts that align matching lines, show word level differences, and display visible whitespace when it is the only difference.
  • Bidirektionale Merges für Add/Add-Konflikte auf DateiebeneTwo-way merges for file level add/add conflicts
  • Möglichkeit, alle Konflikte mit einem einzigen Klick auf die eine oder die andere Weise aufzulösenThe ability to resolve all conflicts to one side or the other with a single click
  • Umschalter, um sich ausschließlich auf Konflikte zu konzentrieren und Unterschiede zu ignorieren, die keinen Konflikt verursachen.A toggle to focus on just conflicts, ignoring non-conflicting differences
New Merge Editor Experience
Auflösen von Mergekonflikten mit dem Merge-EditorResolve Merge Conflicts with the Merge Editor

WPF- und UWP ToolsWPF/UWP Tooling

Anzeigen von Toolboxelementen aus einem NuGet-Paket ohne über einen Paketverweis zu verfügenShow Toolbox items from a NuGet package without having a package reference

Viele Autoren von Steuerelementbibliotheken möchten, dass ihre Steuerelemente in der Toolbox angezeigt werden, auch wenn das aktuelle Projekt noch nicht auf die Bibliothek verwiesen hat, da dies die Auffindbarkeit unterstützt.Many control library authors want their controls to be seen in the Toolbox even when the current project hasn't referenced the library yet, as this helps with discoverability. WPF .NET Framework SDKs haben dies in der Vergangenheit mithilfe von Registrierungseinträgen erreicht, dies wird jedoch von .NET Core nicht unterstützt.WPF .NET Framework SDKs have historically accomplished this using registry entries, but this is not supported by .NET Core. Für WPF .NET Core kann die Toolbox nun mit Steuerelementen aus VisualStudioToolsManifest.xml-Dateien aus WPF .NET Core NuGet-Paketen in NuGet-Fallbackordnern aufgefüllt werden.For WPF .NET Core, Toolbox can now be populated with controls from VisualStudioToolsManifest.xml files found within WPF .NET Core NuGet packages in NuGet fallback folders. Weitere Informationen finden Sie im GitHub-Repository für XAML-Designer-Erweiterbarkeit.For more details, see the XAML Designer Extensibility GitHub repo.

Lokaler Prozess mit KubernetesLocal Process with Kubernetes

Local Process with Kubernetes
Lokaler Prozess mit KubernetesLocal Process with Kubernetes

Lokaler Prozess mit Kubernetes ermöglicht es Ihnen, Ihren .NET-Code auf Ihrer Entwicklungsarbeitsstation zu schreiben, zu testen und zu debuggen, während Sie mit dem Rest Ihrer Anwendung oder Dienste mit Ihrem Kubernetes-Cluster verbunden sind.Local Process with Kubernetes allows you to write, test and debug your .NET code on your development workstation while connected to your Kubernetes cluster with the rest of your application or services. Durch Verbinden Ihrer Entwicklungsarbeitsstation mit Ihrem Cluster entfällt die Notwendigkeit, abhängige Dienste manuell auf Ihrem Entwicklungscomputer auszuführen und zu konfigurieren.By connecting your development workstation to your cluster, you eliminate the need to manually run and configure dependent services on your development machine. Umgebungsvariablen, Verbindungszeichenfolgen und Volumes aus dem Cluster sind für Ihren Microservicecode verfügbar, der lokal ausgeführt wird.Environment variables, connection strings and volumes from the cluster are available to your microservice code running locally. Zusätzliche Ressourcen, etwa Dockerfile- oder Kubernetes-Manifeste, sind nicht erforderlich.There is no need for extra assets, such as a Dockerfile or Kubernetes manifests. Sie können Ihren .NET-Code wie gewohnt ausführen, debuggen und testen.Run, debug, and test your .NET code as you normally would.

Um „Lokaler Prozess mit Kubernetes“ zu aktivieren, navigieren Sie zu „Extras > Optionen > Umgebung > Vorschaufunktionen“ und wählen „Lokales Debuggen für Kubernetes Services aktivieren“ aus.To enable Local Process with Kubernetes, go to Tools > Options > Envrionment > Preview Features and select "Enable local debugging for Kubernetes services".

Enable Preview Features
Aktivieren von VorschaufunktionenEnable Preview Features

Für .NET-Konsolenanwendungen ist ein zusätzlicher Schritt erforderlich.For .NET console applications, an additional step is required. Installieren Sie das NuGet-Paket „Microsoft.VisualStudio.Azure.Kubernetes.Tools.Targets“.Install the "Microsoft.VisualStudio.Azure.Kubernetes.Tools.Targets" Nuget Package.

Die wichtigsten behobenen Probleme in Visual Studio 2019, Version 16.7, Vorschau 2Top Issues Fixed in Visual Studio 2019 version 16.7 Preview 2


  • Fehler beim Installieren der WMI-Anbieterkomponente behoben.Fixed WMI Provider component installation failure.

Aus der EntwicklercommunityFrom Developer Community


Release Notes Icon Visual Studio 2019, Version 16.7, Vorschauversion 1Visual Studio 2019 version 16.7 Preview 1

Veröffentlicht am 19. Mai 2020released May 19, 2020

Inhalte des Release von Visual Studio 2019, Version 16.7, Vorschauversion 1In This Release of Visual Studio 2019 version 16.7 Preview 1


Dynamisches Definieren von WiedergabelistenDefine playlists dynamically

Sie können jetzt Wiedergabelisten dynamisch auf der Grundlage von Projekt, Klasse oder Namespace definieren.You can now define playlists dynamically based on Project, Class, or Namespace. Dies bedeutet, dass Sie eine Wiedergabeliste so konfigurieren können, dass sie alles in einem bestimmten Projekt/einer bestimmten Klasse/einem bestimmten Namespace enthält. Jeder neue Test, der zu dieser Gruppe hinzugefügt wird, wird automatisch in Ihre Wiedergabeliste aufgenommen!This means you can configure a playlist to include everything in a certain project/class/namespace; any new test added to that group will automatically be included in your playlist!

  • Erstellen Sie eine Wiedergabeliste, indem Sie mit der rechten Maustaste auf ein Projekt, einen Namespace oder eine Klassengruppierung im Test-Explorer klicken.Create a playlist by right clicking on a project, namespace, or class grouping in the Test Explorer.
Test Explorer: Create a playlist
Test-Explorer: Erstellen einer WiedergabelisteTest Explorer: Create a playlist
  • Bearbeiten Sie die Gruppen, die in der Wiedergabeliste enthalten sind, indem Sie auf der Symbolleiste auf die Schaltfläche „Bearbeiten“ klicken.Edit what groups are included in the playlist by clicking on the edit button in the tool bar. Kontrollkästchen werden angezeigt.Check boxes will appear. Bearbeiten Sie Gruppen wie gewünscht.Edit groups as desired.
Test Explorer: Edit a playlist
Test-Explorer: Bearbeiten einer WiedergabelisteTest Explorer: Edit a playlist
  • Anstatt eine statische Liste von Tests anzugeben, werden diese Wiedergabelisten dynamisch basierend auf Regeln aktualisiert.Instead of being a static list of tests these playlists dynamically update based on rules. Wenn Sie besser verstehen möchten, welche Regeln Ihre dynamischen Wiedergabeliste generieren, speichern Sie die Wiedergabelistendatei auf dem Datenträger mit der Schaltfläche „Speichern“, und zeigen Sie die generierten Regeln im XML-Code an.If you want to better understand what rules are generating your dynamic playlist, save the playlist file to disk with the save button and view the rules generated in the xml.
PlayList file dynamic rule set
Dynamischer Regelsatz für PlayList-DateiPlayList file dynamic rule set
  • Sie können auch weiterhin einzelne Tests einschließen bzw. ausschließen. Die Wiedergabeliste kann entweder die dynamischen Regeln aktualisieren oder dazu zurückkehren, Tests als statische Liste nachzuverfolgen.You can continue to include/exclude individual tests and the playlist will be able to either update its dynamic rules or switch back to keeping track of tests as a static list. Sie können auch Merkmale verwenden, um eine dynamische Gruppe zu definieren, indem Sie die XML-Wiedergabelistendatei direkt bearbeiten.You can also use traits to define a dynamic group by editing the playlist xml file directly.

Windows FormsWindows Forms

Windows Forms-Designer für .NET CoreWindows Forms Designer for .NET Core

Der Windows Forms-Designer für .NET Core-Projekte ist jetzt verfügbar.The Windows Forms designer for .NET Core projects is now available. Um den Designer in Visual Studio zu aktivieren, navigieren Sie zu „Extras > Optionen> Umgebung > Previewfunktionen“, und wählen Sie die Option „Use the preview Windows Forms designer for .NET Core apps“ (Vorschauversion des Windows Forms-Designers für .NET Core-Apps verwenden) aus.To enable the designer in Visual Studio, go to Tools > Options > Environment > Preview Features and select the Use the preview Windows Forms designer for .NET Core apps option.

In diesem Release werden nun die folgenden Steuerelemente zusammen mit anderen Verbesserungen unterstützt:In this release the following controls are now supported along with other improvements:

  • UserControl und Infrastruktur benutzerdefinierter SteuerelementeUserControl and custom controls infrastructure
  • TableLayoutPanelTableLayoutPanel
  • Grundlagen für die Unterstützung von Steuerelementen von DrittanbieternFundamentals for third-party controls support
  • Grundlagen der Unterstützung von DatenbindungFundamentals for data binding support
  • Verbesserungen bei der Designer-Interaktion mit TableLayoutPanelImprovements in designer interaction with the TableLayoutPanel

WPF- und UWP ToolsWPF/UWP Tooling

XAML-Editor:XAML Editor:

Inlinefarbvorschau im XAML-Code-Editor: Im XAML-Code-Editor steht nun eine Inlinefarbschnellansicht zur Verfügung:Inline Color Previews in XAML Code Editor: An inline color visualizer is now available in the XAML Code Editor:

Inline Color Previews in XAML Code Editor
Inlinefarbvorschau im XAML-Code-EditorInline Color Previews in XAML Code Editor
Hinweis: Farben aus Ressourcen werden zurzeit nicht unterstützt, diese Unterstützung wird aber in einem zukünftigen Release verfügbar sein. Note: Colors from resources are currently not supported, but this support is coming in a future release.

Diagnose von XAML-Bindungsfehlern:XAML Binding Failures Diagnostic:

Diagnoseverbesserungen für XAML-BindungsfehlerXAML Binding Failures diagnostic improvements

In diesem Release fügen wir Visual Studio neue Features hinzu, die das Erkennen und Anzeigen der Details von XAML-Bindungsfehlern vereinfachen. Diese Verbesserungen umfassen Folgendes:In this release we’re adding new features to Visual Studio that makes becoming aware of and seeing the details of XAML binding failures easier, these improvements include:

  • Neues Indikatorsymbol für XAML-Bindungsfehler in der Symbolleiste der App für WPF- und UWP-Entwickler.New XAML Binding failure indicator icon in the in-app toolbar experience for WPF and UWP developers. Dieses Symbol wird rot, wenn mindestens eine Bindung fehlschlägt. Wenn Sie es hervorheben, wird die Gesamtanzahl fehlerhafter Bindungen in der QuickInfo angezeigt.This icon will change red if at least one binding fails and highlighting it will show you the total number of failed bindings in the tooltip. Wenn Sie auf das Symbol klicken, gelangen Sie zum neuen Bereich „XAML-Bindungsfehler“.Clicking the icon will take you to the new XAML Binding Failures panel
  • Neuer Bereich „XAML-Bindungsfehler“, der die Bindungsfehler angibt, die zuvor nur im Ausgabefenster verfügbar waren, und die Überprüfung in der neuen dedizierten Benutzeroberfläche mit Features wie Sortieren, Suchen und Gruppieren ähnlicher Fehler vereinfacht.New XAML Binding Failures panel that takes the binding failures that were previously only available in the Output window and makes them easy to review in the new dedicated experience with features such as sorting, searching and grouping of similar errors. Dieser Bereich funktioniert für WPF-, UWP- und Xamarin.Forms-Projekte (Hinweis: erfordert Xamarin, Version 4.5.0.266-vor3 oder höher).This panel works for WPF, UWP and Xamarin.Forms projects (note: requires Xamarin version 4.5.0.266-pre3 or higher)
XAML Binding Failures Improvements
Verbesserungen für XAML-BindungsfehlerXAML Binding Failures Improvements

Diese Funktion befindet sich noch in der Entwicklung und ist nur verfügbar, wenn sie von Kunden aktiviert wird.This feature is still in development and is only available if enabled by customers. Um diese Benutzeroberfläche zu aktivieren, navigieren Sie zu „Optionen > Umgebung > Previewfunktionen“ und aktivieren das Fenster für XAML-Bindungsfehler.To enable this experience, go to Options > Environment > Preview Features and enable “XAML Binding Failure Window”.

Bekannte Einschränkungen: Wenn Sie im Bereich auf Bindungsfehler klicken, erfolgt noch keine Navigation zum Code.Known Limitations: Clicking on binding failures in the panel does not yet navigate to code. Auch das Anfügen an einen aktuell ausgeführten Prozess funktioniert nicht, und Sie müssen die Debugbenutzeroberfläche über F5 aufrufen.Also attaching to a running process will not work, you must F5 into the debug experience for this experience.

XAML-Designer:XAML Designer:

Mithilfe von vorgeschlagenen Aktionen im XAML-Designer können Sie einfach auf häufige Eigenschaften zugreifen, wenn ein Steuerelement im XAML-Designer ausgewählt ist.XAML Designer Suggested Actions enables easy access to common properties when a control is selected within the XAML Designer. Sie müssen dieses Feature zunächst unter „Optionen > Previewfunktion > Vorgeschlagene XAML-Aktionen“ aktivieren.To use this feature first enable it through Options > Preview Features > XAML Suggested Actions. Klicken Sie anschließend auf ein unterstütztes Steuerelement, und nutzen Sie die Glühbirne, um die Benutzeroberfläche für vorgeschlagene Aktionen zu aufzuklappen oder mit dieser zu interagieren.Once enabled click on a supported control and use the lightbulb to expand and interact with the Suggestion Actions UI. In diesem Release werden z. B. folgende Steuerelemente unterstützt:In this release supported controls include:

  • Für UWP: Border, Button, Canvas, CheckBox, ComboBox, Grid, HyperlinkButton, Image, ListBox, ListView, NavigationView, RadioButton, Slider, StackPanel, TextBlockFor UWP: Border, Button, Canvas, CheckBox, ComboBox, Grid, HyperlinkButton, Image, ListBox, ListView, NavigationView, RadioButton, Slider, StackPanel, TextBlock
  • Für WPF: Border, Button, Canvas, CheckBox, ComboBox, Grid, Image, Label, ListBox, ListView, StackPanel, TextBlock und TextBox.For WPF: Border, Button, Canvas, CheckBox, ComboBox, Grid, Image, Label, ListBox, ListView, StackPanel, TextBlock, TextBox.

Diese Funktion ist für UWP-, WPF .NET Core- und WPF .NET Framework-Anwendungen (mit aktiviertem Featureflag „Neuer WPF-XAML-Designer für .NET Framework“) verfügbar, unterstützt keine Erweiterbarkeit und umfasst nicht den vollständigen Funktionsumfang.This feature is available for UWP, WPF .NET Core and WPF .NET Framework (with enabled “New WPF XAML Designer for .NET Framework” feature flag) applications and doesn’t support extensibility, nor is it feature complete.

XAML Designer: Suggested Actions
XAML-Designer: Vorgeschlagene AktionenXAML Designer: Suggested Actions

Der neue WPF-XAML-Designer für .NET Framework-Projekte ist jetzt als frühe Vorschauversion verfügbar.The New WPF XAML Designer for .NET Framework Projects is now available for early preview. Damit steht die Unterstützung für Designer und Erweiterbarkeit für WPF-.NET Core-Entwickler auch in WPF-.NET Framework zur Verfügung.This brings the same designer and extensibility support available for WPF .NET Core developers to WPF .NET Framework. Zu den Vorteilen dieses verbesserten XAML-Designers zählen eine schnellere Ladeleistung, Unterstützung für die 64-Bit-Konfiguration (benutzerdefinierte Steuerelemente werden normalerweise wie in der x86-Konfiguration geladen), verbesserte Stabilität und neue Features wie vorgeschlagene Aktionen.Benefits of this improved XAML designer includes faster load performance, 64-bit configuration support (custom controls would load normally just like they do in x86 configuration), improved stability and new features such as Suggested Actions.

Navigieren Sie zunächst zu „Optionen > Previewfunktion“, wählen Sie „Neuen WPF-XAML-Designer für .NET Framework aktivieren“ aus, und starten Sie Visual Studio neu, um mit der Verwendung zu beginnen.To get started, go to Options > Preview Features, select “New WPF XAML Designer for .NET Framework” and restart Visual Studio. Diese Funktion ist nur im Vorschaukanal für frühe Tests verfügbar, und die Details zum endgültigen Release wurden noch nicht festgelegt.This feature is only available in the Preview channel for early testing; its final release details have not yet been determined. Wir empfehlen allen WPF-.NET Framework-Kunden, diesen Designer zu testen und Probleme über den VS-Feedback-Hub zu melden.We encourage all WPF .NET Framework customers to give this designer a try and report any issues you encounter through the VS Feedback Hub.

C++C++

  • Wir haben erstklassige Unterstützung für das Debuggen von CMake-Projekten auf Remotesystemen mit gdbserver hinzugefügt.We've added first-class support for debugging CMake projects on remote systems with gdbserver.
  • Sie können Speicherbeschädigungsfehler mit einer experimentellen Implementierung von AddressSanitizer für C++ in Visual Studio einfach ermitteln, die jetzt für native x64-Projekte verfügbar ist.Find memory corruption errors easily with an experimental implementation of AddressSanitizer for C++ in Visual Studio, now available for x64 native projects. Wir unterstützen jetzt auch die Verwendung von Debuglaufzeiten (/MTd,/MDd,/LDd).We also now support the use of debug runtimes (/MTd, /MDd, /LDd).

JavaScript/TypeScriptJavaScript/TypeScript

  • Die Implementierungen von Vervollständigung und QuickInfo wurden aktualisiert, um LiveShare-Szenarien besser zu unterstützen.The implementations of Completion and Quick Info have been updated to better support LiveShare scenarios.

.NET-Produktivität.NET Productivity

  • Es gibt jetzt eine schnelle Aktion zum Hinzufügen eines DebuggerDisplay-Attributs zu einer Klasse.There is now a quick action to add a debugger display attribute to a class. Dadurch können Sie Eigenschaften im Debugger programmgesteuert in Ihrem Code anheften.This allows you to pin properties within the debugger programmatically in your code. Platzieren Sie Ihren Cursor auf dem Klassennamen.Place your cursor on the class name. Drücken Sie (Ctrl+ . ), um das Menü Schnellaktionen und Refactorings zu öffnen.Press (Ctrl+.) to trigger the Quick Actions and Refactorings menu. Wählen Sie DebuggerDisplay-Attribut hinzufügen aus.Select Add ‘DebuggerDisplay` attribute. Dadurch wird das DebuggerDisplay-Attribut am Anfang der Klasse hinzugefügt und eine automatische Methode generiert, die ToString() zurückgibt. Diese Angabe können Sie bearbeiten, um den Eigenschaftswert zurückzugeben, der im Debugger angeheftet werden soll.This will add the debugger display attribute to the top of your class and generate an auto method that returns ToString() which you can edit to return the property value you want pinned in the debugger.
Add Debugger Display Attribute
DebuggerDisplay-Attribut hinzufügenAdd Debugger Display Attribute
  • Es gibt jetzt eine Codekorrektur für versehentliche Zuweisungen oder Vergleiche mit derselben Variablen.There is now a code fix for accidental assignments or comparisons to the same variable. Platzieren Sie den Cursor auf der Warnung.Place your cursor on the warning. Drücken Sie (Ctrl+ . ), um das Menü Schnellaktionen und Refactorings zu öffnen.Press (Ctrl+.) to trigger the Quick Actions and Refactorings menu. Wählen Sie für versehentliche Zuweisungen .wert zuweisen aus.For accidental assignments, select Assign to .value. Wählen Sie für versehentliche Vergleiche Mit .wert vergleichen aus.For accidental comparisons, select Compare to .value.
Accidental Assignments Code Fix
Codekorrektur für versehentliche ZuweisungenAccidental Assignments Code Fix
Accidental Comparisons Code Fix
Codekorrektur für versehentliche VergleicheAccidental Comparisons Code Fix
  • Sie können jetzt Vergleichsoperatoren für Typen generieren, die IComparable implementieren.You can now generate comparison operators for types that implement IComparable. Platzieren Sie den Cursor entweder innerhalb der Klasse oder auf IComparable.Place your cursor either inside the class or on IComparable. Drücken Sie (Ctrl+ . ), um das Menü Schnellaktionen und Refactorings zu öffnen.Press (Ctrl+.) to trigger the Quick Actions and Refactorings menu. Wählen Sie Vergleichsoperatoren generieren aus.Select Generate comparison operators. Mit den Vergleichsoperatoren wird ein Textbaustein für Sie generiert.A boiler plate will be generated for you with the comparison operators.
Generate Comparison Operators
Vergleichsoperatoren generierenGenerate Comparison Operators
  • Sie können jetzt IEquatable-Operatoren generieren, wenn Sie .Equals für Strukturen generieren.You can now generate IEquatable operators when generating .Equals for structs. Es war bereits ein Refactoring zum Generieren von Equals und GetHashCode für Werttypen verfügbar.We already had a refactoring to Generate Equals and GetHashCode for value types. Nun fügen wir mit Strukturen automatisch die IEquatable- sowie die Gleichheits- und Ungleichheitsoperatoren hinzu.Now with structs we will automatically add the IEquatable as well as the equals and not equals operators for you. Platzieren Sie den Cursor in der Struktur.Place your cursor within the struct. Drücken Sie (Ctrl+ . ), um das Menü Schnellaktionen und Refactorings zu öffnen.Press (Ctrl+.) to trigger the Quick Actions and Refactorings menu. Wählen Sie Equals(object) generieren aus.Select Generate Equals(object).
Generate IEquatable Operators
IEquatable-Operatoren generierenGenerate IEquatable Operators
  • Sie können jetzt Eigenschaften oder Felder für alle nicht verwendeten Konstruktorparameter erstellen und zuweisen.You can now create and assign properties or fields for all unused constructor parameters. Es war bereits eine schnelle Aktion verfügbar, die es ihnen ermöglichte, diesen Vorgang für einen einzelnen Parameter durchzuführen, aber jetzt ist dies für alle nicht verwendeten Parameter gleichzeitig möglich.We already had a quick action that allowed you to do this on an individual parameter, but now you can do it for all unused parameters at once. Platzieren Sie den Cursor auf einem der verbleibenden Parameter.Place your cursor on any of the remaining parameters. Drücken Sie (Ctrl+ . ), um das Menü Schnellaktionen und Refactorings zu öffnen.Press (Ctrl+.) to trigger the Quick Actions and Refactorings menu. Um Eigenschaften zu erstellen und zu initialisieren, wählen Sie Verbleibende Parameter als Eigenschaften erstellen und zuweisen aus.To create and initialize properties, select Create and assign remaining as properties. Um Felder zu erstellen und zu initialisieren, wählen Sie Verbleibende Parameter als Felder erstellen und zuweisen aus.To create and initialize fields, select Create and assign remaining as fields.
Create and Assign Remaining Fields
Verbleibende Parameter als Felder erstellen und zuweisenCreate and Assign Remaining Fields
Create and Assign Remaining Properties
Verbleibende Parameter als Eigenschaften erstellen und zuweisenCreate and Assign Remaining Properties
  • IntelliSense-Vervollständigung in DateTime- und TimeSpan-Zeichenfolgenliteralen ist jetzt verfügbar.There is now IntelliSense completion in DateTime and TimeSpan string literals. Platzieren Sie den Cursor innerhalb des DateTime- oder TimeSpan-Zeichenfolgenliterals, und drücken Sie (STRG+LEERTASTE).Place your cursor inside the DateTime or TimeSpan string literal and press (Ctrl+Space). Anschließend werden Vervollständigungsoptionen und eine Erläuterung zur Bedeutung der einzelnen Zeichen angezeigt.You will then see completion options and an explanation as to what each character means. Sowohl das Datums-/Uhrzeitformat als auch ein Beispiel werden bereitgestellt.Both the date time format and an example will be provided.
IntelliSense Completion in DateTime and TimeSpan
IntelliSense-Vervollständigung in DateTime- und TimeSpan-ZeichenfolgenliteralenIntelliSense Completion in DateTime and TimeSpan string literals
  • Sie können nun im Dialogfeld Signatur ändern einen Parameter hinzufügen.You can now add a parameter within the Change Signature dialog. Platzieren Sie den Cursor in der Signatur der Methode.Place your cursor within the method’s signature. Drücken Sie (Ctrl+ . ), um das Menü Schnellaktionen und Refactorings zu öffnen.Press (Ctrl+.) to trigger the Quick Actions and Refactorings menu. Wählen Sie Signatur ändern aus.Select Change signature. Das folgende Dialogfeld wird geöffnet, in dem Sie nun Hinzufügen auswählen können, um einen Parameter hinzuzufügen.The following dialog will open where you can now select Add to add a parameter. Nachdem Sie Hinzufügen ausgewählt haben, wird das neue Dialogfeld Parameter hinzufügen geöffnet.Once you select Add, the new Add Parameter dialog will open. Mit dem Dialogfeld Parameter hinzufügen können Sie einen Typnamen und einen Parameternamen hinzufügen.The Add Parameter dialog allows you to add a type name and a parameter name. Sie können mit einem Standardwert festlegen, ob der Parameter erforderlich oder optional ist.You can choose to make the parameter required or optional with a default value. Sie können dann auf der Aufrufsite einen Wert hinzufügen und ein benanntes Argument für diesen Wert auswählen, oder Sie können eine TODO-Variable einführen.You can then add a value at the call site and choose a named argument for that value or you can introduce a TODO variable. Die TODO-Variable fügt ein TODO in Ihren Code ein, sodass Sie jeden Fehler untersuchen und jede Aufrufsite unabhängig durchlaufen und entscheiden können, was übergeben werden soll.The TODO variable puts a TODO in your code so you can visit each error and go through each call site independently and decide what to pass. Für optionale Parameter besteht die Möglichkeit, die Aufrufsite vollständig auszulassen.For optional parameters you have the option to omit the call site completely.
Change Signature Dialog
Dialogfeld „Signatur ändern“Change Signature Dialog
Add Parameter Dialog
Dialogfeld „Parameter hinzufügen“Add Parameter Dialog
  • Autoren von Analysetools können nun CompletionProviders für IntelliSense-Vervollständigungen verwenden, wenn sie ihre Analysetools mit NuGet ausliefern.Analyzer authors can now use CompletionProviders for IntelliSense completions when shipping their analyzers with NuGet. Zuvor mussten Autoren von Bibliotheken eine separate VSIX-Datei erstellen, da CompletionProviders nur in VSIX verfügbar waren.Before, library authors would have to create a separate VSIX since CompletionProviders was only available in VSIX. Autoren von Bibliotheken können nun IntelliSense-Vervollständigungen im NuGet-Paket implementieren, in dem ihre Analysetools enthalten sind, und sie müssen dies nicht separat durchführen.Now library authors can implement IntelliSense completions in the NuGet package where their analyzers are, and they don’t need to do it separately. In NuGet-Paketen implementierte Vervollständigungsanbieter bieten auch Vorschläge speziell für einzelne Projekte und funktionieren automatisch in jeder IDE, die diese Funktion unterstützt.Completion providers implemented in NuGet packages will also provide suggestions specific to individual projects and will automatically work in each IDE supporting the feature.

Die wichtigsten behobenen Probleme in Visual Studio 2019, Version 16.7, Vorschau 1Top Issues Fixed in Visual Studio 2019 version 16.7 Preview 1


Aus der EntwicklercommunityFrom Developer Community

Bekannte ProblemeKnown Issues

Unter dem folgenden Link können Sie sich über alle offenen Probleme und verfügbaren Problemumgehungen in Visual Studio 2019 informieren.See all open issues and available workarounds in Visual Studio 2019 by following the below link.


FeedbackFeedback

Wir freuen uns auf Ihr Feedback!We would love to hear from you! Informieren Sie uns über die Option Ein Problem melden in der oberen rechten Ecke im Installer oder direkt in der Visual Studio-IDE über mögliche Probleme.For issues, let us know through the Report a Problem option in the upper right-hand corner of either the installer or the Visual Studio IDE itself. DieThe Feedback Icon Symbol befindet sich in der oberen rechten Ecke.icon is located in the upper right-hand corner. Sie können einen Vorschlag zu einem Produkt einreichen oder Ihre Probleme in der Entwicklercommunity für Visual Studio nachverfolgen, in der Sie auch Fragen stellen und nach Antworten suchen sowie neue Features vorschlagen können.You can make a product suggestion or track your issues in the Visual Studio Developer Community, where you can ask questions, find answers, and propose new features. Über unseren Livechatsupport erhalten Sie zudem kostenlose Hilfe bei der Installation.You can also get free installation help through our Live Chat support.


BlogsBlogs

Profitieren Sie von den Einblicken und Empfehlungen auf der Webseite mit Blogs zu Entwicklertools, um sich bei allen Releases auf dem neuesten Stand zu halten und Zugang zu ausführlichen Beiträgen zu zahlreichen Funktionen zu erhalten.Take advantage of the insights and recommendations available in the Developer Tools Blogs site to keep you up-to-date on all new releases and include deep dive posts on a broad range of features.


Verlauf der Versionshinweise zu Visual Studio 2019Visual Studio 2019 Release Notes History

Weitere Informationen bezüglich der früheren Versionen von Visual Studio 2019 finden Sie auf der Seite Verlauf der Versionshinweise zu Visual Studio 2019.For more information relating to past versions of Visual Studio 2019, see the Visual Studio 2019 Release Notes History page.


Seitenanfang

Top of Page