Arbeiten mit R in Visual StudioWork with R in Visual Studio

R ist eine hochgradig erweiterbare Sprache und Umgebung für die statistische Berechnungen und Grafiken.R is a highly extensible language and environment for statistical computing and graphics. Die Sprache wird kostenlos unter der GNU General Public License (GNU GPL) bereitgestellt, wird von einer starken Community unterstützt und ist für ihre Fähigkeit bekannt, hochwertige Plots einschließlich mathematischer Symbole und Formeln zu erzeugen.It's distributed for free under the GNU General Public License, enjoys strong community support, and is known for its ability to produce publication-quality plots including mathematical symbols and formulae. Weitere Informationen zu R erhalten Sie unter r-project.org und An Introduction to R (Einführung in R).You can learn more about R at r-project.org and An Introduction to R.

R Tools für Visual Studio (RTVS) ist eine kostenlose Open Source-Erweiterung für Visual Studio 2017 und Visual Studio 2015 Update 3 (oder höher) und wurde unter der MIT-Lizenz veröffentlicht.R Tools for Visual Studio (RTVS) is a free, open-source extension for Visual Studio 2017 and Visual Studio 2015 Update 3 (or higher), released under the MIT license. (Eine zweite Open Source-Komponente namens RHost, die eine Verknüpfung mit den Binärdateien des R-Interpreters bietet, wurde unter der GNU Public License V2 veröffentlicht.)(A second open-source component called RHost, which links to the R interpreter binaries, is released under the GNU Public License V2.)

Note

RTVS wird derzeit nur in Visual Studio 2017 unter Windows und nicht in Visual Studio für Mac unterstützt.RTVS is presently supported only in Visual Studio 2017 on Windows and not Visual Studio for Mac. Die Erweiterung steht für Visual Studio 2019 nicht zur Verfügung.It is not available for Visual Studio 2019.

Gehen Sie folgendermaßen vor, um mit R in Visual Studio zu arbeiten:To experience R in Visual Studio:

Folgen Sie anschließend den unten stehenden Links, um mehr über R-Features sowie über die allgemeinen Features von Visual Studio zu erfahren.Then follow the links below to learn more about R-related features as well as the general capabilities of Visual Studio itself.

FeatureFeature BeschreibungDescription Allgemeine Visual Studio-DokumentationGeneral Visual Studio Documentation
Visual Studio-ProjektsystemVisual Studio project system Organisieren und verwalten Sie verknüpfte Dateien in einer praktischen Struktur, und profitieren Sie von nützlichen Vorlagen für Elemente wie R-Code, R-Dokumentation, R Markdown, SQL-Abfragen und gespeicherte Prozeduren.Organize and manage related files in a convenient structure, and take advantage of useful templates for items such as R code, R documentation, R Markdown, SQL queries, and stored procedures. Nutzen Sie zudem den Paket-Manager und die SQL Server-Integration.Also enjoy the package manager and SQL Server integration. Projektmappen und Projekte in Visual StudioSolutions and Projects in Visual Studio
ArbeitsbereichWorkspace RTVS kann in lokale und Remotearbeitsbereiche eingebunden werden – so können Sie R-Code lokal mit kleineren Datasets entwickeln, den Code dann auf leistungsfähigeren cloudbasierten Computern mit wesentlich größeren Datasets ausführen.RTVS can bind to local and remote workspaces, allowing you to develop R code locally with smaller data sets, then easily run the code on more powerful cloud-based computers with much larger data sets. n/vn/a
Optionen für R ToolsR Tools options Steuern Sie verschiedene Aspekte von RTVS.Control various aspects of RTVS. Dialogfeld „Optionen“Options dialog box
Vielfältige Bearbeitungsfunktionen, IntelliSense und CodeausschnitteRich editing, IntelliSense, and code snippets Umfasst Syntaxfarben, IntelliSense über den gesamten Code und allen Bibliotheken hinweg, Codeformatierung, Signaturhilfe, „Gehe zu Definition“, „Alle Verweise suchen“, Codeausschnitte und vieles mehr.Includes syntax coloring, IntelliSense across all your code and libraries, code formatting, signature help, Go to Definition, Find All References, code snippets, and more. Features des Code-EditorsFeatures of the code editor
R MarkdownR Markdown Mit R Markdown-Dokumenten können Sie Ihre Datenergebnisse mit integriertem R-Code in Markdowncodeblöcken freigeben.R Markdown documents help you share your data results, with integrated R code inside markdown code blocks. n/vn/a
Interaktives FensterInteractive Window Dieses Fenster bietet eine vollständige REPL-Oberfläche für R, mit der Sie Code in einer Quelldatei im interaktiven Fenster ausführen können.Provides a full REPL experience for R with the ability to easily run code in a source file in the interactive window. n/vn/a
Visualisieren von DatenVisualizing data Plotting ist ein wesentlicher Bestandteil von R, und RTVS unterstützt mehrere, voneinander unabhängige Plotfenster. Jedes Fenster bietet einen eigenen Verlauf, und Sie können Plots zwischen Fenstern verschieben.Plotting is an integral part of the R experience, and RTVS supports multiple, independent plot windows, each with their own history and the ability to move plots between windows. Plots können in Bitmap- und PDF-Dateien gespeichert oder als Bitmap- oder Metadatei in die Zwischenablage kopiert werden.Plots can be saved to bitmap and PDF files, or copied to the clipboard as a bitmap or metafile. n/vn/a
Variablen-ExplorerVariable Explorer Untersuchen Sie Variablen auf globaler oder paketspezifischer Ebene, zeigen Sie sortierbare Tabellen an, und exportieren Sie diese in das CSV-Format.Examine variables in the global or package-specific scopes, with the ability to view sortable tables and export to CSV. n/vn/a
Vollständige DebugfeaturesFull-featured debugging Umfasst die Integration in das interaktive Fenster.Includes integration with the interactive window. Debuggen in Visual StudioDebugging in Visual Studio

Weitere Informationen finden Sie auch unter Häufig gestellte Fragen.Also see Frequently asked questions.

Kamerasymbol für Videomovie camera icon for video Im Video (youtube.com) finden Sie eine Übersicht zu R-Tools für Visual Studio (12 Minuten 36 Sekunden).Watch a video (youtube.com) for an overview of R Tools for Visual Studio (12m 36s). Informationen finden Sie auch in weiteren Videos über R-Tools.Also see more R Tools videos.

Senden Sie uns Ihr Feedback!Send us your feedback!

  1. GitHub-Issues: Sie erreichen das RTVS-Team am besten, indem Sie ein Issue auf GitHub erstellen oder das Menü R Tools > Feedback verwenden.GitHub issues: The best way to reach the RTVS team is by filing an issue on GitHub, or by using the R Tools > Feedback menu.

  2. Senden eines Lächelns oder Stirnrunzelns: Das Menü R Tools > Feedback bietet eine schnelle Möglichkeit, Feedback zu senden und RTVS-Protokolldateien anzufügen, die bei der Diagnose Ihres Problems helfen können.Send a Smile / Frown: The R Tools > Feedback menu is a quick way to send feedback and attach RTVS log files to assist in the diagnosis of your issue. (Protokolle werden in %temp%/RTVSlogs.zip geschrieben, falls Sie sie separat senden möchten.) Die Protokollierung ist deaktiviert, falls Sie die Visual Studio-Telemetrie über den Menübefehl Hilfe > Feedback > Einstellungen oder während der Installation deaktiviert haben.(Logs are written into %temp%/RTVSlogs.zip in case you want to send them separately.) Logging is disabled if you've opted out of Visual Studio telemetry through the Help > Feedback > Settings menu command, or during installation.

  3. E-Mail: Sie können unter rtvsuserfeedback (at) microsoft.com direktes Feedback an das Team senden.Email: You can send direct feedback to the team at rtvsuserfeedback (at) microsoft.com.