Übersicht über Blend für Visual StudioBlend for Visual Studio overview

Blend für Visual Studio unterstützt Sie beim Erstellen von XAML-basierten Windows- und Web-Anwendungen.Blend for Visual Studio helps you design XAML-based Windows and Web applications. Es bietet die gleiche einfache XAML-Entwurfsumgebung wie Visual Studio und fügt visuelle Designer für erweiterte Aufgaben hinzu, z. B. Animationen und Verhalten.It provides the same basic XAML design experience as Visual Studio and adds visual designers for advanced tasks such as animations and behaviors. Einen Vergleich zwischen Blend und Visual Studio finden Sie unter Entwerfen von XAML in Visual Studio und Blend für Visual Studio.For a comparison between Blend and Visual Studio, see Design XAML in Visual Studio and Blend for Visual Studio.

Blend für Visual Studio ist eine Komponente von Visual Studio.Blend for Visual Studio is a component of Visual Studio. Wählen Sie für die Installation von Blend im Visual Studio-Installer entweder die Workload Entwicklung für die universelle Windows-Plattform oder .NET Desktopentwicklung .To install Blend, in the Visual Studio Installer choose either the Universal Windows Platform development or .NET desktop development workload. Beide Workloads umfassen die Komponente „Blend für Visual Studio“.Both of these workloads include the Blend for Visual Studio component.

Komponenten der UWP-Workload    Komponenten der Workload „.NET Desktopentwicklung“

Wenn Sie mit Blend für Visual Studio nicht vertraut sind, nehmen Sie sich einen Moment Zeit, um die besonderen Funktionen des Arbeitsbereichs kennenzulernen.If you're new to Blend for Visual Studio, take a moment to become familiar with the unique features of the workspace. In diesem Abschnitt erhalten Sie eine kurze Führung.This topic takes you on a quick tour.

WerkzeugbereichTools panel

Mithilfe des Bereichs Werkzeuge in Blend für Visual Studio können Sie in Ihrer Anwendung Objekte erstellen und ändern.You can use the Tools panel in Blend for Visual Studio to create and modify objects in your application. Der Bereich Extras wird auf der linken Seite im XAML-Designer angezeigt, wenn Sie eine .XAML -Datei geöffnet haben.The Tools panel appears on the left-hand side of the XAML designer when you have a .xaml file open.

Die Objekte werden erstellt, indem Sie ein Werkzeug auswählen und die Objekte mit der Maus auf die Zeichenfläche ziehen.You create the objects by selecting a tool and drawing on the artboard with your mouse.

Screenshot: Bereich „Extras“ in Blend für Visual Studio

Tipp

Einige der Tools im Bereich Tools haben Variationen, beispielsweise können Sie anstelle eines Rechtecks eine Ellipse oder eine Linie auswählen.Some of the tools in the Tools panel have variations, for example, instead of a rectangle, you can choose an ellipse or a line. Wenn Sie auf diese Variationen zugreifen möchten, klicken Sie mit der rechten Maustaste auf das Tool, oder klicken Sie auf das Tool, und halten Sie die Maustaste dabei gedrückt.To access these variations, right-click or click and hold on the tool.

Screenshot: Formenwerkzeugvariationen in Blend für Visual Studio

AuswahltoolsSelection tools

Wählen Sie Objekte und Pfade aus.Select objects and paths. Verwenden Sie das Werkzeug Direktauswahl , um geschachtelte Objekte und Pfadsegmente auszuwählen.Use the Direct Selection tool to select nested objects and path segments.

AnsichtstoolsView tools

Mit diesen Werkzeugen kann die Ansicht der Zeichenfläche beispielsweise zum Schwenken und Zoomen verwendet werden.Adjust the view of the artboard, such as for panning and zooming.

PinseltoolsBrush tools

Arbeiten Sie mit den visuellen Attributen eines Objekts, wie z.B. der Transformation eines Pinsels oder der Anwendung eines Farbverlaufs.Work with the visual attributes of an object, such as transforming a brush or applying a gradient.

ObjektbibliothekstoolsObject tools

Sie dienen zum Zeichnen der gängigsten Objekte auf der Zeichenfläche, z.B. Pfade, Formen, Layoutbereiche, Text und Steuerelemente.Draw the most common objects on the artboard, such as paths, shapes, layout panels, text, and controls.

ObjekttoolsAsset tools

Sie ermöglichen den Zugriff auf das Fenster „Objekt“ und die Anzeige des zuletzt verwendeten Objekts aus der Bibliothek.Access the Assets window and show the most recently used asset from the library.

ObjektfensterAssets window

Das Objektfenster enthält alle verfügbaren Steuerelemente und ähnelt der Toolbox in Visual Studio.The Assets window contains all the available controls and is similar to the Toolbox in Visual Studio. Zusätzlich zu den Steuerelementen befinden sich alle zur Zeichenfläche hinzufügbaren Objekte im Objektfenster , einschließlich Stile, Medien, Verhalten und Effekte.In addition to controls, you'll find everything you can add to your artboard in the Assets window, including styles, media, behaviors, and effects. Wenn Sie das Objektfenster öffnen möchten, wählen Sie entweder Ansicht > Objektfenster aus, oder Sie drücken STRG+ALT+X .To open the Assets window, choose View > Assets Window or press Ctrl+Alt+X .

Screenshot: Objektfenster in Blend für Visual Studio

  • Geben Sie in das Feld Objekte suchen Text ein, um die Liste der Objekte zu filtern.Enter text in the Search Assets box to filter the list of assets.
  • Wechseln Sie mithilfe der Schaltflächen in der oberen rechten Ecke zwischen dem Rastermodus und der Listenansicht für Objekte.Switch between Grid mode and List mode view view of assets by using the buttons at the top right.

Objekte und Zeitachsen (Fenster)Objects and Timeline window

Verwenden Sie dieses Fenster, um die Objekte auf der Zeichenfläche zu organisieren und gegebenenfalls zu animieren.Use this window to organize the objects on your artboard and, if you want, to animate them. Um das Fenster Objekte und Zeitachsen zu öffnen, wählen Sie Ansicht > Dokumentgliederung aus.To open the Objects and Timeline window, choose View > Document Outline . Zusätzlich zu den Funktionen, die im Fenster Dokumentgliederung in Visual Studio zur Verfügung stehen, enthält das Fenster „Objekte und Zeitachse“ in Blend für Visual Studio auf der rechten Seite einen Bereich für die Komposition der Zeitachse.In addition to the functionality provided in the Document Outline window in Visual Studio, the Objects and Timeline window in Blend for Visual Studio has a timeline composition area on the right. Verwenden Sie die Zeitachse, wenn Sie Animationen erstellen und bearbeiten.Use the timeline when you're creating and editing animations.

Screenshot: Fenster „Objekte und Zeitachsen“ im Animationsmodus

Verwenden der Storyboard-SchaltflächenUse the storyboard-related buttons Storyboard-Schaltflächen in Blend für Visual Studio zum Erstellen, Löschen, Schließen oder Auszuwählen eines Storyboards.to create, delete, close, or select a storyboard. Verwenden Sie den Bereich für die Zeitachsenkomposition auf der rechten Seite, um die Zeitachse anzuzeigen und Keyframes zu verschieben.Use the Timeline composition area on the right to view the timeline and move keyframes.

Fahren Sie mit dem Mauszeiger über jede Schaltfläche im Fenster, um mehr über die verfügbaren Funktionen zu erfahren.Hover over each button in the window to learn more about the available functionality.

Weitere Informationen:See also