Entwerfen mithilfe von XAML in Visual Studio und Blend für Visual Studio

Gilt für:yes Visual Studio noVisual Studio für Mac noVisual Studio Code

Visual Studio und Blend für Visual Studio sind visuelle Tools zum Erstellen ansprechender Benutzeroberflächen und Rich-Media-Umgebungen mit XAML für eine Vielzahl von App-Typen. Beide integrierten Entwicklungsumgebungen (IDE) teilen sich eine Reihe von Funktionen, wie z.B. einen visuellen XAML-Editor (Designer). Blend für Visual Studio, das die WPF-und UWP-Plattformen unterstützt, stellt zusätzliche Tools zum Entwerfen von visuellen Zuständen und zum Erstellen von Animationen bereit.

Sie können zwischen Visual Studio und Blend für Visual Studio wechseln. Sie können sogar in beiden IDEs dasselbe Projekt geöffnet haben. Änderungen an XAML-Dateien in einer IDE lassen sich beim Wechsel zur anderen IDE automatisch neu laden. Sie können das Neuladenverhalten steuern, indem Sie in beiden IDE zu Tools>Options>Environment>Documents navigieren.

Installation

  • Um WPF-Apps zu erstellen, installieren Sie die Workload .NET-Desktopentwicklung in Visual Studio. Blend für Visual Studio wird ebenfalls installiert.

    Screenshot of the .NET Desktop Development workload from the Visual Studio Installer

  • Um UWP-Apps zu erstellen, installieren Sie die Workload Universelle Windows-Plattformentwicklung in Visual Studio. Blend für Visual Studio wird ebenfalls installiert.

    Screenshot of the Universal Windows Platform Development workload from the Visual Studio Installer

  • Um Xamarin.Forms-Apps zu erstellen, installieren Sie die Workload Mobile-Entwicklung mit .NET in Visual Studio. Blend für Visual Studio wird nicht installiert. Xamarin.Forms-Apps werden in Blend nicht unterstützt.

    Screenshot of the Mobile Development with .NET workload from the Visual Studio Installer

Gemeinsam genutzte Funktionen

Für die meisten grundlegenden Entwicklungsaufgaben teilen sich Visual Studio und Blend für Visual Studie denselben Fenster- und Funktionssatz, mit einigen geringfügigen Unterschieden. Einige Highlights:

  • Intellisense: Beide IDEs unterstützen IntelliSense-Funktionen wie den Abschluss von Anweisungen.

  • Debuggen: Sie können in Visual Studio und Blend für Visual Studio debuggen, einschließlich der Einstellung von Haltepunkten im Code zum Debuggen einer ausgeführten App und mithilfe von Hot Reload , um Ihren XAML-Code während der Ausführung der App zu ändern. Für ein einheitliches Debugerlebnis in Visual Studio beinhaltet Blend für Visual Studio die meisten der Debugfenster und -symbolleisten von Visual Studio.

  • Datei neu laden: Sie können Ihre XAML-Dateien in Visual Studio oder Blend für Visual Studio bearbeiten. Bearbeitete Dateien, die gespeichert wurden, werden automatisch neu geladen, wenn Sie zwischen den IDES wechseln. Sie können das Neuladenverhalten steuern, indem Sie in beiden IDE zu Tools>Options>Environment>Documents navigieren.

  • Synchronisierte Layouts und Einstellungen: Designanpassungstool-Fensterlayouts und Einstellungseinstellungen für Visual Studio oder Blend für Visual Studio werden auf Ihren Geräten und Versionen synchronisiert, wenn Sie sich mit demselben Personalisierungskonto anmelden. Weitere Informationen finden Sie unterSynchronisieren von Visual Studio-Einstellungen auf mehreren Computern.

Erweiterte Funktionen in Blend für Visual Studio

Verwenden Sie Blend für Visual Studio für die folgenden Aufgaben, um Ihre Produktivität zu steigern. Dies sind die Bereiche, in denen Blend mehr Funktionalität bietet als Visual Studio-Designer oder Code allein.

Aufgabe Visual Studio Blend for Visual Studio Weitere Informationen
Visuelle Zustände für Designs Es gibt kein Tool, das Sie beim Entwerfen visueller Zustände unterstützt. Sie müssen sie programmgesteuert erstellen. Verwenden Sie Designtools, um das Erscheinungsbilds eines Steuerelements basierend auf dessen Status zu ändern. Visuelle Zustände
Erstellen von Animationen Es gibt kein Designwerkzeug für Animationen; Sie müssen sie programmgesteuert erstellen. Dies erfordert ein grundlegendes Verständnis des Animations- und Zeitsteuerungssystems in WPF sowie umfangreiche Codierungskenntnisse. Sie können Animationen in Blend für Visual Studio visuell erstellen und eine Vorschau anzeigen. Dies ist schneller und präziser, als Animationen in Code zu erstellen. Sie können Trigger hinzufügen, um die Benutzerinteraktion zu verarbeiten, und Sie können zum Code wechseln, um Ereignishandler und andere Funktionen zu verarbeiten. Animieren von Objekten
Umwandeln von Formen und Text in Pfade für eine einfachere Bearbeitung Wird nicht unterstützt. Sie können geringfügige oder erhebliche Änderungen an den Formen (z. B. Rechtecke und Ellipsen) vornehmen, indem Sie sie in Pfade konvertieren, die eine bessere Bearbeitungssteuerung bieten. Sie können Pfade umformen oder kombinieren und zusammengesetzte Pfade aus mehreren Formen erstellen.

Sie können auch Textblöcke in Pfade umwandeln, um sie als Vektorgrafiken zu bearbeiten.
Zeichnen von Formen und Pfaden
Bearbeiten von Steuerelementen, Vorlagen und Stilen Erfordert die Codierung von sowie Kenntnisse über WPF-Stile und -Vorlagen. Wandeln Sie ein Bild in ein Steuerelement um.

Verwenden Sie die Tools zum Bearbeiten von Vorlagen, um Steuerelemente, Stile und Vorlagen mit nur wenigen Mausklicks zu ändern.

Beispielsweise können Sie Blend für Visual Studio-Ressourcen verwenden, um WPF-Standardsteuerelemente (z. B. Schaltflächen, Listenfeldern, Bildlaufleisten, Menüs usw.) zu implementieren und um die Farbe, den Stil oder die zugrunde liegende Vorlage direkt in Blend zu ändern. Sie können dann, falls gewünscht, zum Code wechseln, um Ihrer Arbeit den letzten Schliff zu geben.
Ändern des Stils von Objekten
Verbinden der Benutzeroberfläche mit Daten Sie können eine Datenquelle aus Ressourcen, wie SQL Server-Datenbanken, WCF oder Webdiensten, Objekten oder SharePoint-Listen, erstellen und die Datenquelle mit den Steuerelementen der Benutzeroberfläche verknüpfen.

Daten müssen für ein interaktives Designerlebnis zur Entwurfszeit manuell erstellt werden.
Für .NET Framework-Apps erstellen Sie mühelos die Beispieldaten für die Prototyperstellung und für Tests. Wechseln Sie zu den Livedaten, wenn Sie bereit sind.

Die Blend-Funktionen zur Datengenerierung von Visual Studio sind hervorragend. Sie können Namen, Zahlen, URLs und Fotos problemlos bei laufendem Betrieb hinzufügen, wodurch Sie viel Zeit sparen können.

Bei Live-Daten können Sie die Steuerelemente der Benutzeroberfläche mit einer XML-Datei oder einer beliebigen CLR-Datenquelle verknüpfen.
Anzeigen von Daten

Informationen zu erweiterten XAML-Designs finden Sie unter Erstellen einer Benutzeroberfläche mit Blend für Visual Studio.

Weitere Informationen