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Fehlerprüfung 0x7E: SYSTEM_THREAD_EXCEPTION_NOT_HANDLED

Die SYSTEM_THREAD_EXCEPTION_NOT_HANDLED-Fehlerprüfung weist den Wert 0x0000007E auf. Diese Fehlerprüfung gibt an, dass ein Systemthread eine Ausnahme generiert hat, die vom Fehlerhandler nicht erfasst wurde.

Wichtig

Dieser Artikel richtet sich an Programmierer. Wenn Sie ein Kunde sind, der während der Verwendung Ihres Computers einen Bluescreen-Fehlercode erhalten hat, finden Sie weitere Informationen unter Behandeln von Bluescreenfehlern.

SYSTEM_THREAD_EXCEPTION_NOT_HANDLED Parameter

Parameter BESCHREIBUNG
1 Der Ausnahmecode, der nicht behandelt wurde.
2 Die Adresse, an der die Ausnahme aufgetreten ist.
3 Die Adresse des Ausnahmedatensatzes.
4 Die Adresse des Kontextdatensatzes.

Ursache

Diese Fehlerprüfung gibt an, dass ein Systemthread eine Ausnahme generiert hat, die vom Fehlerhandler nicht erfasst wurde. Um sie zu interpretieren, müssen Sie feststellen, welche Ausnahme generiert wurde.

Zu den gängigen Ausnahmecodes gehören:

  • 0x80000002: STATUS_DATATYPE_MISALIGNMENT gibt an, dass ein nicht ausgerichteter Datenverweis gefunden wurde.

  • 0x80000003: STATUS_BREAKPOINT gibt an, dass ein Haltepunkt oder ASSERT gefunden wurde, wenn kein Kerneldebugger an das System angefügt wurde.

  • 0xC0000005: STATUS_ACCESS_VIOLATION gibt an, dass eine Speicherzugriffsverletzung aufgetreten ist.

Eine vollständige Liste der Ausnahmecodes finden Sie unter NTSTATUS-Werte. Die Ausnahmecodes sind in ntstatus.h definiert, einer Headerdatei, die vom Windows Driver Kit bereitgestellt wird. Weitere Informationen finden Sie unter Headerdateien im Windows Driver Kit.

Lösung

Wenn Sie dieses Problem debuggen möchten, sollte die Ausnahmeadresse (Parameter 2) den Treiber oder die Funktion identifizieren, die das Problem verursacht hat.

Wenn ein Treiber in der Fehlermeldung zur Fehlerüberprüfung nach Namen aufgeführt ist, deaktivieren oder entfernen Sie diesen Treiber. Wenn das Problem auf einen einzelnen Treiber beschränkt ist, legen Sie Haltepunkte fest, und legen Sie den Code in einem einzelnen Schritt voran, um den Fehler zu finden und Einblicke in Ereignisse zu erhalten, die zum Absturz führen.

Die !analyze-Debuggererweiterung zeigt Informationen zur Fehlerüberprüfung an und kann bei der Ermittlung der Grundursache hilfreich sein.

Weitere Analysen können mithilfe der !thread-Erweiterung und der Befehle dds, dps und dqs (Wörter und Symbole anzeigen) durchgeführt werden. Diese Technik ist sinnvoll, wenn WinDbg "Wahrscheinlich durch : ntkrnlmp.exe verursacht" meldet.

Wenn Ausnahmecode 0x80000003 auftritt, wurde ein hartcodierter Haltepunkt oder eine hartcodierte Assertion getroffen, aber das System wurde mit dem Schalter /NODEBUG gestartet. Dieses Problem sollte nicht häufig auftreten. Wenn dies wiederholt auftritt, stellen Sie sicher, dass ein Kerneldebugger verbunden ist und das System mit dem Schalter /DEBUG gestartet wird.

Wenn ausnahmecode 0x80000002 auftritt, stellt der Trapframe zusätzliche Informationen bereit.

Weitere Informationen zu WinDbg und !analyze finden Sie unter:

Hinweise

Wenn Sie nicht in der Lage sind, den Windows-Debugger zu verwenden, um dieses Problem zu beheben, sollten Sie einige grundlegende Problembehandlungstechniken verwenden:

  • Überprüfen Sie die system log in Ereignisanzeige auf weitere Fehlermeldungen, die dazu beitragen können, das Gerät oder den Treiber zu identifizieren, das die Fehlerüberprüfung 0x7E verursacht.

  • Wenn in der Fehlerprüfungsmeldung ein Treiber angegeben ist, deaktivieren Sie ihn, oder wenden Sie sich an den Hersteller, um Treiberupdates anzufordern.

  • Erkundigen Sie sich bei Ihrem Hardwareanbieter nach ACPI- oder anderen Firmwareupdates. Auch Hardwareprobleme wie Systeminkompatibilitäten, Arbeitsspeicherkonflikte und IRQ-Konflikte können diesen Fehler verursachen.

  • Deaktivieren Sie das Zwischenspeichern/Schatten des BIOS, um den Fehler zu beheben. Sie können auch Hardware-Diagnose ausführen, die der Systemhersteller bereitstellt.

  • Vergewissern Sie sich, dass alle installierten neuen Hardwaregeräte mit der installierten Version von Windows kompatibel sind. Informationen zu erforderlicher Hardware finden Sie beispielsweise unter Windows 10 Spezifikationen.

Allgemeine Informationen zur Problembehandlung finden Sie unter Bluescreen-Daten.