Schritt 1: Öffnen und Analysieren von ETL-Dateien in WPAStep 1: Opening and Analyzing ETL Files in WPA

Dieser Abschnitt enthält eine ausführliche Exemplarische Vorgehensweise der Funktionen der Windows Performance Analyzer (WPA)-Benutzeroberfläche.This section presents a detailed walkthrough of the capabilities of the Windows Performance Analyzer (WPA) user interface (UI).

Schritt 1: Öffnen einer ETL-DateiStep 1: Opening an ETL File

WPA kann alle ETL-Dateien (Event Trace Log) öffnen, die mit Windows Performance Recorder (WPR) oder XPerf erstellt werden.WPA can open any event trace log (ETL) files that are created by using Windows Performance Recorder (WPR) or Xperf.

So öffnen Sie eine ETL-Datei in WPATo open an ETL file in WPA

  1. Klicken Sie im Menü Datei auf Öffnen.On the File menu, click Open.

  2. Wenn Sie Ihre ETL-Datei an einem anderen Speicherort als dem Standard Speicherort gespeichert haben, navigieren Sie zu diesem Speicherort.If you have saved your ETL file to a location other than the default, navigate to that location. Standardmäßig speichert WPR ETL-Dateien im\Ordner "WPR-Dateien".By default, WPR saves ETL files in your Documents\WPR Files folder.

  3. Wählen Sie die gewünschte Datei aus, und klicken Sie auf Öffnen.Select the desired file, and click Open.

    Sie können WPA auch über die Ergebnisseite der Bewertungen öffnen, die mit der Bewertungsplattform erstellt wurden.You can also open WPA from the results page of assessments that are created by using the Assessment Platform.

So öffnen Sie WPA über eine BewertungTo open WPA from an assessment

  • Nachdem Sie den Auftrag ausgeführt haben, klicken Sie auf der Seite Ergebnisse anzeigen im Bereich Probleme auf den Link WPA-ausführliche Analyse.After you have run the job, click the WPA in-depth analysis link in the Issues pane on the View Results page. Möglicherweise müssen Sie das Problem erweitern, um diesen Link anzuzeigen.You may have to expand the issue to see this link.

Schritt 2: Auswählen von DiagrammenStep 2: Selecting Graphs

Alle verfügbaren Diagramme für eine Aufzeichnung werden im Fenster Graph-Explorer angezeigt.All available graphs for a recording are visible in the Graph Explorer window. Erweitern Sie einen beliebigen Knoten, indem Sie auf das kleine Dreieck klicken.Expand any node by clicking the small triangle. Ziehen Sie dann die Diagramme auf die Registerkarte Analyse, um die vollständige Version des Diagramms und der zugehörigen Datentabelle anzuzeigen.Then, drag the graphs to the Analysis tab to view the full-size version of the graph and its associated data table. Sie können auch auf das Diagramm doppelklicken, um es auf der Registerkarte Analyse zu öffnen.You can also double-click the graph to open it on the Analysis tab.

Mithilfe der Layoutsymbole auf der rechten Seite der Diagramm Titelleiste können Sie auswählen, nur das Diagramm, nur die Datentabelle oder beides anzuzeigen.By using the layout icons on the right of the graph title bar, you can select to view only the graph, only the data table, or both.

Schritt 3: Auswählen eines ZeitintervallsStep 3: Selecting a Time Interval

Auf der Registerkarte Analyse können Sie ein Zeitintervall auswählen, indem Sie den Zeiger horizontal über einen Abschnitt des Diagramms ziehen.On the Analysis tab, you can select a time interval by dragging the pointer horizontally across a section of the graph. Die Zeitachse unten auf der Registerkarte gilt für alle Diagramme auf der Registerkarte.The timeline at the bottom of the tab applies to all graphs on the tab.

Schritt 4: Vergrößern eines ZeitintervallsStep 4: Zooming in on a Time Interval

Nachdem Sie ein Zeitintervall ausgewählt haben, können Sie vergrößern, um dieses Zeitintervall auf die gesamte Breite der Registerkarte Analyse zu erweitern. Klicken Sie hierzu mit der rechten Maustaste auf das Intervall, und wählen Sie dann Zoom zu ausgewähltem Zeitraum aus.After you have selected a time interval, you can zoom in to expand that time interval to the full width of the Analysis tab. To do this, right-click the interval, and then select Zoom to selected time range. Sie können diesen Schritt mehrmals wiederholen, um ausführliche Details zu einem sehr kleinen Zeitintervall anzuzeigen.You can repeat this step several times to see very fine detail of a very small time interval.

Alle Diagramme auf der Registerkarte "Analyse" verwenden die gleiche Zeitachse.All graphs on the Analysis tab use the same timeline. Diese Aktion erweitert daher dasselbe Zeitintervall für alle diese Diagramme.Therefore, this action expands the same time interval for all those graphs.

Schritt 5: Markieren eines ausgewählten ZeitintervallsStep 5: Highlighting a Selected Time Interval

Nachdem Sie ein Zeitintervall ausgewählt haben, können Sie dieses Zeitintervall auch in allen Diagrammen auf der Registerkarte Analyse und im Fenster Graph-Explorer hervorheben.After you have selected a time interval, you can also highlight that time interval in all graphs on the Analysis tab and in the Graph Explorer window. Klicken Sie hierzu mit der rechten Maustaste auf das Intervall, und wählen Sie dann Auswahl markieren aus.To do this, right-click the interval, and then select Highlight Selection. Durch diese Aktion wird die Auswahl unabhängig davon eingefroren, wo Sie auf andere Weise klicken.This action freezes the selection regardless of where else you click. Um die Auswahl zu löschen, klicken Sie mit der rechten Maustaste auf das Intervall, und wählen Sie dann Auswahl löschen aus.To clear the selection, right-click the interval, and then select Clear Selection.

Schritt 6: Anpassen einer DatentabelleStep 6: Customizing a Data Table

Sie können Spalten an eine beliebige Position in der Datentabelle ziehen.You can drag columns to any position in the data table. Sie können auf den Tabellenheader über eine beliebige Spalte klicken, um nach dieser Spalte zu sortieren.You can click the table header over any column to sort by that column. Sie können auch erneut auf den Tabellenheader klicken, um die Sortierung umzukehren.You can also click the table header again to reverse the sorting. Wenn Sie die Datentabelle ändern, werden die Änderungen auch im Legenden Steuerelement des Diagramms widergespiegelt.When you change the data table, the changes are also reflected in the Legend control of the graph. Die Legenden-Spalte der Datentabelle entspricht dem Legenden Steuerelement des Diagramms.The Legend column of the data table matches the Legend control of the graph.

Sie können Datentabellen anpassen, indem Sie die anzuzeigenden Spalten auswählen.You can customize data tables by selecting what columns to display. Um das Feld Spaltenauswahl zu öffnen, klicken Sie mit der rechten Maustaste auf den Tabellenheader.To open the Column Chooser box, right-click the table header. Anschließend können Sie Spalten einzeln auswählen, oder Sie können vordefinierte Kombinationen von Spalten erstellen oder anwenden, um Sie anzuzeigen.You can then select columns individually or create or apply preset combinations of columns to display.

Datentabellen sind Pivot-Tabellen.Data tables are pivot tables. Die Spalten auf der linken Seite der vertikalen goldleiste sind Schlüssel.The columns to the left of the vertical gold bar are keys. Die Spalten zwischen der vertikalen goldleiste und dem vertikalen blauen Balken sind die Datenspalten.The columns between the vertical gold bar and the vertical blue bar are the data columns. Wenn der senkrechte goldene Balken nicht angezeigt wird, Scrollen Sie nach rechts.If you do not see the vertical gold bar, scroll to the right.

Sie können eine beliebige Spalte nach links neben der vertikalen goldleiste ziehen, um Sie zu einem Schlüssel zu machen.You can drag any column to the left of the vertical gold bar to make it a key. Sie können auch Spalten rechts von der vertikalen blauen Leiste ziehen, um Sie zu grafisch zu gestalten.You can also drag some columns to the right of the vertical blue bar to make them graphing elements.

Sie können eine kleine Auswahl von Spalten fixieren, indem Sie mit der rechten Maustaste klicken, um vertikale graue Stopp leisten anzuzeigen.You can freeze a small selection of columns by right-clicking to show vertical gray freeze bars. Dann scrollt die Bild Lauf Leiste nur zwischen den Spalten zwischen den Fixierungs leisten.Then, the scroll bar scrolls only between the columns between the freeze bars. Sie können die Fixierungs leisten ziehen, um beliebig viele Spalten einzuschließen.You can drag the freeze bars to include any number of columns.

Schritt 7: Öffnen einer neuen Registerkarte "Analyse"Step 7: Opening a new Analysis Tab

Alle Diagramme und Tabellen auf einer Registerkarte "Analyse" verwenden dieselbe Zeitachse und werden gemeinsam vergrößert und vergrößert.All graphs and tables on an Analysis tab share the same timeline and are zoomed in and out together. Wenn Sie einige Diagramme auf einer anderen Zeitachse anzeigen möchten, können Sie eine zusätzliche Analyse Registerkarte öffnen. Klicken Sie hierzu im Menü Fenster auf neue Analyse Ansicht, und ziehen Sie die gewünschten Diagramme in die neue Registerkarte.If you want to view some graphs on a different timeline, you can open an additional Analysis tab. To do this, click New Analysis View on the Window menu, and then drag the desired graphs to the new tab.

Schritt 8: Öffnen oder Schließen von FensternStep 8: Opening or Closing Windows

Wählen Sie im Menü Fenster die Fenster aus, die Sie öffnen oder schließen möchten.On the Window menu, select the windows that you want to open or close.

Schritt 9: Erstellen und Anwenden eines Ansichts ProfilsStep 9: Creating and Applying a View Profile

Nachdem Sie das Layout auf die gewünschte Weise festgelegt haben, können Sie ein Ansichts Profil erstellen, das das aktuelle Layout entweder bei jedem Öffnen von WPA oder nur für bestimmte Arten von Aufzeichnungen wiederherstellt.After you have set the layout in the way that you want, you can create a view profile that reproduces the current layout either every time that you open WPA or only for specific types of recordings. Klicken Sie im Menü Profile auf exportieren, um ein Ansichts Profil zu erstellen, klicken Sie auf übernehmen, um ein Ansichts Profil anzuwenden, das Sie zuvor erstellt haben, oder klicken Sie auf Start Profil speichern, um die aktuelle Layoutansicht bei jedem Öffnen von WPA anzuzeigen.On the Profiles menu, click Export to create a view profile, click Apply to apply a view profile that you previously created, or click Save Startup Profile to see the current layout view every time that you open WPA.

Schritt 10: Suchen und FilternStep 10: Searching and Filtering

Sie können die Daten in einem Diagramm und der zugehörigen Datentabelle filtern, indem Sie mit der rechten Maustaste auf das Diagramm Legenden-Steuerelement klicken und die gewünschten Elemente aktivieren oder deaktivieren.You can filter the data in a graph and its associated data table by right-clicking the graph Legend control and enabling or disabling the desired items. Wenn Sie nur die ausgewählten Zeilen anzeigen möchten, klicken Sie mit der rechten Maustaste auf die Datentabelle, und klicken Sie dann auf zur Auswahl filtern.To show only the selected row or rows, right-click the data table, and then click Filter To Selection.

Um die Spalten auszuwählen, die in der Datentabelle angezeigt werden sollen, klicken Sie mit der rechten Maustaste auf den Tabellenheader, und wählen Sie dann die Spalten im Feld Spaltenauswahl aus, oder löschen Sie Sie.To select the columns to display in the data table, right-click the table header, and then select or clear the columns in the Column Chooser box.

Um den Text in der Datentabelle zu durchsuchen, klicken Sie mit der rechten Maustaste auf die Tabelle, und wählen Sie dann suchen, weiter suchen oder Vorheriges suchen aus.To search the text in the data table, right-click the table, and then select Find, Find Next, or Find Previous.

Schritt 11: Festlegen von BenutzereinstellungenStep 11: Setting User Preferences

Derzeit können Sie WPA zum Laden von Symbolen festlegen, und Sie können Symbol Pfade festlegen.Currently, you can set WPA to load symbols, and you can set symbol paths. Diese Optionen sind im Menü Ablauf Verfolgung verfügbar.These options are available on the Trace menu.

Schritt 12: Verwenden der Diagnose KonsoleStep 12: Using the Diagnostic Console

In diesem Fenster werden Ausnahmen aufgelistet, die im Analyse Workflow aufgetreten sind.This window lists exceptions that occurred in the analysis workflow. Sie können Probleme bei der Symbol Decodierung in dieser Konsole diagnostizieren.You can diagnose symbol decoding issues from this console.

Schritt 13: Anzeigen der Bewertungs Analyse und Problem DetailsStep 13: Viewing Assessment Analysis and Issue Details

Wenn Sie WPA über eine Bewertung öffnen, die in der Bewertungs Konsole ausgeführt wurde und zusätzliche Analysen bereitstellt, werden die Probleme, die von der Bewertung identifiziert werden, im Fenster "Probleme" angezeigt.When you open WPA from an assessment that was run in the Assessment Console and that provides additional analysis, the issues that the assessment identifies appear in the Issues window. Wenn Sie auf eines dieser Probleme klicken, werden Details und eine empfohlene Lösung auf der Registerkarte "Analyse" unter "Problem Details" angezeigt.If you click one of these issues, details and a recommended solution appear in the Analysis tab under Issue Details. Sie können die Liste der Probleme auch mithilfe der Suchoptionen am oberen Rand des Fensters Probleme durchsuchen.You can also search the list of issues by using the Search options at the top of the Issues window. Weitere Informationen zu dieser Funktionalität finden Sie im Fenster "Probleme".More information about this functionality is available in Issues Window.