Konfiguration des physischen Switches für konvergierte NICPhysical switch configuration for Converged NIC

Gilt für: Windows Server (halbjährlicher Kanal), Windows Server 2016Applies to: Windows Server (Semi-Annual Channel), Windows Server 2016

In diesem Thema erhalten Sie Richtlinien für die Konfiguration physischer Switches.In this topic, we provide you with guidelines for configuring your physical switches.

Dabei handelt es sich nur um Befehle und deren Verwendung. Sie müssen die Ports, mit denen die NICs verbunden sind, in Ihrer Umgebung bestimmen.These are only commands and their uses; you must determine the ports to which the NICs are connected in your environment.

Wichtig

Stellen Sie sicher, dass die VLAN-und die No-Drop-Richtlinie für die Priorität festgelegt ist, über die SMB konfiguriert istEnsure that the VLAN and no-drop policy is set for the priority over which SMB is configured.

Arista Switch ( DCS - 7050s - 64, EOS - 4.13.7 m)Arista switch (dcs-7050s-64, EOS-4.13.7M)

  1. (zum Admin-Modus wechseln, in der Regel nach einem Kennwort gefragt werden)en (go to admin mode, usually asks for a password)
  2. Konfiguration ( , die in den Konfigurations Modus eingegeben werden soll)config (to enter into configuration mode)
  3. Ausführung anzeigen ( zeigt die aktuell laufende Konfiguration an)show run (shows current running configuration)
  4. Suchen Sie die Switchports, mit denen die NICs verbunden sind.find out switch ports to which your NICs are connected to. In diesem Beispiel lauten Sie 14/1, 15/1, 16/1, 17/1.In these example, they are 14/1,15/1,16/1,17/1.
  5. int 1, 16/1, 16/1, 17/1, ( in den Konfigurations Modus für diese Ports.)int eth 14/1,15/1,16/1,17/1 (enter into config mode for these ports)
  6. dcbx-Modus IEEEdcbx mode ieee
  7. Prioritäts Fluss-Steuerungs Modus fürpriority-flow-control mode on
  8. Switchport-trunk natives VLAN 225switchport trunk native vlan 225
  9. Switchport-trunk zulässige VLAN 100-225switchport trunk allowed vlan 100-225
  10. switchportmodus-trunkswitchport mode trunk
  11. Prioritäts Fluss-Steuerungs Priorität 3 nicht ablegenpriority-flow-control priority 3 no-drop
  12. QoS Trust COSqos trust cos
  13. ausführen anzeigen ( Überprüfen Sie, ob die Konfiguration auf den Ports ordnungsgemäß eingerichtet ist)show run (verify that configuration is setup correctly on the ports)
  14. WR ( , damit die Einstellungen über den switchneustart beibehalten werden)wr (to make the settings persists across switch reboot)

Tipps:Tips:

  1. Nein #Command # negiert einen Befehl.No #command# negates a command
  2. Vorgehensweise beim Hinzufügen eines neuen VLANs: int VLAN 100 ( if Storage Network on VLAN 100)How to add a new VLAN: int vlan 100 (If storage network is on VLAN 100)
  3. Überprüfen vorhandener VLANs: VLAN anzeigenHow to check existing VLANs : show vlan
  4. Weitere Informationen zum Konfigurieren des Arista-Switchs finden Sie online nach: Arista EOS ManualFor more information on configuring Arista Switch, search online for: Arista EOS Manual
  5. Verwenden Sie diesen Befehl, um die PFC-Einstellungen zu überprüfen: Details der Prioritäts Fluss-Steuerungs Zähler anzeigenUse this command to verify PFC settings: show priority-flow-control counters detail

Dell Switch ( S4810, f: 9,9 ( 0,0))Dell switch (S4810, FTOS 9.9 (0.0))

    !
    dcb enable
    ! put pfc control on qos class 3
    configure
    dcb-map dcb-smb
    priority group 0 bandwidth 90 pfc on
    priority group 1 bandwidth 10 pfc off
    priority-pgid 1 1 1 0 1 1 1 1
    exit
    ! apply map to ports 0-31
    configure
    interface range ten 0/0-31
    dcb-map dcb-smb
    exit

Cisco Switch ( Nexus 3132, Version 6,0 ( 2, ) U6 ( 1))Cisco switch (Nexus 3132, version 6.0(2)U6(1))

GlobalGlobal

    class-map type qos match-all RDMA
    match cos 3
    class-map type queuing RDMA
    match qos-group 3
    policy-map type qos QOS_MARKING
    class RDMA
    set qos-group 3
    class class-default
    policy-map type queuing QOS_QUEUEING
    class type queuing RDMA
    bandwidth percent 50
    class type queuing class-default
    bandwidth percent 50
    class-map type network-qos RDMA
    match qos-group 3
    policy-map type network-qos QOS_NETWORK
    class type network-qos RDMA
    mtu 2240
    pause no-drop
    class type network-qos class-default
    mtu 9216
    system qos
    service-policy type qos input QOS_MARKING
    service-policy type queuing output QOS_QUEUEING
    service-policy type network-qos QOS_NETWORK

Port spezifischPort specific

    switchport mode trunk
    switchport trunk native vlan 99
    switchport trunk allowed vlan 99,2000,2050   çuse VLANs that already exists
    spanning-tree port type edge
    flowcontrol receive on (not supported with PFC in Cisco NX-OS)
    flowcontrol send on (not supported with PFC in Cisco NX-OS)
    no shutdown
    priority-flow-control mode on