Exportieren und Erstellen einer Unity-Projektmappe für Visual StudioExporting and building a Unity Visual Studio solution

Wenn Ihre APP die System Tastatur nicht benötigt, empfiehlt es sich, D3D zu verwenden, damit Ihre APP etwas weniger Arbeitsspeicher und eine schnellere Startzeit verwendet.If your app doesn't need the system keyboard, our recommendation is to use D3D so that your app uses slightly less memory and a faster launch time. Wenn Sie jedoch die System Tastatur über die touchscreenkeyboard-API verwenden, müssen Sie das Projekt als XAML exportieren.However, if you're using the system keyboard through the TouchScreenKeyboard API, you need to export the project as XAML.

Exportieren aus UnityHow to export from Unity

Unity-BuildeinstellungenUnity build settings
Buildeinstellungen im Unity-EditorBuild settings in Unity editor

  1. Wenn Sie bereit sind, Ihr Projekt aus Unity zu exportieren, öffnen Sie das Menü Datei , und wählen Sie Buildeinstellungen aus .When you're ready to export your project from Unity, open the File menu and select Build Settings...
  2. Wählen Sie offene Szenen hinzufügen aus, um die Szene dem Build hinzuzufügen.Select Add Open Scenes to add your scene to the build.
  3. Wählen Sie im Dialogfeld " Buildeinstellungen " die folgenden Optionen für den Export in hololens aus:In the Build Settings dialog, choose the following options to export for HoloLens:
    • Plattform: universelle Windows-Plattform , und stellen Sie sicher, dass Sie Switch Platform auswählen, damit die Auswahl wirksam wird.Platform: Universal Windows Platform and be sure to select Switch Platform for your selection to take effect.
    • SDK: Universal 10.SDK: Universal 10.
    • UWP-Buildtyp: D3D.UWP Build Type: D3D.
  4. Optional: Unity c#-Projekte: aktiviert.Optional: Unity C# Projects: Checked.

Hinweis

Wenn Sie dieses Kontrollkästchen aktivieren, können Sie Folgendes ausführen:Checking this box allows you to:

  • Debuggen Sie Ihre APP im Visual Studio Remote Debugger.Debug your app in the Visual Studio remote debugger.
  • Bearbeiten Sie Skripts im Unity-c#-Projekt, während Sie IntelliSense für WinRT-APIs verwenden.Edit scripts in the Unity C# project while using IntelliSense for WinRT APIs.
  1. Öffnen Sie im Fenster " Buildeinstellungen " die Player-Einstellungen...From the Build Settings... window, open Player Settings...
  2. Wählen Sie die Einstellungen für universelle Windows-Plattform Registerkarte aus.Select the Settings for Universal Windows Platform tab.
  3. Erweitern Sie die Gruppe XR-Einstellungen.Expand the XR Settings group.
  4. Aktivieren Sie im Abschnitt " XR-Einstellungen " das Kontrollkästchen " Virtual Reality supported ", um eine neue Virtual Reality-Geräte Liste hinzuzufügen, und vergewissern Sie sich, dass Windows Mixed Reality als unterstütztes Gerät aufgeführt ist.In the XR Settings section, check the Virtual Reality Supported checkbox to add a new Virtual Reality Devices list and confirm "Windows Mixed Reality" is listed as a supported device.
  5. Kehren Sie zum Dialogfeld " Buildeinstellungen " zurück.Return to the Build Settings dialog.
  6. Wählen Sie Build aus.Select Build.
  7. Erstellen Sie im daraufhin angezeigten Dialogfeld Windows-Explorer einen neuen Ordner, der die Buildausgabe von Unity enthalten soll.In the Windows Explorer dialog that appears, create a new folder to hold Unity's build output. Im allgemeinen benennen wir den Ordner "App".Generally, we name the folder "App".
  8. Wählen Sie den neu erstellten Ordner aus, und klicken Sie auf Ordner auswählen.Select the newly created folder and select Select Folder.
  9. Nachdem die Erstellung von Unity abgeschlossen ist, wird ein Windows-Explorer-Fenster für das Projektstamm Verzeichnis geöffnet.Once Unity has finished building, a Windows Explorer window will open to the project root directory. Navigieren Sie in den neu erstellten Ordner.Navigate into the newly created folder.
  10. Öffnen Sie die generierte Visual Studio-Projektmappendatei in diesem Ordner.Open the generated Visual Studio solution file located inside this folder.

Wann sollten Sie den erneuten Export aus Unity durch Schreiben?When to re-export from Unity

Wenn Sie das Kontrollkästchen c#-Projekte beim Exportieren Ihrer APP aus Unity aktivieren, wird eine Visual Studio-Projekt Mappe erstellt, die alle Ihre Unity-Skriptdateien enthältChecking the C# Projects checkbox when exporting your app from Unity creates a Visual Studio solution that includes all your Unity script files. Wenn Sie alle Skripts an einem Ort haben, können Sie die durchlaufen ohne erneutes exportieren aus Unity durchlaufen.Having all your scripts in one place lets you iterate without re-exporting from Unity. Wenn Sie jedoch Änderungen an Ihrem Projekt vornehmen, die nicht nur den Inhalt von Skripts ändern, müssen Sie einen erneuten Export aus Unity durchführen.However, if you make changes to your project that aren't just changing the contents of scripts, you'll need to re-export from Unity. Es folgen einige Beispiele für den erneuten Export von Unity:Some examples of times you need to re-export from Unity are:

  • Sie fügen der Registerkarte Projekt Objekte hinzu oder entfernen diese.You add or remove assets in the Project tab.
  • Sie ändern alle Werte auf der Registerkarte Inspektor.You change any value in the Inspector tab.
  • Objekte werden der Registerkarte Hierarchie hinzugefügt oder daraus entfernt.You add or remove objects from the Hierarchy tab.
  • Sie ändern alle Unity-Projekteinstellungen.You change any Unity project settings

Entwickeln und Bereitstellen einer Unity-Visual Studio-Projekt MappeBuilding and deploying a Unity Visual Studio solution

Der Rest der Bereitstellung und Bereitstellung von apps erfolgt in Visual Studio.The remainder of building and deploying apps happens in Visual Studio. Sie müssen eine Unity-Buildkonfiguration angeben.You will need to specify a Unity build configuration. Die Benennungs Konventionen von Unity unterscheiden sich möglicherweise von dem, was Sie in Visual Studio verwendet haben:Unity's naming conventions may differ from what you're used to in Visual Studio:

KonfigurationConfiguration ErklärungExplanation
DebuggenDebug Alle Optimierungen und der Profiler werden aktiviert.All optimizations off and the profiler is enabled. Dient zum Debuggen von SkriptsUsed to debug scripts.
MasterMaster Alle Optimierungen sind aktiviert, und der Profiler ist deaktiviert.All optimizations are turned on and the profiler is disabled. Wird verwendet, um apps an den Store zu übermitteln.Used to submit apps to the Store.
ReleaseRelease Alle Optimierungen sind aktiviert, und der Profiler ist aktiviert.All optimizations are turned on and the profiler is enabled. Dient zum Auswerten der APP-Leistung.Used to evaluate app performance.

Beachten Sie, dass es sich bei der obigen Liste um eine Teilmenge der allgemeinen Trigger handelt, die bewirken, dass das Visual Studio-Projekt generiert werden muss.Note, the above list is a subset of the common triggers that will cause the Visual Studio project to need to be generated. Im Allgemeinen erfordert die Bearbeitung von CS-Dateien in Visual Studio nicht, dass das Projekt in Unity neu generiert wird.In general, editing .cs files from within Visual Studio won't require the project to be regenerated from within Unity.

ProblembehandlungTroubleshooting

Wenn Sie feststellen, dass Änderungen an den CS-Dateien nicht in Ihrem Visual Studio-Projekt erkannt werden, stellen Sie sicher, dass Unity c#-Projekte geprüft werden, wenn Sie das vs-Projekt über das Menü "Build" von Unity generieren.If you find that edits to your .cs files aren't being recognized in your Visual Studio project, ensure that Unity C# Projects is checked when you generate the VS project from Unity's Build menu.