2. Initialisieren Ihres Projekts und Bereitstellen Ihrer ersten Anwendung2. Initializing your project and deploying your first application

In diesem Tutorial erfahren Sie, wie Sie ein neues Unity-Projekt erstellen, es für die Entwicklung mit dem Mixed Reality Toolkit (MRTK) konfigurieren und das MRTK importieren.In this tutorial, you'll learn how to create a new Unity project, configure it for Mixed Reality Toolkit (MRTK) development, and import MRTK. Außerdem werden Sie durch Konfiguration, Erstellung und Bereitstellung einer einfachen Unity-Szene aus Visual Studio auf Ihrer HoloLens 2 geführt.You'll also walk through configuring, building, and deploying a basic Unity scene from Visual Studio to your HoloLens 2. Nachdem Sie diese auf Ihrer HoloLens 2 bereitgestellt haben, sollten Sie ein Gittermodell für die Raumzuordnung sehen, das die Oberflächen bedeckt, die von der HoloLens erkannt wurden.Once you have deployed it to your HoloLens 2, you should see a spatial mapping mesh covering the surfaces that are perceived by the HoloLens. Darüber hinaus sollten Sie Indikatoren auf Ihren Händen und Fingern für die Handverfolgung und einen Frameratenzähler zum Überwachen der App-Leistung sehen.Additionally, you should see indicators on your hands and fingers for hand tracking and a frame rate counter for keeping an eye on app performance.

ZieleObjectives

  • Erfahren, wie Unity für die HoloLens-Entwicklung konfiguriert wirdLearn how to configure Unity for HoloLens development
  • Erfahren, wie Ihre App erstellt und in HoloLens bereitgestellt wirdLearn how to build and deploy your app to HoloLens
  • Kennenlernen des Gittermodells für die Raumzuordnung, der Hand-Meshes und des Frameratenzählers auf dem HoloLens 2-GerätExperience the spatial mapping mesh, hand meshes, and the framerate counter on HoloLens 2 device

Erstellen des Unity-ProjektsCreating the Unity project

Starten Sie Unity Hub, wählen Sie die Registerkarte Projects (Projekte) aus, und klicken Sie auf den Abwärtspfeil neben der Schaltfläche New (Neu):Launch Unity Hub, select the Projects tab, and click the down arrow next to the New button:

Unity-Hub mit hervorgehobener Schaltfläche „New“

Wählen Sie in der Dropdownliste die Unity-Version aus, die oben in den Voraussetzungen angegeben ist:In the dropdown, select the Unity version specified in the Prerequisites:

Unity-Hub mit Versionsauswahl-Dropdown „NEW“

Tipp

Wenn diese bestimmte Unity-Version nicht auf dem Unity Hub verfügbar ist, können Sie die Installation aus dem Downloadarchiv von Unity einleiten.If the particular Unity version is not available in Unity Hub, you can initiate the installation from Unity's Download Archive.

Erstellen Sie im Fenster ein neues Projekt:In the Create a new project window:

  • Vergewissern Sie sich, dass Templates (Vorlagen) auf 3D festgelegt istEnsure Templates is set to 3D
  • Geben Sie einen passenden Project Name (Projektnamen) ein, z. B. MRTK-TutorialsEnter a suitable Project Name, for example, MRTK Tutorials
  • Wählen Sie eine geeignete Location (Speicherort) zum Speichern Ihres Projekts, z. B. D:\MixedRealityLearningChoose a suitable Location to store your project, for example, D:\MixedRealityLearning
  • Klicken Sie auf die Schaltfläche Create (Erstellen), um das neue Unity-Projekt zu erstellenClick the Create button to create and launch your new Unity project

Unity-Hub mit ausgefülltem Fenster „Create new project“ (Neues Projekt erstellen)

Achtung

Wenn Sie unter Windows arbeiten, müssen Sie den MAX_PATH-Grenzwert von 255 Zeichen beachten.When working on Windows, there is a MAX_PATH limit of 255 characters. Daher sollten Sie das Unity-Projekt in der Nähe des Stammverzeichnisses des Laufwerks speichern.Consequently, you should save the Unity project close to the root of the drive.

Warten Sie, bis Unity das Projekt erstellt hat:Wait for Unity to create the project:

Unity: Erstellen eines neuen Projekts in Bearbeitung

Wechseln der BuildplattformSwitching the build platform

Wählen Sie im Unity-Menü File > Build Settings... (Datei > Buildeinstellungen...) aus, um das Fenster Build Settings (Buildeinstellungen) zu öffnen:In the Unity menu, select File > Build Settings... to open the Build Settings window:

Unity: Build Settings... Menüpfad

Wählen Sie im Build Settings-Fenster Universal Windows Platform (Universelle Windows-Plattform) aus, und klicken Sie auf die Schaltfläche Switch Platform (Plattform wechseln):In the Build Settings window, select Universal Windows Platform and click the Switch Platform button:

Unity-Fenster „Build Settings“ mit ausgewählter UWP, um von der Plattform „Eigenständig“ zu wechseln

Warten Sie, bis Unity den Wechsel der Plattform abgeschlossen hat:Wait for Unity to finish switching the platform:

Unity: Wechsel der Plattform in Bearbeitung

Wenn Unity den Plattformwechsel abgeschlossen hat, klicken Sie auf das rote x-Symbol, um das Build Settings-Fenster zu schließen:When Unity has finished switching the platform, click the red x icon to close the Build Settings window:

Unity-Fenster „Build“ mit hervorgehobenem Symbol zum Schließen

Importieren der TextMeshPro Essential-RessourcenImporting the TextMeshPro Essential Resources

Wählen Sie im Unity-Menü Window > TextMeshPro > Import TMP Essential Resources (Fenster > TextMeshPro > TMP Essential Resources importieren) aus, um das Importfenster für Unity-Pakete zu öffnen:In the Unity menu, select Window > TextMeshPro > Import TMP Essential Resources to open the Import Unity Package window:

Unity: Menüpfad für „Import TMP Essential Resources“

Klicken Sie im Import Unity Package-Fenster (Unity-Paket importieren) auf die Schaltfläche All (Alle), um sicherzustellen, dass alle Assets ausgewählt sind, und klicken Sie dann auf die Schaltfläche Import (Importieren), um die Assets zu importieren:In the Import Unity Package window, click the All button to ensure all the assets are selected, then click the Import button to import the assets:

Unity-Fenster für Importieren von „TMP Essential Resources“

Tipp

Die TextMeshPro Essential-Ressourcen sind für die Benutzeroberflächenelemente des MRTK erforderlich.The TextMeshPro Essential Resources are required by MRTK's UI elements. Sie können diesen Schritt überspringen, wenn Sie nicht beabsichtigen, die Benutzeroberflächenelemente des MRTK in Ihrem Projekt zu verwenden.You can skip this step if you are not planning to use MRTK's UI elements in your project.

Importieren des Mixed Reality-ToolkitsImporting the Mixed Reality Toolkit

Zum Importieren des Mixed Reality-Toolkits in das Unity-Projekt müssen Sie das Mixed Reality-Featuretool verwenden, das Entwicklern das Erkennen, Aktualisieren und Hinzufügen von Mixed Reality-Featurepaketen zu Unity-Projekten ermöglicht.To Import Mixed Reality Toolkit into the Unity Project you will have to use Mixed Reality Feature Tool which allows developers to discover, update, and add Mixed Reality feature packages into Unity projects. Sie können Pakete vor dem Importieren nach Name oder Kategorie durchsuchen, ihre Abhängigkeiten anzeigen und sogar Änderungsvorschläge für Ihre Projektmanifestdatei anzeigen.You can search packages by name or category, see their dependencies, and even view proposed changes to your projects manifest file before importing.

Laden Sie die neueste Version des Mixed Reality-Featuretools aus dem Microsoft Download Center herunter. Wenn der Download abgeschlossen ist, entpacken Sie die Datei, und speichern Sie sie auf Ihrem Desktop.Download the latest version of the Mixed Reality Feature Tool from the Microsoft Download Center, When the download is complete, unzip the file and save it to your desktop.

Hinweis

Installieren Sie die .NET 5.0 Runtime, damit Sie das Mixed Reality-Featuretool ausführen können.Before you can run the Mixed Reality Feature Tool please instal .NET 5.0 runtime

Hinweis

Das Mixed Reality-Featuretool kann zurzeit nur unter Windows ausgeführt werden. Wenn Sie MacOS verwenden, befolgen Sie diese Vorgehensweise, um das Mixed Reality-Toolkit herunterzuladen und in das Unity-Projekt zu importieren.The Mixed Reality Feature Tool currently only runs on Windows, For MacOS please follow this procedure to download and import the Mixed Reality Toolkit into the unity project.

Öffnen Sie die ausführbare Datei MixedRealityFeatureTool aus dem heruntergeladenen Ordner, um das Mixed Reality-Featuretool zu starten.Open the executable file MixedRealityFeatureTool from the downloaded folder to launch the Mixed Reality Feature Tool.

Öffnen von MixedRealityFeatureTool

Klicken Sie nach dem Öffnen von MixedRealityFeatureTool auf „Start“ um mit dem Mixed Reality-Featuretool loszulegen.Once MixedRealityFeatureTool is opened click on start to get started with Mixed Reality Feature Tool.

MixedRealityFeatureTool

Die Features sind nach Kategorie gruppiert, damit sie leichter zu finden sind. Klicken Sie auf das Dropdownmenü Mixed Reality-Toolkit, um Pakete im Zusammenhang mit dem Mixed Reality-Toolkit zu finden.Features are grouped by category to make things easier to find, click on Mixed Reality Toolkit dropdown to find packages relating to the Mixed Reality Toolkit.

MixedRealityFeatureTool-Fenster

Aktivieren Sie die Mixed Reality Toolkit Foundation, und klicken Sie auf die Dropdownliste daneben, um die erforderliche MRTK-Version auszuwählen. Wählen Sie für diese Tutorialreihe 2.5.3 aus.check the Mixed Reality Toolkit Foundation, and click on the dropdown next to it to select the required MRTK version, for this tutorial series please select 2.5.3. Klicken Sie dann auf die Schaltfläche Get Features (Features abrufen), um die ausgewählten Pakete herunterzuladen.then click on Get features button to download the selected packages.

Auswählen von Mixed Reality Foundation

Das ausgewählte Paket Mixed Reality Toolkit Foundation 2.5.3 wird zusammen mit seinem Abhängigkeitspaket Mixed Reality Toolkit Standard Assets 2.5.3 im Fenster Import Features (Features importieren) angezeigt.Selected package Mixed Reality Toolkit Foundation 2.5.3 is presented, along with its dependence package Mixed Reality Toolkit Standard Assets 2.5.3 in the Import Features window.

Sie müssen darüber hinaus den Speicherort des Unity-Zielprojekts festlegen. Zum Angeben des Projektpfads klicken Sie auf die Drei Punkte neben dem Projektpfad, und wechseln Sie im Explorer zu Ihrem Projektordner, beispielsweise D:\MixedRealityLearning\MRTK Tutorials.You also need to set the location of the target unity project to provide the Project path, click on the Three dots next to the Project path and browse to your project folder in the explorer for example D:\MixedRealityLearning\MRTK Tutorials.

Hinweis

Das Dialogfeld, das angezeigt wird, wenn Sie das Dateisystem nach dem Unity-Projektordner durchsuchen, enthält '' als den Dateinamen.The dialog that's displayed when browsing for the Unity project folder contains '' as the file name. Es muss ein Wert für den Dateinamen vorhanden sein, um die Auswahl des Ordners zu ermöglichen.There must be a value for the file name to enable the folder to be selected.

Klicken Sie dann auf die Schaltfläche Validate (Überprüfen), um das ausgewählte Paket zu überprüfen, Es wird ein Popupfenster mit der Nachricht No validation issues were detected (Bei der Überprüfung wurden keine Probleme erkannt) angezeigt. Klicken Sie auf OK, um das Popup zu schließen, und klicken Sie auf die Schaltfläche Import (Importieren).Next click on the Validate button to validate the selected package, you will get a popup with message No validation issues were detected click on OK to close the popup and click on Import button.

Überprüfen der Mixed Reality Foundation

Klicken Sie auf die Schalftläche Approve (Genehmigen), um dem Projekt das Mixed Reality-Toolkit hinzuzufügen.Click on Approve Button to add the Mixed Reality Toolkit into the project.

Genehmigen von Mixed Reality Foundation

Konfigurieren des Unity-ProjektsConfiguring the Unity project

1. Übernehmen der Einstellungen des MRTK-Projektkonfigurators1. Apply the MRTK Project Configurator settings

Nachdem Unity das Importieren des Pakets aus dem vorherigen Abschnitt abgeschlossen hat, sollte das Fenster des MRTK-Projektkonfigurators angezeigt werden.After Unity has finished importing the package from the previous section, the MRTK Project Configurator window should appear. Wenn das nicht der Fall ist, öffnen Sie es, indem Sie zu Mixed Reality Toolkit > Utilities > Configure Unity Project (Mixed Reality-Toolkit > Hilfsprogramme > Unity-Projekt konfigurieren) wechseln:If it doesn't, you can manually open it by going to Mixed Reality Toolkit > Utilities > Configure Unity Project:

Unity: Menüpfad für „Configure Unity Project“

Klappen Sie im Projektkonfiguratorfenster des MRTK den Abschnitt Modify Configurations (Konfigurationen ändern) auf, vergewissern Sie sich, dass alle Optionen aktiviert sind, und klicken Sie auf die Schaltfläche Apply (Übernehmen), um die Einstellungen zu übernehmen:In the MRTK Project Configurator window, expand the Modify Configurations section, ensure all options are checked, and click the Apply button to apply the settings:

Unity MRTK-Projektkonfigurator-Fenster

Tipp

Die Anwendung der MRTK-Standardeinstellungen ist optional, wird aber dringend empfohlen, weil es bei der Konfiguration einiger empfohlener Unity-Einstellungen hilfreich ist:Applying the MRTK Default Settings is optional but strongly recommended as it will help configure some recommended Unity settings:

  • Legen Sie den Single Pass-instanziierten Renderingpfad fest: Verbessert die Grafikleistung, indem die Renderpipeline für beide Augen im selben Zeichnen-Aufruf ausgeführt wird.Set Single Pass Instanced rendering path: Improves graphics performance by executing the render pipeline for both eyes in the same draw call. Weitere Informationen zu diesem Thema finden Sie im Abschnitt Single Pass-instanziiertes Rendering der Leistungsdokumentation von MRTK.To learn more about this topic, you can refer to the Single-Pass Instanced rendering section of MRTK's Performance documentation.
  • Standardebene für Spatial Awareness (räumliche Wahrnehmung) festlegen: Erstellt eine Unity-Ebene namens „Spatial Awareness“ und konfiguriert MRTK für die Verwendung dieser Ebene für das Gittermodell für räumliche Wahrnehmung.Set default Spatial Awareness layer: Creates a Unity Layer named Spatial Awareness and configures MRTK to use this layer for the spatial awareness mesh. Weitere Informationen zu Unity-Ebenen finden Sie in der Unity-Dokumentation zum Anpassen Ihres Arbeitsbereichs.To learn more about Unity Layers, you can refer to Unity's Customizing Your Workspace documentation.

2. Konfigurieren zusätzlicher Projekteinstellungen2. Configure additional project settings

Wählen Sie im Unity-Menü Edit > Project Settings... (Bearbeiten > Projekteinstellungen...) aus, um das Fenster „Project Settings“ (Projekteinstellungen) zu öffnen:In the Unity menu, select Edit > Project Settings... to open the Project Settings window:

Wählen Sie im Fenster „Project Settings“ (Projekteinstellungen) Player > XR Settings (Player > XR-Einstellungen) aus, aktivieren Sie das Kontrollkästchen Virtual Reality Supported (Virtual Reality unterstützt), klicken Sie auf das + -Symbol, und wählen Sie „Windows Mixed Reality“ aus, um das Windows Mixed Reality SDK hinzuzufügen:In the Project Settings window, select Player > XR Settings and check the Virual Reality Supported checkbox then click the + icon, and select Windows Mixed Reality to add the Windows Mixed Reality SDK:

Unity: XR-Einstellungen mit ausgewähltem „Windows Mixed Reality SDK hinzufügen“

Nachdem Unity das Importieren des Windows Mixed Reality SDK abgeschlossen hat, sollte wieder das Fenster des MRTK-Projektkonfigurators angezeigt werden.After Unity has finished importing the Windows Mixed Reality SDK, the MRTK Project Configurator window should appear again. Geschieht dies nicht, können Sie es manuell aus dem Unity-Menü öffnen, indem Sie zu Mixed Reality Toolkit > Utilities > Configure Unity Project (Mixed Reality-Toolkit > Hilfsprogramme > Konfigurieren) navigieren.If it doesn't, you can manually open it from the Unity menu by going to Mixed Reality Toolkit > Utilities > Configure Unity Project

Verwenden Sie im Fenster des MRTK-Projektkonfigurators die Dropdownliste Audio spatializer (Räumliche Audiowiedergabe), um den MS HRTF Spatializer auszuwählen, und klicken Sie dann auf die Schaltfläche Übernehmen, um die Einstellung zu übernehmen:In the MRTK Project Configurator window, use the Audio spatializer dropdown to select the MS HRTF Spatializer, then click the Apply button to apply the setting:

Unity: XR-Einstellungen mit ausgewähltem „Windows Mixed Reality SDK hinzufügen“

Tipp

Das Festlegen der „Audio Spatializer“-Eigenschaft ist optional, kann aber die Audioerfahrung in Ihrem Projekt verbessern.Setting the Audio spatializer property is optional but may improve the audio experience in your project. Wenn Sie sie auf „MS HRTF Spatializer“ festlegen, wird dieses Spatializer-Plug-In verwendet, wenn die Eigenschaft „AudioSource.spatialize“ von Unity aktiviert ist.If you set it to MS HRTF Spatializer, this spatializer plugin will be used when Unity's AudioSource.spatialize property is enabled. Weitere Informationen zu diesem Thema finden Sie in den Tutorials zur räumlichen Audiowiedergabe.To learn more about this topic, you can refer to the Spatial audio tutorials.

Wählen Sie im Fenster „Project Settings“ (Projekteinstellungen) Player > XR Settings (Player > XR-Einstellungen) aus, und verwenden Sie dann die Dropdownliste Depth Format (Tiefenformat), um 16-Bit Tiefe auszuwählen:In the Project Settings window, select Player > XR Settings, then use the Depth Format dropdown to select 16-bit depth:

Unity: Tiefe 16 aktivieren

Tipp

Das Verringern des Tiefenformats auf 16 Bit ist optional, kann aber bei der Verbesserung der Grafikleistung in Ihrem Projekt helfen.Reducing the Depth Format to 16-bit is optional but my help improve graphics performance in your project. Weitere Informationen zu diesem Thema finden Sie im Abschnitt Tiefenpufferfreigabe (HoloLens) der Leistungsdokumentation des MRTK.To learn more about this topic, you can refer to the Depth buffer sharing (HoloLens) section of MRTK's Performance documentation.

Wählen Sie im Fenster „Project Settings“ (Projekteinstellungen) Player > Publishing Settings (Player > Veröffentlichungseinstellungen) aus, geben Sie dann im Feld Package name (Paketname) einen passenden Namen ein, beispielsweise MRTKTutorials-GettingStarted:In the Project Settings window, select Player > Publishing Settings, then in the Package name field, enter a suitable name, for example, MRTKTutorials-GettingStarted:

Unity: „Publishing Settings“ mit konfiguriertem Paketnamen

Hinweis

Der Paketname stellt den eindeutigen Bezeichner für die App dar.The 'Package name' is the unique identifier for the app. Sie sollten diesen Bezeichner ändern, bevor Sie die App bereitstellen, um das Überschreiben zuvor installierter Apps zu vermeiden.You should change this identifier before deploying the app to avoid overwriting previously installed apps.

Tipp

Der „Product Name“ (Produktname) ist der Name, der im HoloLens-Startmenü angezeigt wird.The 'Product Name' is the name displayed in the HoloLens Start menu. Um das Auffinden der App während der Entwicklung zu erleichtern, fügen Sie vor dem Namen einen Unterstrich hinzu, sodass sie in Listen oben einsortiert wird.To make the app easier to locate during development, add an underscore in front of the name to sort it to the top.

Erstellen und Konfigurieren der SzeneCreating and configuring the scene

Wählen Sie im Unity-Menü File > New Scene (Datei > Neue Szene) aus, um eine neue Szene zu erstellen:In the Unity menu, select File > New Scene to create a new scene:

Unity: Menüpfad für „New Scene“

Wählen Sie im Unity-Menü Mixed Reality Toolkit > Add to Scene and Configure... (Mixed Reality-Toolkit > Zu Szene hinzufügen und konfigurieren) aus, um Ihrer aktuellen Szene das MRTK hinzuzufügen:In the Unity menu, select Mixed Reality Toolkit > Add to Scene and Configure... to add the MRTK to your current scene:

Unity: Menüpfad zu „Add to Scene and Configure...“

Überprüfen Sie bei im Hierarchiefenster ausgewähltem MixedRealityToolkit-Objekt im Inspektorfenster, ob das Konfigurationsprofil des Mixed Reality-Toolkits auf DefaultMixedRealityToolkitConfigurationProfile festgelegt ist:With the MixedRealityToolkit object still selected in the Hierarchy window, in the Inspector window, verify that the MixedRealityToolkit configuration profile is set to DefaultMixedRealityToolkitConfigurationProfile:

MixedRealityToolkit-Komponente von Unity mit ausgewähltem DefaultMixedRealityTookitConfigurationProfile

Wählen Sie im Unity-Menü File > Save As... (Datei > Speichern unter...) aus, um das Save Scene-Fenster (Szene speichern) zu öffnen:In the Unity menu, select File > Save As... to open the Save Scene window:

Unity: Menüpfad für „Save As...“

Navigieren Sie im Save Scene-Fenster zum Ordner Scenes (Szenen), geben Sie Ihrer Szene einen passenden Namen, beispielsweise ErsteSchritte, und klicken Sie auf die Schaltfläche Save (Speichern), um die Szene zu speichern:In the Save Scene window, navigate to your project's Scenes folder, give your scene a suitable name, for example, GettingStarted, and click the Save button to save the scene:

Unity: Aufforderungsfenster zum Speichern der Szene

Erstellen Ihrer Anwendung auf der HoloLens 2Building your application to your HoloLens 2

1. Erstellen des Unity-Projekts1. Build the Unity project

Wählen Sie im Unity-Menü File > Build Settings... (Datei > Buildeinstellungen...) aus, um das Fenster Build Settings (Buildeinstellungen) zu öffnen.In the Unity menu, select File > Build Settings... to open the Build Settings window.

Klicken Sie im Build Settings-Fenster (Buildeinstellungen) auf die Schaltfläche Add Open Scenes (Geöffnete Szenen hinzufügen), um der Liste Scenes In Build (Szenen im Build) Ihre aktuelle Szene hinzuzufügen, und klicken Sie dann auf die Schaltfläche Build (Erstellen), um das Build Universal Windows Platform-Fenster (Erstellen für Universelle Windows-Plattform) zu öffnen:In the Build Settings window, click the Add Open Scenes button to add your current scene to the Scenes In Build list, then click the Build button to open the Build Universal Windows Platform window:

Unity-Fenster „Build Settings“ mit ausgewählter UWP

Wählen Sie im Build Universal Windows Platform-Fenster einen passenden Speicherort aus, um Ihren Build zu speichern, beispielsweise D:\MixedRealityLearning\Builds, erstellen Sie einen neuen Ordner mit einem passenden Namen, z. B. GettingStarted, und klicken Sie dann auf die Schaltfläche Select Folder (Ordner auswählen), um den Buildvorgang zu starten:In the Build Universal Windows Platform window, choose a suitable location to store your build, for example, D:\MixedRealityLearning\Builds, create a new folder and give it a suitable name, for example, GettingStarted, and then click the Select Folder button to start the build process:

Unity-Fenster „Build Settings“ mit Aufforderungsfenster zum Auswählen eines Ordners

Warten Sie, bis Unity den Buildvorgang abgeschlossen hat:Wait for Unity to finish the build process:

Unity: Buildvorgang wird ausgeführt

2. Erstellen und Bereitstellen der Anwendung2. Build and deploy the application

Wenn der Buildvorgang abgeschlossen ist, fordert Unity den Windows Datei-Explorer auf, den Speicherort zu öffnen, in dem Sie den Build gespeichert haben.When the build process has completed, Unity will prompt Windows File Explorer to open the location you stored the build. Navigieren Sie zum Ordner, und doppelklicken Sie auf die Projektmappendatei, um sie in Visual Studio zu öffnen:Navigate inside the folder, and double-click the solution file to open it in Visual Studio:

Windows-Explorer mit neu erstellter, ausgewählter Visual Studio-Projektmappe

Hinweis

Wenn Sie von Visual Studio zur Installation neuer Komponenten aufgefordert werden, nehmen Sie sich einen Moment Zeit, um zu überprüfen, ob alle erforderlichen Komponenten (wie in der Dokumentation Installieren der Tools angegeben) installiert sind.If Visual Studio asks you to install new components, take a moment to check that you have all the prerequisite components in the Install the Tools documentation.

Konfigurieren Sie Visual Studio für HoloLens 2, indem Sie die Master- oder Release-Konfiguration, die ARM64-Architektur und Gerät als Ziel auswählen:Configure Visual Studio for HoloLens by selecting the Master or Release configuration, the ARM64 architecture, and Device as target:

Visual Studio, konfiguriert für die Bereitstellung in HoloLens 2

Tipp

Wenn Sie auf HoloLens (1. Generation) bereitstellen, wählen Sie die x86-Architektur aus.If you're deploying to HoloLens (1st generation), select the x86 architecture.

Hinweis

Für HoloLens erstellen Sie normalerweise für die ARM-Architektur.For HoloLens, you will typically build for the ARM architecture. Jedoch besteht ein bekanntes Problem in Unity 2019.3, das zu Fehlern führt, wenn ARM in Visual Studio als Buildarchitektur ausgewählt wird.However, there is a known issue in Unity 2019.3 that causes errors when selecting ARM as the build architecture in Visual Studio. Die empfohlene Umgehung besteht darin, Builds für ARM64 zu erstellen.The recommended workaround is to build for ARM64. Wenn diese Option nicht in Frage kommt, navigieren Sie zu Edit > Project Settings > Player > Other Settings (Bearbeiten > Projekteinstellungen > Player > Weitere Einstellungen), und deaktivieren Sie Graphics Jobs (Grafikaufträge).If that is not an option, go to Edit > Project Settings > Player > Other Settings and disable Graphics Jobs.

Hinweis

Wenn „Device“ (Gerät) nicht als Zieloption angezeigt wird, müssen Sie möglicherweise das Startprojekt für die Visual Studio-Projektmappe vom Projekt „IL2CPP“ zum Projekt „UWP“ ändern.If you don't see Device as a target option, you may need to change the startup project for the Visual Studio solution from the IL2CPP project to the UWP project. Klicken Sie dazu im Projektmappen-Explorer mit der rechten Maustaste auf den Namen Ihres Projekts (Universal Windows), und wählen Sie Set as StartUp Project (Als Startprojekt festlegen) aus.To do this, in the Solution Explorer, right-click on YourProjectName (Universal Windows) and select Set as StartUp Project.

Verbinden Sie Ihre HoloLens mit Ihrem Computer, wählen Sie dann Debug > Start Without Debugging (Debuggen > Ohne Debuggen starten) aus, um zu erstellen und auf Ihrem Gerät bereitzustellen:Connect your HoloLens to your computer, then select Debug > Start Without Debugging to build and deploy to your device:

Visual Studio-Menüpfad für „Ohne Debuggen starten“

Wichtig

Bevor Sie den Build für Ihr Gerät erstellen, muss das Gerät in den Entwicklermodus versetzt und mit Ihrem Entwicklungscomputer gekoppelt werden.Before building to your device, the device must be in Developer Mode and paired with your development computer. Sie können beide Schritte ausführen, indem Sie diese Anweisungen befolgen.Both of these steps can be completed by following these instructions.

Tipp

Sie können auch auf dem HoloLens Emulator bereitstellen oder ein App-Paket zum Querladen erstellen.You can also deploy to the HoloLens Emulator or create an App Package for sideloading.

Bei der Option „Start Without Debugging“ (Ohne Debuggen starten) wird die App auf Ihrem Gerät automatisch ohne angefügten Visual Studio-Debugger gestartet.Using Start Without Debugging automatically starts the app on your device without the Visual Studio debugger attached.

Wählen Sie Build > Deploy Solution (Erstellen > Projektmappe bereitstellen) aus, um die Anwendung auf Ihrem Gerät bereitzustellen, ohne dass sie automatisch gestartet wird.Select Build > Deploy Solution to deploy to your device without having the app start automatically.

Hinweis

Möglicherweise fällt Ihnen in der App die Diagnoseprofilerstellung auf. Sie können sie mithilfe des Sprachbefehls Toggle Diagnostics (Diagnose ein-/ausschalten) ein- und ausblenden.You may notice the Diagnostics profiler in the app, which you can toggle on or off by using the speech command Toggle Diagnostics. Es empfiehlt sich, während der Entwicklung den Profiler die meiste Zeit anzuzeigen, um zu verstehen, wann Änderungen an der App die Leistung beeinträchtigen können.It's recommended that you keep the profiler visible most of the time during development to understand when changes to the app may impact performance. Beispielsweise sollten HoloLens-Apps durchgängig bei 60 FPS ausgeführt werden.For example, HoloLens apps should continuously run at 60 FPS.

Herzlichen Glückwunsch!Congratulations

Sie haben jetzt Ihre erste HoloLens-App bereitgestellt.You've now deployed your first HoloLens app. Während Sie sich in ihr bewegen, sollten Sie ein Gittermodell für die Raumzuordnung sehen, das die Oberflächen bedeckt, die von der HoloLens erkannt wurden.As you walk around, you should see a spatial mapping mesh covering the surfaces that are perceived by the HoloLens. Darüber hinaus sollten Sie Indikatoren auf Ihren Händen und Fingern für die Handverfolgung und einen Frameratenzähler zum Überwachen der App-Leistung sehen.Additionally, you should see indicators on your hands and fingers for hand tracking and a frame rate counter for keeping an eye on app performance. Diese Features sind nur einige der grundlegenden Bestandteile von MRTK.These features are just a few foundational pieces included with MRTK. In den bevorstehenden Tutorials fügen Sie Ihrer Szene Inhalte hinzu, um die Funktionen von HoloLens und des MRTK kennenzulernen.In the upcoming tutorials, you'll add content to your scene to explore the capabilities of HoloLens and the MRTK.