Erstellen einer einseitigen xamarin. Forms-AnwendungCreate a Single Page Xamarin.Forms Application

Beispiel herunterladen Das Beispiel herunterladenDownload Sample Download the sample

In dieser Schnellstartanleitung erfahren Sie Folgendes:In this quickstart, you will learn how to:

  • Erstellen Sie eine plattformübergreifende xamarin. Forms-Anwendung.Create a cross-platform Xamarin.Forms application.
  • Definieren Sie die Benutzeroberfläche für eine Seite mithilfe von XAML (Extensible Application Markup Language).Define the user interface for a page using eXtensible Application Markup Language (XAML).
  • Interaktion mit XAML-Benutzeroberflächen Elementen aus dem Code.Interact with XAML user interface elements from code.

In der Schnellstartanleitung erfahren Sie, wie Sie eine plattformübergreifende xamarin. Forms-Anwendung erstellen, die es Ihnen ermöglicht, einen Hinweis einzugeben und ihn im Gerätespeicher beizubehalten.The quickstart walks through how to create a cross-platform Xamarin.Forms application, which enables you to enter a note and persist it to device storage. Die fertige Anwendung wird unten gezeigt:The final application is shown below:

Erforderliche VoraussetzungenPrerequisites

  • Visual Studio 2019 (neueste Version) mit installierter Mobile-Entwicklung mit .net -Arbeitsauslastung.Visual Studio 2019 (latest release), with the Mobile development with .NET workload installed.
  • Kenntnisse von C#.Knowledge of C#.
  • optionale Ein gekoppelter Mac zum Erstellen der Anwendung unter IOS.(optional) A paired Mac to build the application on iOS.

Weitere Informationen zu diesen Voraussetzungen finden Sie unter Installieren von xamarin.For more information about these prerequisites, see Installing Xamarin. Informationen zum Verbinden von Visual Studio 2019 mit einem Mac-Buildhost finden Sie unter Durchführen einer Kopplung mit einem Mac für die Xamarin.iOS-Entwicklung.For information about connecting Visual Studio 2019 to a Mac build host, see Pair to Mac for Xamarin.iOS development.

Einstieg in Visual Studio 2019Get started with Visual Studio 2019

  1. Starten Sie Visual Studio 2019, und klicken Sie im Startfenster auf Neues Projekt erstellen , um ein neues Projekt zu erstellen:Launch Visual Studio 2019, and in the start window click Create a new project to create a new project:

  2. Wählen Sie im Fenster Neues Projekt erstellen in der Dropdown-Dropdown-Dropdown- Datei die Option Mobil aus, wählen Sie die Vorlage Mobile App (xamarin. Forms) aus, und klicken Sie auf die Schaltfläche weiterIn the Create a new project window, select Mobile in the Project type drop down, select the Mobile App (Xamarin.Forms) template, and click the Next button:

  3. Legen Sie im Fenster Neues Projekt konfigurieren den Projektnamen auf Notizenfest, wählen Sie einen geeigneten Speicherort für das Projekt aus, und klicken Sie auf die Schaltfläche Erstellen :In the Configure your new project window, set the Project name to Notes, choose a suitable location for the project, and click the Create button:

    Wichtig

    Für die C#- und XAML-Codeausschnitte in diesem Schnellstart ist es erforderlich, dass die Projektmappe Notes genannt wird.The C# and XAML snippets in this quickstart requires that the solution is named Notes. Die Verwendung eines anderen Namens führt zu Buildfehlern, wenn Sie Code aus diesem Schnellstart in die Projektmappe kopieren.Using a different name will result in build errors when you copy code from this quickstart into the solution.

  4. Klicken Sie im Dialogfeld neue plattformübergreifende App auf leere App, und klicken Sie dann auf die Schaltfläche OK :In the New Cross Platform App dialog, click Blank App, and click the OK button:

    Weitere Informationen zur .NET Standard-Bibliothek, die erstellt wird, finden Sie unter Aufbau einer Xamarin.Forms-Anwendung im Artikel Ausführliche Erläuterungen zum Xamarin.Forms-Schnellstart.For more information about the .NET Standard library that gets created, see Anatomy of a Xamarin.Forms application in the Xamarin.Forms Quickstart Deep Dive.

  5. Doppelklicken Sie im Projektmappen-Explorer im Projekt Notes auf die Datei MainPage.xaml, um sie zu öffnen:In Solution Explorer, in the Notes project, double-click MainPage.xaml to open it:

  6. Entfernen Sie in MainPage.xaml den gesamten Vorlagencode, und ersetzen Sie ihn durch den folgenden:In MainPage.xaml, remove all of the template code and replace it with the following code:

    <?xml version="1.0" encoding="utf-8"?>
    <ContentPage xmlns="http://xamarin.com/schemas/2014/forms"
                 xmlns:x="http://schemas.microsoft.com/winfx/2009/xaml"
                 x:Class="Notes.MainPage">
        <StackLayout Margin="10,35,10,10">
            <Label Text="Notes"
                   HorizontalOptions="Center"
                   FontAttributes="Bold" />
            <Editor x:Name="editor"
                    Placeholder="Enter your note"
                    HeightRequest="100" />
            <Grid>
                <Grid.ColumnDefinitions>
                    <ColumnDefinition Width="*" />
                    <ColumnDefinition Width="*" />
                </Grid.ColumnDefinitions>
                <Button Text="Save"
                        Clicked="OnSaveButtonClicked" />
                <Button Grid.Column="1"
                        Text="Delete"
                        Clicked="OnDeleteButtonClicked"/>
            </Grid>
        </StackLayout>
    </ContentPage>
    

    Mit diesem Code wird die Benutzeroberfläche für die Seite deklarativ definiert, die aus einer Label zum Anzeigen von Text, einer Editor für die Texteingabe und zwei Button Instanzen besteht, die die Anwendung anweisen, eine Datei zu speichern oder zu löschen.This code declaratively defines the user interface for the page, which consists of a Label to display text, an Editor for text input, and two Button instances that direct the application to save or delete a file. Die beiden Button-Instanzen sind horizontal in einem Grid angeordnet, wobei die Label, Editor und Grid vertikal in einem StackLayout angeordnet sind.The two Button instances are horizontally laid out in a Grid, with the Label, Editor, and Grid being vertically laid out in a StackLayout. Weitere Informationen zum Erstellen der Benutzeroberfläche finden Sie unter User Interface in the xamarin. Forms Quick Start Deep Dive.For more information about creating the user interface, see User interface in the Xamarin.Forms Quickstart Deep Dive.

    Speichern Sie die Änderungen an MainPage.xaml, indem Sie STRG+S drücken, und schließen Sie die Datei.Save the changes to MainPage.xaml by pressing CTRL+S, and close the file.

  7. Erweitern Sie MainPage.xaml im Projektmappen-Explorer im Projekt Notes, und doppelklicken Sie dann auf die Datei MainPage.xaml.cs, um sie zu öffnen:In Solution Explorer, in the Notes project, expand MainPage.xaml and double-click MainPage.xaml.cs to open it:

  8. Entfernen Sie in MainPage.xaml.cs den gesamten Vorlagencode, und ersetzen Sie ihn durch den folgenden:In MainPage.xaml.cs, remove all of the template code and replace it with the following code:

    using System;
    using System.IO;
    using Xamarin.Forms;
    
    namespace Notes
    {
        public partial class MainPage : ContentPage
        {
            string _fileName = Path.Combine(Environment.GetFolderPath(Environment.SpecialFolder.LocalApplicationData), "notes.txt");
    
            public MainPage()
            {
                InitializeComponent();
    
                if (File.Exists(_fileName))
                {
                    editor.Text = File.ReadAllText(_fileName);
                }
            }
    
            void OnSaveButtonClicked(object sender, EventArgs e)
            {
                File.WriteAllText(_fileName, editor.Text);
            }
    
            void OnDeleteButtonClicked(object sender, EventArgs e)
            {
                if (File.Exists(_fileName))
                {
                    File.Delete(_fileName);
                }
                editor.Text = string.Empty;
            }
        }
    }
    

    Dieser Code definiert ein _fileName-Feld, das auf eine Datei namens notes.txt verweist, die Notes-Daten im lokalen Anwendungsdatenordner der Anwendung speichert.This code defines a _fileName field, which references a file named notes.txt that will store note data in the local application data folder for the application. Wenn der Seitenkonstruktor ausgeführt wird, wird die Datei gelesen, falls sie vorhanden, und im Editor angezeigt.When the page constructor is executed the file is read, if it exists, and displayed in the Editor. Wenn die auf Speichern Button gedrückt haben, wird der OnSaveButtonClicked-Ereignishandler ausgeführt wird der Inhalt des Editor in die Datei gespeichert.When the Save Button is pressed the OnSaveButtonClicked event handler is executed, which saves the content of the Editor to the file. Wenn Sie auf LöschenButton gedrückt haben, wird der OnDeleteButtonClicked-Ereignishandler ausgeführt, sodass die Datei (falls vorhanden) gelöscht und sämtlicher Text aus dem Editor entfernt wird.When the Delete Button is pressed the OnDeleteButtonClicked event handler is executed, which deletes the file, provided that it exists, and removes any text from the Editor. Weitere Informationen zur Benutzerinteraktion finden Sie unter reagieren auf die Benutzerinteraktion im xamarin. Forms-Schnellstart Deep Dive.For more information about user interaction, see Responding to user interaction in the Xamarin.Forms Quickstart Deep Dive.

    Speichern Sie die Änderungen an MainPage.xaml.cs, indem Sie STRG+S drücken, und schließen Sie die Datei.Save the changes to MainPage.xaml.cs by pressing CTRL+S, and close the file.

Erstellen des SchnellstartsBuilding the quickstart

  1. Klicken Sie in Visual Studio auf die Menüelemente Erstellen > Projektmappe erstellen, oder drücken Sie F6.In Visual Studio, select the Build > Build Solution menu item (or press F6). Die Projektmappe wird erstellt, und eine Erfolgsmeldung wird in der Statusleiste von Visual Studio angezeigt:The solution will build and a success message will appear in the Visual Studio status bar:

    Wenn Fehler auftreten, wiederholen Sie die vorherigen Schritte, und beheben Sie sie, bis die Projektmappe erfolgreich erstellt wird.If there are errors, repeat the previous steps and correct any mistakes until the solution builds successfully.

  2. Klicken Sie in der Symbolleiste von Visual Studio auf Starten (die dreieckige Wiedergabetaste), um die Anwendung in Ihrem ausgewählten Android-Emulator zu starten:In the Visual Studio toolbar, press the Start button (the triangular button that resembles a Play button) to launch the application in your chosen Android emulator:

    Geben Sie eine Notiz ein, und drücken Sie auf die Schaltfläche Speichern.Enter a note and press the Save button.

    Weitere Informationen zur Art und Weise, wie die Anwendung auf jeder Plattform gestartet wird, finden Sie unter " Starten der Anwendung auf jeder Plattform " in der Schnellstartanleitung zu xamarin. Forms.For more information about how the application is launched on each platform, see Launching the application on each platform in the Xamarin.Forms Quickstart Deep Dive.

    Hinweis

    Die folgenden Schritte sollten nur durchgeführt werden, wenn Sie einen gekoppelten Mac haben, der die Systemanforderungen für die Entwicklung von Xamarin.Forms erfüllt.The following steps should only be carried out if you have a paired Mac that meets the system requirements for Xamarin.Forms development.

  3. Klicken Sie in der Visual Studio-Symbolleiste mit der rechten Maustaste auf das Projekt Notes.iOS, und wählen Sie Als Startprojekt festlegen aus.In the Visual Studio toolbar, right-click on the Notes.iOS project, and select Set as StartUp Project.

  4. Drücken Sie in der Symbolleiste von Visual Studio die Schaltfläche Start (die dreieckige Schaltfläche, die einer Play-Taste ähnelt), um die Anwendung in dem von Ihnen gewählten iOS-Remotesimulator zu starten:In the Visual Studio toolbar, press the Start button (the triangular button that resembles a Play button) to launch the application in your chosen iOS remote simulator:

    Geben Sie eine Notiz ein, und drücken Sie auf die Schaltfläche Speichern.Enter a note and press the Save button.

    Weitere Informationen zur Art und Weise, wie die Anwendung auf jeder Plattform gestartet wird, finden Sie unter " Starten der Anwendung auf jeder Plattform " in der Schnellstartanleitung zu xamarin. Forms.For more information about how the application is launched on each platform, see Launching the application on each platform in the Xamarin.Forms Quickstart Deep Dive.

Erforderliche VoraussetzungenPrerequisites

  • Visual Studio 2017 mit installierter Mobile-Entwicklung mit .net -Arbeitsauslastung.Visual Studio 2017, with the Mobile development with .NET workload installed.
  • Kenntnisse von C#.Knowledge of C#.
  • optionale Ein gekoppelter Mac zum Erstellen der Anwendung unter IOS.(optional) A paired Mac to build the application on iOS.

Weitere Informationen zu diesen Voraussetzungen finden Sie unter Installieren von xamarin.For more information about these prerequisites, see Installing Xamarin. Informationen zum Verbinden von Visual Studio 2019 mit einem Mac-Buildhost finden Sie unter Durchführen einer Kopplung mit einem Mac für die Xamarin.iOS-Entwicklung.For information about connecting Visual Studio 2019 to a Mac build host, see Pair to Mac for Xamarin.iOS development.

Einstieg in Visual Studio 2017Get started with Visual Studio 2017

  1. Starten Sie Visual Studio 2017, und klicken Sie auf der Startseite auf Neues Projekt erstellen... , um ein neues Projekt zu erstellen:Launch Visual Studio 2017, and on the start page click Create new project... to create a new project:

  2. Klicken Sie im Dialogfeld Neues Projekt auf Plattformübergreifend, wählen Sie die Vorlage Mobile App (Xamarin.Forms) aus, geben Sie für „Name“ Notes ein, wählen Sie einen geeigneten Speicherort für das Projekt aus, und klicken Sie auf OK:In the New Project dialog, click Cross-Platform, select the Mobile App (Xamarin.Forms) template, set the Name to Notes, choose a suitable location for the project and click the OK button:

    Wichtig

    Für die C#- und XAML-Codeausschnitte in diesem Schnellstart ist es erforderlich, dass die Projektmappe Notes genannt wird.The C# and XAML snippets in this quickstart requires that the solution is named Notes. Die Verwendung eines anderen Namens führt zu Buildfehlern, wenn Sie Code aus diesem Schnellstart in die Projektmappe kopieren.Using a different name will result in build errors when you copy code from this quickstart into the solution.

  3. Klicken Sie im Dialogfeld New Cross Platform App (Neue plattformübergreifende App) auf Leere App, wählen Sie .NET Standard als Strategie für die Codefreigabe aus, und klicken Sie auf OK:In the New Cross Platform App dialog, click Blank App, select .NET Standard as the Code Sharing Strategy, and click the OK button:

    Weitere Informationen zur .NET Standard-Bibliothek, die erstellt wird, finden Sie unter Aufbau einer Xamarin.Forms-Anwendung im Artikel Ausführliche Erläuterungen zum Xamarin.Forms-Schnellstart.For more information about the .NET Standard library that gets created, see Anatomy of a Xamarin.Forms application in the Xamarin.Forms Quickstart Deep Dive.

  4. Doppelklicken Sie im Projektmappen-Explorer im Projekt Notes auf die Datei MainPage.xaml, um sie zu öffnen:In Solution Explorer, in the Notes project, double-click MainPage.xaml to open it:

  5. Entfernen Sie in MainPage.xaml den gesamten Vorlagencode, und ersetzen Sie ihn durch den folgenden:In MainPage.xaml, remove all of the template code and replace it with the following code:

    <?xml version="1.0" encoding="utf-8"?>
    <ContentPage xmlns="http://xamarin.com/schemas/2014/forms"
                 xmlns:x="http://schemas.microsoft.com/winfx/2009/xaml"
                 x:Class="Notes.MainPage">
        <StackLayout Margin="10,35,10,10">
            <Label Text="Notes"
                   HorizontalOptions="Center"
                   FontAttributes="Bold" />
            <Editor x:Name="editor"
                    Placeholder="Enter your note"
                    HeightRequest="100" />
            <Grid>
                <Grid.ColumnDefinitions>
                    <ColumnDefinition Width="*" />
                    <ColumnDefinition Width="*" />
                </Grid.ColumnDefinitions>
                <Button Text="Save"
                        Clicked="OnSaveButtonClicked" />
                <Button Grid.Column="1"
                        Text="Delete"
                        Clicked="OnDeleteButtonClicked"/>
            </Grid>
        </StackLayout>
    </ContentPage>
    

    Mit diesem Code wird die Benutzeroberfläche für die Seite deklarativ definiert, die aus einer Label zum Anzeigen von Text, einer Editor für die Texteingabe und zwei Button Instanzen besteht, die die Anwendung anweisen, eine Datei zu speichern oder zu löschen.This code declaratively defines the user interface for the page, which consists of a Label to display text, an Editor for text input, and two Button instances that direct the application to save or delete a file. Die beiden Button-Instanzen sind horizontal in einem Grid angeordnet, wobei die Label, Editor und Grid vertikal in einem StackLayout angeordnet sind.The two Button instances are horizontally laid out in a Grid, with the Label, Editor, and Grid being vertically laid out in a StackLayout. Weitere Informationen zum Erstellen der Benutzeroberfläche finden Sie unter User Interface in the xamarin. Forms Quick Start Deep Dive.For more information about creating the user interface, see User interface in the Xamarin.Forms Quickstart Deep Dive.

    Speichern Sie die Änderungen an MainPage.xaml, indem Sie STRG+S drücken, und schließen Sie die Datei.Save the changes to MainPage.xaml by pressing CTRL+S, and close the file.

  6. Erweitern Sie MainPage.xaml im Projektmappen-Explorer im Projekt Notes, und doppelklicken Sie dann auf die Datei MainPage.xaml.cs, um sie zu öffnen:In Solution Explorer, in the Notes project, expand MainPage.xaml and double-click MainPage.xaml.cs to open it:

  7. Entfernen Sie in MainPage.xaml.cs den gesamten Vorlagencode, und ersetzen Sie ihn durch den folgenden:In MainPage.xaml.cs, remove all of the template code and replace it with the following code:

    using System;
    using System.IO;
    using Xamarin.Forms;
    
    namespace Notes
    {
        public partial class MainPage : ContentPage
        {
            string _fileName = Path.Combine(Environment.GetFolderPath(Environment.SpecialFolder.LocalApplicationData), "notes.txt");
    
            public MainPage()
            {
                InitializeComponent();
    
                if (File.Exists(_fileName))
                {
                    editor.Text = File.ReadAllText(_fileName);
                }
            }
    
            void OnSaveButtonClicked(object sender, EventArgs e)
            {
                File.WriteAllText(_fileName, editor.Text);
            }
    
            void OnDeleteButtonClicked(object sender, EventArgs e)
            {
                if (File.Exists(_fileName))
                {
                    File.Delete(_fileName);
                }
                editor.Text = string.Empty;
            }
        }
    }
    

    Dieser Code definiert ein _fileName-Feld, das auf eine Datei namens notes.txt verweist, die Notes-Daten im lokalen Anwendungsdatenordner der Anwendung speichert.This code defines a _fileName field, which references a file named notes.txt that will store note data in the local application data folder for the application. Wenn der Seitenkonstruktor ausgeführt wird, wird die Datei gelesen, falls sie vorhanden, und im Editor angezeigt.When the page constructor is executed the file is read, if it exists, and displayed in the Editor. Wenn die auf Speichern Button gedrückt haben, wird der OnSaveButtonClicked-Ereignishandler ausgeführt wird der Inhalt des Editor in die Datei gespeichert.When the Save Button is pressed the OnSaveButtonClicked event handler is executed, which saves the content of the Editor to the file. Wenn Sie auf LöschenButton gedrückt haben, wird der OnDeleteButtonClicked-Ereignishandler ausgeführt, sodass die Datei (falls vorhanden) gelöscht und sämtlicher Text aus dem Editor entfernt wird.When the Delete Button is pressed the OnDeleteButtonClicked event handler is executed, which deletes the file, provided that it exists, and removes any text from the Editor. Weitere Informationen zur Benutzerinteraktion finden Sie unter reagieren auf die Benutzerinteraktion im xamarin. Forms-Schnellstart Deep Dive.For more information about user interaction, see Responding to user interaction in the Xamarin.Forms Quickstart Deep Dive.

    Speichern Sie die Änderungen an MainPage.xaml.cs, indem Sie STRG+S drücken, und schließen Sie die Datei.Save the changes to MainPage.xaml.cs by pressing CTRL+S, and close the file.

Erstellen des SchnellstartsBuilding the quickstart

  1. Klicken Sie in Visual Studio auf die Menüelemente Erstellen > Projektmappe erstellen, oder drücken Sie F6.In Visual Studio, select the Build > Build Solution menu item (or press F6). Die Projektmappe wird erstellt, und eine Erfolgsmeldung wird in der Statusleiste von Visual Studio angezeigt:The solution will build and a success message will appear in the Visual Studio status bar:

    Wenn Fehler auftreten, wiederholen Sie die vorherigen Schritte, und beheben Sie sie, bis die Projektmappe erfolgreich erstellt wird.If there are errors, repeat the previous steps and correct any mistakes until the solution builds successfully.

  2. Klicken Sie in der Symbolleiste von Visual Studio auf Starten (die dreieckige Wiedergabetaste), um die Anwendung in Ihrem ausgewählten Android-Emulator zu starten:In the Visual Studio toolbar, press the Start button (the triangular button that resembles a Play button) to launch the application in your chosen Android emulator:

    Geben Sie eine Notiz ein, und drücken Sie auf die Schaltfläche Speichern.Enter a note and press the Save button.

    Weitere Informationen zur Art und Weise, wie die Anwendung auf jeder Plattform gestartet wird, finden Sie unter " Starten der Anwendung auf jeder Plattform " in der Schnellstartanleitung zu xamarin. Forms.For more information about how the application is launched on each platform, see Launching the application on each platform in the Xamarin.Forms Quickstart Deep Dive.

    Hinweis

    Die folgenden Schritte sollten nur durchgeführt werden, wenn Sie einen gekoppelten Mac haben, der die Systemanforderungen für die Entwicklung von Xamarin.Forms erfüllt.The following steps should only be carried out if you have a paired Mac that meets the system requirements for Xamarin.Forms development.

  3. Klicken Sie in der Visual Studio-Symbolleiste mit der rechten Maustaste auf das Projekt Notes.iOS, und wählen Sie Als Startprojekt festlegen aus.In the Visual Studio toolbar, right-click on the Notes.iOS project, and select Set as StartUp Project.

  4. Drücken Sie in der Symbolleiste von Visual Studio die Schaltfläche Start (die dreieckige Schaltfläche, die einer Play-Taste ähnelt), um die Anwendung in dem von Ihnen gewählten iOS-Remotesimulator zu starten:In the Visual Studio toolbar, press the Start button (the triangular button that resembles a Play button) to launch the application in your chosen iOS remote simulator:

    Geben Sie eine Notiz ein, und drücken Sie auf die Schaltfläche Speichern.Enter a note and press the Save button.

    Weitere Informationen zur Art und Weise, wie die Anwendung auf jeder Plattform gestartet wird, finden Sie unter " Starten der Anwendung auf jeder Plattform " in der Schnellstartanleitung zu xamarin. Forms.For more information about how the application is launched on each platform, see Launching the application on each platform in the Xamarin.Forms Quickstart Deep Dive.

Erforderliche VoraussetzungenPrerequisites

  • Visual Studio für Mac (neueste Version) mit installierter IOS-und Android-Platt Form Unterstützung.Visual Studio for Mac (latest release), with iOS and Android platform support installed.
  • Xcode (neueste Version).Xcode (latest release).
  • Kenntnisse von C#.Knowledge of C#.

Weitere Informationen zu diesen Voraussetzungen finden Sie unter Installieren von xamarin.For more information about these prerequisites, see Installing Xamarin.

Erste Schritte mit Visual Studio für MacGet started with Visual Studio for Mac

  1. Starten Sie Visual Studio für Mac, und klicken Sie im Startfenster auf neu , um ein neues Projekt zu erstellen:Launch Visual Studio for Mac, and in the start window click New to create a new project:

  2. Klicken Sie im Dialogfeld Vorlage für neues Projekt auswählen auf Multi-Plattform > App, wählen Sie die Vorlage Leere Forms-App aus, und klicken Sie auf Weiter:In the Choose a template for your new project dialog, click Multiplatform > App, select the Blank Forms App template, and click the Next button:

  3. Benennen Sie im Dialog Leere Formularanwendung konfigurieren die neue Anwendung mit Notes, stellen Sie sicher, dass die Option .NET-Standard verwenden ausgewählt ist, und klicken Sie auf die Schaltfläche Weiter:In the Configure your Blank Forms app dialog, name the new app Notes, ensure that the Use .NET Standard radio button is selected, and click the Next button:

  4. Behalten Sie im Dialogfeld Ihre neue leere Formularanwendung konfigurieren die Namen für die Projektmappe und das Projekt als Notes bei, wählen Sie einen passenden Speicherort für das Projekt, und klicken Sie auf die Schaltfläche Erstellen, um das Projekt zu erstellen:In the Configure your new Blank Forms app dialog, leave the Solution and Project names set to Notes, choose a suitable location for the project, and click the Create button to create the project:

    Wichtig

    Die C#- und XAML-Codeausschnitte in diesem Schnellstart erfordern, dass die Projektmappe und das Projekt beide den Namen Notes tragen.The C# and XAML snippets in this quickstart requires that the solution and project are both named Notes. Die Verwendung eines anderen Namens führt zu Buildfehlern, wenn Sie Code aus diesem Schnellstart in das Projekt kopieren.Using a different name will result in build errors when you copy code from this quickstart into the project.

    Weitere Informationen zur .NET Standard-Bibliothek, die erstellt wird, finden Sie unter Aufbau einer Xamarin.Forms-Anwendung im Artikel Ausführliche Erläuterungen zum Xamarin.Forms-Schnellstart.For more information about the .NET Standard library that gets created, see Anatomy of a Xamarin.Forms application in the Xamarin.Forms Quickstart Deep Dive.

  5. Doppelklicken Sie im Lösungspad im Projekt Notes auf die Datei MainPage.xaml, um sie zu öffnen:In the Solution Pad, in the Notes project, double-click MainPage.xaml to open it:

  6. Entfernen Sie in MainPage.xaml den gesamten Vorlagencode, und ersetzen Sie ihn durch den folgenden:In MainPage.xaml, remove all of the template code and replace it with the following code:

    <?xml version="1.0" encoding="utf-8"?>
    <ContentPage xmlns="http://xamarin.com/schemas/2014/forms"
                 xmlns:x="http://schemas.microsoft.com/winfx/2009/xaml"
                 x:Class="Notes.MainPage">
        <StackLayout Margin="10,35,10,10">
            <Label Text="Notes"
                   HorizontalOptions="Center"
                   FontAttributes="Bold" />
            <Editor x:Name="editor"
                    Placeholder="Enter your note"
                    HeightRequest="100" />
            <Grid>
                <Grid.ColumnDefinitions>
                    <ColumnDefinition Width="*" />
                    <ColumnDefinition Width="*" />
                </Grid.ColumnDefinitions>
                <Button Text="Save"
                        Clicked="OnSaveButtonClicked" />
                <Button Grid.Column="1"
                        Text="Delete"
                        Clicked="OnDeleteButtonClicked"/>
            </Grid>
        </StackLayout>
    </ContentPage>
    

    Mit diesem Code wird die Benutzeroberfläche für die Seite deklarativ definiert, die aus einer Label zum Anzeigen von Text, einer Editor für die Texteingabe und zwei Button Instanzen besteht, die die Anwendung anweisen, eine Datei zu speichern oder zu löschen.This code declaratively defines the user interface for the page, which consists of a Label to display text, an Editor for text input, and two Button instances that direct the application to save or delete a file. Die beiden Button-Instanzen sind horizontal in einem Grid angeordnet, wobei die Label, Editor und Grid vertikal in einem StackLayout angeordnet sind.The two Button instances are horizontally laid out in a Grid, with the Label, Editor, and Grid being vertically laid out in a StackLayout. Weitere Informationen zum Erstellen der Benutzeroberfläche finden Sie unter User Interface in the xamarin. Forms Quick Start Deep Dive.For more information about creating the user interface, see User interface in the Xamarin.Forms Quickstart Deep Dive.

    Speichern Sie die Änderungen an MainPage.xaml, indem Sie auf Datei > Speichern klicken (oder indem Sie ⌘+S drücken), und schließen Sie die Datei.Save the changes to MainPage.xaml by choosing File > Save (or by pressing ⌘ + S), and close the file.

  7. Erweitern Sie MainPage.xaml im Lösungspad im Projekt Notes, und doppelklicken Sie dann auf die Datei MainPage.xaml.cs, um sie zu öffnen:In the Solution Pad, in the Notes project, expand MainPage.xaml and double-click MainPage.xaml.cs to open it:

  8. Entfernen Sie in MainPage.xaml.cs den gesamten Vorlagencode, und ersetzen Sie ihn durch den folgenden:In MainPage.xaml.cs, remove all of the template code and replace it with the following code:

    using System;
    using System.IO;
    using Xamarin.Forms;
    
    namespace Notes
    {
        public partial class MainPage : ContentPage
        {
            string _fileName = Path.Combine(Environment.GetFolderPath(Environment.SpecialFolder.LocalApplicationData), "notes.txt");
    
            public MainPage()
            {
                InitializeComponent();
    
                if (File.Exists(_fileName))
                {
                    editor.Text = File.ReadAllText(_fileName);
                }
            }
    
            void OnSaveButtonClicked(object sender, EventArgs e)
            {
                File.WriteAllText(_fileName, editor.Text);
            }
    
            void OnDeleteButtonClicked(object sender, EventArgs e)
            {
                if (File.Exists(_fileName))
                {
                    File.Delete(_fileName);
                }
                editor.Text = string.Empty;
            }
        }
    }
    

    Dieser Code definiert ein _fileName-Feld, das auf eine Datei namens notes.txt verweist, die Notes-Daten im lokalen Anwendungsdatenordner der Anwendung speichert.This code defines a _fileName field, which references a file named notes.txt that will store note data in the local application data folder for the application. Wenn der Seitenkonstruktor ausgeführt wird, wird die Datei gelesen, falls sie vorhanden, und im Editor angezeigt.When the page constructor is executed the file is read, if it exists, and displayed in the Editor. Wenn die auf Speichern Button gedrückt haben, wird der OnSaveButtonClicked-Ereignishandler ausgeführt wird der Inhalt des Editor in die Datei gespeichert.When the Save Button is pressed the OnSaveButtonClicked event handler is executed, which saves the content of the Editor to the file. Wenn Sie auf LöschenButton gedrückt haben, wird der OnDeleteButtonClicked-Ereignishandler ausgeführt, sodass die Datei (falls vorhanden) gelöscht und sämtlicher Text aus dem Editor entfernt wird.When the Delete Button is pressed the OnDeleteButtonClicked event handler is executed, which deletes the file, provided that it exists, and removes any text from the Editor. Weitere Informationen zur Benutzerinteraktion finden Sie unter reagieren auf die Benutzerinteraktion im xamarin. Forms-Schnellstart Deep Dive.For more information about user interaction, see Responding to user interaction in the Xamarin.Forms Quickstart Deep Dive.

    Speichern Sie die Änderungen an MainPage.xaml.cs, indem Sie auf Datei > Speichern klicken (oder indem Sie ⌘+S drücken), und schließen Sie die Datei.Save the changes to MainPage.xaml.cs by choosing File > Save (or by pressing ⌘ + S), and close the file.

Erstellen des SchnellstartsBuilding the quickstart

  1. Wählen Sie in Visual Studio für Mac die Menüelemente Erstellen > Alle erstellen aus, oder drücken Sie ⌘+B.In Visual Studio for Mac, select the Build > Build All menu item (or press ⌘ + B). Das Projekt wird erstellt, und in der Symbolleiste von Visual Studio für Mac wird eine Erfolgsmeldung angezeigt.The projects will build and a success message will appear in the Visual Studio for Mac toolbar.

    Wenn Fehler auftreten, wiederholen Sie die vorherigen Schritte, und beheben Sie sie, bis das Projekt erfolgreich erstellt wird.If there are errors, repeat the previous steps and correct any mistakes until the projects build successfully.

  2. Wählen Sie im Lösungspaddas Projekt Notes. IOS aus, klicken Sie mit der rechten Maustaste, und wählen Sie als Startprojekt festlegenaus:In the Solution Pad, select the Notes.iOS project, right-click, and select Set As Startup Project:

  3. Klicken Sie in der Symbolleiste von Visual Studio für Mac auf Starten (die dreieckige Schaltfläche, die einer Wiedergabetaste ähnelt), um die Anwendung im ausgewählten iOS-Simulator zu starten:In the Visual Studio for Mac toolbar, press the Start button (the triangular button that resembles a Play button) to launch the application inside your chosen iOS Simulator:

    Geben Sie eine Notiz ein, und drücken Sie auf die Schaltfläche Speichern.Enter a note and press the Save button.

    Weitere Informationen zur Art und Weise, wie die Anwendung auf jeder Plattform gestartet wird, finden Sie unter " Starten der Anwendung auf jeder Plattform " in der Schnellstartanleitung zu xamarin. Forms.For more information about how the application is launched on each platform, see Launching the application on each platform in the Xamarin.Forms Quickstart Deep Dive.

  4. Wählen Sie im Lösungspaddas Projekt Notes. Droid aus, klicken Sie mit der rechten Maustaste, und wählen Sie als Startprojekt festlegenaus:In the Solution Pad, select the Notes.Droid project, right-click, and select Set As Startup Project:

  5. Klicken Sie in der Symbolleiste von Visual Studio für Mac auf Starten (die dreieckige Schaltfläche, die einer Wiedergabetaste ähnelt), um die Anwendung im ausgewählten Android-Emulator zu starten:In the Visual Studio for Mac toolbar, press the Start button (the triangular button that resembles a Play button) to launch the application inside your chosen Android emulator:

    Geben Sie eine Notiz ein, und drücken Sie auf die Schaltfläche Speichern.Enter a note and press the Save button.

    Weitere Informationen zur Art und Weise, wie die Anwendung auf jeder Plattform gestartet wird, finden Sie unter " Starten der Anwendung auf jeder Plattform " in der Schnellstartanleitung zu xamarin. Forms.For more information about how the application is launched on each platform, see Launching the application on each platform in the Xamarin.Forms Quickstart Deep Dive.

Nächste SchritteNext steps

In dieser Schnellstartanleitung haben Sie Folgendes gelernt:In this quickstart, you learned how to:

  • Erstellen Sie eine plattformübergreifende xamarin. Forms-Anwendung.Create a cross-platform Xamarin.Forms application.
  • Definieren Sie die Benutzeroberfläche für eine Seite mithilfe von XAML (Extensible Application Markup Language).Define the user interface for a page using eXtensible Application Markup Language (XAML).
  • Interaktion mit XAML-Benutzeroberflächen Elementen aus dem Code.Interact with XAML user interface elements from code.

Fahren Sie mit dem nächsten Schnellstart fort, um diese Single-Page-Anwendung in eine Anwendung mit mehreren Seiten umzuwandeln.To turn this single page application into a multi-page application, continue to the next quickstart.