Access Denied message in the Report Viewer in Business Portal for Microsoft Dynamics SL

This article provides a solution to an Access Denied message that displays when you try to print or export a report by using the report viewer on a Business Portal center page.

Applies to:   Microsoft Dynamics SL 2011
Original KB number:   2790389

Symptoms

When you try to print or export a report by using the report viewer on a Business Portal center page, you may receive an error message that resembles the following one:

Access denied. Error in File 6d948fe1-9c3d-4b8b-ae1c-e960e689072d {0CAC72C2-BC49-43B9-83A4-85D206A99313}.rpt: Access to report file denied. Another program may be using it.

Cause

The report viewer doesn't have Read permissions to the temp directory in the application pool identity's profile.

Resolution

Create a Windows profile for the Application Pool identity on the Web server and then assign Read permissions to the Everyone group to the temp directory contained in the profile. To do it, follow these steps:

  1. Sign in to the web server where Business Portal is installed by using the Windows credentials of the application pool identity that is associated with the site that Business Portal is installed on.

  2. Browse to the temp directory in the application pool identity's profile. C:\Users\<USER NAME>\AppData\Local\Temp

  3. Right-click the Temp directory and then select Properties.

  4. On the Security tab, select Edit and then select Add.

  5. Select Locations, locate to the web server's name, and then select OK.

  6. Type Everyone in the Enter the object names to select box and then select OK.

  7. Select Apply and then select OK.

More information

To determine the name of the identity user for the application pool that Business Portal is using, follow these steps:

  1. Select Start, select All Programs, select Administrative Tools, and then select Internet Information Services (IIS) Manager.

  2. In IIS Manager, expand the server name, and then select Application Pools.

  3. Right-click the name of the Application Pool that is associated with the site that is hosting Business Portal, select Advanced Settings and note the Identity value.