Get started with Visual Studio and Unity

Note

This guide assumes you already have installed Unity using the Unity Hub program. If you are new to Unity, we recommend visiting Unity Learn and complete the Unity Essentials learning path first.

Install Unity support for Visual Studio

Visual Studio Tools for Unity is a free extension that provides support for writing and debugging C# and more. Visit the Tools for Unity overview for a complete list of what the extensions includes.

Note

This installation guide is for Visual Studio. If you're using Visual Studio Code, please visit the Unity Development with VS Code documentation.

  1. Download the Visual Studio installer, or run it if already installed.

  2. Click Modify (if already installed) or Install (for new installations) for your desired version of Visual Studio.

  3. On the Workloads tab, scroll to the Gaming section and select the Game development with Unity workload.

    Game development with Unity workload box in the installer

Note

This installation guide is for Visual Studio for Mac. If you're using Visual Studio Code, please visit the Unity Development with VS Code documentation.

Tools for Unity is included with the installation of Visual Studio for Mac and no separate installation steps are required. You can verify this in the Visual Studio for Mac > Extensions > Game Development menu. Visual Studio for Mac Tools for Unity should be enabled.

Extension Manager view showing Visual Studio for Mac Tools for Unity enabled

Check for updates

It's recommended to keep Visual Studio and Visual Studio for Mac updated so you have the latest bug fixes, features, and Unity support. This doesn't require an update of Unity versions.

  1. Click the Help > Check for Updates menu.

    The Check for Updates menu in Visual Studio 2019

  2. If there is an update available, the Visual Studio Installer will show a new version. Click the Update button.

  1. Click the Visual Studio for Mac > Check for Updates... menu to open the Visual Studio Update dialog.
  2. If there is an update available, click the Install button.

Configure Unity to use Visual Studio

By default, Unity should already be configured to use Visual Studio or Visual Studio for Mac as a script editor. You can confirm this or change the external script editor to a specific version of Visual Studio from the Unity Editor.

  1. In the Unity Editor, select the Edit > Preferences menu..

  2. Select the External Tools tab on the left.

  3. The External Script Editor dropdown list provides a way to choose different installations of Visual Studio. You can also click Browse... from the dropdown list to add an unlisted version.

    The External Tools preference menu in the Unity Editor on Windows

  4. If Browse... was selected, navigate to the Common7/IDE directory inside your Visual Studio installation directory and select devenv.exe. Then, click Open.

  5. Once Visual Studio is selected in the External Script Editor list, confirm that the Editor Attaching checkbox is selected.

  6. Close the Preferences dialog to complete the configuration process.

  1. In the Unity Editor, select the Unity > Preferences menu..

  2. Select the External Tools tab on the left.

  3. The External Script Editor dropdown list provides a way to choose different installations of Visual Studio. You can also click Browse... from the dropdown list to add an unlisted version.

    The External Tools preference menu in the Unity Editor on macOS

  4. Close the Preferences dialog to complete the configuration process.

Next steps

To learn how to work with and debug your Unity project in Visual Studio, visit Using Visual Studio Tools for Unity.