question

thp avatar image
1 Vote"
thp asked ·

Using ACR across subscriptions with Web App for Containers fails

I'm unable to get a docker image from ACR in app service that lives in a different subscription.

To Reproduce

  1. Create ACR in one subscription, add container

  2. Add Web App for Containers in another subscription

  3. Since the ACR won't show up in the Web App dropdown menu, enter connection details in private registry tab and save

  4. Exit and re-enter container settings

  5. The settings were moved to the Azure Container Registry tab and are not working => no image is being deployed

Expected behavior

The settings should stay in the private registry tab and a container should be pulled from ACR.

Setting the DOCKER_REGISTRY_SERVER_URL, DOCKER_REGISTRY_SERVER_USERNAME & DOCKER_REGISTRY_SERVER_PASSWORD values in the app config directly does not work.

Any relevant environment information

  • Azure Portal

Additional context

Issue is also being discussed here https://github.com/Azure/acr/issues/345 and here https://github.com/microsoft/vscode-docker/issues/743

azure-webapps
· 1
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @thp,

When you created your ACR, did you enable 'Admin' access on the registry and supplied the credentials ?

3583-2020-02-28-17-00-21-testingdevspaceacr-access-keys.png

What log output are you getting when your webapp container blade?

0 Votes 0 · ·

0 Answers