question

MichaelWiskman-8614 avatar image
MichaelWiskman-8614 asked ·

Unable to add more than one DAG member server in Exchange Server 2019.

From EAC, creating DAG itself worked with no issues. Then we went ahead and added first mailbox server to the DAG without problems. This is where the problems begin. We are unable to add more servers.

A server-side database availability group administrative operation failed. Error The operation failed. CreateCluster errors may result from incorrectly configured static addresses. Error: An error occurred while attempting a cluster operation. Error: Cluster API failed: "AddClusterNode() (MaxPercentage=100) failed with 0x5b4. Error: This operation returned because the timeout period expired". [Server: server.domain.com]

Event 1146 Microsoft-Windows-FailoverClustering
The cluster Resource Hosting Subsystem (RHS) process was terminated and will be restarted. This is typically associated with cluster health detection and recovery of a resource. Refer to the System event log to determine which resource and resource DLL is causing the issue.

We have been following this article https://www.xpertstec.com/how-to-configure-a-database-availability-group-dag-in-exchange-server-2019/

CNO has Exchange Trusted Subsystem assigned with “Full Control”
Local Administrator Group has Exchange Trusted Subsystem assigned with “Full Control”
The Cluster Name can update the DNS record.


[1]: https://www.xpertstec.com/how-to-configure-a-database-availability-group-dag-in-exchange-server-2019/


office-exchange-server-administrationoffice-exchange-server-itprooffice-exchange-server-deployment
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

YukiSun-MSFT avatar image
YukiSun-MSFT answered ·

Hi @MichaelWiskman-8614,

Then we went ahead and added first mailbox server to the DAG without problems. This is where the problems begin. We are unable to add more servers.

Were all the mailbox servers built using a same base image which has been installed with all the prerequisites including Failover Cluster Manager? If this is the case, it's suggested to try removing and reinstalling the Failover Cluster Manager feature for the other mailbox servers you want to add into the DAG and see if the error can be resolved. The Failover Cluster Manager feature can be removed and installed via the Server Manager:
26246-1.png

Here is a blog with the same error message for reference: Incorrectly Configured Static Address when creating a DAG.
Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.


If an Answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


1.png (77.0 KiB)
4 comments Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Thank you for your answer. We have allaredan tried to reinstall the Failover Cluster Manager and the DAG. We have also started with a base image of each server with the most up-to-date CU. Any more suggetions?

0 Votes 0 · ·
YukiSun-MSFT avatar image YukiSun-MSFT MichaelWiskman-8614 ·

@MichaelWiskman-8614, Please have a check on a problematic node and make sure DHCP Client service is in the running status:

26247-1.png

With that confirmed, I'd suggest running a validate test in cluster on the problematic node to see if there is any error in the test result:

 Test-Cluster

Besides, based on my research, this error could also be related to firewall or anti-malware software, so if you have any kind of security software installed, it's recommended to try temporarily disabling them on both nodes and see if the DAG member can be added successfully.


If an Answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


0 Votes 0 · ·
1.png (3.0 KiB)

We have tested most of what we can find using Google without success. But I attach the log from the cluster log. As you can see, something is happening at the port 3343.


26843-cluster-log-anonymous.txt


0 Votes 0 · ·
YukiSun-MSFT avatar image YukiSun-MSFT MichaelWiskman-8614 ·

Thanks @MichaelWiskman-8614 for the cluster log. From the log, it seems to me that this could be related to some sort of network communications glitch between the two nodes. I tried to search using some keywords like "routeInfo is nullptr" from the log but hardly find any information useful. During my research, I noticed that "route is not in routeDb" in your log file was included in the logs shared in this thread from the archived WindowsClustering forum. From the discussion there, it's also mentioned to check the network issue between the nodes.

Additionally, it's suggested to run the Validate a Configuration Wizard for both nodes, this can help check the configuration in a variety of ways and generates a Validation report.


0 Votes 0 · ·
AshokM-8240 avatar image
AshokM-8240 answered ·

Hi,

Can you please try the below steps and see if that helps,

  1. Is there any firewall between the exchange servers? - If so, try allowing Any-any rule between the exchange servers and add it again

  2. Turn off windows firewall if its on and try

  3. Uninstall the failover cluster manager, disable IPv6 using registry, reboot the server and then try adding it

Disabling IPv6 using registry, HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\TCPIP6\Parameters
Set DisabledComponents to ffffffff

Please Note: Take the backup of the registry before making changes and be careful in the changes as the improper configuration would lead to other issues.

Also, its not recommended to disable IPv6, this is only for addressing this issue and check if this resolves. I fixed the similar issue in an environment by disabling IPv6 and once the node is added successfully, I re-enabled it again.






Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

MichaelWiskman-8614 avatar image
MichaelWiskman-8614 answered ·

Thank you for your answers. As I said, have tested most things. Has now escalated it to Microsoft Support. I will write here if they find the solution. Then it can always be helpful to someone else.

1 comment Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.


Has now escalated it to Microsoft Support. I will write here if they find the solution. Then it can always be helpful to someone else.

Thanks @MichaelWiskman-8614 for letting us know the current status of this issue. Hopefully it can be resolved soon! And it's really appreciated that you are willing to keep us posted with the solution, that would definitely be beneficial to others reading this thread.

0 Votes 0 · ·