question

chrisrdba avatar image
0 Votes"
chrisrdba asked AnuragSharma-MSFT commented

Azure firewall exclusion not working.

Greetings. I've got two Azure SQL servers/ databases, one for DEV and one for Prod.

Each server has the same firewall rules set up. We have a developer that can access DEV w no problem, but cannot access Prod and it throws up the normal "your IP address does not have access to the server....." message.

Even though his IP address is within a exclusion known range, I tried adding his IP specifically to it's own new exclusion JIC -- no dice.

Any ideas?

azure-sql-databaseazure-firewall
· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @chrisrdba, welcome to Microsoft Q&A forum.

This issue looks strange. I tried creating 2 databases and was able to connect to both. Assuming that both the databases have similar configuration. Could you please help us with below information?

  1. How are you trying to connect to databases, through SDK or any other way?

  2. Are you using Azure Sql Database as PaaS?

  3. Are both the databases on same server or different server?





0 Votes 0 ·

1) The person having the issue is simply trying to connect from SSMS, the same way he's connecting to DEV.

2) Azure SQL database.

3) Different servers, both created by me.

0 Votes 0 ·

Hi @chrisrdba, I was trying the similar configuration you provided above but could not see any issue.

Is it possible that the production database is sitting behind a VNET?. You can check it as mentioned in below screenshot:


26913-image.png


0 Votes 0 ·
image.png (51.6 KiB)

0 Answers