question

JeffersonCo-5101 avatar image
0 Votes"
JeffersonCo-5101 asked ·

RD Gateway High Availability

Hi,

The current setup was users are able to access most of the servers using the public IP which I know is unsafe. So I have this project to setup a Remote Desktop Gateway so we can take out the NAT'ed public IP's
I already setup one RD Gateway and it's currently working. I'd like to setup a server farm for 2 RD Gateway. I added RDG-2 to RDG-1 and status shows 'unreachable' Cannot determine number of connections. Same as when I added RDG-1 to RDG-2 server farm, shows the same error message, not sure where or what I'm missing.

Thanks

windows-remote-desktop-services
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

KarlieWeng-MSFT avatar image
1 Vote"
KarlieWeng-MSFT answered ·

Hey @JeffersonCo-5101

Please check the following:
1) Is the newly added gateway server linked to your Active Directory?
2) Have you add all the RD gateway servers to the server farm?
3) Does the server has RD Gateway server role installed?

I followed the instruction below to set up RDgateway HA:
https://docs.microsoft.com/en-us/windows-server/remote/remote-desktop-services/rds-rdweb-gateway-ha

The certificate needs to be re-installed.


28244-image.png

Also this need to configured on each RD Gateway server:

28245-image.png28178-image.png




If the Answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

Best Regards
Karlie






image.png (43.8 KiB)
image.png (44.0 KiB)
image.png (40.3 KiB)
· 3 · Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hello @JeffersonCo-5101

Good day!

I'm just following up to make sure you received my last reply.

You can enable email notifications for a variety of different events in Microsoft Q&A:
https://docs.microsoft.com/en-us/answers/articles/67444/email-notifications.html

If you have any further questions or suggestions about this case, please let me know.

If the Answer is helpful, please click "Accept Answer" and upvote it.

Best Regards
Karlie

0 Votes 0 · ·

I was able to add it to the Server Farm tab with both status as 'OK' So I went ahead and proceeded with installing Microsoft NLB to load balance the 2 RD Gateways. My new issue is I do have a cluster with a cluster IP. But everytime I used the cluster internet name, it doesn't work. Just shows me 'There was a problem connecting the remote resource'.

0 Votes 0 · ·

Hi,
Please use these 2 links to help you check the configuration steps:

How to Configure Network Load Balancing In Windows Server 2019
Step by step NLB cluster installation and configuration

If it doesn’t help, would you please provide more details and screenshots for further troubleshoot.

Thanks
Karlie

0 Votes 0 · ·
JeffersonCo-5101 avatar image
0 Votes"
JeffersonCo-5101 answered ·

I spun up 2 VM's and my objective is to setup RD gateway HA. GW01: 192.168.2.51GW02: 192.168.2.52
Both are installed with Win Server 2019 Std. Fully patch. Installed RD Gateway role and both have been added to 'Server Farm' tab under RD Gateway properties and bot shows 'OK' status. 1. Connection Auth: enabled with domain users and domain admins groups added under 'Requirements', Device Redirection: enabled. 2. Resource Auth: added both groups domain users and domain admins, Network Resource: allow users to connect to any network resource, Allow Ports: any port. 3. under NPS > Policies > TS Gateway Auth: Authentication set to Accept users w/o validating credential. 4. under Network policies > Conditions > user groups: add both domain users and admins

Jeff

· Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

JeffersonCo-5101 avatar image
0 Votes"
JeffersonCo-5101 answered ·

Both has valid certificate. Both have been install with NLB and add to a Cluster name: rdgw.domain.com with cluster IP 192.168.2.50, this cluster IP is NAT'ed outside with a WAN IP. Both RD gateways are working individually but if I use the cluster rdgw.domain.com it doesn't work, Just shows me an error msg saying:
There was a problem connecting to the remote resource. Ask your network administrator for help.

· 3 · Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hey Jeff @JeffersonCo-5101

How's everything ?

I cannot find anything wrong in your deployment. Have you find the workaround now? Hope you can share with us.

Thank you!
Karlie

0 Votes 0 · ·

Hi Karlie,

Yes thanks for the follow up and yes every thing is now working fine. So I setup the Server Farm and and it shows both 'OK' for the status. I setup NLB and both shows 'reachable'
Found out that my Remote Desktop Client is somehow broken! It works fine without an RD Gateway but every time I set an RD Gateway then it shows me an error, please refer to this article below.

https://docs.microsoft.com/en-us/answers/questions/112453/weird-remote-desktop-connection-client-issue.html

After trying a different test pc then only to find out that it was already working. Thanks for the inputs and have a great day ahead.

Jeff

0 Votes 0 · ·

Hey Jeff,

Really glad to hear that!

Kindly mark useful reply as answer, which would be much more efficient for other community members to find useful information.

Have a good day ! :)

karlie




0 Votes 0 · ·
JeffersonCo-5101 avatar image
0 Votes"
JeffersonCo-5101 answered ·

sorry had to break it into 2 replies since there's a limit to each reply

· Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.