question

MichaelHaworth-5877 avatar image
0 Votes"
MichaelHaworth-5877 asked DamienLimSingapore-2868 commented

Microsoft Edge Update Aug 2020 - Broken Urls

Hi, Ever since MS Edge 85.0.564.33 has rolled out via Windows updates our icons have changed and stopped working. All we get now is this.

28319-capture2.png


I roll desktop url shortcuts out via GPO and also apply an ICON file to identify specific sites.
In an attempt to fix I have added this into our XML file on netlogon which pushes out via the computer policy.

<Association ApplicationName="Microsoft Edge" ProgId="MSEdgeHTM" Identifier=".html"/>
<Association ApplicationName="Microsoft Edge" ProgId="MSEdgeHTM" Identifier=".htm"/>
<Association ApplicationName="Microsoft Edge" ProgId="MSEdgeHTM" Identifier="http"/>
<Association ApplicationName="Microsoft Edge" ProgId="MSEdgeHTM" Identifier="https"/>
<Association ApplicationName="Microsoft Edge" ProgId="MSEdgeHTM" Identifier=".url"/>

However now all we get is this asking users to reset or choose a browser.

28288-capture.png

This is clearly an issue with the new version of Edge as all my other clients are picking up edge as the default and the urls are working ok.

I'm not after doing this as a reg hack as I need users to be able to choose there own default web browsers. Is there a way to make Edge, as in the new version, the default browser whilst still allowing users to specify a different one if they should so choose?

Thanks
Mick


windows-group-policyms-edge
capture2.png (18.9 KiB)
capture.png (51.2 KiB)
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Change the URL line from MSEdgeHTM to MSEdgeURL

<Association ApplicationName="Microsoft Edge" ProgId="MSEdgeURL" Identifier=".url"/>

tested and work on Chromium Edge version 91

cheers

0 Votes 0 ·
HannahXiong-MSFT avatar image
0 Votes"
HannahXiong-MSFT answered

Hello,

Thank you so much for posting here.

If possible, we could update Microsoft Edge to the latest version 85.0.564.63.

For any question, please feel free to contact us.

Best regards,
Hannah Xiong

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

MichaelHaworth-5877 avatar image
0 Votes"
MichaelHaworth-5877 answered

Hi Hannah,

Thanks for this. I can confirm it works but only after you have done a manual reset.

28665-capture.png



Is there a way to force this via GPO?
Thanks
Mick


capture.png (7.9 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

HannahXiong-MSFT avatar image
0 Votes"
HannahXiong-MSFT answered

Hi Mick,

You are welcome. Thank you so much for your kindly reply.

To set Microsoft Edge as the default browser via GPO, we could configure this policy:

Open the Group Policy editor and go to the Computer Configuration\Administrative Templates\Windows Components\File Explorer.
Select Set a default associations configuration file.
Click policy setting, and then click Enabled.
Under Options:, type the location to your default associations configuration file.
Click OK to save the policy settings.

For more information, we could refer to:
https://docs.microsoft.com/en-us/deployedge/edge-default-browser

For any question, please feel free to contact us.

Best regards,
Hannah Xiong


============================================
If the Answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

MichaelHaworth-5877 avatar image
0 Votes"
MichaelHaworth-5877 answered

Hi Hannah,

Thanks again for your support.

I already have it setup this way but I have Google Chrome set as the default instead of Edge. I have tried with Edge too but the same happens. The browser is set to show as Google Chrome but its not until you click RESET that the icons change back to the correct ico image and the links start to work again.

I must emphasise it only does this if the new version of Edge in installed. One you have pressed RESET and rebooted the machine its ok on version 85.0.564.63, but I cant really have hundreds of users needing to do this themselves. So I just wondered if there was a way to do the RESET bit via GPO? Its almost like the new Edge is superseding what is being set as default. Strange! Maybe a reg hack will do it?

Thanks
Mick

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

HannahXiong-MSFT avatar image
0 Votes"
HannahXiong-MSFT answered

Hi Mick,

You are welcome. Thank you so much for your kindly reply.

We mainly focus on Group Policy issue, so sorry that we are not professional with Microsoft Edge. We have researched but it seems there is no way to do the RESET via GPO since there is no such GPO configuration.

According to our description, we have created and stored a default associations configuration file. This file is stored on a network share. Then we configure the group policy for a default file type and protocol associations configuration file.

Please note: If this setting is enabled and the user's device is domain-joined, the associations configuration file is processed the next time the user signs on.

Since it is configured via GPO, we could check whether the configuration is correct and then run gpresult /h C:\report.html to check whether the policy is applied to the computers.

We also mentioned that the icons changed back to the correct image after clicking RESET. What are these icons and where could we see these icons?

Besides, according to the following official document, the associations file is a little different from yours. Provided information for our reference as shown below.

https://docs.microsoft.com/en-us/deployedge/edge-default-browser (which was provided before)

https://docs.microsoft.com/en-us/microsoftsearch/set-default-browser

I am not sure whether the provided information is helpful or not. Hope it could give us some inspiration. Please forgive me for being unprofessional with Edge. I am trying my best to figure it out.

Thank you so much for your understanding and support.


Best regards,
Hannah Xiong

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.