question

AdamGrzywiski-2229 avatar image
0 Votes"
AdamGrzywiski-2229 asked ·

Windows Server 2019 problem with menu start and blank icons

Hello,

I have a problem with menu start and blank shortcuts in desktop in Windows Server 2019.

In administrator account everything works fine, but when I log in to another user then the start menu does not work and the icons on the desktop are blank. It is impossible to run any shortcut and create a new folder, etc.
User can open explorer and manually opens files from disks.

In event manager i saw an EventID 10010 - The server did not register with DCOM within the required timeout.

I'm trying:
1. sfc /scannow
2. DISM commands
3. Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”} --
4. Deleting SharedAccess keys in HKLM
5. Creating new user with Administrator rights
6. Windows Server full updated

Nothing helped.

If anyone has any suggestions it would be appreciated.

windows-serverwindows-server-2019
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

CarlFan-5627 avatar image
0 Votes"
CarlFan-5627 answered ·

Hi,
You mean that only the built-in administrator user is normal, and even the newly created administrator account, desktop icon is not normal, right?
Have you tried to delete Tile cache and check the result.
Open below locations and confirm that if icon of applications are correctly displays:
%ProgramData%\Microsoft\Windows\Start Menu\Programs
%AppData%\Microsoft\Windows\Start Menu\Programs

Please check below:
1. HKEY_CLASSES_ROOT\lnkfile\shellex\IconHandler, make sure it has subentry as below:
Name: (Default)
Type: REG_SZ
Data: {00021401-0000-0000-c000-000000000046}

  1. Stop explorer.exe via Task Manager.

  2. Deleted iconcache database:
    cd %userprofile%\appdata\local
    attrib -h IconCache.db
    del IconCache.db

Also I saw you found the EventID 10010 in Event Viewer. It refers to DCOM permission. Have you seen the APPID or CLSID? Try to add the DCOM permission in Registry.
Some steps below to add the permission.
https://social.technet.microsoft.com/Forums/windowsserver/en-US/4763f80d-d113-4ddc-8578-01bbf4152e31/event-id-10016-dcom-error-source-microsoftwindowsdistributedcom-level-error?forum=winserverDS

Hope this helps and please help to accept as Answer if the response is useful.
Best Regards,
Carl

·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

AdamGrzywiski-2229 avatar image
0 Votes"
AdamGrzywiski-2229 answered ·

Thanks for your feedback.

Problem was resolved yesterday.
The problem was incorrect permissions on the Root key in the registry.
After changes, everything works fine.

· 1 ·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hello,
What was the issue exactly please? Which key?
Thanks,
Jean-Luc

0 Votes 0 ·