question

Goofoff avatar image
Goofoff asked ·

Azure Vm Extension Stuck?

Can someone give me some guidance on how to get my monitoring extension working?
We did a rename and this new VM is from the previous disk, we are going to have a lot of these in our migration.
Any help is greatly appreciated.
1. yes I have tried to uninstall from the dashboard- it fails
2. I have tried force removing it with PowerShell and it throws some no content error
3. I have one that shows installed and 1 vm that doesn't, they both show the same error.
4. the one that showed installed, I tried uninstalling it, installing manually with workspace id and keys. still nothing.
5. I need this because I can't turn on, disk encryption, update management, inventory, etc..
6. If I get the status in PowerShell all I see is
Extensions[0] :
Name : MicrosoftMonitoringAgent
VMAgent :
VmAgentVersion : Unknown
Statuses[0] :
Code : ProvisioningState/Unavailable
Level : Warning
DisplayStatus : Not Ready
Message : VM status blob is found but not yet populated.
Time : 11/12/19 8:01:54 PM

ANY help would be greatly appreciated. Please. I am out of ideas


azure-virtual-machinesazure-virtual-machines-extensionazure-virtual-machines-monitoring
8 comments
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Whats the base OS of your VM? windows or linux

0 Votes 0 · ·

They are a mix of Server 2012/2016.

0 Votes 0 · ·

In addition to what @jakaruna-MSFT asked, can you provide some specific errors you get from removing it via the portal and PowerShell? That might help narrow it down. Also, based on the last error regarding the VM agent, that might be the issue. You cannot use extensions if the Agent is not working. You can reinstall the agent though which might resolve everything all up. Here is the doc on the VM agent: https://docs.microsoft.com/en-us/azure/virtual-machines/extensions/agent-windows it is for windows but if you are running Linux on the left hand menu there is another option for linux.

0 Votes 0 · ·

If I goto update management/inventory/change tracking, etc..
I receive
"The xxxxxxx solution cannot be enabled"
"The solution cannot be enabled on this virtual machine because VM agent is missing or not responding"

When I try to remove it from the portal through the uninstall option.
"Failed to delete the virtual machine extension
Failed to delete the virtual machine extension 'MicrosoftMonitoringAgent'. Error: error"
PowerShell just says No content and doesn't go anything even if I try the -force switch.

0 Votes 0 · ·

Try logging into the VM then manually installing the Agent. This should replace it with a working version then at which point you could manage the extensions again from the portal:https://docs.microsoft.com/en-us/azure/virtual-machines/extensions/agent-windows#manual-installation

0 Votes 0 · ·
Show more comments

I have tried every suggestion people have made and nothing has worked. I am going to resort to rebuilding the VM

0 Votes 0 · ·

If you like, I can get you in touch with Technical Support to see what they can do. I just would need you to email me at AzCommunity@microsoft.com and provide your SubscriptionID and link to this issue.

0 Votes 0 · ·

1 Answer

WeilKi avatar image
WeilKi answered ·

Hi Goofoff,

i have the same Problem. A Call with the MS Azure Support give me the workaround:
1. Create a Snapshot from the Disk
2. Create a VM from that Disk
3. Don´t install the Extensions Manuel, just enable the Features u need like Diagnostic Settings
4. The Extensions will me installed automaticly

Best Regards,

Kim



2 comments Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Failed during deployment. both agents show unavailable.
"provisioningOperation": "Create", "provisioningState": "Failed", "statusCode": "Conflict", "statusMessage": { "status": "Failed", "error": { "code": "ResourceDeploymentFailure", "message": "The resource operation completed with terminal provisioning state 'Failed'.", "details": [ { "code": "VMAgentStatusCommunicationError", "message": "VM 'X' has not reported status for VM agent or
extensions. verify VM has a running VM agent and can establish outbound connections to Azure storage.", id": "/Microsoft.Insights.VMDiagnosticsSettings"



0 Votes 0 · ·

and by both I mean. the Diagnostics agent failed during deployment. I tried to install the Microsoft monitoring agent. It went to unavailable when I enabled it from the dashboard.

0 Votes 0 · ·