question

rvdli avatar image
0 Votes"
rvdli asked MarschallPatrick-1470 commented

Slowness on RemoteApps (Windows Server 2019/Windows 10 clients)

I'm having some issues running RDS with some published RemoteApps on a 2019 Server.

Some clients report the Remoteapps performing extremely slowly, even with high speed connections and the servers on the farm running without any unusual RAM and CPU usage.


After reading some reports of other people with the same problem before the Windows 10 1803 update, I've tested and confirmed that with some mouses which has a higher DPI/polling rate, the Remoteapps perform extremely slow in any client running Windows 10 1803 or newer. I did the test myself on my workstation running Windows 10 2004, switching between two Microsoft mouses: a Classic Intellimouse (1000hz/polls per second) and a Wireless 4000 (125hz/polls per second). I didn't even close the app when switching the mouses. It looks like mouses like the Classic Intellimouse, or others like better Logitech and Razor models, for example, somehow overload the Remoteapp connection.

I have many clients with the same issue, in many places and different hardware configurations, but seems like the common point is running Windows 10 1803 or newer and having a high DPI mouse. On an old Technet thread people solved by replacing their mouses by cheaper ones or in some cases, replacing mstsc.exe and mstscax.dll by copies from a Windows 10 1709 machine. Both solutions are quite hard for the users in my case. What else can be done? Is there any fix for this?

The old technet thread which guided me to test the mouses is: https://social.technet.microsoft.com/Forums/en-US/f3e9852b-393c-4aa0-9d2f-961a82cfc603/remoteapp-after-windows-10-update-1803-are-slow-and-right-mouse-button-is-not-responding-it-reacts?forum=winserverTS

remote-desktop-servicesremote-desktop-client
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi,

Have you checked if the answer helps?

If the Answer is helpful, please click "Accept Answer" and upvote it.

Thanks,
Eleven

0 Votes 0 ·
ElevenYu-MSFT avatar image
0 Votes"
ElevenYu-MSFT answered

Hi,

From my knowledge, it seems there is no better solution for this issue.

But you could try to modify below group policy to see if any improvement.

Computer Configration\Administrative Templates\Windows Componets\Remote Desktop Services\Remote Desktop Session Host\Remote Session Environment

  • Use advanced RemoteFX graphics for RemoteApp

  • Configure compression for RemoteFX data

  • Configure image quality for RemoteFX Adaptive Graphics

  • Configure RemoteTX Adaptive Graphics

Also, you can post your feedback of resolving the issue in windows later version to Microsoft Remote Desktop User Voice

Thanks,
Eleven


If the Answer is helpful, please click "Accept Answer" and upvote it.



5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

rvdli avatar image
1 Vote"
rvdli answered rvdli commented

Tried those settings, didn't improve much. It's still usable only if I change my mouse for a simpler one.
This happens only on Remoteapps. I used an app which monitor the mouse polling rate to test and If I connect to a full desktop RDP session, it caps the mouse polling rate to about 60hz and I can use it fine. But on Remoteapps it shows between 600 and 1000hz. Handling almost a thousand requests per second on a TCP connection probably is the cause of the extreme slowness.

· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi,

If there any update for your issue?

Thanks,
Eleven

0 Votes 0 ·
rvdli avatar image rvdli ElevenYu-MSFT ·

Coming back after a long time to say that I still have the same issue. None of those GPO settings worked, using the "maximum performance" settings on Control Panel > System also didn't work.

0 Votes 0 ·

there has to be a way to software limit these newer mice. I'm having user's dig out old crappy mice because they just don't lag in the rdp app's.

0 Votes 0 ·
ElevenYu-MSFT avatar image
0 Votes"
ElevenYu-MSFT answered

Hi,

If so, could you please try to modify below settings to see if any improvement?

Computer Configration\Administrative Templates\Windows Componets\Remote Desktop Services\Remote Desktop Session Host\Connections
- Select RDP transport protocols

Thanks,
Eleven


If the Answer is helpful, please click "Accept Answer" and upvote it.



5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

56312915 avatar image
1 Vote"
56312915 answered MarschallPatrick-1470 commented

Encountered this very same issue today. Thanks to OP for pointing me in the right direction. I thought it was an infrastructure issue as other team members were having the same issue. The DPI on the mouse is irrelevant. The setting that kills remote app response is "Report Rate". My Logitech G203 has a default report rate of 1000 times per second. Reducing this to 125 times per second fixes the issue. On my mouse, this is done using the Logitech G Hub app.

· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Wow.... I can't believe this was the cause of my RemoteApps slowness.
Thank you for posting this.

0 Votes 0 ·

Somebody please give this man a cookie!
You are my hero.
Thx a lot :)

0 Votes 0 ·