question

eg1995-5273 avatar image
0 Votes"
eg1995-5273 asked ·

exchange owa error: error: Your request can't be completed right now. Please try again in a few moments.

dears,

i have 4 exchange 2016 servers. OWA is published externally using adfs and wap.
recently, the following is happening on owa externally: error: Your request can't be completed right now. Please try again in a few moments.
whenever i open inbox items, this issue happens.
and when i try to search in the address book or send an email: it is giving make sure that your device is connected to the internet.
however, mail flow internally on owa is working. then issue is just externally.

any idea?

best regards

office-exchange-server-administrationoffice-exchange-server-connectivityoffice-exchange-server-mailflowoffice-exchange-server-itpro
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

AshokM-8240 avatar image
0 Votes"
AshokM-8240 answered ·

Hi,

Is the issue still persists?

In some scenarios, preparing the Schema/AD is required while upgrading from one CU to another on the same Exchange version. For instance, if you are upgrading from Exchange 2016 CU 7 to CU 18, then yes it requires. Please refer the below links for more information,

https://docs.microsoft.com/en-us/exchange/plan-and-deploy/prepare-ad-and-domains?view=exchserver-2016
https://docs.microsoft.com/en-us/exchange/plan-and-deploy/active-directory/ad-schema-changes?view=exchserver-2016

Have you tried accessing it by clearing the cookies and in-private mode?
Internally OWA works and issue is with external - Can you try connecting the same laptop to the internet and access the OWA and check if issue still persists?
Since all users are affected and only external and also you have mentioned recently which means some change might have caused this issue. I would suggest you to check with your network/firewall team and see if there are any blocks for exchange traffic.

·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

LucasLiu-MSFT avatar image
0 Votes"
LucasLiu-MSFT answered ·

Hi @eg1995-5273 ,
What is your Exchange server version?
Only one user have this issue or all users have?
Did you change any settings before this issue occurred?
Please following the steps and see if the issue is resolved:
1.Please try to change another browser to access OWA.
2.If you install or upgrade Exchange server recently, please make suer already prepare Schema/AD/AD domains, and please check if there have Event ID 4999 error log in the Windows Application log. If so, follow the steps in the link below to fix it.
For more information: Error in Outlook Web App after an upgrade to Exchange Server 2013 CU 11 or later: Your request cannot be completed right now
3.Please run the following command in the Windows Powershell to check whether the Windows components required by Exchange are complete:

 Get-WindowsFeature

For more information :Install the required Windows components
4.Considering that there is a problem with the external OWA, please try to temporarily turn off the firewall and log in to OWA again. In addition, if there is a third-party antivirus software, please turn it off temporarily.
5.Check Windows and Anonymous authentication are enabled on OWA virtual directory on exchange back end web site, if not, change them and reset iis.
6.Please try to run the following command to check the external url setting of OWA virtual directory. You also could run the following commands to remove and re-create the OWA virtual directory.

 Get-OWAVirtualdirectory | fl
 Remove-OWAVirtualdirectory
 New-OWAVirtualdirectory

In addition, please check when you login OWA if there have any related error log in Event Viewer and IIS log.



If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.







· 1 ·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @eg1995-5273 ,
I am writing here to confirm with you how thing going now? If the above suggestion helps, please click “Accept as answer” to mark helpful reply as an answer.Your action would be helpful to other users who encounter the same issue and read this thread.
Thanks for your understanding.



If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


0 Votes 0 ·
eg1995-5273 avatar image
0 Votes"
eg1995-5273 answered ·

hey,

.If you install or upgrade Exchange server recently, please make suer already prepare Schema/AD/AD domains. do i have to run this if im just upgrading from cu to cu on the same exchange server version?
Please try to change another browser to access OWA.: same issue
Please run the following command in the Windows Powershell to check whether the Windows components required by Exchange are complete: this is valid
Check Windows and Anonymous authentication are enabled on OWA virtual directory on exchange back end web site, if not, change them and reset iis.: this is set too
all the users are facing it too

the issue isnt on the mail flow, its just i cant open messages nor compose emails:

best regards

· 1 ·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @eg1995-5273 ,
If the problem exists with internal access to OWA?
1. When you upgrade from cu to cu on the same Exchange server, it is not necessary to prepare schema/ad/ad domain, but it is required when performing a large-span update. When you perform Prepare Schema/AD/AD Domain, the corresponding attribute in ADSI is rangeUpper/objectVersion/objectVersion. You can check the corresponding value according to the Exchange Active Directory versions part of the first link provided by AshokM.
2. According to the error information you provided, considering that OWA is published by using ADFS and WAP and only external users are affected, it may be caused by firewall or network is blocking some of your communication to the Exchange server. And agree with what AshokM said, please check your network and firewall configuration is correct. If possible, you could try to temporarily turn off the firewall and third-party anti-virus software, and try to log in to OWA again.

0 Votes 0 ·
eg1995-5273 avatar image
0 Votes"
eg1995-5273 answered ·

issue was related to security configuration on the firewall.

best regards,

·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

BenjaminChai-8579 avatar image
0 Votes"
BenjaminChai-8579 answered ·

able to provide more information on how to resolve?
i am having same issues, but only on chromium browsers

·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.