question

ITGeek82-8422 avatar image
ITGeek82-8422 asked ·

Outlook doesn't search in the delegated mailbox

Hi guys,

The issue happens to both Outlook 2016 and Outlook 365.
I have two mailboxes in Outlook: the primary one and the one I've been delegated Full Access (it is not a regular mailbox and not a shared mailbox).
Emails are hosted in the Microsoft Office 365 (not on an on-premises Exchange Server).
Searching works fine for the emails stored in the primary mailbox.
However nothing is returned when I search for an items stored in the delegated mailbox.
Even if I click on the delegated mailbox searching still doesn't give any results.
I tried to add DWORD key DisableServerAssistedSearch (1) under HKCU\Software\Microsoft\Office\16.0\Outlook\Search but it didn't help.

Is it by design?
Can it be fixed?

office-outlook-itpro
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

JadeLiang-MSFT avatar image
JadeLiang-MSFT answered ·

Hi @ITGeek82-8422

the primary one and the one I've been delegated Full Access

Was your delegated permission obtained in the admin center by this way?
31187-snipaste-2020-10-09-18-01-13.png
If so, what's the working mode of your account on the Outlook(online or cached exchange mode )?

If you are working in cached exchange mode, according to my tests, the searching scope may be "All mailboxes" by default when we directly click the Search field, and it couldn't display the search result normally until I switch the scope to "Current folder" like below. So, please first check your search scope and search again to test if the issue has any difference.
31168-snipaste-2020-10-09-15-18-51.png
Also, I have tested in online mode and found it could work normally without any operations, so it's also suggested to switch the mode to online (File>Account setting>Account setting>change> uncheck use cached exchange mode )to check if the issue still exists.


If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


4 comments Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @ITGeek82-8422,
Does this issue have any upgrades? If it has been resolved, please click "Accept as answer" to mark useful post or share your solution, your action would benefit others who have similar issues. If you have any questions or need further assistance, please feel free to post back. Thanks!

0 Votes 0 · ·

Hi @ITGeek82-8422,
Has your issue been solved after so long?
If not, please provide me with more information about your issue for further analysis.Thanks!

0 Votes 0 · ·

Hi @JadeLiang-MSFT
Yes Full Access is delegated in the same way.
It didn't work for me so I stopped trying it.

0 Votes 0 · ·

Okay, if you would like to research it in the future, welcome to post back here and I would continue to research about it with you.
Have a nice day :)

0 Votes 0 · ·