question

FabioFerraguti avatar image
0 Votes"
FabioFerraguti asked ·

Sharepoint 2019 and One Drive sync

Hi all,
I'm getting a strange issue trying to sync Sharepoint On Prem libraries using the new one drive client (one drive.exe).

I have a Sharepoint 2019 Enterprise Farm, with dedicated web application hosting mysite, managed metadata service and user profile service, configured as described here: https://docs.microsoft.com/en-us/sharepoint/sites/set-up-onedrive-for-business. One drive is working and available for all users.

On my pc I have installed the new one drive sync client, configured as following (https://docs.microsoft.com/it-it/onedrive/use-silent-account-configuration)

In windows registry I have:
DisableFileSyncNGSC = 0
SharePointOnPremFrontDoorUrl = http://mysiteurl.contoso.com
SharePointOnPremPrioritization = 1
SilentAccountConfig = 1

When I try to sync a library using the sync button on the browser:

1) "getting ready to sync" popup appears
2) "set up one drive" pop up appears; my domain\username is correctly configured. Then I click "Sign In"
3) "Sign in to one drive" pop up appears, and I correctly login with my domain\username and password
4) I get an error popup reporting "There was a problem connecting to OneDrive. Check your internet connection, and then try again. (Error code: 0x8004de40)"

Using fiddler I can see that just after 3) I get a 404 error; One Drive is trying to connect to http://mysiteurl.contoso.com/personal/fferra, while my username is fferraguti and my one drive site is of course http://mysiteurl.contoso.com/personal/fferraguti

How can I get rid of this?

Thank your
Fabio

office-sharepoint-server-administrationoffice-sharepoint-server-itprooffice-onedrive-client-itpro
· 2
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @FabioFerraguti,

Is there any progress on this issue?

Please feel free to reply.

0 Votes 0 ·

Hi @FabioFerraguti,

I’m checking how the things are going on about this issue. Whether the post helps you?

You can accept the post as answer if it helps.

Thank you for your understanding and support.

0 Votes 0 ·

1 Answer

JulieWang-MSFT avatar image
0 Votes"
JulieWang-MSFT answered ·

Hi @FabioFerraguti,

Per my test I could reproduce your issue when I set the SharePointOnPremFrontDoorUrl as my personal site(http://sp/personal/myname).

31665-image.png

Then I change the property as top level site of MySiteHost, which works well, for example: http://sp


If an Answer is helpful, please click "Accept Answer" and upvote it.

Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.



image.png (10.5 KiB)
· 2 ·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi Julie,
thank you for your quick reply.
I have to clarify that (sorry for being inaccurate) the key SharePointOnPremFrontDoorUrl is set to http://mysiteurl.contoso.com, which is the My Site top level site (just edited the main topic for more accuracy).

Fabio

0 Votes 0 ·

Hi @FabioFerraguti,

In order to get a better forum experience, we changed your answer to a comment.

Please try use other team sites URL instead of my site host to check the result.

0 Votes 0 ·