question

Chned-6770 avatar image
0 Votes"
Chned-6770 asked ·

Office 365 ProPlus (Intune deployment installs 2 components?)

So I made a Microsoft 365 Apps app within Intune which installs Excel, Outlook, PowerPoint, Skype for Business and Word on Win10.

I notice the following: despite the fact that I selected Office to be installed with only 1 language (default language of operating system) I see the following components in the installed software section of Windows. Office is opening in the right language (operating system language nl-nl), but I'm wondering why this is happening. I don't want any issues afterwards!


34055-image.png


34056-office.png


office-deploymentmem-intune-application-management
image.png (9.2 KiB)
office.png (56.0 KiB)
· 1
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@Chned-6770, From your description, I know the device has two language packs installed for Microsoft 365 apps when the languages is not set in Intune policy. To check our issue, could you check the following information on the affected device:?
1. Please go to the settings of the affected device and check the Language setting on this device; Please get a screenshot of the setting.
34211-image.png

  1. Is this device with any Microsoft 365 app installed before?

  2. Please go to c:\windows\temp and check the cfgxxx.tmp file to see what is the office configuration file we get.

Please check the above information and if there's any question, feel free to let us know.


0 Votes 0 ·
image.png (215.0 KiB)
Chned-6770 avatar image
0 Votes"
Chned-6770 answered ·

See screenshot below.

  1. This is a fresh installed machine.


  2. <Configuration><Add Channel="Deferred" OfficeClientEdition="64" MigrateArch="TRUE"><Product ID="O365ProPlusRetail"><ExcludeApp ID="Access" /><ExcludeApp ID="Bing" /><ExcludeApp ID="Groove" /><ExcludeApp ID="InfoPath" /><ExcludeApp ID="OneDrive" /><ExcludeApp ID="OneNote" /><ExcludeApp ID="Publisher" /><ExcludeApp ID="SharePointDesigner" /><ExcludeApp ID="Teams" /><Language ID="MatchOS" /></Product></Add><Display Level="None" AcceptEULA="TRUE" /><Property Name="SharedComputerLicensing" Value="0" /><ExecCount xmlns="http://schemas.microsoft.com/intune">1</ExecCount><LastExecuteTime xmlns="http://schemas.microsoft.com/intune">10/20/2020 2:48:02 PM</LastExecuteTime></Configuration>



34147-taal.png



taal.png (64.8 KiB)
·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Crystal-MSFT avatar image
0 Votes"
Crystal-MSFT answered ·

@Chned-6770, From the information you provided, I find the "Language ID" is"MatchOS" in configuration file, In the language setting on Windows, I find only one language is there.

To narrow down our issue, I suggest to do two tests:
Test 1:
Add Nederlands language into Intune policy and deploy to see if it will make the Microsoft 365 installed with only one language.

Test 2:
On device side, use the configuration file we get on the affected machine and try to deploy Microsoft 365 via ODT with this configuration file to see how many language packs will be installed for Microsoft 365 app. Here is a link for the reference:
https://docs.microsoft.com/en-us/deployoffice/overview-office-deployment-tool

If there's any update, feel free to let us know.


·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Chned-6770 avatar image
0 Votes"
Chned-6770 answered ·

Test 1:
I tried this to no avail.
Wether the cfgxxx.tmp-file contains <Language ID="MatchOS" /> or <Language ID="nl-nl" /><Language ID="MatchOS" /> it doesn't make any difference.


Test 2.
I used the ODT with the following .XML file, but also then I see 2 entries in the installed software section:

63557-knipsel.png



<Configuration>
<Add OfficeClientEdition="64" Channel="Deferred" MigrateArch="TRUE">
<Product ID="O365ProPlusRetail">
<ExcludeApp ID="Access" />
<ExcludeApp ID="Groove" />
<ExcludeApp ID="InfoPath" />
<ExcludeApp ID="Lync" />
<ExcludeApp ID="OneNote" />
<ExcludeApp ID="Publisher" />
<ExcludeApp ID="SharePointDesigner" />
<ExcludeApp ID="Teams" />
<Language ID="MatchOS" />
</Product>
</Add>
<Display Level="None" AcceptEULA="TRUE" />
<Property Name="SharedComputerLicensing" Value="0" />
<ExecCount xmlns="http://schemas.microsoft.com/intune">1</ExecCount>;
<LastExecuteTime xmlns="http://schemas.microsoft.com/intune">2/2/2021 2:38:01 PM</LastExecuteTime>
</Configuration>



knipsel.png (29.9 KiB)
· 6 ·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Update:

When I use ODT with Language ID "nl-nl" then only one Office version is installed.
Question remains; why doesn't this work properly when using 'MatchOS'?

OS language definately is Dutch (NL). It also is the only language installed:

63535-knipsel.png



0 Votes 0 ·
knipsel.png (155.5 KiB)

@Chned-6770,Thanks for the reply.

From your description, I know the ODT with Language ID "nl-nl" is working as expected. But MatchOS is not. Based on my research, I find a similar case.
https://social.technet.microsoft.com/Forums/en-US/df3f0bf4-bf7d-47f2-920b-212ef0dcdad9/how-to-use-office-365-with-matchos-option-in-the-xml-file?forum=officesetupdeploy

It seems this can be related with the OS. Here, we suggest to check the registry to see if en-us is the installed language of Windows 10. We can see more details in the following link:
https://www.tenforums.com/tutorials/30656-see-system-default-ui-language-windows-10-a.html
Mote: Non-Microsoft link, just for the reference.

Hope it can help.

0 Votes 0 ·

As you can see it is Dutch:

63909-naamloos.png


0 Votes 0 ·
naamloos.png (36.3 KiB)
Show more comments