question

adminadmin213-1817 avatar image
adminadmin213-1817 asked ·

connecting outlook on mobile to internal exchange server

Hi

I can easily connect the outlook on pcs to my internal exchange server 2019 with both imap and mapi method.
but on mobile devices i encounter "timeout" and "can't reach server" problem !

I tried all possible way with android gmail and outlook and ios mail and outlook but from these only gmail and ios mail work with imap method!
the firewall on server is totally turned off and checked dns autodiscover and _autodiscover and i even scaned the open ports on server with same mobile devices and all corresponding port (25,143,443,993,587,465 ) are open!
and even set internal and external addresses of owa autodiscover ecp mapi imap the same but still gets timed out!!!
plz help
Tnx

office-exchange-server-administrationoffice-exchange-server-connectivity
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

ManuPhilip avatar image
ManuPhilip answered ·

The best online tool to start troubleshooting the issue from Microsoft is here: [exchange][1]

You will find the actual issue (firewall, port, certificate etc.) from the detailed error message
[1]: https://testconnectivity.microsoft.com/tests/exchange

4 comments Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.


tnx for answer but this tool checks from internet and isn't useful for this scenario because anything is in private network.

0 Votes 0 · ·
ManuPhilip avatar image ManuPhilip adminadmin213-1817 ·

Just trying to understand, how the mobile can connect to the internal network? If it does in someway, make sure that the ssl certificate is applied correctly

0 Votes 0 · ·

from internal wifi same as other pcs
and also internet with vpn that works correctly

0 Votes 0 · ·
Show more comments
LucasLiu-MSFT avatar image
LucasLiu-MSFT answered ·

Hi @adminadmin213-1817 ,
Is this your first time configuring Outlook on your mobile?
Only one account have this issue or all have?
1. I agree with ManuPhilip said that please make sure to configure the SSL certificate correctly.
2. Please try to clean up the cached information in Outlook for IOS/Android, then uninstall and reinstall Outlook, and finally follow the specific steps in the following link to configure.
For more information: Set up email in the Outlook for Android app and Set up the Office app and Outlook on iOS devices



If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.




4 comments Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

HI
yea it 's first time and all the emails have this problem
i think outlook mobile app essentially doesn't accept local ip and record and that's the case !
ssl is fine all the possible public and private name is included in it and only problem is the ca trust things... that is should be.

0 Votes 0 · ·
LucasLiu-MSFT avatar image LucasLiu-MSFT adminadmin213-1817 ·

Hi @adminadmin213-1817 ,
You also could try to connect to Exchange server using the other email software that comes with your phone.
You could run the following command to check the authentication and URL settings of ActiveSync virtual directory:

 Get-ActiveSyncVirtualDirectory | fl

For more information:Default settings for Exchange virtual directories



If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.





0 Votes 0 · ·

Hi @adminadmin213-1817 ,
Do suggestions above help? If the issue has been resolved, please click “Accept as answer” to mark helpful reply as an answer, this will make answer searching in the forum easier and be beneficial to other community members as well.

Thanks for your understanding.



If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


0 Votes 0 · ·

Hi @adminadmin213-1817 ,
I am writing here to confirm with you how thing going now? If the above suggestion helps, please click “Accept as answer” to mark helpful reply as an answer.Your action would be helpful to other users who encounter the same issue and read this thread.
Thanks for your understanding.



If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


0 Votes 0 · ·